2012 網路報稅 Ubuntu 版 [論壇 - Ubuntu 與工具程式及軟體推薦]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊

(1) 2 »


2012 網路報稅 Ubuntu 版

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1404 / 1756
MP : 4456 / 46363
EXP: 24
離線
2012 網路報稅 Ubuntu 版

本站前輩 hepha 寫在他的 google+ 於 arch linux 網路報稅之方法 囑咐我改成 ubuntu 方式 網路報稅 與大家分享
=========================================================
(一) zh_TW.big5 locale 是否已安裝
1-1. 首先檢查你的系統上是否有安裝 zh_TW.big5 locale
locale -a | grep zh_TW.big5
如果有回應 zh_TW.big5 就是已經有安裝 zh_TW.big5 locale 不必再安裝
如果沒回應 就是沒有安裝 zh_TW.big5 locale 需要安裝 zh_TW.big5 locale
1-2. 準備安裝 zh_TW.big5 locale
sudo gedit /var/lib/locales/supported.d/local
原內容不動
加在最後一行
zh_TW.BIG5 BIG5
儲存
1-3. 產生 zh_TW.big5 locale
sudo locale-gen
會出現
...(略)
zh_TW.BIG5... done
...(略)
1-4. 確認已安裝 zh_TW.big5 locale
locale -a | grep zh_TW.big5
回應
zh_TW.big5 # 安裝 zh_TW.big5 locale 成功
=========================================================
(二) 在 ubuntu 12.04 安裝 oracle java 7 for 32 bits
2-1. 下載
jdk-7u4-linux-i586.tar.gz
2-2. 解壓縮
sudo tar -xzvf jdk-7u4-linux-i586.tar.gz
2-3. sudo mkdir -p /usr/lib/jvm
2-4. sudo cp -a ./jdk1.7.0_04 /usr/lib/jvm
2-5. sudo ls -al /usr/lib/jvm | grep jdk1.7.0_04
drwxr-xr-x...略...jdk1.7.0_04 # OK
2-6. sudo add-apt-repository ppa:nilarimogard/webupd8 # 加入webupd8的源
2-7. sudo aptitude update
2-8. sudo aptitude safe-upgrade # 加上這個程序 比較不會因相依條件問題而失敗
2-9. sudo aptitude install update-java
勾選 /usr/lib/jvm/jdk1.7.0_04
2-10. sudo dpkg -l | grep oracle-java7-installer
回應
oracle-java7-installer 7u3-0~webupd8~9 Sun Java(TM) ...
註 如果你是 64 bits 請參考 nana 的 這一篇
=========================================================
(三)建立 網路報稅 可執行檔
3-1. gedit ~/ircweb
......虛線以內內容直接 copy 貼到 ircweb 檔內.................
#!/bin/bash
#
if [ -n "$(readlink -f $(which java)|grep openjdk)" ] ; then
echo "不能工作於openjdk"
exit
else
export _JAVA_OPTIONS="-Dawt.useSystemAAFontSettings=on -Dsun.java2d.opengl=true -Dfile.encoding=big5"
fi
export LANG="zh_TW.big5"
pgrep firefox && echo "請關閉firefox此腳本"
firefox -new-window https://rtn.tax.nat.gov.tw/ircweb/index.jsp
export LANG="zh_TW.UTF-8"
......虛線以內內容直接 copy 貼到 ircweb 檔內.................
3-2. sudo chmod +x ~/ircweb
3-3. ~/ircweb # 出現下述 網路報稅網頁























謝謝 hepha 前輩 ! 也祝你愉快報稅 !

4. hepha 說:
4-1. 我有試 oracle java 沒試 openjdk
......p.s openjdk 我這測試無法下載 jvm plug 放棄
4-2. 兩種晶片我都沒試,沒有那種東西XD

2012/5/5 21:38
應用擴展 工具箱
回覆: 2012 網路報稅 Ubuntu 版
會員三級
註冊日期:
2009/1/1 10:11
所屬群組:
已註冊使用者
等級: 9
HP : 0 / 205
MP : 34 / 5972
EXP: 20
離線
big5問題解決,但接著firefox安裝npHiPKIClient-linux.xpi就卡住
他說與firefox 12.0不相容
有人遇到這個問題嗎?

2012/5/6 21:47
應用擴展 工具箱
回覆: 2012 網路報稅 Ubuntu 版

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1404 / 1756
MP : 4456 / 46363
EXP: 24
離線
接著firefox安裝npHiPKIClient-linux.xpi就卡住

什麼原因要安裝 npHiPKIClient-linux.xpi

2012/5/6 21:50
應用擴展 工具箱
回覆: 2012 網路報稅 Ubuntu 版
會員一級
註冊日期:
2011/5/2 18:12
所屬群組:
已註冊使用者
等級: 2
HP : 0 / 43
MP : 5 / 973
EXP: 74
離線
自然人憑證plunin,我也碰到,搞不定,又回win去報.
結果在下載所得及扣除額時有個滿意度調查,就毫不客氣選了非常不滿意,並小小抱怨一下,希望明年會有改進.

2012/5/7 8:17
應用擴展 工具箱
回覆: 2012 網路報稅 Ubuntu 版
會員三級
註冊日期:
2009/1/1 10:11
所屬群組:
已註冊使用者
等級: 9
HP : 0 / 205
MP : 34 / 5972
EXP: 20
離線
poloshiao 寫到:
接著firefox安裝npHiPKIClient-linux.xpi就卡住

什麼原因要安裝 npHiPKIClient-linux.xpi


不知道,依檔案名看來應該是跟憑證有關
到使用者登錄頁面就會碰到

2012/5/7 9:44
應用擴展 工具箱
回覆: 2012 網路報稅 Ubuntu 版

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1404 / 1756
MP : 4456 / 46363
EXP: 24
離線
什麼原因要安裝 npHiPKIClient-linux.xpi

已發文向 hepha 請教

另外 把
npHiPKIClient-linux.xpi
輸入 google 搜尋框
除了 您貼的文章外
找不到 其它文章
不知 npHiPKIClient-linux.xpi 英文文字 是否完全正確

2012/5/7 10:25
應用擴展 工具箱
回覆: 2012 網路報稅 Ubuntu 版
會員二級
註冊日期:
2012/4/3 1:22
所屬群組:
已註冊使用者
等級: 5
HP : 0 / 110
MP : 14 / 2176
EXP: 43
離線
我在 Firefox 10 上成功用自然人憑證報完稅了,
樓上說和 Firefox 12 不相容的問題也許可以舊版的 Add-on Compatibility Reporter 試看看能不能強制安裝 我試過了,不行。

2012/5/21 2:47
應用擴展 工具箱
回覆: 2012 網路報稅 Ubuntu 版
會員二級
註冊日期:
2012/4/3 1:22
所屬群組:
已註冊使用者
等級: 5
HP : 0 / 110
MP : 14 / 2176
EXP: 43
離線
阿萬 寫到:
big5問題解決,但接著firefox安裝npHiPKIClient-linux.xpi就卡住
他說與firefox 12.0不相容
有人遇到這個問題嗎?

我找到原因了:
npHiPKIClient-linux.xpi 裡面的 install.rdf 檔內有一行
<em:maxVersion>10.5</em:maxVersion>
指定能安裝該套件的最大 Firefox 版本為 10.5,
所以用 Firefox 12.0 會無法安裝。

如果把它改大一點 (例如 20.5),
就能順利安裝了。

2012/5/22 1:21
應用擴展 工具箱
回覆: 2012 網路報稅 Ubuntu 版
會員五級
註冊日期:
2008/6/15 2:56
所屬群組:
已註冊使用者
等級: 38
HP : 189 / 945
MP : 757 / 29039
EXP: 81
離線
抱歉太晚上來了XD
npHiPKIClient-linux.xpi我也沒裝耶…那抓的?

2012/7/31 21:24
應用擴展 工具箱
回覆: 2012 網路報稅 Ubuntu 版
會員二級
註冊日期:
2012/4/3 1:22
所屬群組:
已註冊使用者
等級: 5
HP : 0 / 110
MP : 14 / 2176
EXP: 43
離線
hepha 寫到:
抱歉太晚上來了XD
npHiPKIClient-linux.xpi我也沒裝耶…那抓的?

在報稅網頁上。

我記得當時火狐出現要安裝缺少的外掛程式提示,
但我按了之後火狐出現的外掛程式搜尋對話方塊一直搜尋不到,
後來我就在報稅網頁的登入處直接輸入身分證號並按下一步,
接著網頁就出現「需要安裝中華電信自然人憑證登入plugin」點話盒,
按確定後就出現下載頁面了,
以下是我當時的截圖:


附件:



png  missing plugin 5.png (62.43 KB)
30044_501af79988cd8.png 600X455 px

2012/8/3 6:09
應用擴展 工具箱

(1) 2 »

 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.