無法取得套件 vim [論壇 - 新手村]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊



無法取得套件 vim
會員一級
註冊日期:
2015/4/9 19:13
所屬群組:
已註冊使用者
等級: 1
HP : 0 / 11
MP : 2 / 155
EXP: 47
離線
小弟最近接觸UBUNTU
聽朋友VIM 可以去試用看
但是用apt-get install vim
要去安裝時

正在讀取套件清單... 完成

正在重建相依關係

正在讀取狀態資料... 完成

無法取得套件 vim,但它卻被其它的套件引用了。

這意味著這個套件可能已經消失了、被廢棄了,或是只能由其他的來源取得

ssh也是這樣

去GOOGLE後
但上面的版本都是11.10版本的
小弟裝的是12.10

照著上面去改source.list不僅沒幫助
還改的沒辦法開機= =
煩請有經驗的各位幫我解答一下
感激不盡

2015/4/9 19:21
應用擴展 工具箱
回覆: 無法取得套件 vim
會員五級
註冊日期:
2009/10/29 4:50
所屬群組:
已註冊使用者
等級: 41
HP : 201 / 1007
MP : 894 / 29329
EXP: 29
離線
Ubuntu 12.10早已停止支援了,
請安裝Ubuntu 14.04。

2015/4/9 19:44
應用擴展 工具箱
回覆: 無法取得套件 vim
會員五級
註冊日期:
2012/4/22 10:50
所屬群組:
已註冊使用者
等級: 34
HP : 169 / 847
MP : 574 / 18527
EXP: 89
離線
xenomorph0525 寫到:
Ubuntu 12.10早已停止支援了,
請安裝Ubuntu 14.04。


補充一下!

可以先了解「Ubuntu LTS」所代表的涵義。

參考「這一頁」。


LTS is an abbreviation for “Long Term Support”.



還有「這篇文章」。

或是「Wiki的介紹」。

我個人通常會安裝「LTS」這個版本。
我是從12.04開始安裝的,所以經歷下面兩個「LTS」版本。
「12.04」
「14.04」
我的策略是兩年重新安裝一次。

以上是我個人的作法,僅供參考




另外「這篇討論」,有提到 「Ubuntu old release 」相關的議題。或是參考「這篇」或是「這篇」或是「這篇」。

2015/4/9 20:23
應用擴展 工具箱
回覆: 無法取得套件 vim
會員一級
註冊日期:
2015/4/9 19:13
所屬群組:
已註冊使用者
等級: 1
HP : 0 / 11
MP : 2 / 155
EXP: 47
離線
所以沒有辦法從12.10更新了嗎
OTZ
小弟有某種限制要用12.10去學習

2015/4/10 0:23
應用擴展 工具箱
回覆: 無法取得套件 vim
會員五級
註冊日期:
2010/9/26 16:05
所屬群組:
已註冊使用者
等級: 27
HP : 0 / 660
MP : 317 / 17487
EXP: 43
離線
avatarroy 寫到:
所以沒有辦法從12.10更新了嗎
OTZ
小弟有某種限制要用12.10去學習


試試下載deb檔,然後直接點擊安裝
以下二個連結,一個是32位元,一個是64位元

http://packages.ubuntu.com/trusty/i386/vim/download
http://packages.ubuntu.com/trusty/amd64/vim/download

2015/4/10 10:25
應用擴展 工具箱
回覆: 無法取得套件 vim
會員五級
註冊日期:
2012/4/22 10:50
所屬群組:
已註冊使用者
等級: 34
HP : 169 / 847
MP : 574 / 18527
EXP: 89
離線
avatarroy 寫到:
所以沒有辦法從12.10更新了嗎
OTZ
小弟有某種限制要用12.10去學習


我上面的回覆,最後有一段話,您可以先研究一下裡面的連結文章。

samwhelp 寫到:

另外「這篇討論」,有提到 「Ubuntu old release 」相關的議題。或是參考「這篇」或是「這篇」或是「這篇」。


2015/4/10 12:37
應用擴展 工具箱
回覆: 無法取得套件 vim
會員二級
註冊日期:
2006/2/6 13:19
所屬群組:
已註冊使用者
等級: 4
HP : 0 / 92
MP : 11 / 3681
EXP: 68
離線
樓上是正解,更新 source.list 後 apt-get update 一次就可以使用 apt-get install vim 來安裝了。

2015/4/23 1:03
應用擴展 工具箱


 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.