(已解決啦,耶!)有沒有人使用威寶無線網卡(ZTE MF-626 HSDPA USB MODEM)成功上網呢? [論壇 - Ubuntu硬體支援]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊

« 1 2 (3)


回覆: 有沒有人使用威寶無線網卡(ZTE MF-626 HSDPA USB MODEM)成功上網呢?
會員一級
註冊日期:
2009/8/16 12:23
所屬群組:
已註冊使用者
等級: 1
HP : 0 / 8
MP : 1 / 125
EXP: 34
離線
嗚!依然無法解決嗎?

2009/8/26 0:22
應用擴展 工具箱
回覆: 有沒有人使用威寶無線網卡(ZTE MF-626 HSDPA USB MODEM)成功上網呢?
會員二級
註冊日期:
2008/7/8 20:57
所屬群組:
已註冊使用者
等級: 5
HP : 0 / 118
MP : 16 / 2136
EXP: 75
離線
我可以上網了
以下是我到google跟討論此主題的前輩,自己拼湊而成的,可能有點粗糙或者不對,還請路過得大大,矯正我。
希望能幫到你

vim /etc/hal/fdi/information/10-modem.fdi
=========================================以下是內容
<!– -*- SGML -*- –>
<deviceinfo version=”0.2″>
<device>
<!– ZTE MF626 HSDPA USB Modem –>
<match key=”@info.parent:usb.vendor_id” int=”0×19d2″>
<match key=”@info.parent:usb.product_id” int=”0×0031″>
<match key=”@info.parent:usb.interface.number” int=”3″>
<append key=”modem.command_sets” type=”strlist”>GSM-07.07</append>
<append key=”modem.command_sets” type=”strlist”>GSM-07.05</append>
<append key=”info.capabilities” type=”strlist”>modem</append>
</match>
</match>
</match>
</device>
</deviceinfo>
================================以上

安裝usb_modeswitch 到
http://www.draisberghof.de/usb_modeswitch/#download 抓usb_modeswitch

解壓縮,進入檔案執行make install

vim /etc/usb_modeswitch.conf
=============================更改以下內容,將MF626內容有加上分號的都去掉。
########################################################
# ZTE MF626 (tested version from Telia / Sweden)
#
# Contributor: Joakim Wennergren
#
# Also applies to MF627 (Tested 3 UK) JF

DefaultVendor= 0x19d2
DefaultProduct= 0x2000

TargetVendor= 0x19d2
TargetProduct= 0x0031

MessageEndpoint=0x01
MessageContent="55534243123456782000000080000c85010101180101010101000000000000"
========================================以上


vim /etc/udev/rules.d/999-zte.rules
==================================增加以下內容
SUBSYSTEM=="usb", SYSFS{idProduct}=="2000", SYSFS{idVendor}=="19d2", RUN+="/usr/sbin/usb_modeswitch"
===================================以上

執行usb_modeswitch

執行/usr/bin/wvdaiconf

執行/usr/bin/wvdai

再到/root底下增加script
vim vibo.sh
=====================以下是內容
#!/bin/bash
echo "此程式要執行四個步驟,約1分鐘時間,請耐心等待:"
echo "請稍等......15"
/bin/sleep 5
echo "請稍等......10"
/bin/sleep 5
echo "請稍等.......5"
/bin/sleep 1
echo "請稍等.......4"
/bin/sleep 1
echo "請稍等.......3"
/bin/sleep 1
echo "請稍等.......2"
/bin/sleep 1
echo "請稍等.......1"
/bin/sleep 1
echo "I.切換 modem 模式......"
#/usr/sbin/usb_modeswitch -W -c /etc/usb_modeswitch.conf
sudo /usr/sbin/usb_modeswitch -c /etc/usb_modeswitch.conf
echo "請稍等......15"
/bin/sleep 5
echo "請稍等......10"
/bin/sleep 5
echo "請稍等.......5"
/bin/sleep 1
echo "請稍等.......4"
/bin/sleep 1
echo "請稍等.......3"
/bin/sleep 1
echo "請稍等.......2"
/bin/sleep 1
echo "請稍等.......1"
/bin/sleep 1
echo "II.啟動 modem 模式......"
sudo /sbin/rmmod usbserial
/bin/sleep 2
sudo /sbin/modprobe usbserial vendor=0x19d2 product=0x031
echo "請稍等......20"
/bin/sleep 5
echo "請稍等......15"
/bin/sleep 5
echo "請稍等......10"
/bin/sleep 5
echo "請稍等.......5"
/bin/sleep 1
echo "請稍等.......4"
/bin/sleep 1
echo "請稍等.......3"
/bin/sleep 1
echo "請稍等.......2"
/bin/sleep 1
echo "請稍等.......1"
/bin/sleep 1
echo "III.偵測 ttyUSB ......"
sudo /usr/bin/wvdialconf /etc/wvdial.conf
#echo "請稍等......15"
/bin/sleep 5
echo "請稍等......10"
/bin/sleep 5
echo "請稍等.......5"
/bin/sleep 1
echo "請稍等.......4"
/bin/sleep 1
echo "請稍等.......3"
/bin/sleep 1
echo "請稍等.......2"
/bin/sleep 1
echo "請稍等.......1"
/bin/sleep 1
echo "IV.開始撥接......"
echo "請稍等......10"
/bin/sleep 5
echo "請稍等.......5"
/bin/sleep 1
echo "請稍等.......4"
/bin/sleep 1
echo "請稍等.......3"
/bin/sleep 1
echo "請稍等.......2"
/bin/sleep 1
echo "請稍等.......1"
sudo /usr/bin/wvdial
===========================以上

完畢後將vibo改成可執行
執行vibo.sh

如果撥號不能上的話,請至vim /etc/wvdai.conf
更改usb-port 在試看看
我是改2 他會跑出usb0,1,2

2009/8/26 9:13
應用擴展 工具箱
回覆: 有沒有人使用威寶無線網卡(ZTE MF-626 HSDPA USB MODEM)成功上網呢?
會員三級
註冊日期:
2008/11/10 13:45
所屬群組:
已註冊使用者
等級: 10
HP : 0 / 230
MP : 41 / 3914
EXP: 22
離線
sudo /usr/bin/wvdialconf /etc/wvdial.conf

會自動偵測port

man wvdialconf

wvdialconf --help

看看說明

2009/8/26 10:24
應用擴展 工具箱
回覆: 有沒有人使用威寶無線網卡(ZTE MF-626 HSDPA USB MODEM)成功上網呢?
會員二級
註冊日期:
2008/7/8 20:57
所屬群組:
已註冊使用者
等級: 5
HP : 0 / 118
MP : 16 / 2136
EXP: 75
離線
我後來又去試了一台pc
主機板 D945GCLF
系統ubuntu 9.04
照先前的方法作 卻發現usb_modeswitch以更新0.4版了
先前我是用0.2版
照理應該舊版可以新版應該ok
測試結果失敗,他抓不道zte626
於是我換回舊版的0.2版來測試,是有抓到了,且也撥上了
但卻無法連接網路
local-IP及remote-IP跟dns都給了
就是無法連上 ping也ping不到
真是怪

2009/8/26 17:27
應用擴展 工具箱
回覆: 有沒有人使用威寶無線網卡(ZTE MF-626 HSDPA USB MODEM)成功上網呢?
會員二級
註冊日期:
2008/7/8 20:57
所屬群組:
已註冊使用者
等級: 5
HP : 0 / 118
MP : 16 / 2136
EXP: 75
離線
不好意思是我 gateway沒繞出去
我在搞笑 抱歉
因該是OK的

2009/8/30 15:31
應用擴展 工具箱
alextu
回覆: 有沒有人使用威寶無線網卡(ZTE MF-626 HSDPA USB MODEM)成功上網呢?
Anon:alextu
不好意思,請問一下,
gateway沒繞出去是什麼意思,如何解決呢,
因為我也會常發生撥上威宝了,但連不出去的問題,
常常就是要重新開機,再撥一次就可以連上了。

我用ifconfig看ppp0沒有gateway的設定說....

2009/11/10 10:19 | 05bcb dff30 18aab 5afc4
應用擴展 工具箱
回覆: 有沒有人使用威寶無線網卡(ZTE MF-626 HSDPA USB MODEM)成功上網呢?
會員三級
註冊日期:
2007/11/22 11:24
所屬群組:
已註冊使用者
等級: 11
HP : 0 / 253
MP : 48 / 5022
EXP: 13
離線
Ooo, 各位同好,MF-626現在可以上網了。此刻的我,感覺好幸福,一邊聽Hinedo的台北愛樂,一邊把可以上網的設定PO上來和大家分享。話不多說了,
第一步,首先,開啟終端機,以管理者帳號到“/etc/udev/rules.d”這個路徑下新增“90-zte.rules”這個檔案。指令如下:sudo gedit /etc/udev/rules.d/90-zte.rules。按Enter後,先輸入管理者帳號的密碼,然後在90-zte.rules的檔案內容裡貼上以下引號內的內容

ACTION!="add", GOTO="ZTE_End"

SUBSYSTEM=="usb", SYSFS{idProduct}=="2000", SYSFS{idVendor}=="19d2", GOTO="ZTE_ZeroCD"

LABEL="ZTE_ZeroCD"
RUN+="/usr/sbin/usb_modeswitch -W -c /etc/usb_modeswitch.conf"

LABEL="ZTE_End"

然後存檔,重開機。
第二步,插入MF-626後,稍等一下,待出現綠閃光後,先掛載ZTEMODEM,然後再退出。具體做法如下:滑鼠左鍵先點位置,再點ZTEMODEM,這樣就把ZTEMODEM掛載,桌面會先有ZTEMODEM的圖示,請在ZTEMODEM圖示上按滑鼠右鍵,選Eject, (這一步最重要了)。Eject後,MODEM綠閃光會先變成紅閃光。
第三步,開啟網路連線,新增Vibo的行動寬頻連線(裝置要選ZTE Incorporated ZTE CDMA Technologies MSM), 國家選Taiwan,
提供者選Vibo Telecom/ Aurora,然後一直向前,再選套用,然後要輸入使用者名稱和密碼,另外,可以勾取自動連線和所有使用者皆可使用,最後選套用。然後再重開機,進到桌面後,點工具列的位置,先掛載ZTEMODEM(光碟片圖示),然後到桌面的ZTEMODEM藍色圖示按右鍵選退出後,沒幾秒鐘就會自動撥接上網了。

附註:
1>參考網頁網址:http://www.chiark.greenend.org.uk/~ryounger/workbench/zte-mf626-ubuntu.html
2>系統是UBUNTU 9.10,GNOME:2.28.1 ,核心(Kernal):2.6.31-20-generic
3>測試過的主機:IBM筆記型電腦1834-PV3,EeePC 701SDX (把9.10裝在FLASH DISK(Apacer AH321)用它來開機)。
4> 威寶這支行動網卡的頻寬好像比較窄,一樣是YOUTUBE的影像,台灣大的順,而威寶的很累格,讓我受不了,要來去威寶客服反應一下:(。

2010/4/16 4:01
最後修改: lin-lin_224 於 2010/4/17 7:56:00
應用擴展 工具箱
回覆: 有沒有人使用威寶無線網卡(ZTE MF-626 HSDPA USB MODEM)成功上網呢?
會員三級
註冊日期:
2010/3/19 23:44
所屬群組:
已註冊使用者
等級: 10
HP : 0 / 243
MP : 45 / 3176
EXP: 75
離線
您好,可以請您介紹一下90-zte.rules這個檔案的作用嗎?

還有,Eject,在中文版是叫「安全退出」還是「移除」?

2010/4/16 9:10
應用擴展 工具箱
回覆: 有沒有人使用威寶無線網卡(ZTE MF-626 HSDPA USB MODEM)成功上網呢?
會員三級
註冊日期:
2007/11/22 11:24
所屬群組:
已註冊使用者
等級: 11
HP : 0 / 253
MP : 48 / 5022
EXP: 13
離線
我是參考網路上的PO文,至於90-zte.rules的作用,我現在真的沒辦法回答你。Eject是「退出」,不是安全的移除裝置。

2010/4/16 9:26
應用擴展 工具箱
回覆: (已解決啦,耶!)有沒有人使用威寶無線網卡(ZTE MF-626 HSDPA USB MODEM)成功上網呢?
會員三級
註冊日期:
2010/3/19 23:44
所屬群組:
已註冊使用者
等級: 10
HP : 0 / 243
MP : 45 / 3176
EXP: 75
離線
恩,在Ubuntu裡,對裝置有「缷載」、「退出」、跟「移除」,老實說我分不太清它們的區別。

2010/4/16 13:58
應用擴展 工具箱

« 1 2 (3)

 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.