玉山銀行出了支援Linux Firefox的Plugin了 [論壇 - Ubuntu 哈啦]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊

« 1 2 3 (4) 5 6 7 8 »


回覆: 玉山銀行出了支援Linux Firefox的Plugin了
會員五級
註冊日期:
2008/6/15 2:56
所屬群組:
已註冊使用者
等級: 38
HP : 189 / 945
MP : 757 / 31338
EXP: 81
離線
照這樣說不用玉山的金融卡,也可以用他的服務嗎?

什麼是「玉山WebATM」?

註1:只要您持國內各金融機構發行之晶片金融卡持卡人均可使用,亦不用額外申請。
註2:本服務手續費比照ATM服務,除跨行轉帳手續費每筆新台幣17元外,其他服務目前皆為免費。

2009/6/18 4:54
應用擴展 工具箱
回覆: 玉山銀行出了支援Linux Firefox的Plugin了
會員一級
註冊日期:
2006/10/19 10:49
所屬群組:
已註冊使用者
等級: 2
HP : 0 / 37
MP : 4 / 1429
EXP: 50
離線
各位好,我是最近才把作業環境固定在 Ubuntu Desktop 8.04.1 的。我的讀卡機是 EasyATM III,我也想直接在 Ubuntu 下使用 WebATM,不過實在不太清楚該做什麼。

玉山銀行 WebATM plug-in 元件 這一頁的說明,要在 Firefox 安裝這擴充套件前,要先安裝 pcscd 及讀卡機的驅動程式

而我問了 EasyATM 的廠商,他們給的 Linux 驅動程式(直連廠商網站下載),裡面的說明檔,大概寫了這些。(節錄)

安裝 libusb 寫到:

INSTALL OF PC/SC LITE & CCID DRIVER
===================================

This document decribes the installation of PC/SC Lite and CCID driver.
You can also read the texts in particular directory.

INSTALL OF LIBUSB
=================
Before install PC/SC Lite, You should install Libusb fist. Libusb is a
portable API available for usage of USB reader.

[usr@localhost] tar xvzf Smart.tar.gz
[usr@localhost] cd libusb-0.1.8
[usr@localhost] ./configure

# Hint:You can add your own environment variables by typing ./configure -h

Compile Libusb.
[usr@localhost] make

Get the root privileges.
[root@localhost] make install

Libusb will default install in /usr/local/



不過在這階段,我就碰上了些問題。(檔案我有從 Linux Driver Smart.tar.gz 裡重新解開了)

錯誤訊息 寫到:

user@localhost:/tmp/RamDisk/Driver/libusb-0.1.8$ ./configure
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
/tmp/RamDisk/Driver/libusb-0.1.8/missing: Unknown `--run' option
Try `/tmp/RamDisk/Driver/libusb-0.1.8/missing --help' for more information
configure: WARNING: `missing' script is too old or missing
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking build system type... i686-pc-linux-gnu
checking host system type... i686-pc-linux-gnu
checking for style of include used by make... GNU
checking for gcc... gcc
checking for C compiler default output... configure: error: C compiler cannot create executables
See `config.log' for more details.

user@localhost:/tmp/RamDisk/Driver/libusb-0.1.8$ make
make: *** No targets specified and no makefile found. Stop.




檔案 missing 和 config.log 兩個,內容都很長,我就暫時不貼上來了。

我試著用 sudo 去執行 configure 也是一樣,不知道有沒有人能給些意見?謝謝。

2009/6/18 9:44
應用擴展 工具箱
回覆: 玉山銀行出了支援Linux Firefox的Plugin了
會員五級
註冊日期:
2008/10/7 21:19
所屬群組:
已註冊使用者
等級: 36
HP : 0 / 896
MP : 661 / 28900
EXP: 85
離線
有安裝編譯套件:build-essential嗎?

2009/6/18 10:41
I′m UGP
應用擴展 工具箱
guest
回覆: 玉山銀行出了支援Linux Firefox的Plugin了
Anon:guest
我也裝不起來.
我是 ubuntu 8.10 , 下載了 pcsc-lite-1.5.3.tar.bz2

cd /tmp/pcsc-lite-1.5.3
./configure --enable-libusb --disable-libhal
最後出現錯誤
configure: error: usb.h not found, use ./configure LIBUSB_CFLAGS=...

請問要如何處理..

2009/6/18 10:44 | f0a8d 71273 82209 58d38
應用擴展 工具箱
guest
回覆: 玉山銀行出了支援Linux Firefox的Plugin了
Anon:guest
奇怪, 為何玉山一直要我裝最新版元件 , 在這頁面 https://netbank.esunbank.com.tw/webatm/
然後我的 ez100 有抓到.

lsusb
Bus 002 Device 005: ID 0ca6:0010 Castles Technology Co., Ltd EZUSB PC/SC Smart Card Reader

2009/6/18 10:50 | f0a8d 71273 82209 58d38
應用擴展 工具箱
回覆: 玉山銀行出了支援Linux Firefox的Plugin了
會員一級
註冊日期:
2009/6/11 18:37
所屬群組:
已註冊使用者
等級: 2
HP : 0 / 40
MP : 5 / 1230
EXP: 62
離線
wini 寫到:
各位好,我是最近才把作業環境固定在 Ubuntu Desktop 8.04.1 的。我的讀卡機是 EasyATM III,我也想直接在 Ubuntu 下使用 WebATM,不過實在不太清楚該做什麼。

玉山銀行 WebATM plug-in 元件 這一頁的說明,要在 Firefox 安裝這擴充套件前,要先安裝 pcscd 及讀卡機的驅動程式

而我問了 EasyATM 的廠商,他們給的 Linux 驅動程式(直連廠商網站下載),裡面的說明檔,大概寫了這些。(節錄)

恕刪...

看來廠商提供的Driver很舊了,

請試試看直接用Snyaptic套件管理程式安裝看看,如下圖:
圖片

裝完後需重新開機,或 執行

sudo /etc/init.d/pcscd restart

如果執行成功,插上讀卡機,執行 pcsc_scan 看看系統有沒有捉到讀卡機

2009/6/18 10:57
應用擴展 工具箱
回覆: 玉山銀行出了支援Linux Firefox的Plugin了
會員一級
註冊日期:
2009/6/11 18:37
所屬群組:
已註冊使用者
等級: 2
HP : 0 / 40
MP : 5 / 1230
EXP: 62
離線
guest 寫到:
奇怪, 為何玉山一直要我裝最新版元件 , 在這頁面 https://netbank.esunbank.com.tw/webatm/
然後我的 ez100 有抓到.

lsusb
Bus 002 Device 005: ID 0ca6:0010 Castles Technology Co., Ltd EZUSB PC/SC Smart Card Reader


lsusb 只是列出你有接上的USB 裝置,要讓讀卡機可以運作還需要以下的三個步驟(缺一不可)
1.安裝 pcscd,pcsc-tools
2.安裝讀卡機 驅動程式
3.安裝玉山銀行 plug-in

請先執行 pcsc_scan(需安裝pcsc-tools) 看看前兩個步驟是否已經完成,如果完成應該會有如圖的回應
圖片

2009/6/18 11:13
應用擴展 工具箱
guest
回覆: 玉山銀行出了支援Linux Firefox的Plugin了
Anon:guest
出現錯誤訊息.
>pcsc_scan
PC/SC device scanner
V 1.4.14 (c) 2001-2008, Ludovic Rousseau
Compiled with PC/SC lite version: 1.4.99
SCardEstablishContext: Cannot Connect to Resource Manager: Service not available. (0x8010001D)

sudo 試著用 /etc/init.d/pcscd restart 後還是一樣,
奇怪, 是不 pcscd 起不來.

2009/6/18 11:37 | f0a8d 71273 82209 58d38
應用擴展 工具箱
回覆: 玉山銀行出了支援Linux Firefox的Plugin了
會員一級
註冊日期:
2009/6/11 18:37
所屬群組:
已註冊使用者
等級: 2
HP : 0 / 40
MP : 5 / 1230
EXP: 62
離線
guest 寫到:
出現錯誤訊息.
>pcsc_scan
PC/SC device scanner
V 1.4.14 (c) 2001-2008, Ludovic Rousseau
Compiled with PC/SC lite version: 1.4.99
SCardEstablishContext: Cannot Connect to Resource Manager: Service not available. (0x8010001D)

sudo 試著用 /etc/init.d/pcscd restart 後還是一樣,
奇怪, 是不 pcscd 起不來.


試試看以下的指令,看看有什麼錯誤訊息
>sudo pcscd -f

2009/6/18 12:31
應用擴展 工具箱
回覆: 玉山銀行出了支援Linux Firefox的Plugin了
會員一級
註冊日期:
2006/10/19 10:49
所屬群組:
已註冊使用者
等級: 2
HP : 0 / 37
MP : 4 / 1429
EXP: 50
離線
感謝 nyson,裝好 libccid libpcsclite1 libpcsc-perl pcscd pcsc-tools 這些套件並重啟 pcscd 後,就可以正常驅動讀卡機的功能了。

接著只要裝玉山銀行提供的 Firefox 擴充套件重開 Firefox,就可以正常使用玉山銀行的 WebATM 了。

(不過比較可惜的是,非玉山的卡只能使用一小部分的功能……)

nyson 寫到:
wini 寫到:
各位好,我是最近才把作業環境固定在 Ubuntu Desktop 8.04.1 的。我的讀卡機是 EasyATM III,我也想直接在 Ubuntu 下使用 WebATM,不過實在不太清楚該做什麼。

玉山銀行 WebATM plug-in 元件 這一頁的說明,要在 Firefox 安裝這擴充套件前,要先安裝 pcscd 及讀卡機的驅動程式

而我問了 EasyATM 的廠商,他們給的 Linux 驅動程式(直連廠商網站下載),裡面的說明檔,大概寫了這些。(節錄)

恕刪...

看來廠商提供的Driver很舊了,

請試試看直接用Snyaptic套件管理程式安裝看看,如下圖:
圖片

裝完後需重新開機,或 執行

sudo /etc/init.d/pcscd restart

如果執行成功,插上讀卡機,執行 pcsc_scan 看看系統有沒有捉到讀卡機

2009/6/18 13:01
應用擴展 工具箱

« 1 2 3 (4) 5 6 7 8 »

 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.