Bumblebee 3.1 已經發行 附有 Primus 支援 [論壇 - 自由軟體中文翻譯討論]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊



Bumblebee 3.1 已經發行 附有 Primus 支援

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1053 / 1756
MP : 4456 / 67451
EXP: 24
離線
Bumblebee 3.1 Released With Primus Support [Nvidia Optimus GPU Switching]

如果你的顯卡支援 Optimus 功能 :

0. Bumblebee 3.1 已經發行 附有 Primus 支援

1. 安裝 Bumblebee 3.1 (Ubuntu 13.04 12.10 12.04 11.10 10.04)
sudo add-apt-repository ppa:bumblebee/stable
sudo apt-get update
sudo apt-get install bumblebee bumblebee-nvidia

2. 登出 再登入

3. 如果 你不是 安裝 ubuntu 官方套件庫 顯卡驅動 nvidia-current 需要 修改 設定檔
sudo gedit /etc/bumblebee/bumblebee.conf
<修改內容待補充>

4. 從終端機 試試
optirun glxspheres

5. 使用具有 Optimus 功能的 nVidia 顯卡 執行程式或遊戲 例如 Steam 遊戲
optirun steam

6. 增加 Primus 支援

6-1. 安裝 primus
6-1-1. 從 ppa:bumblebee/stable
sudo add-apt-repository ppa:bumblebee/stable
sudo apt-get update
sudo apt-get install primus # 只適用於 32 bits
sudo apt-get install primus-libs-ia32:i386 # 只適用於 64 bits
6-1-2. 從 ppa:zhurikhin/primus
sudo add-apt-repository ppa:zhurikhin/primus
sudo apt-get update
sudo apt-get install primus # 只適用於 32 bits
sudo apt-get install primus-lib:i386:i386 # 只適用於 64 bits
6-1-3. 6-1-1 及 6-1-2. 只能任選一種.
如果你已經從其中一個來源庫安裝 primus
要從另外一個來源庫安裝另一個 primus 以前
必須先移除已經安裝的 primus 以及 其原來的 ppa 來源庫

6-2. 修改設定檔
sudo gedit /etc/bumblebee/bumblebee.conf
把 "Bridge" 參數值 改爲 "primus"
6-2-1. 也可以使用 指令 optirun 直接 呼叫 primus
optirun -b primus APP # APP 表示 程式或遊戲
6-2-2. 例如 steam
optirun -b primus steam

7. License: CC BY-SA 3.0

2013/2/26 18:30
應用擴展 工具箱


 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.