ubuntu完全手冊 第八章 安裝java Runtime Environment不能安裝 呀 [論壇 - Ubuntu 中文書籍討論區]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊

(1) 2 »


ubuntu完全手冊 第八章 安裝java Runtime Environment不能安裝 呀

註冊日期:
2006/12/20 1:25
所屬群組:
已註冊使用者
等級: NAN
HP : NAN / NAN
MP : NAN / NAN
EXP: NAN
離線
ubuntu完全手冊 第八章 安裝java Runtime Environment不能安裝 呀

書上的操作方式是 sudo apt-get install sun-java5-jre sun-java5-plugin

但是沒有用耶

2007/1/18 2:24
應用擴展 工具箱
Re: ubuntu完全手冊 第八章 安裝java Runtime Environment不能安裝 呀
管理員
註冊日期:
2005/6/10 6:54
所屬群組:
網站管理員
已註冊使用者
等級: 4
HP : 0 / 92
MP : 11 / 3839
EXP: 68
離線
有無錯誤訊息?

是否開啟 multiverse 套件庫?

你的 Ubuntu 版本是 edgy 嗎?


2007/1/18 11:06
應用擴展 工具箱
Re: ubuntu完全手冊 第八章 安裝java Runtime Environment不能安裝 呀
會員五級
註冊日期:
2007/1/15 14:06
所屬群組:
已註冊使用者
等級: 29
HP : 0 / 705
MP : 369 / 26127
EXP: 20
離線
選單> 添加/移除程式 搜尋java, 打勾, 套用
這樣比較快, 我裝都ok

除非你是amd64版本, 那可能就得再等一陣子了

2007/1/18 12:04
應用擴展 工具箱
Re: ubuntu完全手冊 第八章 安裝java Runtime Environment不能安裝 呀

註冊日期:
2006/12/20 1:25
所屬群組:
已註冊使用者
等級: NAN
HP : NAN / NAN
MP : NAN / NAN
EXP: NAN
離線
是的 我的是edgy的版本。
利用本書的內容安裝不能安裝~

利用synatpic 安裝java 是1.42的版本,這是舊版的吧~那有什麼差別呢

請各位前輩多多指教~~謝謝~


2007/1/19 0:19
應用擴展 工具箱
Re: ubuntu完全手冊 第八章 安裝java Runtime Environment不能安裝 呀
會員五級
註冊日期:
2007/1/15 14:06
所屬群組:
已註冊使用者
等級: 29
HP : 0 / 705
MP : 369 / 26127
EXP: 20
離線
http://java.sun.com/javase/namechange.html

The number "5.0" was arrived at by dropping the leading "1." from "1.5.0". Where you might have expected to see 1.5.0, it is now 5.0 (and where it was 1.5, it is now 5).


J2SE 1.4.2 Mantis June 26, 2003
J2SE 5.0 (1.5.0) Tiger Sept 29, 2004

Sun故意將編號搞得很複雜, 一般人絕對弄不清楚...

1.5.0 是開發者代號, 正式版本號是 5.0

正式版本號5.0 就是砍掉代號前面的"1"

舊版真的沒差, 可用就好!

比較有差的是Flash... 凸 (給Adobe)

2007/1/19 9:28
應用擴展 工具箱
Re: ubuntu完全手冊 第八章 安裝java Runtime Environment不能安裝 呀

註冊日期:
2006/12/20 1:25
所屬群組:
已註冊使用者
等級: NAN
HP : NAN / NAN
MP : NAN / NAN
EXP: NAN
離線
那在請教一個問題是奇摩網站上有一些是用macromedia FLASH 7 Plug-in,但 裝了以後網頁就firefox就開不了了,會一直關閉,一開馬上就關閉了
為什麼呢
....

2007/1/19 12:05
應用擴展 工具箱
Re: ubuntu完全手冊 第八章 安裝java Runtime Environment不能安裝 呀
會員五級
註冊日期:
2007/1/15 14:06
所屬群組:
已註冊使用者
等級: 29
HP : 0 / 705
MP : 369 / 26127
EXP: 20
離線
你裝的一定是flash 9, flash 7沒問題, 雖然右鍵選單會出現亂碼, 但那算是"正常"

去添加移除, 徹底移除flash 9

檢查 .mozilla/plugins 資料夾內的 libflashplayer.so 之類有沒有刪掉,

/usr/lib/firefox/plugins/libflashplayer.so 也找找, 還看到就用sudo rm 砍了

最後重裝Flash 7, 我找不到Adboe網路上的舊檔案... 到這裡看看囉:

http://sluglug.ucsc.edu/macromedia/site_ucsc.html

Good Luck!

2007/1/19 12:45
應用擴展 工具箱
Re: ubuntu完全手冊 第八章 安裝java Runtime Environment不能安裝 呀
會員五級
註冊日期:
2007/1/15 14:06
所屬群組:
已註冊使用者
等級: 29
HP : 0 / 705
MP : 369 / 26127
EXP: 20
離線
這是我上國外網站看到的解法 (應該是和咱們這裡ssh大大是同一人)

Re: flashplugin-nonfree 9.0.21.78.2 from ssh at 2006-12-07 03:13:47 UTC

https://launchpad.net/ubuntu/+source/flashplugin-nonfree/+bug/74738

I use LANG=zh_TW.UTF-8 in my edgy.
I found this bug , if the flickr flash photo player in the Website (Blog), the firefox 2 crash.
But I use "unset XMODIFIERS; export LC_ALL=en_US.UTF-8" , use Firefox 2 again .
I visit the Website (have flickr flash photo player), the Firefox 2 is normal.

The flashplugin-nonfree package is 9.0.21.78.2ubuntu .

Thanks.



Edgy Flash player 9
http://blog.ssh.tw/?p=331
December 7th, 2006 by sshsiung

若這幾天用 Edgy 更新到 Flash player 9 (flashplugin-nonfree 9.0.21.78.2.ubuntu) , 請小心了, 因為 flash player 9 套件問題?
所以在瀏覽某些網站, 會造成 firefox 2 crash , 暫時解決方法就是不要安裝 Flash Player 9

sudo apt-get remove flashplugin-nonfree

或者退回到 flash player 7 。

Edgy 套件品質又被扣分了 :(

update: 回報 Bug

https://launchpad.net/distros/ubuntu/+source/flashplugin-nonfree/+bug/74738

update:目前暫時解決方法

sudo vi /usr/bin/firefox 加上這兩行
unset XMODIFIERS

export LC_ALL=en_US.UTF-8

Trackback URI | Comments RSS


(非官方教學手冊內好像也有寫)

請多用站內搜尋

2007/1/19 13:04
應用擴展 工具箱
Re: ubuntu完全手冊 第八章 安裝java Runtime Environment不能安裝 呀

註冊日期:
2006/12/20 1:25
所屬群組:
已註冊使用者
等級: NAN
HP : NAN / NAN
MP : NAN / NAN
EXP: NAN
離線
謝謝 bird 哥 ,那麼仔細的回答後輩的問題
真的很感謝。

2007/1/19 17:23
應用擴展 工具箱
Re: ubuntu完全手冊 第八章 安裝java Runtime Environment不能安裝 呀
會員五級
註冊日期:
2007/1/15 14:06
所屬群組:
已註冊使用者
等級: 29
HP : 0 / 705
MP : 369 / 26127
EXP: 20
離線
賣啦, 我不是什麼哥... bird = 鳥...

就是菜鳥的鳥也

接觸Ubuntu不到一個月... 只因為 Ubuntu真的很好學,

所以我才能學一個月便提了半桶水在這邊現學現賣

像我資質這麼魯鈍的都能上來分享使用經驗了, 可見Ubuntu有多好用!

就算大家都是菜鳥也罷, 總之互相學習咩~


2007/1/20 0:11
應用擴展 工具箱

(1) 2 »

 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.