[已解決]關於安裝Kompozer 找不到套件 [論壇 - Ubuntu安裝問題]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊

(1) 2 3 »


[已解決]關於安裝Kompozer 找不到套件
會員二級
註冊日期:
2014/9/22 11:50
所屬群組:
已註冊使用者
等級: 8
HP : 0 / 182
MP : 29 / 2709
EXP: 29
離線
小弟想要安裝Kompozer 作網頁
按照http://wiki.ubuntu-tw.org/index.php?title=Kompozer 操作
到了
sudo apt-get install kompozer
這一步驟時
出現
正在讀取套件清單... 完成
正在重建相依關係
正在讀取狀態資料... 完成
E: 找不到套件 kompozer

請問該怎麼辦順利完成安裝呢?

2014/10/6 11:48
應用擴展 工具箱
回覆: [請益]關於安裝Kompozer 找不到套件
會員五級
註冊日期:
2012/4/22 10:50
所屬群組:
已註冊使用者
等級: 34
HP : 169 / 847
MP : 574 / 18579
EXP: 90
離線
Neilcc 寫到:
小弟想要安裝Kompozer 作網頁
按照http://wiki.ubuntu-tw.org/index.php?title=Kompozer 操作
到了
sudo apt-get install kompozer
這一步驟時
出現
正在讀取套件清單... 完成
正在重建相依關係
正在讀取狀態資料... 完成
E: 找不到套件 kompozer

請問該怎麼辦順利完成安裝呢?


我印象中 kompozer 應該沒在ubuntu的套件庫

$ apt-cache search kompozer

直接去官網下載吧

另外以前好像瞥見,跟kompozer同樣性質的軟體,好像有另外一個,忘了叫啥?

找到再來補充

更新:

* 剛看到有ppa可以加

https://launchpad.net/~giuseppe-iuculano/+archive/ubuntu/ppa


* 剛到「wiki / KompoZer」查到了,我說的那套叫「BlueGriffon」。我以前是從「這篇文章」看到的。


* 剛測試加入ppa的方式,結果不行,「看起來」是沒有新的套件符合目前的ubuntu。

$ sudo add-apt-repository ppa:giuseppe-iuculano/ppa
$ sudo apt-get update

會出現下面的訊息
----------------------------------
...
W: Failed to fetch http://ppa.launchpad.net/giuseppe-iuculano/ppa/ubuntu/dists/trusty/main/binary-i386/Packages 404 Not Found

E: Some index files failed to download. They have been ignored, or old ones used instead.
----------------------------------

這個方式,跟你一開始提到的哪個「網頁」說的方式,本質上是一樣的,我一開始沒看到「這一頁」,就回覆你了,歹勢 :p

* 先提供一個可以使用「bluegriffon」的安裝方式吧

## 32位元
$ wget -c http://bluegriffon.org/freshmeat/1.7.2/bluegriffon-1.7.2.Ubuntu13.04.i686.tar.bz2
$ tar xf bluegriffon-1.7.2.Ubuntu13.04.i686.tar.bz2
$ cd bluegriffon
$ ./bluegriffon

以上是在xubuntu 14.04 32位元測試的

## 64位元

$ wget -c http://bluegriffon.org/freshmeat/1.7.2/bluegriffon-1.7.2.Ubuntu13.04.x86_64.tar.bz2
$ tar xf bluegriffon-1.7.2.Ubuntu13.04.x86_64.tar.bz2
$ cd bluegriffon
$ ./bluegriffon
以上是在xubuntu 14.04 64位元測試的

* 另外我有測試兩個方式安裝「Kompozer」,以下是在xubuntu 14.04 32位元測試的。

# 直接下載tarball。
$ wget -O kompozer-0.8b3.zh-TW.gcc4.2-i686.tar.gz -c http://downloads.sourceforge.net/project/kompozer/current/0.8b3/linux-i686/kompozer-0.8b3.zh-TW.gcc4.2-i686.tar.gz?r=http%3A%2F%2Fwww.kompozer.net%2Fdownload.php&ts=1412572407&use_mirror=ncu

$ tar xf kompozer-0.8b3.zh-TW.gcc4.2-i686.tar.gz
$ cd kompozer/
$ ./kompozer

下面的方式好像都沒作用,所以作罷,沒有去深究為甚麼沒有作用 。
不過過程中發現要安裝「libjpeg62」這個套件。應該是讓上面有作用的原因,因為我一開始測試tarball的方式是沒作用的。後來又有了。
以下貼出來當參考吧
# 直接下在deb來安裝,請參考「這一頁
$ sudo apt-get install libjpeg62

$ wget -c http://ppa.launchpad.net/giuseppe-iuculano/ppa/ubuntu/pool/main/k/kompozer/kompozer-data_0.8~b3-2~ubuntu10.04~1_all.deb
$ wget -c http://ppa.launchpad.net/giuseppe-iuculano/ppa/ubuntu/pool/main/k/kompozer/kompozer_0.8~b3-2~ubuntu10.04~1_i386.deb


$ sudo dpkg -i kompozer-data_0.8~b3-2~ubuntu10.04~1_all.deb
$ sudo dpkg -i kompozer_0.8~b3-2~ubuntu10.04~1_i386.deb

$ komposer #沒有反應...


2014/10/6 12:09
應用擴展 工具箱
回覆: [請益]關於安裝Kompozer 找不到套件
會員五級
註冊日期:
2009/10/16 8:57
所屬群組:
已註冊使用者
等級: 22
HP : 0 / 541
MP : 204 / 15861
EXP: 67
離線
to Neilcc:

在目前網頁標準混沌不明,誰也不服誰的情況下,寫網頁是很累的。

建議可以用這類工具來學習網頁的技巧,但不要用來真正寫動態網頁。你可用它來設計基本架構(可不用就不用)。

這類網頁輔助工具個人感覺寫靜態網頁較合適。

我目前就碰到一個慘痛的經驗,你可參考:
http://www.ubuntu-tw.org/modules/newbb/viewtopic.php?post_id=326696#forumpost326696

原作者就是用類似的工具 Adobe Dreamweaver 一頁一頁照抄 Orz..

2014/10/6 13:50
同源一体、感同身受、樂於分享、教學相長!
寬廣的心, 世界不會小 ^_^
CreMaker 的生活網誌
應用擴展 工具箱
回覆: [請益]關於安裝Kompozer 找不到套件
會員二級
註冊日期:
2014/9/22 11:50
所屬群組:
已註冊使用者
等級: 8
HP : 0 / 182
MP : 29 / 2709
EXP: 29
離線
小弟進到
Kompozer官網
之後下載
但是目前卡到一個問題
如何打開kompozer-0.8b3.zh-TW.gcc4.2-i686.tar.gz 檔案?

2014/10/6 14:06
應用擴展 工具箱
回覆: [請益]關於安裝Kompozer 找不到套件
會員五級
註冊日期:
2012/4/22 10:50
所屬群組:
已註冊使用者
等級: 34
HP : 169 / 847
MP : 574 / 18579
EXP: 90
離線
Neilcc 寫到:
小弟進到
Kompozer官網
之後下載
但是目前卡到一個問題
如何打開kompozer-0.8b3.zh-TW.gcc4.2-i686.tar.gz 檔案?


$ tar xf kompozer-0.8b3.zh-TW.gcc4.2-i686.tar.gz

上面的回覆,我有更新,要請你再看一次,歹勢,我是陸續寫上去的。

另外關於「tar」的用法,可以參考我之前回覆其他議題的這篇

另外建議閱讀「這篇教學」,講的比較詳細摟。


2014/10/6 14:18
應用擴展 工具箱
回覆: [請益]關於安裝Kompozer 找不到套件
版主
註冊日期:
2008/7/14 0:03
來自 螢幕的另一端
所屬群組:
網站管理員
已註冊使用者
討論區管理群
等級: 32
HP : 0 / 798
MP : 497 / 26322
EXP: 95
離線
直接加舊版的軟體來源來安裝是最快的方法
sudo vim /etc/apt/sources.list
加入底下這行
#just for kompozer
deb http://ftp.tw.debian.org/debian/ squeeze main non-free
然後下指令
aptitude update
aptitude install kompozer
安裝完之後,要記得把剛剛加進去的那行給註解掉,避免出錯。
另外要處理一下自動斷行問題,請參考此頁

2014/10/6 15:50
應用擴展 工具箱
回覆: [請益]關於安裝Kompozer 找不到套件
會員四級
註冊日期:
2010/10/28 17:23
來自 台灣-台南市
所屬群組:
已註冊使用者
等級: 19
HP : 0 / 464
MP : 148 / 12206
EXP: 59
離線
kompozer似乎很久沒維護了,所以可能因此被移出套件庫。
我目前是用bluefish,程式碼部份功能很不錯,缺點是沒有所見即所得。

2014/10/6 16:55
lubuntu 16.04.2 (AMD64)
ASUS K53BR筆電
RAM: 1.5GB
應用擴展 工具箱
回覆: [請益]關於安裝Kompozer 找不到套件
會員二級
註冊日期:
2014/9/22 11:50
所屬群組:
已註冊使用者
等級: 8
HP : 0 / 182
MP : 29 / 2709
EXP: 29
離線
reppk 寫到:
kompozer似乎很久沒維護了,所以可能因此被移出套件庫。
我目前是用bluefish,程式碼部份功能很不錯,缺點是沒有所見即所得。



小弟跟大大是一樣情況
目前苦用blusfish
因為沒有立即顯示已經修改的結果
所以才詢問kompozer的安裝問題 :(

2014/10/6 17:09
應用擴展 工具箱
回覆: [請益]關於安裝Kompozer 找不到套件
會員五級
註冊日期:
2012/4/22 10:50
所屬群組:
已註冊使用者
等級: 34
HP : 169 / 847
MP : 574 / 18579
EXP: 90
離線
Neilcc 寫到:
reppk 寫到:
kompozer似乎很久沒維護了,所以可能因此被移出套件庫。
我目前是用bluefish,程式碼部份功能很不錯,缺點是沒有所見即所得。



小弟跟大大是一樣情況
目前苦用blusfish
因為沒有立即顯示已經修改的結果
所以才詢問kompozer的安裝問題 :(


既然你懂得html,寫網頁,其實只要「純文字編輯器」,搭配「瀏覽器」,就應該很足夠了。
有的人會搭配「live reload」,但我還是習慣手動重整瀏覽器頁面。
呵呵,這是我個人習慣,聽聽就好。

「瀏覽器」最常選的是「Firefox」或是「Chrome」。

「Firefox」我都會安裝「firebug」。
不過現在「Firefox」有內建的「Developer Tools」,你可以善用他的「Inspector」的功能。
按下「Ctrl + Shift + i」,就可以叫出「Developer Tools」,在他的左上方,有一個「箭頭+box」的圖示,
你按下他,就可以在你所在的頁面,想要找的元素按下,就會指到那段程式碼了。

「Firebug」也有這樣的功能。

在「Chrome」也有相同的功能,一樣按下「Ctrl + Shift + i」,就可以叫出「Developer Tools」,然後選擇左上方的「放大鏡(查詢)」圖示。
一樣可以在所在的頁面,想要找的元素按下,就會指到那段程式碼了。

以上小小的經驗參考


2014/10/6 17:44
應用擴展 工具箱
回覆: [請益]關於安裝Kompozer 找不到套件
會員二級
註冊日期:
2014/9/22 11:50
所屬群組:
已註冊使用者
等級: 8
HP : 0 / 182
MP : 29 / 2709
EXP: 29
離線
samwhelp 寫到:
Neilcc 寫到:
reppk 寫到:
kompozer似乎很久沒維護了,所以可能因此被移出套件庫。
我目前是用bluefish,程式碼部份功能很不錯,缺點是沒有所見即所得。



小弟跟大大是一樣情況
目前苦用blusfish
因為沒有立即顯示已經修改的結果
所以才詢問kompozer的安裝問題 :(


既然你懂得html,寫網頁,其實只要「純文字編輯器」,搭配「瀏覽器」,就應該很足夠了。
有的人會搭配「live reload」,但我還是習慣手動重整瀏覽器頁面。
呵呵,這是我個人習慣,聽聽就好。

「瀏覽器」最常選的是「Firefox」或是「Chrome」。

「Firefox」我都會安裝「firebug」。
不過現在「Firefox」有內建的「Developer Tools」,你可以善用他的「Inspector」的功能。
按下「Ctrl + Shift + i」,就可以叫出「Developer Tools」,在他的左上方,有一個「箭頭+box」的圖示,
你按下他,就可以在你所在的頁面,想要找的元素按下,就會指到那段程式碼了。

在「Chrome」也有相同的功能,一樣按下「Ctrl + Shift + i」,就可以叫出「Developer Tools」,然後選擇左上方的「放大鏡(查詢)」圖示。
一樣可以在所在的頁面,想要找的元素按下,就會指到那段程式碼了。

以上小小的經驗參考




關於Firefox、Chrome的內建網頁開發工具小弟已經有用過了XD
而且小弟作的網頁檔案都存放在磁碟裡面
所以打算用類似frontpage軟體製作
才來找只能在linux用的kompozer軟體
另外
大大知道如果用Firefox、Chrome的開發工具作網頁
那些網頁檔案存放的地方嗎?

2014/10/6 18:35
應用擴展 工具箱

(1) 2 3 »

 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.