無法安裝bin ---- bash: No such file or directory [論壇 - 新手村]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊



無法安裝bin ---- bash: No such file or directory
會員一級
註冊日期:
2011/2/7 0:54
所屬群組:
已註冊使用者
等級: 3
HP : 0 / 57
MP : 7 / 1731
EXP: 31
離線
最近想要在vmplayer 中的 14.04 64bit 下安裝 android NDK

於是到 https://developer.android.com/tools/sdk/ndk/index.html

下載了 Linux 64-bit (x86) 版本的.bin


按照下面的 install guide

chmod a+x android-ndk-r10c-linux-x86_64.bin
./android-ndk-r10c-darwin-x86_64.bin

但這時候卻出現 bash: /android-ndk-r10c-linux-x86_64.bin: No such file or directory


自首一下我沒花很多時間找答案 ...... (死

我看了一般的問題大部分都是系統跟安裝檔位元不同,才會出現這種問題,或者是沒有讓.bin變成 executable


請問有各為大大有其他解嗎 感恩

2014/11/2 2:46
應用擴展 工具箱
回覆: 無法安裝bin ---- bash: No such file or directory
會員五級
註冊日期:
2012/4/22 10:50
所屬群組:
已註冊使用者
等級: 35
HP : 172 / 861
MP : 598 / 22776
EXP: 45
離線
Fallenzone 寫到:
最近想要在vmplayer 中的 14.04 64bit 下安裝 android NDK

於是到 https://developer.android.com/tools/sdk/ndk/index.html

下載了 Linux 64-bit (x86) 版本的.bin


按照下面的 install guide

chmod a+x android-ndk-r10c-linux-x86_64.bin
./android-ndk-r10c-darwin-x86_64.bin

但這時候卻出現 bash: /android-ndk-r10c-linux-x86_64.bin: No such file or directory


自首一下我沒花很多時間找答案 ...... (死

我看了一般的問題大部分都是系統跟安裝檔位元不同,才會出現這種問題,或者是沒有讓.bin變成 executable


請問有各為大大有其他解嗎 感恩


我在我的系統測試OK。我測試的環境是「Xubuntu 14.04 64位元」。

我執行的方式如下,應該跟你的方式是一樣的

```sh
$ wget -c http://dl.google.com/android/ndk/android-ndk-r10c-linux-x86_64.bin
$ chmod a+x android-ndk-r10c-linux-x86_64.bin
$ ./android-ndk-r10c-linux-x86_64.bin
```

猜測你是不是檔案「android-ndk-r10c-linux-x86_64.bin」沒有下載完整?

用下面的指令來確認

```sh
$ md5sum android-ndk-r10c-linux-x86_64.bin
```

應該會出現下面的

```sh
792c61706cd9ec6713fa1b69b2f42996 android-ndk-r10c-linux-x86_64.bin
```

比對你上面哪一頁的「MD5 Checksum」那個欄位的值。
若值不一樣,表示你的檔案跟他提供的是不一致的。

```
$ ls -l android-ndk-r10c-linux-x86_64.bin
```

應該也要看到檔案的大小是「449013322」,要符合「Size (Bytes)」那個欄位的值。


另外你是不是有在「這裡」發帖詢問。
因為我用「bash: /android-ndk-r10c-linux-x86_64.bin: No such file or directory」查詢。
因為我覺得這個訊息怎麼不是「bash: ./android-ndk-r10c-linux-x86_64.bin: No such file or directory」。,前面少了個「.」,呵呵,結果就查到那篇。


另外發現一件事,也是那篇討論到的。

就是哪個「android-ndk-r10c-linux-x86_64.bin」是「7zip自我解壓縮檔」。

若你的已經解過一次,就會存在一個資料夾「android-ndk-r10c」
然後你在執行一次「./android-ndk-r10c-linux-x86_64.bin 」。
就會出現下面的訊息。

```
7-Zip SFX 9.20 Copyright (c) 1999-2010 Igor Pavlov 2010-11-18
p7zip Version 9.20 (locale=en_US.UTF-8,Utf16=on,HugeFiles=on,4 CPUs)

Processing archive: ./android-ndk-r10c-linux-x86_64.bin

file android-ndk-r10c/prebuilt/linux-x86_64/bin/2to3
already exists. Overwrite with
android-ndk-r10c/prebuilt/linux-x86_64/bin/2to3?
(Y)es / (N)o / (A)lways / (S)kip all / A(u)to rename all / (Q)uit?
```

所以若你有安裝「p7zip-full」這個套件的話。

執行

```sh
$ dpkg --get-selections | grep p7zip-full
```


```sh
dpkg -l p7zip-full
```
檢查「p7zip-full」是否有安裝。

若沒有安裝的話,先安裝「p7zip-full」這個套件

```sh
$ sudo apt-get install p7zip-full
```

也可以執行下面的指令來解壓縮「android-ndk-r10c-linux-x86_64.bin」那個檔

```sh
$ 7z x android-ndk-r10c-linux-x86_64.bin
```

其他關於權限的設定,請參考「這篇」的說明。


2014/11/2 10:27
應用擴展 工具箱
回覆: 無法安裝bin ---- bash: No such file or directory
會員一級
註冊日期:
2011/2/7 0:54
所屬群組:
已註冊使用者
等級: 3
HP : 0 / 57
MP : 7 / 1731
EXP: 31
離線
1.感謝你 ,我最後使用 7z 的方式解決

2.對不起,我漏打了一個 ".",然後我沒有在google code 上詢問 哈哈,我下次會先去那邊看看的!謝謝



我最後也找到真正的問題如下 :

http://blog.qt.digia.com/blog/2014/03/26/qt-weekly-3-qt-for-android-tips-and-tricks/


Linux 64-bit: Android SDK installation on 64-bit Linux machines (Ubuntu, Fedora) often doesn’t work out of the box. Running <PATH_SDK>/platform-tools/adb can return errors like:

Ubuntu: bash: ./adb: No such file or directory
Fedora: adb: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory or adb: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory


the SDK comes with 32-bit version of the libraries. To fix this problem you can install:

Ubuntu: sudo apt-get install libstdc++6:i386

Fedora: yum install glibc.i686 glibc-devel.i686 libstdc++.i686 zlib-devel.i686 ncurses-devel.i686 libX11-devel.i686 libXrender.i686 libXrandr.i686


再次謝謝大大 !!!

2014/11/3 1:53
應用擴展 工具箱
回覆: 無法安裝bin ---- bash: No such file or directory
會員五級
註冊日期:
2012/4/22 10:50
所屬群組:
已註冊使用者
等級: 35
HP : 172 / 861
MP : 598 / 22776
EXP: 45
離線
呵呵,我才要感謝你,讓我學到新東西。

喔喔,根據你這篇的說明,這樣終於說得通了,為什麼我測試會成功了。

我就在納悶「這篇」提到的一件事。

我用下面指令

```sh
$ file android-ndk-r10c-linux-x86_64.bin
```
也是會出現
```
android-ndk-r10c-linux-x86_64.bin: ELF 32-bit LSB executable, Intel 80386, version 1 (SYSV), dynamically linked (uses shared libs), for GNU/Linux 2.6.24, BuildID[sha1]=e66db713307fc18e379de1e2fc79b3f8af074120, stripped
```
主要是這個「ELF 32-bit LSB executable」讓我納悶。因為我的環境是「Xubuntu 14.04 64位元」。

而你這篇提到的「Ubuntu: sudo apt-get install libstdc++6:i386」。

我的確有裝。因為我之前安裝「skype」和「teamviewer」 的關係,應該伴隨著有裝這個lib

所以在我的64位元環境測試,才會成功。

```sh
$ wget -c http://dl.google.com/android/ndk/android-ndk-r10c-linux-x86_64.bin
$ chmod a+x android-ndk-r10c-linux-x86_64.bin
$ ./android-ndk-r10c-linux-x86_64.bin
```

===============================================================

檢查系統是否有安裝「libstdc++6:i386」。

```
dpkg -l libstdc++6:i386
```
===============================================================

下載並解開「skype-ubuntu-precise_4.3.0.37-1_i386.deb」。

```sh
$ wget -c http://download.skype.com/linux/skype-ubuntu-precise_4.3.0.37-1_i386.deb
$ dpkg -e skype-ubuntu-precise_4.3.0.37-1_i386.deb
```
觀看control資訊

```sh
$ vi DEBIAN/control
```
就會看到「Depends」哪個欄位,有「libstdc++6 」,所以當我安裝「skype」時,我的系統也有設定「sudo dpkg --add-architecture i386」,就會安裝「libstdc++6 」這個「32位元」的套件。

```
Depends: libc6 (>= 2.3.6-6~), libc6 (>= 2.7), libgcc1 (>= 1:4.1.1), libqt4-dbus (>= 4:4.5.3), libqt4-network (>= 4:4.8.0), libqt4-xml (>= 4:4.5.3), libqtcore4 (>= 4:4.7.0~beta1), libqtgui4 (>= 4:4.8.0), libqtwebkit4 (>= 2.2~2011week36), libstdc++6 (>= 4.2.1), libx11-6, libxext6, libxss1, libxv 1, libssl1.0.0, libpulse0, libasound2-plugins
```
===============================================================

下載並解開「teamviewer_linux_x64.v9.0.32150.deb」。

```sh
$ wget -c http://download.teamviewer.com/download/teamviewer_linux_x64.deb -O teamviewer_linux_x64.v9.0.32150.deb
$ dpkg -e teamviewer_linux_x64.v9.0.32150.deb
```
觀看control資訊

```sh
$ vi DEBIAN/control
```

就會看到

```
Depends: bash (>= 3.0), libc6-i386 (>= 2.4), lib32asound2, lib32z1, libxext6, ia32-libs
```


Fallenzone 寫到:
1.感謝你 ,我最後使用 7z 的方式解決

2.對不起,我漏打了一個 ".",然後我沒有在google code 上詢問 哈哈,我下次會先去那邊看看的!謝謝



我最後也找到真正的問題如下 :

http://blog.qt.digia.com/blog/2014/03/26/qt-weekly-3-qt-for-android-tips-and-tricks/


Linux 64-bit: Android SDK installation on 64-bit Linux machines (Ubuntu, Fedora) often doesn’t work out of the box. Running <PATH_SDK>/platform-tools/adb can return errors like:

Ubuntu: bash: ./adb: No such file or directory
Fedora: adb: /lib/ld-linux.so.2: bad ELF interpreter: No such file or directory or adb: error while loading shared libraries: libstdc++.so.6: cannot open shared object file: No such file or directory


the SDK comes with 32-bit version of the libraries. To fix this problem you can install:

Ubuntu: sudo apt-get install libstdc++6:i386

Fedora: yum install glibc.i686 glibc-devel.i686 libstdc++.i686 zlib-devel.i686 ncurses-devel.i686 libX11-devel.i686 libXrender.i686 libXrandr.i686


再次謝謝大大 !!!

2014/11/3 3:13
應用擴展 工具箱


 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.