升級15.10後無法連線(已解決) [論壇 - Ubuntu基本設定]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊

« 1 2 3 (4)


回覆: 升級15.10後無法連線(已解決)
會員二級
註冊日期:
2015/3/28 21:29
所屬群組:
已註冊使用者
等級: 8
HP : 0 / 176
MP : 27 / 3214
EXP: 6
離線
samwhelp 寫到:
MMX 寫到:
samwhelp 寫到:
MMX 寫到:

感謝您熱心的測試,
請問,目前您如果不用ppoeconf,只用networkmanager
可以穩定的自動連線嗎?(重開機後可自動連上 xdsl)

:)



可以,我上面測試的兩個版本16.04和15.10都可以

不管是使用「ppoeconf」或是「networkmanager」
重開機後都可自動連上,而且穩定,我就是在這樣的環境回覆你的。

以上



再次感謝您的熱心,
這兩天有空時會測試以後回報,

謝謝!

:)



另外我想到我在「networkmanager」新增連線時,是「選 DSL」
然後設定時
* 除了在「DSL」那個頁籤,填帳號密碼,
* 在「Ethernet」那個頁籤的「Device」有選「enp5s0 (A3:4E:07:86:ZF:CD)」<--後面那個是Mac,下拉就有選項可以選不用填
* 在「General」的第一個選項有打勾「Automatic connect to this network when it is available」
第二個預設就有打勾了。

然後就是上面提「/etc/network/interfaces」哪裡要注意



恩,再麻煩你測試回報結果了,
你測試的時候可以觀看「/var/log/syslog」,
看看能不能找到一些線索,協助你排除障礙,


以上



感謝您的熱心

同時我認為您這
「我是先透過「無線網路」連線成功,安裝後「pppoeconf」這個套件成功後」...

您這句話是重點,
因為若只純用dsl設定
目前的xubuntu16.04 daily
(我新下載了ISO)仍是連不上的。
但還是謝謝您~
也許等正式版時我再來試試吧?謝謝

2016/4/19 19:35
應用擴展 工具箱
回覆: 升級15.10後無法連線(已解決)
會員四級
註冊日期:
2015/9/29 21:19
所屬群組:
已註冊使用者
等級: 16
HP : 0 / 380
MP : 100 / 6361
EXP: 22
離線
這就奇怪了....
從10.XX 開始, 我就沒在設定 pppoe 帳號密碼
把網路線插到電腦上, 不用設定就能上網了

中華電信 ADSL

2016/4/19 20:03
應用擴展 工具箱
回覆: 升級15.10後無法連線(已解決)
會員五級
註冊日期:
2012/4/22 10:50
所屬群組:
已註冊使用者
等級: 35
HP : 172 / 861
MP : 598 / 23044
EXP: 45
離線
Newman 寫到:


感謝您的熱心

同時我認為您這
「我是先透過「無線網路」連線成功,安裝後「pppoeconf」這個套件成功後」...

您這句話是重點,
因為若只純用dsl設定
目前的xubuntu16.04 daily
(我新下載了ISO)仍是連不上的。
但還是謝謝您~
也許等正式版時我再來試試吧?謝謝


以下純討論,

我的理解,「pppoeconf」這個套件,只是輔助撰寫設定檔的工具,

真正在連線的應該是「ppp」這個套件。

所以「pppoeconf」這個套件,不是必要安裝的,

所以我推測,也可以手寫設定檔,雖然我沒這樣嘗試過,

若有興趣探究的話,你可以再回去看我上面「回覆的紀錄」,
我有把「pppoeconf」執行完後,設定了那些檔,做一些紀錄,
不過我不確定是否完整,我只是粗略的看一下「/usr/sbin/pppoeconf」這個「shell script」來「找線索」,
沒真的完全理解裡面寫的整個流程,有些是用推敲的方式來推測的。

然後看ps,隱約看到,若是「NetworkManger」若是做「pppoe」連線,
則是載入某個「so檔(Plugin)」的樣子,這部份沒再去深究了。

以上我也只是這次和你們討論,去做測試,初步的了解,
我對這些概念,也沒真的研究透徹,
測試的結果還是要依照你們自己的環境而定。

因為我主要的環境還是會透過一個機器去串接,由那台機器去做連線,
所以我的桌機使用「pppoe」的連線的機會應該沒有。
只是這次測試,把那台機器拆掉來測試而已。

上面的紀錄,只是留給未來想要深入探索的人,可以有個入口。


以上




PS: 我也在等16.04,呵呵

2016/4/19 21:07
應用擴展 工具箱
回覆: 升級15.10後無法連線(已解決)
會員三級
註冊日期:
2011/7/9 13:27
所屬群組:
已註冊使用者
等級: 9
HP : 0 / 207
MP : 35 / 6034
EXP: 30
離線
回報一下,

晚上把系統還原到初始安裝裝態(第一次安裝後的備份),

然後測試了一下,結果是 殘念…

之前有懷疑過,是不是 hinet 的 PPPoE Authentication 方面的問題,
不過家裡有兩三款不同廠牌的無線分享器,都是samwhelp設定好PPPoE帳號密碼後一開機就連上了,
所以看來問題不是出在hinet 的 PPPoE Authentication方面 …

剩下的另一個可能,就是軟體方面的問題了,也許是程式碼或預設的一些參數改變,
導致PPPoE連不上(認證失敗?)

看看等 16.04出來了以後這問題有沒有改善了 @@

再次感謝samwhelp網友的熱心,謝謝~


:)

2016/4/19 23:56
應用擴展 工具箱

« 1 2 3 (4)

 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.