ubuntu16.04 無法安裝 google chrome ?? [論壇 - Ubuntu安裝問題]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊

« 1 (2)


回覆: ubuntu16.04 無法安裝 google chrome ??
會員一級
註冊日期:
2014/4/20 12:53
所屬群組:
已註冊使用者
等級: 2
HP : 0 / 43
MP : 5 / 466
EXP: 74
離線
雖然順利安裝成功,但chrome開的網頁,文字變得很淡很白,有辦法調整嗎?眼睛看的很不舒服@@

2016/4/24 13:13
應用擴展 工具箱
回覆: ubuntu16.04 無法安裝 google chrome ??
會員一級
註冊日期:
2014/4/20 12:53
所屬群組:
已註冊使用者
等級: 2
HP : 0 / 43
MP : 5 / 466
EXP: 74
離線
關於字體過白的問題,我剛才有google一下找一遍解決的方法,有需要的朋友可以參考一下,感謝大家的幫忙~~

http://www.ithao123.cn/content-5992636.html

2016/4/24 14:19
應用擴展 工具箱
回覆: ubuntu16.04 無法安裝 google chrome ??
會員一級
註冊日期:
2014/4/20 12:53
所屬群組:
已註冊使用者
等級: 2
HP : 0 / 43
MP : 5 / 466
EXP: 74
離線
關於字體過白的問題,我剛才有google一下找一遍解決的方法,有需要的朋友可以參考一下,感謝大家的幫忙~~

http://www.ithao123.cn/content-5992636.html

2016/4/24 14:19
應用擴展 工具箱
回覆: ubuntu16.04 無法安裝 google chrome ??
會員二級
註冊日期:
2008/12/6 11:34
所屬群組:
已註冊使用者
等級: 6
HP : 0 / 147
MP : 21 / 3886
EXP: 89
離線
怎麼試還是不行,連帶系統更新也出問題。


vege@vege-G1-Sniper-B6:~$ wget -c https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb

--2017-01-28 21:37:15-- https://dl.google.com/linux/direct/google-chrome-stable_current_amd64.deb
正在查找主機 dl.google.com (dl.google.com)... 74.125.203.93, 74.125.203.136, 74.125.203.190, ...
正在連接 dl.google.com (dl.google.com)|74.125.203.93|:443... 連上了。
已送出 HTTP 要求,正在等候回應... 200 OK
長度: 45722926 (44M) [application/x-debian-package]
Saving to: ‘google-chrome-stable_current_amd64.deb’

google-chrome-stabl 100%[===================>] 43.60M 2.39MB/s in 18s

2017-01-28 21:37:33 (2.37 MB/s) - ‘google-chrome-stable_current_amd64.deb’ saved [45722926/45722926]

vege@vege-G1-Sniper-B6:~$ sudo dpkg -i google-chrome-stable_current_amd64.deb
(讀取資料庫 ... 目前共安裝了 238328 個檔案和目錄。)
準備解開 google-chrome-stable_current_amd64.deb ...
Unpacking google-chrome-stable (56.0.2924.76-1) over (56.0.2924.76-1) ...
dpkg: 因相依問題,無法設定 google-chrome-stable:
google-chrome-stable 相依於 libappindicator1﹔然而:
套件 libappindicator1 未安裝。

dpkg: error processing package google-chrome-stable (--install):
相依問題 - 保留未設定
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for man-db (2.7.5-1) ...
處理時發生錯誤:
google-chrome-stable
vege@vege-G1-Sniper-B6:~$ sudo apt-get install -f
N: 略過 '/etc/apt/apt.conf.d/' 目錄的 '20auto-upgrades.ucf-dist' 檔案,因其檔案副檔名無效
N: 略過 '/etc/apt/sources.list.d/' 目錄的 'google-chrome.list.1' 檔案,因其檔案副檔名無效
E: 來源列表 /etc/apt/sources.list.d/google-chrome.list 中的第 1 行的格式錯誤(類型)
E: 無法讀取來源列表。
N: 略過 '/etc/apt/sources.list.d/' 目錄的 'google-chrome.list.1' 檔案,因其檔案副檔名無效
E: 來源列表 /etc/apt/sources.list.d/google-chrome.list 中的第 1 行的格式錯誤(類型)
E: 無法讀取來源列表。
vege@vege-G1-Sniper-B6:~$ sudo apt-get remove chrome-chrome-stable
N: 略過 '/etc/apt/apt.conf.d/' 目錄的 '20auto-upgrades.ucf-dist' 檔案,因其檔案副檔名無效
N: 略過 '/etc/apt/sources.list.d/' 目錄的 'google-chrome.list.1' 檔案,因其檔案副檔名無效
E: 來源列表 /etc/apt/sources.list.d/google-chrome.list 中的第 1 行的格式錯誤(類型)
E: 無法讀取來源列表。
N: 略過 '/etc/apt/sources.list.d/' 目錄的 'google-chrome.list.1' 檔案,因其檔案副檔名無效
E: 來源列表 /etc/apt/sources.list.d/google-chrome.list 中的第 1 行的格式錯誤(類型)
E: 無法讀取來源列表。

sudo apt install
N: 略過 '/etc/apt/apt.conf.d/' 目錄的 '20auto-upgrades.ucf-dist' 檔案,因其檔案副檔名無效
N: 略過 '/etc/apt/sources.list.d/' 目錄的 'google-chrome.list.1' 檔案,因其檔案副檔名無效
E: 來源列表 /etc/apt/sources.list.d/google-chrome.list 中的第 1 行的格式錯誤(類型)
E: 無法讀取來源列表。
N: 略過 '/etc/apt/sources.list.d/' 目錄的 'google-chrome.list.1' 檔案,因其檔案副檔名無效
E: 來源列表 /etc/apt/sources.list.d/google-chrome.list 中的第 1 行的格式錯誤(類型)
E: 無法讀取來源列表。

sudo apt install
N: 略過 '/etc/apt/apt.conf.d/' 目錄的 '20auto-upgrades.ucf-dist' 檔案,因其檔案副檔名無效
N: 略過 '/etc/apt/sources.list.d/' 目錄的 'google-chrome.list.1' 檔案,因其檔案副檔名無效
E: 來源列表 /etc/apt/sources.list.d/google-chrome.list 中的第 1 行的格式錯誤(類型)
E: 無法讀取來源列表。
N: 略過 '/etc/apt/sources.list.d/' 目錄的 'google-chrome.list.1' 檔案,因其檔案副檔名無效
E: 來源列表 /etc/apt/sources.list.d/google-chrome.list 中的第 1 行的格式錯誤(類型)
E: 無法讀取來源列表。

就連安裝其他軟體都出現錯誤

sudo apt install

N: 略過 '/etc/apt/apt.conf.d/' 目錄的 '20auto-upgrades.ucf-dist' 檔案,因其檔案副檔名無效
N: 略過 '/etc/apt/sources.list.d/' 目錄的 'google-chrome.list.1' 檔案,因其檔案副檔名無效
E: 來源列表 /etc/apt/sources.list.d/google-chrome.list 中的第 1 行的格式錯誤(類型)
E: 無法讀取來源列表。

1/28 21:40:18
應用擴展 工具箱
回覆: ubuntu16.04 無法安裝 google chrome ??
會員五級
註冊日期:
2012/4/22 10:50
所屬群組:
已註冊使用者
等級: 33
HP : 161 / 806
MP : 508 / 13318
EXP: 24
離線
大威 寫到:
怎麼試還是不行,連帶系統更新也出問題。

...略...

就連安裝其他軟體都出現錯誤

sudo apt install

N: 略過 '/etc/apt/apt.conf.d/' 目錄的 '20auto-upgrades.ucf-dist' 檔案,因其檔案副檔名無效
N: 略過 '/etc/apt/sources.list.d/' 目錄的 'google-chrome.list.1' 檔案,因其檔案副檔名無效
E: 來源列表 /etc/apt/sources.list.d/google-chrome.list 中的第 1 行的格式錯誤(類型)
E: 無法讀取來源列表。


先確認一下,你的系統是「i386」還是「amd64」,
目前「Google Chrome」不提供「i386」的版本了。

目前不確定你發生這個問題的關鍵因素在那,

先依照您的錯誤訊息來做處理,

關於下面這個

大威 寫到:
E: 來源列表 /etc/apt/sources.list.d/google-chrome.list 中的第 1 行的格式錯誤(類型)
E: 無法讀取來源列表。



你先把「/etc/apt/sources.list.d/google-chrome.list」移走,

例如執行「sudo mv /etc/apt/sources.list.d/google-chrome.list ~/」,

再執行「sudo apt-get update」。

然後再安裝其他軟體,測試看看是否能正常安裝。

例如執行「sudo apt-get install hello」,安裝「hello」這個套件。

另外也不見得要移走「/etc/apt/sources.list.d/google-chrome.list」
你也可以把裡面的檔案內容註解,這也是種方式。

目前先處理這部份,讓您的安裝系統可以恢復正常。

====================================================

另外關於

大威 寫到:

N: 略過 '/etc/apt/sources.list.d/' 目錄的 'google-chrome.list.1' 檔案,因其檔案副檔名無效




也可以把「/etc/apt/sources.list.d/google-chrome.list.1」這個檔移走,就不會出現上面的訊息了。

====================================================


注意「apt」除了會使用「/etc/apt/sources.list」這個檔案,
也會使用「/etc/apt/sources.list.d/」這裡面的檔案。

請閱讀

$ man sources.list

====================================================

若沒什麼特別需求,
應該也可以考慮使用「chromium-browser」。

* Chromium
* Google_Chrome

====================================================

另外 Google_Chrome 也可以採用一種手動安裝方式,
就是先把相依的套件裝好,
然後直接解開deb檔,直接執行chrome該執行檔就行了。


$ man dpkg
$ man dpkg-deb

執行


$ dpkg -I google-chrome-stable_current_amd64.deb | grep 'Depends:'


顯示


Pre-Depends: dpkg (>= 1.14.0)
Depends: gconf-service, libasound2 (>= 1.0.16), libatk1.0-0 (>= 1.12.4), libc6 (>= 2.11), libcairo2 (>= 1.6.0), libcups2 (>= 1.4.0), libdbus-1-3 (>= 1.1.4), libexpat1 (>= 2.0.1), libfontconfig1 (>= 2.9.0), libfreetype6 (>= 2.3.9), libgcc1 (>= 1:4.1.1), libgconf-2-4 (>= 2.31.1), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.26.0), libgtk2.0-0 (>= 2.24.0), libnspr4 (>= 2:4.9-2~) | libnspr4-0d (>= 1.8.0.10) | libnspr4 (>= 4.9.5-0ubuntu0), libnss3 (>= 2:3.13.4-2~) | libnss3-1d (>= 3.12.4), libpango1.0-0 (>= 1.14.0), libstdc++6 (>= 4.8.0), libx11-6 (>= 2:1.4.99.1), libx11-xcb1, libxcb1 (>= 1.6), libxcomposite1 (>= 1:0.3-1), libxcursor1 (>> 1.1.2), libxdamage1 (>= 1:1.1), libxext6, libxfixes3, libxi6 (>= 2:1.2.99.4), libxrandr2 (>= 2:1.2.99.3), libxrender1, libxss1, libxtst6, ca-certificates, fonts-liberation, libappindicator1, libnss3 (>= 3.17.2), lsb-base (>= 4.1), xdg-utils (>= 1.0.2), wget



只要把「Depends:」列的套件安裝好就行了。

也可以對照「chromium-browser」相依的套件來觀看,執行下面指令


$ apt-cache show chromium-browser | grep Depends:



若是沒有差別的話,可以先安裝「chromium-browser」這樣就會把「google-chrome」相依的套件安裝好,這也是一種方式。



執行下面指令,將「google-chrome-stable_current_amd64.deb」解開到「google-chrome」這個資料夾資料夾


$ dpkg -x google-chrome-stable_current_amd64.deb google-chrome



執行


$ tree google-chrome



顯示


google-chrome
├── etc
│   └── cron.daily
│       └── google-chrome -> /opt/google/chrome/cron/google-chrome
├── opt
│   └── google
│       └── chrome
│           ├── chrome
│           ├── chrome_100_percent.pak
│           ├── chrome_200_percent.pak
│           ├── chrome-sandbox
│           ├── cron
│           │   └── google-chrome
│           ├── default-app-block
│           ├── default_apps
│           │   ├── docs.crx
│           │   ├── drive.crx
│           │   ├── external_extensions.json
│           │   ├── gmail.crx
│           │   └── youtube.crx
│           ├── google-chrome
│           ├── icudtl.dat
│           ├── libwidevinecdmadapter.so
│           ├── libwidevinecdm.so
│           ├── locales
│           │   ├── am.pak
│           │   ├── ar.pak
│           │   ├── bg.pak
│           │   ├── bn.pak
│           │   ├── ca.pak
│           │   ├── cs.pak
│           │   ├── da.pak
│           │   ├── de.pak
│           │   ├── el.pak
│           │   ├── en-GB.pak
│           │   ├── en-US.pak
│           │   ├── es-419.pak
│           │   ├── es.pak
│           │   ├── et.pak
│           │   ├── fa.pak
│           │   ├── fil.pak
│           │   ├── fi.pak
│           │   ├── fr.pak
│           │   ├── gu.pak
│           │   ├── he.pak
│           │   ├── hi.pak
│           │   ├── hr.pak
│           │   ├── hu.pak
│           │   ├── id.pak
│           │   ├── it.pak
│           │   ├── ja.pak
│           │   ├── kn.pak
│           │   ├── ko.pak
│           │   ├── lt.pak
│           │   ├── lv.pak
│           │   ├── ml.pak
│           │   ├── mr.pak
│           │   ├── ms.pak
│           │   ├── nb.pak
│           │   ├── nl.pak
│           │   ├── pl.pak
│           │   ├── pt-BR.pak
│           │   ├── pt-PT.pak
│           │   ├── ro.pak
│           │   ├── ru.pak
│           │   ├── sk.pak
│           │   ├── sl.pak
│           │   ├── sr.pak
│           │   ├── sv.pak
│           │   ├── sw.pak
│           │   ├── ta.pak
│           │   ├── te.pak
│           │   ├── th.pak
│           │   ├── tr.pak
│           │   ├── uk.pak
│           │   ├── vi.pak
│           │   ├── zh-CN.pak
│           │   └── zh-TW.pak
│           ├── nacl_helper
│           ├── nacl_helper_bootstrap
│           ├── nacl_irt_x86_64.nexe
│           ├── natives_blob.bin
│           ├── product_logo_128.png
│           ├── product_logo_16.png
│           ├── product_logo_22.png
│           ├── product_logo_24.png
│           ├── product_logo_256.png
│           ├── product_logo_32.png
│           ├── product_logo_32.xpm
│           ├── product_logo_48.png
│           ├── product_logo_64.png
│           ├── resources.pak
│           ├── snapshot_blob.bin
│           ├── xdg-mime
│           └── xdg-settings
└── usr
    ├── bin
    │   └── google-chrome-stable -> /opt/google/chrome/google-chrome
    └── share
        ├── applications
        │   └── google-chrome.desktop
        ├── doc
        │   └── google-chrome-stable
        │       └── changelog.gz
        ├── gnome-control-center
        │   └── default-apps
        │       └── google-chrome.xml
        ├── man
        │   └── man1
        │       └── google-chrome.1
        └── menu
            └── google-chrome.menu

19 directories, 92 files



只要執行下面這個指令,就可以啟用「Google Chrome」。


$ google-chrome/opt/google/chrome/chrome



另外也可以複製「google-chrome/usr/share/applications/google-chrome.desktop」到「~/.local/share/applications/google-chrome.desktop」


cp google-chrome/usr/share/applications/google-chrome.desktop ~/.local/share/applications/google-chrome.desktop



接下來兩種方式

原本「google-chrome.desktop」的內容是「Exec=/usr/bin/google-chrome-stable」,

所以可以創造一個「Symbolic link」,「/usr/bin/google-chrome-stable」連到剛剛的「google-chrome/opt/google/chrome/chrome」。

再不然就是直接修改「google-chrome.desktop」的內容的路徑。

簡略說明到這,

基本上「手動安裝」這個方式的原理,
跟「自動安裝」的原理是一樣的,
只是手動安裝到不同的位置而已。

一些原理知道的,大概就知道怎麼舉一反三,觸類旁通了。

====================================================

以上提供參考


1/29 0:26:02
應用擴展 工具箱
回覆: ubuntu16.04 無法安裝 google chrome ??
會員五級
註冊日期:
2012/4/22 10:50
所屬群組:
已註冊使用者
等級: 33
HP : 161 / 806
MP : 508 / 13318
EXP: 24
離線
大威 寫到:
怎麼試還是不行,連帶系統更新也出問題。

.....略...

就連安裝其他軟體都出現錯誤

sudo apt install

N: 略過 '/etc/apt/apt.conf.d/' 目錄的 '20auto-upgrades.ucf-dist' 檔案,因其檔案副檔名無效
N: 略過 '/etc/apt/sources.list.d/' 目錄的 'google-chrome.list.1' 檔案,因其檔案副檔名無效
E: 來源列表 /etc/apt/sources.list.d/google-chrome.list 中的第 1 行的格式錯誤(類型)
E: 無法讀取來源列表。



關於

大威 寫到:
N: 略過 '/etc/apt/apt.conf.d/' 目錄的 '20auto-upgrades.ucf-dist' 檔案,因其檔案副檔名無效




我沒去特別動過「/etc/apt/apt.conf.d/」這個資料夾,
我提供我系統上的相關訊息給您參考,
我的系統是「Xubuntu 16.04 (64位元) 英文界面」。

執行


$ ls /etc/apt/apt.conf.d/ -1



顯示


00aptitude
00trustcdrom
01autoremove
01autoremove-kernels
01-vendor-ubuntu
10periodic
15update-stamp
20archive
20auto-upgrades
20dbus
50appstream
50unattended-upgrades
70debconf
99synaptic
99update-notifier




執行


$ cat /etc/apt/apt.conf.d/20auto-upgrades



顯示


APT::Periodic::Update-Package-Lists "1";
APT::Periodic::Unattended-Upgrade "1";




執行


$ dpkg -S /etc/apt/apt.conf.d/20auto-upgrades



顯示


dpkg-query: no path found matching pattern /etc/apt/apt.conf.d/20auto-upgrades



表示這個檔「/etc/apt/apt.conf.d/20auto-upgrades」不是屬於某個套件的,比較有可能是從「Maintainer Script」產生的。

所以執行下面指令,來找看看有沒有相關的線索


$ grep '20auto-upgrades' /var/lib/dpkg/info/* -R -n



顯示


/var/lib/dpkg/info/unattended-upgrades.config:3:AUTO_UPGRADE="/etc/apt/apt.conf.d/20auto-upgrades"
/var/lib/dpkg/info/unattended-upgrades.list:44:/usr/share/unattended-upgrades/20auto-upgrades-disabled
/var/lib/dpkg/info/unattended-upgrades.list:45:/usr/share/unattended-upgrades/20auto-upgrades
/var/lib/dpkg/info/unattended-upgrades.md5sums:11:1c261d6541420797f8b824d65ac5c197  usr/share/unattended-upgrades/20auto-upgrades
/var/lib/dpkg/info/unattended-upgrades.md5sums:12:a4bae82f58cf12cfbc370080bc1eb152  usr/share/unattended-upgrades/20auto-upgrades-disabled
/var/lib/dpkg/info/unattended-upgrades.postinst:36:     CONFIG="/etc/apt/apt.conf.d/20auto-upgrades"
/var/lib/dpkg/info/unattended-upgrades.postinst:38:         NEWFILE="/usr/share/unattended-upgrades/20auto-upgrades"
/var/lib/dpkg/info/unattended-upgrades.postinst:43:         NEWFILE="/usr/share/unattended-upgrades/20auto-upgrades-disabled"
/var/lib/dpkg/info/unattended-upgrades.postrm:24:               ucf --purge /etc/apt/apt.conf.d/20auto-upgrades
/var/lib/dpkg/info/unattended-upgrades.postrm:27:       rm -f /etc/apt/apt.conf.d/20auto-upgrades



這部份暫時trace到這。


執行


$ dpkg -S /etc/apt/apt.conf.d/



顯示


appstream, apt, update-notifier-common, unattended-upgrades, debconf, aptdaemon: /etc/apt/apt.conf.d



表示「/etc/apt/apt.conf.d」這個資料夾裡面的檔案,
是來自於「appstream」, 「apt」, 「update-notifier-common」, 「unattended-upgrades」, 「debconf」, 「aptdaemon」這幾個套件。

以上相關訊息參考。

然後回到

大威 寫到:
N: 略過 '/etc/apt/apt.conf.d/' 目錄的 '20auto-upgrades.ucf-dist' 檔案,因其檔案副檔名無效



您要確認的是「/etc/apt/apt.conf.d/20auto-upgrades.ucf-dist」這個檔怎麼跑出來的?
我的系統則是「/etc/apt/apt.conf.d/20auto-upgrades」這個檔名。

因為我之前也沒去深究「/etc/apt/apt.conf.d/」這個資料夾,
所以暫時對這裡面各個檔案的功用還沒有概念。

先提供剛剛簡單探索的紀錄,讓您參考。


1/29 0:56:07
應用擴展 工具箱

« 1 (2)

 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.