unmet dependencies && broken packages [論壇 - Ubuntu安裝問題]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊

« 1 (2) 3 4 5 »


回覆: unmet dependencies && broken packages
會員五級
註冊日期:
2012/4/22 10:50
所屬群組:
已註冊使用者
等級: 36
HP : 177 / 889
MP : 647 / 27617
EXP: 56
離線
liuCC 寫到:

再上上篇你提到
====
會請你看「/etc/apt/sources.list.d/」這裡有沒有其他的檔,
是想說,要不要先把其他額外加入的套件庫來源先停用。
====
想問問看該如何停用
(不知道到這個時候停用有用嗎...)



先回覆這一段,建立一些概念

關於這個,相關的概念可以參考「這篇」和「這篇」。

不過我用我理解到的概念,簡易做個說明。
「/etc/apt/sources.list」,你可以觀看他的內容,就像你上面回覆的圖。
基本上就是「deb」或「deb-src」開頭組成的。
而目前的狀況,應該不需要去動到「「/etc/apt/sources.list」這個檔。

目前需要確認的是「/etc/apt/sources.list.d/」有沒有任何檔案。
若有,你可以觀看這些檔的內容,是否內容也是「deb」或「deb-src」開頭組成的。

若要停用,簡易說明兩個方法,

* 一種是把「/etc/apt/sources.list.d/」裡面的檔移走。
* 一種是把「/etc/apt/sources.list.d/」裡面的檔,內容「deb」或「deb-src」開頭那幾行,加上「#」註解。
* 有GUI可以操作,這個就不講解了,請自行找尋相關的文章,這部份GUI程式,我很少用,但我知道有這樣的程式。

## 參考步驟

### 把「/etc/apt/sources.list.d/」裡面的檔移走


在家目錄,建立一個備份資料夾

執行


$ mkdir ~/backup -p



把「/etc/apt/sources.list.d/」裡面的所有檔,移到剛剛建立的「/etc/apt/sources.list.d/」

執行


$ sudo mv /etc/apt/sources.list.d/* ~/backup/



然後執行


$ sudo apt-get update



就會更新你機器上的「套件庫的套件資訊」,相關的檔案會放在「/var/lib/apt/lists/」這個資料夾。
你可以做一些實驗,
當你把「/etc/apt/sources.list.d/*」裡面的檔移走,或是註解掉,
然後再執行「sudo apt-get update」,
觀察「/var/lib/apt/lists/」這個資料夾,這裡面檔案的變化,是否有減少。

這部份也可以研讀「man apt-cache」,最下方有列「/var/lib/apt/lists/」這個資料夾。


我先休息一下,可能晚點,或明天再回



2016/5/20 22:42
應用擴展 工具箱
回覆: unmet dependencies && broken packages
會員一級
註冊日期:
2016/5/18 17:50
所屬群組:
已註冊使用者
等級: 3
HP : 0 / 70
MP : 8 / 1357
EXP: 83
離線
samwhelp很感謝你
願意跟我一起討論
我不久前發現了一個問題(好像也是問題的癥結)
在最一開始的問題提到
我有更改了來源(tw->us)
那時我是參考了這篇
http://www.arthurtoday.com/2010/11/ubuntu-apt-get.html

之後種種問題好像也是因為如此
我便把來源更改了回來
發現一堆指令都可以執行了
也不會出現
The following packages have unmet dependencies
等等的問題(我猜應該是us的來源不支援吧...?)
反正一切很順利的安裝下去了
等一切安頓好後
我便重開機

於是..
黑屏了

於是..
重灌了
.
..
...

現在我正努力重新設定回來
希望別再有問題了XD
若再出現
可能又要跟你討論了
(抱歉都是因為來源的更改造成一堆問題的開始)
麻煩你了
謝謝XD

2016/5/20 22:44
應用擴展 工具箱
回覆: unmet dependencies && broken packages
會員五級
註冊日期:
2012/4/22 10:50
所屬群組:
已註冊使用者
等級: 36
HP : 177 / 889
MP : 647 / 27617
EXP: 56
離線
liuCC 寫到:
samwhelp很感謝你
願意跟我一起討論
我不久前發現了一個問題(好像也是問題的癥結)
在最一開始的問題提到
我有更改了來源(tw->us)
那時我是參考了這篇
http://www.arthurtoday.com/2010/11/ubuntu-apt-get.html

之後種種問題好像也是因為如此
我便把來源更改了回來
發現一堆指令都可以執行了
也不會出現
The following packages have unmet dependencies
等等的問題(我猜應該是us的來源不支援吧...?)
反正一切很順利的安裝下去了
等一切安頓好後
我便重開機

於是..
黑屏了

於是..
重灌了
.
..
...

現在我正努力重新設定回來
希望別再有問題了XD
若再出現
可能又要跟你討論了
(抱歉都是因為來源的更改造成一堆問題的開始)
麻煩你了
謝謝XD


喔喔,了解,解決了就好,我一直怕不能些協助你解決,
害你把系統搞爛了,我就罪過了,這樣我也鬆了一口氣。

我是比較想要去重現那個狀況,這樣以後遇到這樣的問題,就有頭緒可以去解,
現在我一時也沒有想法怎麼去重現,我還沒能靜下心來好好研究這一段,
呵呵



2016/5/20 22:50
應用擴展 工具箱
回覆: unmet dependencies && broken packages
會員一級
註冊日期:
2016/5/18 17:50
所屬群組:
已註冊使用者
等級: 3
HP : 0 / 70
MP : 8 / 1357
EXP: 83
離線
再灌好該準備的東西後
不幸的事情又發生了
sudo apt-get upgrade後
又是libgbm1無法upgrade
一樣參照
http://askubuntu.com/questions/595400/unmet-dependencies-cannot-remove-package-libgbm1
用sudo dpkg --force-all -P libgbm1將他移掉
再執行
sudo apt-get -f install結果顯示
----------------------
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
libcogl15 : Depends: libgbm1 (>= 8.1~0) but it is not installed
libqt5gui5 : Depends: libgbm1 (>= 8.1~0) but it is not installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies
他又回來了
-----------------------------
執行sudo apt-get install libgbm1
結果
-----------------------------
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
libgbm1 : Depends: libgl1-mesa-dri (= 11.0.4~git20151026+11.0.ec14e6f8-0ubuntu0ricotz~trusty)
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
又是無線循環了..
--------------------------------
執行sudo apt-get -u dist-upgrade
顯示出:
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
libcogl15 : Depends: libgbm1 (>= 8.1~0) but it is not installed
libqt5gui5 : Depends: libgbm1 (>= 8.1~0) but it is not installed
E: Unmet dependencies. Try using -f.
--------------------------------------
於是乎..
我無解了...
(右上角又出現紅色警告 內容跟前幾篇一樣...)
我來尋求幫助了...

2016/5/21 0:18
應用擴展 工具箱
回覆: unmet dependencies && broken packages
會員五級
註冊日期:
2012/4/22 10:50
所屬群組:
已註冊使用者
等級: 36
HP : 177 / 889
MP : 647 / 27617
EXP: 56
離線
liuCC 寫到:
再灌好該準備的東西後
不幸的事情又發生了
sudo apt-get upgrade後
又是libgbm1無法upgrade
一樣參照
http://askubuntu.com/questions/595400/unmet-dependencies-cannot-remove-package-libgbm1
用sudo dpkg --force-all -P libgbm1將他移掉
再執行
sudo apt-get -f install結果顯示

...略...



========================================

樓主,想請您做個嘗試

改執行「sudo apt-get dist-upgrade」,不使用「sudo apt-get upgrade」

看看還會不會出現你說的那種情形

=========================================

喔喔,一般的狀況,建議不要把套件強制移除拉,
雖然我知道你是要解決你遇到的狀況。

當你把某個套件強制移除,你要確保你要強制移除的套件,沒有被其他的套件相依。

執行


$ sudo dpkg -r libgbm1



或是執行


$ sudo dpkg -P libgmb1



就會出現類似下面的訊息


dpkg: dependency problems prevent removal of libgbm1:amd64:
libegl1-mesa:amd64 depends on libgbm1 (>= 8.1~0).
libqt5gui5:amd64 depends on libgbm1 (>= 8.1~0).
xserver-xorg-video-amdgpu depends on libgbm1 (>= 10.2~0).
xserver-xorg-core depends on libgbm1 (>= 8.1~0).
libcogl20:amd64 depends on libgbm1 (>= 8.1~0).

dpkg: error processing package libgbm1:amd64 (--remove):
dependency problems - not removing
Errors were encountered while processing:
libgbm1:amd64



因為有「其他已經安裝在系統的套件」相依「libgbm1」,所以「套件管理系統」不讓你移除「libgbm1」
而你多了「--force-all」就會強制移除「libgbm1」,
後面的情形你上面回覆就已經了解了,
所以就不要這樣嘗試了喔


然後你使用下面的指令移除「libgbm1」


$ sudo apt-get remove libgbm1



或是執行


$ sudo apt-get purge libgbm1



在14.04應該會出現確認訊息,會跟你確認,除了會移除「libgbm」還會移除相依「libgbm1」的套件,
他會問你「Y/n」,這時候你要按下「n」,就不會繼續執行下去了。


或是你也可以執行加上「-s」也就是「simulate(模擬)」


$ sudo apt-get remove libgbm1 -s



或是執行


$ sudo apt-get purge libgbm1 -s



只是模擬,會做哪些動作,印出來,並不會真的移除

可以閱讀「$ man apt-get」找「--simulate」那個參數來閱讀。


========================================================

2016/5/21 13:46
應用擴展 工具箱
回覆: unmet dependencies && broken packages
會員一級
註冊日期:
2016/5/18 17:50
所屬群組:
已註冊使用者
等級: 3
HP : 0 / 70
MP : 8 / 1357
EXP: 83
離線
sudo apt-get dist-upgrade執行後的結果
跟sudo apt-get upgrade一樣
---------------------------------
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
libcogl15 : Depends: libgbm1 (>= 8.1~0) but it is not installed
libqt5gui5 : Depends: libgbm1 (>= 8.1~0) but it is not installed
E: Unmet dependencies. Try using -f.
----------------------------------
所以我是該再重灌一次嗎XD
還是說這個問題有辦法解決呢?

2016/5/21 14:59
應用擴展 工具箱
回覆: unmet dependencies && broken packages
會員五級
註冊日期:
2012/4/22 10:50
所屬群組:
已註冊使用者
等級: 36
HP : 177 / 889
MP : 647 / 27617
EXP: 56
離線
liuCC 寫到:
sudo apt-get dist-upgrade執行後的結果
跟sudo apt-get upgrade一樣
---------------------------------
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
libcogl15 : Depends: libgbm1 (>= 8.1~0) but it is not installed
libqt5gui5 : Depends: libgbm1 (>= 8.1~0) but it is not installed
E: Unmet dependencies. Try using -f.
----------------------------------
所以我是該再重灌一次嗎XD
還是說這個問題有辦法解決呢?


對,我指的是重灌一次,然後執行


$ sudo apt-get update;
$ sudo apt-get dist-upgrade;


然後看看下面這個情形還會不會出現,


liuCC 寫到:

再灌好該準備的東西後
不幸的事情又發生了
sudo apt-get upgrade後
又是libgbm1無法upgrade




我剛剛本來是要自己灌個14.04嘗試看看,
不過我這個當下有其他的事情需要處理,
所以可能先麻煩你自己先測一下了
歹勢,


2016/5/21 15:05
應用擴展 工具箱
回覆: unmet dependencies && broken packages
會員一級
註冊日期:
2016/5/18 17:50
所屬群組:
已註冊使用者
等級: 3
HP : 0 / 70
MP : 8 / 1357
EXP: 83
離線
好的 我重灌試試看
我也覺得將那個刪掉怪怪的
可是不知道該如何處理 或是 刪了後該如何安裝
我測看看是否可行
謝謝

2016/5/21 17:47
應用擴展 工具箱
回覆: unmet dependencies && broken packages
會員一級
註冊日期:
2016/5/18 17:50
所屬群組:
已註冊使用者
等級: 3
HP : 0 / 70
MP : 8 / 1357
EXP: 83
離線
執行sudo apt-get dist-upgrade
顯示出
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
libgbm1
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
跟sudo apt-get upgrade一樣

2016/5/21 18:47
應用擴展 工具箱
回覆: unmet dependencies && broken packages
會員五級
註冊日期:
2012/4/22 10:50
所屬群組:
已註冊使用者
等級: 36
HP : 177 / 889
MP : 647 / 27617
EXP: 56
離線
liuCC 寫到:
執行sudo apt-get dist-upgrade
顯示出
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
libgbm1
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
跟sudo apt-get upgrade一樣


等我一下,我這邊正在執行


$ sudo apt-get dist-upgrade



我還在等結果,等會再寫個測試報告給你


2016/5/21 18:53
應用擴展 工具箱

« 1 (2) 3 4 5 »

 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.