Debian / LMDE 安裝 compiz [論壇 - Ubuntu 非官方發行版討論]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊



Debian / LMDE 安裝 compiz
會員四級
註冊日期:
2015/9/29 21:19
所屬群組:
已註冊使用者
等級: 16
HP : 0 / 380
MP : 100 / 4050
EXP: 22
離線
Ubuntu 的安裝方法
# apt-get install compiz compizconfig-settings-manager compiz-plugins


分析依賴:

===============================
compiz
===============================
........compiz-core

........compiz-plugins-default
................libpng12-0
................compiz-core
................libdecoration0

........compiz-gnome
................libdecoration0
................libcompizconfig0
........................libprotobuf9v5
................compiz-plugins-default
........................libpng12-0
........................compiz-core
........................libdecoration0

................gnome-settings-daemon-schemas

................libmetacity-private3a
........................metacity-common

................session-migration

===============================
compizconfig-settings-manager
===============================
........python-compizconfig
................libcompizconfig0
........................libprotobuf9v5


===============================
compiz-plugins
===============================
........compiz-core

........compiz-plugins-default
................libdecoration0
................compiz-core

........libdecoration0


Debian / LMDE 安裝順序「以基於sid為例」:

# compiz-core
wget http://mirrors.kernel.org/ubuntu/pool/main/c/compiz/compiz-core_0.9.12.2+16.04.20160415-0ubuntu1_amd64.deb
dpkg -i compiz-core_*.deb

# libdecoration0
wget http://mirrors.kernel.org/ubuntu/pool/main/c/compiz/libdecoration0_0.9.12.2+16.04.20160415-0ubuntu1_amd64.deb
dpkg -i libdecoration0_*.deb

# libpng12-0
wget http://mirrors.kernel.org/ubuntu/pool/main/libp/libpng/libpng12-0_1.2.54-1ubuntu1_amd64.deb
dpkg -i libpng12-0_*.deb

# compiz-plugins-default
wget http://mirrors.kernel.org/ubuntu/pool/main/c/compiz/compiz-plugins-default_0.9.12.2+16.04.20160415-0ubuntu1_amd64.deb
dpkg -i compiz-plugins-default_*.deb

# libprotobuf9v5
# wget http://mirrors.kernel.org/ubuntu/pool/main/p/protobuf/libprotobuf9v5_2.6.1-1.3_amd64.deb
# dpkg -i libprotobuf9v5_*.deb
apt-get install libprotobuf9v5

# libcompizconfig0
wget http://mirrors.kernel.org/ubuntu/pool/main/c/compiz/libcompizconfig0_0.9.12.2+16.04.20160415-0ubuntu1_amd64.deb
dpkg -i libcompizconfig0_*.deb

# metacity-common
wget http://ftp.gnome.org/mirror/cdimage/snapshot/Debian/pool/main/m/metacity/metacity-common_3.18.4-3_all.deb
dpkg -i metacity-common_*.deb
apt-get -f install -y

# libmetacity-private3a
wget http://ftp.gnome.org/mirror/cdimage/snapshot/Debian/pool/main/m/metacity/libmetacity-private3a_3.18.4-3_amd64.deb
dpkg -i libmetacity-private3a_*.deb

# session-migration
wget http://mirrors.kernel.org/ubuntu/pool/main/s/session-migration/session-migration_0.2.3_amd64.deb
dpkg -i session-migration_*.deb

# gnome-settings-daemon-schemas
wget http://mirrors.kernel.org/ubuntu/pool/main/g/gnome-settings-daemon/gnome-settings-daemon-schemas_3.18.2-0ubuntu3_all.deb
dpkg -i gnome-settings-daemon-schemas_*.deb

# compiz-gnome
wget http://mirrors.kernel.org/ubuntu/pool/main/c/compiz/compiz-gnome_0.9.12.2+16.04.20160415-0ubuntu1_amd64.deb
dpkg -i compiz-gnome_*.deb
apt-get -f install -y

# compiz
wget http://mirrors.kernel.org/ubuntu/pool/main/c/compiz/compiz_0.9.12.2+16.04.20160415-0ubuntu1_all.deb
dpkg -i compiz_*.deb

# python-compizconfig
wget http://mirrors.kernel.org/ubuntu/pool/universe/c/compiz/python-compizconfig_0.9.12.2+16.04.20160415-0ubuntu1_amd64.deb
dpkg -i python-compizconfig_*.deb

# compizconfig-settings-manager
wget http://mirrors.kernel.org/ubuntu/pool/universe/c/compiz/compizconfig-settings-manager_0.9.12.2+16.04.20160415-0ubuntu1_all.deb
dpkg -i compizconfig-settings-manager_*.deb

# compiz-plugins
wget http://mirrors.kernel.org/ubuntu/pool/universe/c/compiz/compiz-plugins_0.9.12.2+16.04.20160415-0ubuntu1_amd64.deb
dpkg -i compiz-plugins_*.deb

### LMDE 設定腳本
wget https://github.com/Mint-Fans/linux-package/raw/debian/compiz-settings.tar.gz
tar -zxvf compiz-settings.tar.gz
./compiz-settings


###################################
Compiz 自動安裝腳本
###################################
$ sudo su
# wget https://github.com/Mint-Fans/linux-package/raw/debian/compiz-install
# chmod +x
# ./compiz-install


http://i.imgur.com/a2YY6A5.png

2016/6/14 23:53
應用擴展 工具箱
回覆: Debian / LMDE 安裝 compiz
版主
註冊日期:
2008/7/14 0:03
來自 螢幕的另一端
所屬群組:
網站管理員
已註冊使用者
討論區管理群
等級: 32
HP : 0 / 798
MP : 496 / 25323
EXP: 94
離線
我也一直有在用compiz ,只是compiz 越來越來安裝了
因為原作者不再更新了,套件相依性的問題越來越難處理了

請問你是怎麼解決這些問題的?

2016/6/15 9:40
應用擴展 工具箱
回覆: Debian / LMDE 安裝 compiz
會員四級
註冊日期:
2015/9/29 21:19
所屬群組:
已註冊使用者
等級: 16
HP : 0 / 380
MP : 100 / 4050
EXP: 22
離線
先知道 Ubuntu 版本安裝哪些套件. 我參考 Linux Mint 18 Beta 版 filesystem.manifest
知道套件大概如下

compiz 1:0.9.12.2+16.04.20160415-0ubuntu1
compiz-core 1:0.9.12.2+16.04.20160415-0ubuntu1
compiz-gnome 1:0.9.12.2+16.04.20160415-0ubuntu1
compiz-plugins:amd64 1:0.9.12.2+16.04.20160415-0ubuntu1
compiz-plugins-default:amd64 1:0.9.12.2+16.04.20160415-0ubuntu1
compizconfig-settings-manager 1:0.9.12.2+16.04.20160415-0ubuntu1

libcompizconfig0:amd64 1:0.9.12.2+16.04.20160415-0ubuntu1
python-compizconfig:amd64 1:0.9.12.2+16.04.20160415-0ubuntu1

然後上 http://packages.ubuntu.com/ 查詢相關依賴
主要是裝這三個 compiz compiz-plugins compizconfig-settings-manager

系統要安裝 gdebi
用gdebi打開套件看, 顯示紅字的部份, 就是Debian套件庫沒有的.
然後就下載Ubunu套件庫的依賴套件, 再嘗試用gdebi打開檢查.
Debian大概缺哪些套件, 結果如上面的依賴分析.
補齊依賴就能安裝了.

2016/6/15 20:54
應用擴展 工具箱


 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.