玩 Linux 有些人有更新強迫症 [論壇 - Ubuntu 哈啦]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊



玩 Linux 有些人有更新強迫症
會員四級
註冊日期:
2015/9/29 21:19
所屬群組:
已註冊使用者
等級: 16
HP : 0 / 380
MP : 100 / 4601
EXP: 22
離線
今天試了桌機才知道, 根本沒必要盲目的跟發行版官方腳步更新..

桌機裝了 Geforce 210 的顯示卡, 驅動最高只能用340.96版

在4.6.3核心下 linux-headers-4.6.0-xxx 根本沒辦法編譯 340.96 版的KMS.

我覺得問題是出在 linux-headers

因為 4.5.x 編譯沒問題...

更新有個屁用, 根本不能用

2016/7/30 18:54
應用擴展 工具箱
回覆: 玩 Linux 有些人有更新強迫症
會員五級
註冊日期:
2010/9/16 14:08
所屬群組:
已註冊使用者
等級: 25
HP : 0 / 616
MP : 271 / 16529
EXP: 67
離線
“更新”的定義可以有好幾種,例如某人或者某團隊“已經”做到某種程度的軟硬體相容性測試,最後編譯輸出一個安包裹檔套件,使用者只要確認好這個套件的相容軟硬體環境為何,再執行相對簡單很多的更新檔安裝指令即可(這裡指的是圖形介面而言)。也可能是使用者自行下載原始碼,在編譯的過程自行負擔軟硬體相容性測試,當然也要自行承擔更多的不相容風險。

建議“姜至奐”在寫文章“標題/抬頭”的時候,不要模仿“台灣記者”常用的那套“聳動標題”的“爛習性”,很容易在第一時間誤導閱讀者,實際閱讀內容,會發現跟“標題/抬頭”有落差。這篇的標題應該寫“姜至奐自行編譯的XXX與XXX不相容,導致更新失敗“。標題明確寫出內文大綱,這樣我就不會浪費時間點進來看一篇對我來說沒屁用的文章了。

姜至奐 寫到:
今天試了桌機才知道, 根本沒必要盲目的跟發行版官方腳步更新..

桌機裝了 Geforce 210 的顯示卡, 驅動最高只能用340.96版

在4.6.3核心下 linux-headers-4.6.0-xxx 根本沒辦法編譯 340.96 版的KMS.

我覺得問題是出在 linux-headers

因為 4.5.x 編譯沒問題...

更新有個屁用, 根本不能用 :-)

2016/7/30 20:21
----------------
個人網路文字作品集:
MacOSX10.5.8 安裝、設定、使用,個人經驗分享,正體中文版;以Windows思維用Linux,GNOME桌面篇;PDF
http://www.scribd.com/ianian1979
全字庫注音輸入法表格檔2019 (搭配CNS11643中文全字庫規格的Unicode格式傳統注音輸入法對照表)
https://sites.google.com/site/ianho7979/InputMethodTables
應用擴展 工具箱
回覆: 玩 Linux 有些人有更新強迫症
會員四級
註冊日期:
2015/9/29 21:19
所屬群組:
已註冊使用者
等級: 16
HP : 0 / 380
MP : 100 / 4601
EXP: 22
離線
IanHo 寫到:
例如某人或者某團隊“已經”做到某種程度的軟硬體相容性測試,最後編譯輸出一個安包裹檔套件,使用者只要確認好這個套件的相容軟硬體環境為何,再執行相對簡單很多的更新檔安裝指令即可(這裡指的是圖形介面而言)。


說的好像很簡單, 如果實際操作之後, 才知道「使用者只要確認好這個套件的相容軟硬體環境為何」這句話是在騙人 .因為根本就沒有更新檔可以安裝.

所以(這裡指的是圖形介面而言)這算是誤導....

........

為了搓破這個誤導....我把事實說出來好了

舉例: nvidia 官方驅動只有一個版本....

但是在debian或五本兔同一個驅動套件後面版號有 -1 -2 -3....之類..

這是什麼你一定不知道. 所以才會鐵口直斷 (這裡指的是圖形介面而言)

因為linux核心也會更新 每一版核心都有 nvidia kms 原始碼的相應補釘.
所以不同版本的核心, 不一定能用同一個版號的驅動套件
nvidia kms 是安裝後才編譯的, 並不是編譯好的binary.

其實說到底debian系, 已經淘汰某些舊卡的支援了...

所以2-3年前的卡 再怎麼「執行相對簡單很多的更新檔安裝指令」 其結果就是不能用

2016/7/30 21:13
應用擴展 工具箱
回覆: 玩 Linux 有些人有更新強迫症
會員五級
註冊日期:
2010/9/16 14:08
所屬群組:
已註冊使用者
等級: 25
HP : 0 / 616
MP : 271 / 16529
EXP: 67
離線
看樣子我寫的東西“被誤解”了,而且還被刻意忽略了另一段的內容。
我寫的東西應該沒有這麼複雜,不需要過度解讀。如果願意站在純粹的終端使用者的思維去看我寫的東西的話~~~
不過算了~~~至少我試著表達過了~~~

姜至奐 寫到:

說的好像很簡單, 如果實際操作之後, 才知道「使用者只要確認好這個套件的相容軟硬體環境為何」這句話是在騙人 .因為根本就沒有更新檔可以安裝.

所以(這裡指的是圖形介面而言)這算是誤導.... :-D

........

為了搓破這個誤導....我把事實說出來好了

舉例: nvidia 官方驅動只有一個版本....

但是在debian或五本兔同一個驅動套件後面版號有 -1 -2 -3....之類..

這是什麼你一定不知道. 所以才會鐵口直斷 (這裡指的是圖形介面而言)

因為linux核心也會更新 每一版核心都有 nvidia kms 原始碼的相應補釘.
所以不同版本的核心, 不一定能用同一個版號的驅動套件
nvidia kms 是安裝後才編譯的, 並不是編譯好的binary.

其實說到底debian系, 已經淘汰某些舊卡的支援了...

所以2-3年前的卡 再怎麼「執行相對簡單很多的更新檔安裝指令」 其結果就是不能用 :-D

2016/7/30 21:28
----------------
個人網路文字作品集:
MacOSX10.5.8 安裝、設定、使用,個人經驗分享,正體中文版;以Windows思維用Linux,GNOME桌面篇;PDF
http://www.scribd.com/ianian1979
全字庫注音輸入法表格檔2019 (搭配CNS11643中文全字庫規格的Unicode格式傳統注音輸入法對照表)
https://sites.google.com/site/ianho7979/InputMethodTables
應用擴展 工具箱
回覆: 玩 Linux 有些人有更新強迫症
管理員
註冊日期:
2011/3/11 6:32
所屬群組:
討論區管理群
等級: 44
HP : 216 / 1084
MP : 1088 / 27542
EXP: 38
離線
姜至奐 寫到:
桌機裝了 Geforce 210 的顯示卡, 驅動最高只能用340.96版

在4.6.3核心下 linux-headers-4.6.0-xxx 根本沒辦法編譯 340.96 版的KMS.


姜至奐 寫到:
我覺得問題是出在 linux-headers


用被 Linus 比中指的專有閉源驅動硬體製造商的孤兒機型跟新版本的 Linux 作業系統核心介面不相容還怪 Linux 喔?
Linux 4.6.4 上的 intel 顯示開源驅動在旁邊拉板凳吃雞排喝珍奶...

2016/7/30 21:52
本篇發表文章以「創用CC BY 3.0 或更新之台灣地區版本」授權條款釋出,如何使用敬請參考
 Creative Commons — 姓名標示 3.0 台灣 — CC BY 3.0 TW
 http://creativecommons.org/licenses/by/3.0/tw/

「你不懂的東西就不要亂講,被懂得人看破手腳就算了,騙不懂的人誤導別人,還要別人把你當成大師,這就真的是說不過去了。」
 by Allen Own
 出處 http://www.plurk.com/p/i4uogm

自由知識創作平台介紹
 https://docs.google.com/document/d/1MGG6lW_0qCgH4U785R-IwSc_INdoBGej1l-JxiA4gPE
如何建立新的自由知識創作平台文件
 https://docs.google.com/document/d/11NdzOW2lGYksfyQIcPMPye5tlmj1J0QTkgPTmQvIvKA
應用擴展 工具箱
回覆: 玩 Linux 有些人有更新強迫症
會員四級
註冊日期:
2015/9/29 21:19
所屬群組:
已註冊使用者
等級: 16
HP : 0 / 380
MP : 100 / 4601
EXP: 22
離線
V字龍 寫到:

用被 Linus 比中指的專有閉源驅動硬體製造商的孤兒機型跟新版本的 Linux 作業系統核心介面不相容還怪 Linux 喔?
Linux 4.6.4 上的 intel 顯示開源驅動在旁邊拉板凳吃雞排喝珍奶...


沒有 怪debian而已

debian 滾動套件庫已經沒有 340.96 的 kms patch 了

不過 .... arch linux 有

https://git.archlinux.org/svntogit/packages.git/tree/trunk/linux-4.6.patch?h=packages/nvidia-340xx

2016/7/30 22:59
應用擴展 工具箱
回覆: 玩 Linux 有些人有更新強迫症
會員二級
註冊日期:
2016/2/24 19:05
所屬群組:
已註冊使用者
等級: 5
HP : 0 / 114
MP : 15 / 1253
EXP: 59
離線
姜至奐 寫到:
V字龍 寫到:

用被 Linus 比中指的專有閉源驅動硬體製造商的孤兒機型跟新版本的 Linux 作業系統核心介面不相容還怪 Linux 喔?
Linux 4.6.4 上的 intel 顯示開源驅動在旁邊拉板凳吃雞排喝珍奶...


沒有 怪debian而已

我不記得 Debian 開發者有義務幫您弄相容性修正

2016/7/30 23:12
應用擴展 工具箱
回覆: 玩 Linux 有些人有更新強迫症
會員四級
註冊日期:
2015/9/29 21:19
所屬群組:
已註冊使用者
等級: 16
HP : 0 / 380
MP : 100 / 4601
EXP: 22
離線
林博仁 寫到:

怪他 不代表我認為他有義務

2016/7/30 23:37
應用擴展 工具箱
回覆: 玩 Linux 有些人有更新強迫症
管理員
註冊日期:
2006/10/31 19:52
來自 Baker Street 221B
所屬群組:
網站管理員
已註冊使用者
討論區管理群
等級: 30
HP : 0 / 733
MP : 405 / 27975
EXP: 34
離線
geforce gtx 210, nvidia自己都已經放棄支援了
而且明明就有Nouveau可以用
穩定性比那個不更新的官方驅動好太多了
這樣去怪debian真的很莫名其妙
你自己不會去拿arch kernel patch去build嗎?

2016/7/31 0:19
應用擴展 工具箱
回覆: 玩 Linux 有些人有更新強迫症
會員四級
註冊日期:
2015/9/29 21:19
所屬群組:
已註冊使用者
等級: 16
HP : 0 / 380
MP : 100 / 4601
EXP: 22
離線
Lawliet 寫到:
geforce gtx 210, nvidia自己都已經放棄支援了
而且明明就有Nouveau可以用
穩定性比那個不更新的官方驅動好太多了
這樣去怪debian真的很莫名其妙
你自己不會去拿arch kernel patch去build嗎?


arch linux 4.6 patch to debian 成功!

安裝需要一點技巧

NVIDIA Optimus Geforce 820M + Intel HD


NVIDIA Geforce 210

2016/7/31 6:03
應用擴展 工具箱


 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.