MeshMixer 有人裝起來了嗎? [論壇 - 新手村]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊



MeshMixer 有人裝起來了嗎?
會員四級
註冊日期:
2007/11/25 1:18
所屬群組:
已註冊使用者
等級: 16
HP : 0 / 385
MP : 103 / 10636
EXP: 43
離線
在網路上看到 Autodesk 的 MeshMixer 有 Linux 版 (http://www.meshmixer.com/linux.html), 下載了 .deb 檔後,裝不起來。
註:下載 meshmixer_2.9_amd64.deb 後,點它安裝,跳出「軟體」,點「安裝」,跑了幾秒鐘,又跑回「安裝」,都裝不起來。
OS: Xubuntu16.10

2/14 23:04:46
應用擴展 工具箱
回覆: MeshMixer 有人裝起來了嗎?
會員二級
註冊日期:
2011/10/7 0:22
所屬群組:
已註冊使用者
等級: 6
HP : 0 / 131
MP : 18 / 2143
EXP: 27
離線
剛剛有在虛擬機裡的ezgo12試裝。

一開始有用圖形介面點兩下,讓ezgo12預設的圖形安裝程式安裝,但沒成功。(有試了兩次)

後來使用:

dpkg -i meshmixer_2.9_amd64.deb


就裝好了。

之後,另外在虛擬機裡的LMDE2嚐試,因為依賴的套件版本不同,就沒法讓它可以成功啟動。

2/15 0:35:48
應用擴展 工具箱
回覆: MeshMixer 有人裝起來了嗎?
會員五級
註冊日期:
2012/4/22 10:50
所屬群組:
已註冊使用者
等級: 31
HP : 150 / 754
MP : 432 / 11070
EXP: 16
離線
pnleo 寫到:
在網路上看到 Autodesk 的 MeshMixer 有 Linux 版 (http://www.meshmixer.com/linux.html), 下載了 .deb 檔後,裝不起來。
註:下載 meshmixer_2.9_amd64.deb 後,點它安裝,跳出「軟體」,點「安裝」,跑了幾秒鐘,又跑回「安裝」,都裝不起來。
OS: Xubuntu16.10


從您提供的網址

http://www.meshmixer.com/linux.html


裡面有一行

1) Click to Download the Ubuntu 14.04 64-bit .deb file

就可以大略知道

https://s3.amazonaws.com/autodesk-meshmixer/meshmixer/amd64/meshmixer_2.9_amd64.deb

這個DEB檔案,適合安裝在「Ubuntu 14.04 64-bit」。



================================================================================

以下驗證說明

我的系統是「Xubuntu 16.04 amd64」。

安裝的流程,基本上可以參考我之前回覆的「這篇」所提到的步驟來安裝。

不過應該是安裝不起來,因為「meshmixer_2.9_amd64.deb」有可能相依的套件太舊了,無法滿足相依,所以無法安裝。

執行下面指令,下載「meshmixer_2.9_amd64.deb」


$ wget -c https://s3.amazonaws.com/autodesk-meshmixer/meshmixer/amd64/meshmixer_2.9_amd64.deb



下載完畢後

執行下面的指令,安裝「meshmixer_2.9_amd64.deb」


$ sudo dpkg -i meshmixer_2.9_amd64.deb



顯示


[sudo] password for user:
Selecting previously unselected package meshmixer.
(Reading database ... 434230 files and directories currently installed.)
Preparing to unpack meshmixer_2.9_amd64.deb ...
Unpacking meshmixer (2.9) ...
dpkg: dependency problems prevent configuration of meshmixer:
 meshmixer depends on libavahi-compat-libdnssd1 (>= 0.6.16); however:
  Package libavahi-compat-libdnssd1 is not installed.
 meshmixer depends on libboost-date-time1.54.0; however:
  Package libboost-date-time1.54.0 is not installed.
 meshmixer depends on libboost-filesystem1.54.0; however:
  Package libboost-filesystem1.54.0 is not installed.
 meshmixer depends on libboost-system1.54.0; however:
  Package libboost-system1.54.0 is not installed.
 meshmixer depends on libboost-thread1.54.0; however:
  Package libboost-thread1.54.0 is not installed.
 meshmixer depends on libcgal10; however:
  Package libcgal10 is not installed.
 meshmixer depends on libkml0; however:
  Package libkml0 is not installed.
 meshmixer depends on libsuperlu3 (>= 3.0+20070106); however:
  Package libsuperlu3 is not installed.

dpkg: error processing package meshmixer (--install):
 dependency problems - leaving unconfigured
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Errors were encountered while processing:
 meshmixer




執行


$ sudo apt-get install -f



顯示


Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following package was automatically installed and is no longer required:
  libavahi-compat-libdnssd1
Use 'sudo apt autoremove' to remove it.
The following additional packages will be installed:
  libavahi-compat-libdnssd1
The following packages will be REMOVED:
  meshmixer
The following NEW packages will be installed:
  libavahi-compat-libdnssd1
0 upgraded, 1 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
Need to get 0 B/16.5 kB of archives.
After this operation, 167 MB disk space will be freed.
Do you want to continue? [Y/n]
(Reading database ... 434754 files and directories currently installed.)
Removing meshmixer (2.9) ...
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Selecting previously unselected package libavahi-compat-libdnssd1:amd64.
(Reading database ... 434230 files and directories currently installed.)
Preparing to unpack .../libavahi-compat-libdnssd1_0.6.32~rc+dfsg-1ubuntu2_amd64.deb ...
Unpacking libavahi-compat-libdnssd1:amd64 (0.6.32~rc+dfsg-1ubuntu2) ...
Processing triggers for libc-bin (2.23-0ubuntu5) ...
Setting up libavahi-compat-libdnssd1:amd64 (0.6.32~rc+dfsg-1ubuntu2) ...
Processing triggers for libc-bin (2.23-0ubuntu5) ...




再次執行下面的指令,安裝「meshmixer_2.9_amd64.deb」


$ sudo dpkg -i meshmixer_2.9_amd64.deb



顯示


Selecting previously unselected package meshmixer.
(Reading database ... 434237 files and directories currently installed.)
Preparing to unpack meshmixer_2.9_amd64.deb ...
Unpacking meshmixer (2.9) ...
dpkg: dependency problems prevent configuration of meshmixer:
 meshmixer depends on libboost-date-time1.54.0; however:
  Package libboost-date-time1.54.0 is not installed.
 meshmixer depends on libboost-filesystem1.54.0; however:
  Package libboost-filesystem1.54.0 is not installed.
 meshmixer depends on libboost-system1.54.0; however:
  Package libboost-system1.54.0 is not installed.
 meshmixer depends on libboost-thread1.54.0; however:
  Package libboost-thread1.54.0 is not installed.
 meshmixer depends on libcgal10; however:
  Package libcgal10 is not installed.
 meshmixer depends on libkml0; however:
  Package libkml0 is not installed.
 meshmixer depends on libsuperlu3 (>= 3.0+20070106); however:
  Package libsuperlu3 is not installed.

dpkg: error processing package meshmixer (--install):
 dependency problems - leaving unconfigured
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20160824-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for desktop-file-utils (0.22-1ubuntu5) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Errors were encountered while processing:
 meshmixer



執行下面指令,查詢套件


$ apt-cache search libboost-date-time1.54.0



並沒有「libboost-date-time1.54.0」這個套件

執行


$ apt-cache search libboost-date-time1



顯示


libboost-date-time1.58.0 - set of date-time libraries based on generic programming concepts
libboost-date-time1.58-dev - set of date-time libraries based on generic programming concepts



只有「libboost-date-time1.58.0」這個套件。

測試完畢。

然後執行下面指令,移除「meshmixer」。


$ sudo apt-get remove meshmixer



顯示


Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following package was automatically installed and is no longer required:
  libavahi-compat-libdnssd1
Use 'sudo apt autoremove' to remove it.
The following packages will be REMOVED:
  meshmixer
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 167 MB disk space will be freed.
Do you want to continue? [Y/n]



按下「Enter」,就會繼續執行移除的動作了。

然後執行下面指令,把剛剛額外安裝的相依套件移除。


$ sudo apt-get autoremove



顯示


Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages will be REMOVED:
  libavahi-compat-libdnssd1
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
After this operation, 90.1 kB disk space will be freed.
Do you want to continue? [Y/n]



按下「Enter」,就會繼續執行移除的動作了。

回復完畢。

執行下面指令確認一下


$ sudo apt-get install



顯示


Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.



表示安裝系統目前是正常的狀態。


================================================================================

另外當你把「meshmixer_2.9_amd64.deb」下載下來之後,

可以執行


$ dpkg -I meshmixer_2.9_amd64.deb



顯示


new debian package, version 2.0.
size 36583156 bytes: control archive=12471 bytes.
863 bytes, 10 lines control
55394 bytes, 493 lines md5sums
782 bytes, 24 lines * postinst #!/bin/sh
Package: meshmixer
Version: 2.9
Architecture: amd64
Maintainer: Ara Danielyan <ara.danielyan@autodesk.com>
Installed-Size: 163415
Depends: libavahi-compat-libdnssd1 (>= 0.6.16), libblas3, libboost-date-time1.54.0, libboost-filesystem1.54.0, libboost-system1.54.0, libboost-thread1.54.0, libc6 (>= 2.14), libcgal10, libgcc1 (>= 1:4.1.1), libgl1-mesa-glx | libgl1, libglu1-mesa | libglu1, libgmp10, libkml0, liblapack3, libqt4-network (>= 4:4.8.0), libqt4-opengl (>= 4:4.8.0), libqt4-script (>= 4:4.5.3), libqt4-xml (>= 4:4.5.3), libqtcore4 (>= 4:4.7.0~beta1), libqtgui4 (>= 4:4.8.0), libqtwebkit4, libstdc++6 (>= 4.8.1), libsuperlu3 (>= 3.0+20070106), libxerces-c3.1, zlib1g (>= 1:1.2.0)
Section: misc
Priority: optional
Description: Mesh editing desktop appliation.
Application for aggregating, fixing and editing meshes, and for preparing them for 3d printers.



加上「grep」來過濾


$ dpkg -I meshmixer_2.9_amd64.deb | grep '^ Depends:'




顯示


Depends: libavahi-compat-libdnssd1 (>= 0.6.16), libblas3, libboost-date-time1.54.0, libboost-filesystem1.54.0, libboost-system1.54.0, libboost-thread1.54.0, libc6 (>= 2.14), libcgal10, libgcc1 (>= 1:4.1.1), libgl1-mesa-glx | libgl1, libglu1-mesa | libglu1, libgmp10, libkml0, liblapack3, libqt4-network (>= 4:4.8.0), libqt4-opengl (>= 4:4.8.0), libqt4-script (>= 4:4.5.3), libqt4-xml (>= 4:4.5.3), libqtcore4 (>= 4:4.7.0~beta1), libqtgui4 (>= 4:4.8.0), libqtwebkit4, libstdc++6 (>= 4.8.1), libsuperlu3 (>= 3.0+20070106), libxerces-c3.1, zlib1g (>= 1:1.2.0)



上面列的,可以了解「meshmixer_2.9_amd64.deb」相依的套件有哪些

或是也可以執行下面指令,一樣會得到上面的結果(除了上面「Depends:」前面有一個空白)


$ dpkg -f meshmixer_2.9_amd64.deb | grep '^Depends:'



或是也可以執行下面指令,顯示「Depends」這個欄位的值


$ dpkg -f meshmixer_2.9_amd64.deb Depends



顯示


libavahi-compat-libdnssd1 (>= 0.6.16), libblas3, libboost-date-time1.54.0, libboost-filesystem1.54.0, libboost-system1.54.0, libboost-thread1.54.0, libc6 (>= 2.14), libcgal10, libgcc1 (>= 1:4.1.1), libgl1-mesa-glx | libgl1, libglu1-mesa | libglu1, libgmp10, libkml0, liblapack3, libqt4-network (>= 4:4.8.0), libqt4-opengl (>= 4:4.8.0), libqt4-script (>= 4:4.5.3), libqt4-xml (>= 4:4.5.3), libqtcore4 (>= 4:4.7.0~beta1), libqtgui4 (>= 4:4.8.0), libqtwebkit4, libstdc++6 (>= 4.8.1), libsuperlu3 (>= 3.0+20070106), libxerces-c3.1, zlib1g (>= 1:1.2.0)




您可以執行下面指令,了解系統目前的套件庫,所提供套件的候選狀況。


$ apt-cache policy libavahi-compat-libdnssd1



顯示


libavahi-compat-libdnssd1:
  Installed: (none)
  Candidate: 0.6.32~rc+dfsg-1ubuntu2
  Version table:
     0.6.32~rc+dfsg-1ubuntu2 500
        500 http://tw.archive.ubuntu.com/ubuntu xenial/main amd64 Packages




執行


$ apt-cache policy libboost-date-time1.54.0



顯示


N: Unable to locate package libboost-date-time1.54.0
N: Couldn't find any package by glob 'libboost-date-time1.54.0'
N: Couldn't find any package by regex 'libboost-date-time1.54.0'



其他的相依套件,以此類推

================================================================================


另外有一種手動安裝的方式,這個方式,我在這個「回覆#15」有提到。

您可以把「meshmixer_2.9_amd64.deb」解開,
然後放到對應到「/」的位置,
然後自行安裝相依的套件。
不過這樣的方式安裝完後,您的情況,不見得能work,主要是系統上的lib是否能合用。

解開「meshmixer_2.9_amd64.deb」的指令如下,


$ dpkg -x meshmixer_2.9_amd64.deb meshmixer



會產生一個資料夾「meshmixer」

執行


$ ls meshmixer



顯示


user




執行


$ ls meshmixer/user



顯示


bin lib share




也可以執行使用「tree」來觀看「meshmixer」整個資料夾結構


$ tree meshmixer



顯示


meshmixer
└── usr
    ├── bin
    │   └── meshmixer
    ├── lib
    │   ├── libother_amf.so
    │   ├── libother_cgal.so
    │   ├── libother_core.so
    │   ├── libotherfab_base.so
    │   ├── libotherfab_geom.so
    │   ├── libother_levelset.so
    │   ├── libother_nonlinear.so
    │   ├── libother_otherfab.so
    │   ├── libother_print3d_back.so
    │   ├── libother_xml.so
    │   └── libTimberlineWrapper.so
    └── share
        ├── applications
        │   └── meshmixer.desktop
        ├── doc
        │   └── meshmixer
        │       ├── changelog.gz
        │       └── copyright
        ├── meshmixer
        │   ├── help_docs
        │   │   ├── hotkeys.pdf
        │   │   └── printing3dinfo.pdf
        │   ├── libraries
        │   │   ├── default
...略...

39 directories, 493 files



因為檔案很多,就不全貼上去了。

至於複製到「/」底下,這我就不測試了。

另外有些「deb檔」,即使解開了,有些執行檔也可以直接執行,不見得一定要複製到「/」相對應的位置。

================================================================================

## 額外參考

一些套件操作的討論案例和參考連結,列在這個「索引」。

* man dpkg
* man apt-get
* man apt-cache

================================================================================

以上提供參考

報告完畢。


2/15 0:43:58
應用擴展 工具箱
回覆: MeshMixer 有人裝起來了嗎?
會員二級
註冊日期:
2011/10/7 0:22
所屬群組:
已註冊使用者
等級: 6
HP : 0 / 131
MP : 18 / 2143
EXP: 27
離線
就如S大所說,官方提供的deb包裡所寫的相依套件太舊,所以在某些版本下會無法安裝及啟動。

後來逛了他們的論壇,依照這篇教學:

Debian的依賴問題(英文討論串)

建立相依套件的連結(把新版本連結到一個舊版本的名字),接著修改deb包裡的相依內容,S大提到的指令:

$ dpkg -I meshmixer_2.9_amd64.deb


輸出的內容中有一段:

Depends: libavahi-compat-libdnssd1 (>= 0.6.16), libblas3, 
libboost-date-time1.54.0, libboost-filesystem1.54.0, libboost-system1.54.0, 
libboost-thread1.54.0, libc6 (>= 2.14), libcgal10, 
libgcc1 (>= 1:4.1.1), libgl1-mesa-glx | libgl1, libglu1-mesa | libglu1, libgmp10, 
libkml0, liblapack3, libqt4-network (>= 4:4.8.0), libqt4-opengl (>= 4:4.8.0),
 libqt4-script (>= 4:4.5.3), libqt4-xml (>= 4:4.5.3), libqtcore4 (>= 4:4.7.0~beta1),
 libqtgui4 (>= 4:4.8.0), libqtwebkit4, libstdc++6 (>= 4.8.1), 
libsuperlu3 (>= 3.0+20070106), libxerces-c3.1, zlib1g (>= 1:1.2.0)


在描述套件的相依,需要修改的就是後面那些版本號。
經過這些動作後,LMDE2上也成功安裝和開啟執行,在兔子模型上可以拉出角,其它功能是不是正常,我就沒有多試了。

題外話:
有聽到朋友說用Linux最後還是得開始用指令,雖然一開始不太想承認,也想回應說使用指令只是一種興趣和喜好。但後來覺得有很多好用的軟體只有指令形態或許有其現實上的限制,我是這麼猜想:「在相同的開發時間限制下,同一個開發者,開發同一個功能的軟體,開發的內容如果被分為核心功能和使用者介面兩個部分,那麼往圖形介面軟體和往文字介面軟體(雖然也可以同時兼具兩種介面)之間的核心功能所能爭取到的時間比例應該會有所不同。」

另外,指令除了可以是興趣和喜好之外,有時候還挺方便的:

教學文中需要人製作某些檔案的連結檔:

libsuperlu.so.3 to libsuperlu.so.4
libboost_thread.so.1.54.0 to libboost_thread.so.1.55.0 
libboost_system.so.1.54.0 to libboost_system.so.1.55.0 
libboost_filesystem.so.1.54.0 to libboost_filesystem.so.1.55.0 
libboost_date_time.so.1.54.0 to libboost_date_time.so.1.55.0


這時候,只要打開虛擬終端機,先輸入
echo '

然後,再去網頁上複製上面這串內容貼到終端機上,最後補
'

按ENTER,它就成了一個可以按向上鍵召喚的資料,讓人可以重複對它實驗和處理,比如說這樣:


$echo 'libsuperlu.so.3        to         libsuperlu.so.4
libboost_thread.so.1.54.0            to            libboost_thread.so.1.55.0
libboost_system.so.1.54.0           to             libboost_system.so.1.55.0
libboost_filesystem.so.1.54.0        to            libboost_filesystem.so.1.55.0
libboost_date_time.so.1.54.0        to            libboost_date_time.so.1.55.0' | awk '{print "ln -s",$3,$1}'



它會輸出:
ln -s libsuperlu.so.4 libsuperlu.so.3
ln -s libboost_thread.so.1.55.0 libboost_thread.so.1.54.0
ln -s libboost_system.so.1.55.0 libboost_system.so.1.54.0
ln -s libboost_filesystem.so.1.55.0 libboost_filesystem.so.1.54.0
ln -s libboost_date_time.so.1.55.0 libboost_date_time.so.1.54.0


接著再按一次上,補打
| sudo bash
透過管線把資料餵給bash,就可以執行上面輸出的動作了。(當然,還可以依喜好使用不同的組合工具,例如:xargs,sed、past,cut等等。)

2/15 2:21:26
應用擴展 工具箱
回覆: MeshMixer 有人裝起來了嗎?
會員五級
註冊日期:
2012/4/22 10:50
所屬群組:
已註冊使用者
等級: 31
HP : 150 / 754
MP : 432 / 11070
EXP: 16
離線
Losepacific 寫到:
就如S大所說,官方提供的deb包裡所寫的相依套件太舊,所以在某些版本下會無法安裝及啟動。

後來逛了他們的論壇,依照這篇教學:

Debian的依賴問題(英文討論串)

建立相依套件的連結(把新版本連結到一個舊版本的名字),接著修改deb包裡的相依內容,S大提到的指令:

$ dpkg -I meshmixer_2.9_amd64.deb


輸出的內容中有一段:

Depends: libavahi-compat-libdnssd1 (>= 0.6.16), libblas3,
libboost-date-time1.54.0, libboost-filesystem1.54.0, libboost-system1.54.0,
libboost-thread1.54.0, libc6 (>= 2.14), libcgal10,
libgcc1 (>= 1:4.1.1), libgl1-mesa-glx | libgl1, libglu1-mesa | libglu1, libgmp10,
libkml0, liblapack3, libqt4-network (>= 4:4.8.0), libqt4-opengl (>= 4:4.8.0),
 libqt4-script (>= 4:4.5.3), libqt4-xml (>= 4:4.5.3), libqtcore4 (>= 4:4.7.0~beta1),
 libqtgui4 (>= 4:4.8.0), libqtwebkit4, libstdc++6 (>= 4.8.1),
libsuperlu3 (>= 3.0+20070106), libxerces-c3.1, zlib1g (>= 1:1.2.0)


在描述套件的相依,需要修改的就是後面那些版本號。
經過這些動作後,LMDE2上也成功安裝和開啟執行,在兔子模型上可以拉出角,其它功能是不是正常,我就沒有多試了。

題外話:
有聽到朋友說用Linux最後還是得開始用指令,雖然一開始不太想承認,也想回應說使用指令只是一種興趣和喜好。但後來覺得有很多好用的軟體只有指令形態或許有其現實上的限制,我是這麼猜想:「在相同的開發時間限制下,同一個開發者,開發同一個功能的軟體,開發的內容如果被分為核心功能和使用者介面兩個部分,那麼往圖形介面軟體和往文字介面軟體(雖然也可以同時兼具兩種介面)之間的核心功能所能爭取到的時間比例應該會有所不同。」

另外,指令除了可以是興趣和喜好之外,有時候還挺方便的:

教學文中需要人製作某些檔案的連結檔:

libsuperlu.so.3 to libsuperlu.so.4
libboost_thread.so.1.54.0 to libboost_thread.so.1.55.0
libboost_system.so.1.54.0 to libboost_system.so.1.55.0
libboost_filesystem.so.1.54.0 to libboost_filesystem.so.1.55.0
libboost_date_time.so.1.54.0 to libboost_date_time.so.1.55.0


這時候,只要打開虛擬終端機,先輸入
echo '

然後,再去網頁上複製上面這串內容貼到終端機上,最後補
'

按ENTER,它就成了一個可以按向上鍵召喚的資料,讓人可以重複對它實驗和處理,比如說這樣:


$echo 'libsuperlu.so.3        to         libsuperlu.so.4
libboost_thread.so.1.54.0            to            libboost_thread.so.1.55.0
libboost_system.so.1.54.0           to             libboost_system.so.1.55.0
libboost_filesystem.so.1.54.0        to            libboost_filesystem.so.1.55.0
libboost_date_time.so.1.54.0        to            libboost_date_time.so.1.55.0' | awk '{print "ln -s",$3,$1}'



它會輸出:
ln -s libsuperlu.so.4 libsuperlu.so.3
ln -s libboost_thread.so.1.55.0 libboost_thread.so.1.54.0
ln -s libboost_system.so.1.55.0 libboost_system.so.1.54.0
ln -s libboost_filesystem.so.1.55.0 libboost_filesystem.so.1.54.0
ln -s libboost_date_time.so.1.55.0 libboost_date_time.so.1.54.0


接著再按一次上,補打
| sudo bash
透過管線把資料餵給bash,就可以執行上面輸出的動作了。(當然,還可以依喜好使用不同的組合工具,例如:xargs,sed、past,cut等等。)


================================================================================

您提供的連結提到的,也是其中一種解決方式,

* 將「DEB檔」解開,
* 編輯「control檔」,
* 然後重新打包,
* 再透過「sudo dpkg -i」安裝。

================================================================================

以下步驟簡易說明,上面提到的步驟

執行下面指令,下載「meshmixer_2.9_amd64.deb」


$ wget -c https://s3.amazonaws.com/autodesk-meshmixer/meshmixer/amd64/meshmixer_2.9_amd64.deb



執行下面指令,解開「meshmixer_2.9_amd64.deb」


$ dpkg -x meshmixer_2.9_amd64.deb meshmixer



上面步驟,會產生一個資料夾「meshmixer」。

然後執行下面指令,


$ dpkg -e meshmixer_2.9_amd64.deb meshmixer/DEBIAN



上面步驟,會產生一個資料夾「meshmixer/DEBIAN」,裡面包含了「control檔」和「MaintainerScripts

可以執行下面指令,了解「meshmixer/DEBIAN」的結構


$ tree meshmixer/DEBIAN



顯示


meshmixer/DEBIAN
├── control
├── md5sums
└── postinst

0 directories, 3 files



可以使用您慣用的編輯器,編輯「meshmixer/DEBIAN/control」。

然後執行下面的指令,重新打包。


$ dpkg -b meshmixer meshmixer_2.9_amd6.new.deb



顯示


dpkg-deb: building package 'meshmixer' in 'meshmixer_2.9_amd6.new.deb'.



執行下面指令,安裝「meshmixer_2.9_amd6.new.deb」


$ sudo dpkg -i meshmixer_2.9_amd6.new.deb



以上只是簡略說明流程,其餘的細節,請自行琢磨了。
主要還是要注意系統上的lib是否合用。

* man deb-control
* man dpkg
* man dpkg-deb
* man dpkg-query
* Ubuntu Packaging Guide (之前有列在這個索引)
* Debian Developers' Manuals (之前有列在這個索引)

================================================================================

## lib 議題相關參考網址

* https://www.ptt.cc/bbs/LinuxDev/M.1162669989.A.2E6.html
* http://www.adp-gmbh.ch/cpp/gcc/create_lib.html
* http://tldp.org/HOWTO/Program-Library-HOWTO/index.html
* https://openhome.cc/Gossip/CGossip/
* https://github.com/tinyclub/open-c-book (觀看)
* https://www3.ntu.edu.sg/home/ehchua/programming/cpp/gcc_make.html


* $ man ldd
* $ man ldconfig
* $ man ld.so
* LD_LIBRARY_PATH


後記 (2017-02-24): 另一篇類似的討論在「回覆#4」。

後記 (2017-02-28): 上面提到的另一篇,後來的回覆「#11」還有「#10

================================================================================

之前在這篇「回覆」,有做了一個「簡單的打包練習」,這只是基本的概念,進階的就請自行再去探究了,因為我也還沒去深究。

之前有紀錄一個索引「[影片教學][TOSSUG] Debian 套件打包工作坊」。

該影片講者的部落格有列「相關的文章」。

或是這篇「從範本快速自製 deb」。

## 一些相關的路徑

* /var/lib/dpkg/status
* /var/lib/dpkg/available
* /var/lib/dpkg/info/

## 如何下載 hello 這個套件

這篇「從範本快速自製 deb」提到的


$ sudo apt-get -d install hello
$ cp /var/cache/apt/archives/hello_2.2-3_i386.deb ~



可以改用下面這行指令取代


$ apt-get download hello



就會下載「hello」這個套件了。


================================================================================

在「圖形界面(GUI)」內部也是透過指令來兜一些動作,可能是「call c function」,也可能是「call 外部的指令」。

我個人覺得,只要一些概念或原理懂了,
使用「下指令(CLI)」的方式操作,或是使用「圖形界面(GUI)」的方式,
能達到目標,都是OK的拉,並不拘泥一定要用哪種方式。

不過至少前提是「使用的工具能達到目標」,才能做後續的取捨考量。

:-p

================================================================================

以上提供參考,報告完畢


2/15 4:22:56
應用擴展 工具箱
回覆: MeshMixer 有人裝起來了嗎?
會員四級
註冊日期:
2007/11/25 1:18
所屬群組:
已註冊使用者
等級: 16
HP : 0 / 385
MP : 103 / 10636
EXP: 43
離線
哇!各位太利害了!謝謝!

2/15 9:46:10
應用擴展 工具箱


 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.