如何安裝 StarUML-v2.8.0-64-bit.deb ? [論壇 - 新手村]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊

(1) 2 »


如何安裝 StarUML-v2.8.0-64-bit.deb ?
會員二級
註冊日期:
2009/12/17 21:17
所屬群組:
已註冊使用者
等級: 8
HP : 0 / 186
MP : 30 / 4600
EXP: 46
離線
請教各位前輩,我從

http://staruml.io/download

下載了 StarUML-v2.8.0-64-bit.deb

,安裝不起來,試過

~/下載$ sudo apt-get insatll StarUML-v2.8.0-64-bit
~/下載$ sudo apt-get insatll StarUML-v2.8.0-64-bit.deb

/opt$ sudo apt-get insatll StarUML-v2.8.0-64-bit
/opt$ sudo apt-get insatll StarUML-v2.8.0-64-bit.deb

都是出現錯誤訊息如下:
sudo apt-get install StarUML-v2.8.0-64-bit
正在讀取套件清單... 完成
正在重建相依關係
正在讀取狀態資料... 完成
E: 找不到套件 StarUML-v2.8.0-64-bit
E: Couldn't find any package by glob 'StarUML-v2.8.0-64-bit'
E: 無法按 regex 找到 StarUML-v2.8.0-64-bit 套件

或直接雙擊檔案、進入 Ubuntu軟體 中心,也不行,出現"正在等候安裝"圖示,然後就一直停在那裡、不動幾個小時了;

請教大大們,該放在哪個目錄、及如何安裝呢?

萬分感謝、菜鳥一個,萬物介意、懇請不吝賜教,謝謝!

2017/2/24 11:40
應用擴展 工具箱
回覆: 如何安裝 StarUML-v2.8.0-64-bit.deb ?
會員五級
註冊日期:
2012/4/22 10:50
所屬群組:
已註冊使用者
等級: 33
HP : 163 / 815
MP : 522 / 14524
EXP: 62
離線
clarkliang 寫到:
請教各位前輩,我從

http://staruml.io/download

下載了 StarUML-v2.8.0-64-bit.deb

,安裝不起來,試過

~/下載$ sudo apt-get insatll StarUML-v2.8.0-64-bit
~/下載$ sudo apt-get insatll StarUML-v2.8.0-64-bit.deb

/opt$ sudo apt-get insatll StarUML-v2.8.0-64-bit
/opt$ sudo apt-get insatll StarUML-v2.8.0-64-bit.deb

都是出現錯誤訊息如下:
sudo apt-get install StarUML-v2.8.0-64-bit
正在讀取套件清單... 完成
正在重建相依關係
正在讀取狀態資料... 完成
E: 找不到套件 StarUML-v2.8.0-64-bit
E: Couldn't find any package by glob 'StarUML-v2.8.0-64-bit'
E: 無法按 regex 找到 StarUML-v2.8.0-64-bit 套件

或直接雙擊檔案、進入 Ubuntu軟體 中心,也不行,出現"正在等候安裝"圖示,然後就一直停在那裡、不動幾個小時了;

請教大大們,該放在哪個目錄、及如何安裝呢?

萬分感謝、菜鳥一個,萬物介意、懇請不吝賜教,謝謝!



可以參考「這篇」和「這篇」的案例說明。

若是「多個deb檔」,則是參考「這篇」和「這篇」以及「這篇」。


通常下載下來的「deb檔」,

請執行「$ sudo dpkg -i some.deb」來安裝。

若有相依的套件尚未安裝,上面的指令安裝完後,

然後再執行「$ sudo apt-get install -f」,可以把相依的套件安裝補足。

上面的步驟是在正常的狀況下的操作步驟。

也會遇到一些例外的狀況,就要依照提示的訊息來見招拆招了。

您的案例,請注意網頁上的說明「Ubuntu (14.04 recommended)」-「StarUML-v2.8.0-64-bit.deb」。

若您是在「16.04」安裝的話,會遇到的狀況,應該會跟「這篇」提到會遇到的狀況類似。

更多討論案例,請參考「[索引] 套件操作實務


$ man dpkg
$ man apt-get


另外還有一個工具「gdebi」,系統預設沒有安裝,需要額外先安裝。


## 額外閱讀

* The Debian Administrator's Handbook <-- 之前紀錄「在這
* The Debian Administrator's Handbook / 5.4. 以 dpkg 管理套件
* The Debian Administrator's Handbook / 6.2. aptitude、apt-get、與 apt 命令



2017/2/24 12:11
應用擴展 工具箱
回覆: 如何安裝 StarUML-v2.8.0-64-bit.deb ?
會員二級
註冊日期:
2009/12/17 21:17
所屬群組:
已註冊使用者
等級: 8
HP : 0 / 186
MP : 30 / 4600
EXP: 46
離線
試做了兩次都不行,是否跟我的 Ubuntu 1604LTS 有關呀?真不知如何解決?

/opt$ sudo dpkg -i StarUML-v2.8.0-64-bit.deb
選取了原先未選的套件 staruml。
(讀取資料庫 ... 目前共安裝了 252554 個檔案和目錄。)
準備解開 StarUML-v2.8.0-64-bit.deb ...
解開 staruml (2.8.0) 中...
dpkg: 因相依問題,無法設定 staruml:
staruml 相依於 libgcrypt11 (>= 1.4.5)﹔然而:
套件 libgcrypt11 未安裝。

dpkg: error processing package staruml (--install):
相依問題 - 保留未設定
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
處理時發生錯誤:
staruml


/opt$ sudo apt-get install -f
正在讀取套件清單... 完成
正在重建相依關係
正在讀取狀態資料... 完成
正在修正相依關係... 完成
下列套件將會被【移除】:
staruml
升級 0 個,新安裝 0 個,移除 1 個,有 0 個未被升級。
1 個沒有完整得安裝或移除。
此操作完成之後,會空出 189 MB 的磁碟空間。
是否繼續進行 [Y/n]? [Y/n] y
(讀取資料庫 ... 目前共安裝了 254289 個檔案和目錄。)
移除 staruml (2.8.0) 中...
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...

2017/2/24 15:45
應用擴展 工具箱
回覆: 如何安裝 StarUML-v2.8.0-64-bit.deb ?
會員五級
註冊日期:
2012/4/22 10:50
所屬群組:
已註冊使用者
等級: 33
HP : 163 / 815
MP : 522 / 14524
EXP: 62
離線
clarkliang 寫到:
試做了兩次都不行,是否跟我的 Ubuntu 1604LTS 有關呀?真不知如何解決?

/opt$ sudo dpkg -i StarUML-v2.8.0-64-bit.deb
選取了原先未選的套件 staruml。
(讀取資料庫 ... 目前共安裝了 252554 個檔案和目錄。)
準備解開 StarUML-v2.8.0-64-bit.deb ...
解開 staruml (2.8.0) 中...
dpkg: 因相依問題,無法設定 staruml:
staruml 相依於 libgcrypt11 (>= 1.4.5)﹔然而:
套件 libgcrypt11 未安裝。

dpkg: error processing package staruml (--install):
相依問題 - 保留未設定
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
處理時發生錯誤:
staruml


/opt$ sudo apt-get install -f
正在讀取套件清單... 完成
正在重建相依關係
正在讀取狀態資料... 完成
正在修正相依關係... 完成
下列套件將會被【移除】:
staruml
升級 0 個,新安裝 0 個,移除 1 個,有 0 個未被升級。
1 個沒有完整得安裝或移除。
此操作完成之後,會空出 189 MB 的磁碟空間。
是否繼續進行 [Y/n]? [Y/n] y
(讀取資料庫 ... 目前共安裝了 254289 個檔案和目錄。)
移除 staruml (2.8.0) 中...
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...



請參考上面回覆#2紅字的部份」。

samwhelp 寫到:
您的案例,請注意網頁上的說明「Ubuntu (14.04 recommended)」-「StarUML-v2.8.0-64-bit.deb」。


在「16.04」,我有嘗試過下指令的方式來安裝,結果是安裝不起來沒錯。
測試結果跟您「#3」提到的是一樣的,只是我的是英文訊息而已。

================================================================================

註: 以下我的測試環境是「Xubuntu 16.04 amd64 英文界面」。

================================================================================

然後關於

clarkliang 寫到:
dpkg: 因相依問題,無法設定 staruml:
staruml 相依於 libgcrypt11 (>= 1.4.5)﹔然而:
套件 libgcrypt11 未安裝。


您可以執行


$ apt-cache show libgcrypt11



顯示


N: Can't select versions from package 'libgcrypt11' as it is purely virtual
N: No packages found



表示沒有「libgcrypt11」這個套件。

================================================================================

執行


$ apt-cache search libgcrypt11



顯示


libgcrypt11-dev - transitional libgcrypt11-dev package



只有找到「libgcrypt11-dev」這個套件

================================================================================

執行


$ apt-cache showsrc libgcrypt11-dev



顯示


Package: libgcrypt20
Binary: libgcrypt20-doc, libgcrypt20-dev, libgcrypt20, libgcrypt20-udeb, libgcrypt11-dev
...略...




表示「libgcrypt11-dev」這個「Package(套件)」,

是屬於「libgcrypt20」這個「Source Package(原始碼套件)」。

而「libgcrypt20」這個「Source Package(原始碼套件)」分成不同的「Package(套件)」,

分別是

* libgcrypt20-doc
* libgcrypt20-dev
* libgcrypt20
* libgcrypt20-udeb
* libgcrypt11-dev

================================================================================

$ man apt-cache

================================================================================

我的系統已經有安裝「libgcrypt20」這個套件

所以執行下面的指令


$ dpkg -L libgcrypt20



會顯示


/.
/lib
/lib/x86_64-linux-gnu
/lib/x86_64-linux-gnu/libgcrypt.so.20.0.5
/usr
/usr/share
/usr/share/doc
/usr/share/doc/libgcrypt20
/usr/share/doc/libgcrypt20/changelog.Debian.gz
/usr/share/doc/libgcrypt20/copyright
/usr/share/doc/libgcrypt20/README.gz
/usr/share/doc/libgcrypt20/AUTHORS.gz
/usr/share/doc/libgcrypt20/THANKS.gz
/usr/share/doc/libgcrypt20/NEWS.gz
/lib/x86_64-linux-gnu/libgcrypt.so.20



表示「libgcrypt20」這個套件,安裝那些檔案在系統上


執行


$ ls /lib/x86_64-linux-gnu/libgcrypt.so.20.0.5 -l



顯示


-rw-r--r-- 1 root root 919168 Aug 19 2016 /lib/x86_64-linux-gnu/libgcrypt.so.20.0.5



執行


$ ls /lib/x86_64-linux-gnu/libgcrypt.so.20 -l



顯示


lrwxrwxrwx 1 root root 19 Aug 19 2016 /lib/x86_64-linux-gnu/libgcrypt.so.20 -> libgcrypt.so.20.0.5



表示「/lib/x86_64-linux-gnu/libgcrypt.so.20

Symbolic link

到 「/lib/x86_64-linux-gnu/libgcrypt.so.20.0.5


================================================================================

執行下面指令,下載「StarUML-v2.8.0-64-bit.deb」。


$ wget -c http://staruml.io/download/release/v2.8.0/StarUML-v2.8.0-64-bit.deb




執行


$ dpkg -I StarUML-v2.8.0-64-bit.deb



顯示


new debian package, version 2.0.
size 43585506 bytes: control archive=1846 bytes.
977 bytes, 11 lines control
2539 bytes, 100 lines * postinst #!/bin/sh
450 bytes, 19 lines * postrm #!/bin/sh
1077 bytes, 39 lines * prerm #!/bin/sh
Package: staruml
Version: 2.8.0
Section: devel
Priority: optional
Architecture: amd64
Installed-Size: 184655
Pre-Depends: dpkg (>= 1.14.0)
Depends: gconf-service, libasound2 (>= 1.0.23), libatk1.0-0 (>= 1.12.4), libc6 (>= 2.11), libcairo2 (>= 1.6.0), libcups2 (>= 1.4.0), libdbus-1-3 (>= 1.2.14), libexpat1 (>= 1.95.8), libfontconfig1 (>= 2.8.0), libfreetype6 (>= 2.3.9), libgcc1 (>= 1:4.1.1), libgconf-2-4 (>= 2.31.1), libgcrypt11 (>= 1.4.5), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.18.0), libgtk2.0-0 (>= 2.24.0), libnspr4 (>= 1.8.0.10), libnss3 (>= 3.12.6), libpango1.0-0 (>= 1.22.0), libstdc++6 (>= 4.6), libudev0 (>= 147) | libudev1 (>= 198), libx11-6 (>= 2:1.4.99.1), libxcomposite1 (>= 1:0.3-1), libxdamage1 (>= 1:1.1), libxext6, libxfixes3, libxrandr2 (>= 2:1.2.0), libxrender1, ca-certificates, libcurl3, lsb-base (>= 3.2), xdg-utils (>= 1.0.2), wget
Maintainer: MKLab <support@staruml.io>
Description: StarUML
StarUML is a sophisticated software modeler.



或是執行


$ dpkg -f StarUML-v2.8.0-64-bit.deb



顯示


Package: staruml
Version: 2.8.0
Section: devel
Priority: optional
Architecture: amd64
Installed-Size: 184655
Pre-Depends: dpkg (>= 1.14.0)
Depends: gconf-service, libasound2 (>= 1.0.23), libatk1.0-0 (>= 1.12.4), libc6 (>= 2.11), libcairo2 (>= 1.6.0), libcups2 (>= 1.4.0), libdbus-1-3 (>= 1.2.14), libexpat1 (>= 1.95.8), libfontconfig1 (>= 2.8.0), libfreetype6 (>= 2.3.9), libgcc1 (>= 1:4.1.1), libgconf-2-4 (>= 2.31.1), libgcrypt11 (>= 1.4.5), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.18.0), libgtk2.0-0 (>= 2.24.0), libnspr4 (>= 1.8.0.10), libnss3 (>= 3.12.6), libpango1.0-0 (>= 1.22.0), libstdc++6 (>= 4.6), libudev0 (>= 147) | libudev1 (>= 198), libx11-6 (>= 2:1.4.99.1), libxcomposite1 (>= 1:0.3-1), libxdamage1 (>= 1:1.1), libxext6, libxfixes3, libxrandr2 (>= 2:1.2.0), libxrender1, ca-certificates, libcurl3, lsb-base (>= 3.2), xdg-utils (>= 1.0.2), wget
Maintainer: MKLab <support@staruml.io>
Description: StarUML




上面兩個指令,也可以搭配「grep」來過濾出「Depends:」那行


$ dpkg -I StarUML-v2.8.0-64-bit.deb | grep '^ Depends:'
$ dpkg -f StarUML-v2.8.0-64-bit.deb | grep '^Depends:'



或是執行下面指令,顯示「Depends」這個欄位的值


$ dpkg -f StarUML-v2.8.0-64-bit.deb Depends



則是顯示


gconf-service, libasound2 (>= 1.0.23), libatk1.0-0 (>= 1.12.4), libc6 (>= 2.11), libcairo2 (>= 1.6.0), libcups2 (>= 1.4.0), libdbus-1-3 (>= 1.2.14), libexpat1 (>= 1.95.8), libfontconfig1 (>= 2.8.0), libfreetype6 (>= 2.3.9), libgcc1 (>= 1:4.1.1), libgconf-2-4 (>= 2.31.1), libgcrypt11 (>= 1.4.5), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.18.0), libgtk2.0-0 (>= 2.24.0), libnspr4 (>= 1.8.0.10), libnss3 (>= 3.12.6), libpango1.0-0 (>= 1.22.0), libstdc++6 (>= 4.6), libudev0 (>= 147) | libudev1 (>= 198), libx11-6 (>= 2:1.4.99.1), libxcomposite1 (>= 1:0.3-1), libxdamage1 (>= 1:1.1), libxext6, libxfixes3, libxrandr2 (>= 2:1.2.0), libxrender1, ca-certificates, libcurl3, lsb-base (>= 3.2), xdg-utils (>= 1.0.2), wget




執行下面指令,解開「StarUML-v2.8.0-64-bit.deb」


$ dpkg -x StarUML-v2.8.0-64-bit.deb StarUML



切換到目錄「StarUML/opt/staruml/」


$ cd StarUML/opt/staruml/



執行


./staruml



顯示


./staruml: error while loading shared libraries: libgcrypt.so.11: cannot open shared object file: No such file or directory



執行


$ file staruml



顯示


staruml: Bourne-Again shell script, ASCII text executable



執行顯示


StarUML: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 2.6.24, BuildID[sha1]=2988a3ddac5652cad0d287fa7ebae4b6387486f9, not stripped



然後可以執行


$ ldd ./StarUML



上面指令會顯示一個列表,內容很多,就不列了,請自行執行上面指令來看結果。

再來執行


$ ldd ./StarUML | grep libgcrypt.so



顯示


        libgcrypt.so.11 => not found
        libgcrypt.so.20 => /lib/x86_64-linux-gnu/libgcrypt.so.20 (0x00007f6fdc7d5000)



執行


$ ldd ./StarUML | grep 'not found'



顯示


        libgcrypt.so.11 => not found
        libudev.so.0 => not found



執行


$ ldd lib/libcef.so | grep 'not found'



顯示


        libgcrypt.so.11 => not found



可以執行下面指令,了解如何使用「ldd」。

$ man ldd



我的系統有安裝「libudev1」這個套件。

所以執行下面的指令


$ dpkg -L libudev1



會顯示


/.
/lib
/lib/x86_64-linux-gnu
/lib/x86_64-linux-gnu/libudev.so.1.6.4
/usr
/usr/share
/usr/share/doc
/usr/share/doc/libudev1
/usr/share/doc/libudev1/changelog.Debian.gz
/usr/share/doc/libudev1/copyright
/lib/x86_64-linux-gnu/libudev.so.1



執行


$ apt-cache policy libudev1



顯示


libudev1:
  Installed: 229-4ubuntu16
  Candidate: 229-4ubuntu16
  Version table:
 *** 229-4ubuntu16 500
        500 http://tw.archive.ubuntu.com/ubuntu xenial-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     229-4ubuntu10 500
        500 http://security.ubuntu.com/ubuntu xenial-security/main amd64 Packages
     229-4ubuntu4 500
        500 http://tw.archive.ubuntu.com/ubuntu xenial/main amd64 Packages





其餘的,請參考另一篇討論的回覆「#3」和「#5」「#4」。

在「#5」有列 lib 相關的參考連結,可以了解一些 lib 的概念。


================================================================================

以上提供參考

報告完畢


2017/2/24 16:31
應用擴展 工具箱
回覆: 如何安裝 StarUML-v2.8.0-64-bit.deb ?
會員二級
註冊日期:
2016/2/24 19:05
所屬群組:
已註冊使用者
等級: 5
HP : 0 / 100
MP : 13 / 662
EXP: 2
離線
dpkg 命令並不支援自動滿足軟體依賴關係,請改使用 gdebi 命令(由 gdebi-core 軟體包提供)

至於這樣做能不能裝起來是另一回事,我沒有試

2017/2/24 18:27
應用擴展 工具箱
回覆: 如何安裝 StarUML-v2.8.0-64-bit.deb ?
會員五級
註冊日期:
2012/4/22 10:50
所屬群組:
已註冊使用者
等級: 33
HP : 163 / 815
MP : 522 / 14524
EXP: 62
離線
林博仁 寫到:
dpkg 命令並不支援自動滿足軟體依賴關係,請改使用 gdebi 命令(由 gdebi-core 軟體包提供)

至於這樣做能不能裝起來是另一回事,我沒有試



關於「gdebi」這個工具,我在上面的「回覆#2」有稍微提到,


samwhelp 寫到:
另外還有一個工具「gdebi」,系統預設沒有安裝,需要額外先安裝。



本來想說「$ man gdebi」的「DESCRIPTION」就有提到了,就沒多提,感謝補充說明。


DESCRIPTION

       gdebi  lets you install local deb packages resolving and installing its
       dependencies. apt does the  same,  but  only  for  remote  (http,  ftp)
       located  packages.  It can also resolve build-depends of debian/control
       files.




不過這個工具,印象中,以前我應該是看您某篇回覆提到的,才曉得這個工具,感恩




## 操作步驟


執行下面指令,安裝「gdebi-core」。


$ sudo apt-get install gdebi-core





執行


$ sudo gdebi StarUML-v2.8.0-64-bit.deb




顯示


Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading state information... Done
This package is uninstallable
Dependency is not satisfiable: libgcrypt11 (>= 1.4.5)




相依的問題,請參考上面的「回覆#4

補充說明完畢。



## 相關套件

* gdebi
* gdebi-kde

2017/2/24 18:39
應用擴展 工具箱
回覆: 如何安裝 StarUML-v2.8.0-64-bit.deb ?
會員二級
註冊日期:
2009/12/17 21:17
所屬群組:
已註冊使用者
等級: 8
HP : 0 / 186
MP : 30 / 4600
EXP: 46
離線
試了幾次、一樣不行,錯誤訊息如下:不知如何安裝在 1604LTS 上,請教前輩們,感恩!

/opt$ sudo apt-get install gdebi-core
正在讀取套件清單... 完成
正在重建相依關係
正在讀取狀態資料... 完成
下列【新】套件將會被安裝:
gdebi-core
升級 0 個,新安裝 1 個,移除 0 個,有 0 個未被升級。
需要下載 9,716 B 的套件檔。
此操作完成之後,會多佔用 135 kB 的磁碟空間。
下載:1 http://archive.ubuntu.com/ubuntu xenial/main amd64 gdebi-core all 0.9.5.7ubuntu1 [9,716 B]
取得 9,716 B 用了 0秒 (14.4 kB/s)
選取了原先未選的套件 gdebi-core。
(讀取資料庫 ... 目前共安裝了 252554 個檔案和目錄。)
準備解開 .../gdebi-core_0.9.5.7ubuntu1_all.deb ...
解開 gdebi-core (0.9.5.7ubuntu1) 中...
Processing triggers for man-db (2.7.5-1) ...
設定 gdebi-core (0.9.5.7ubuntu1) ...


/opt$ sudo gdebi StarUML-v2.8.0-64-bit.deb
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading state information... Done
此套件無法安裝
Dependency is not satisfiable: libgcrypt11 (>= 1.4.5)

2017/2/24 22:52
應用擴展 工具箱
回覆: 如何安裝 StarUML-v2.8.0-64-bit.deb ?
會員五級
註冊日期:
2012/4/22 10:50
所屬群組:
已註冊使用者
等級: 33
HP : 163 / 815
MP : 522 / 14524
EXP: 62
離線
clarkliang 寫到:
試了幾次、一樣不行,錯誤訊息如下:不知如何安裝在 1604LTS 上,請教前輩們,感恩!

/opt$ sudo apt-get install gdebi-core
正在讀取套件清單... 完成
正在重建相依關係
正在讀取狀態資料... 完成
下列【新】套件將會被安裝:
gdebi-core
升級 0 個,新安裝 1 個,移除 0 個,有 0 個未被升級。
需要下載 9,716 B 的套件檔。
此操作完成之後,會多佔用 135 kB 的磁碟空間。
下載:1 http://archive.ubuntu.com/ubuntu xenial/main amd64 gdebi-core all 0.9.5.7ubuntu1 [9,716 B]
取得 9,716 B 用了 0秒 (14.4 kB/s)
選取了原先未選的套件 gdebi-core。
(讀取資料庫 ... 目前共安裝了 252554 個檔案和目錄。)
準備解開 .../gdebi-core_0.9.5.7ubuntu1_all.deb ...
解開 gdebi-core (0.9.5.7ubuntu1) 中...
Processing triggers for man-db (2.7.5-1) ...
設定 gdebi-core (0.9.5.7ubuntu1) ...


/opt$ sudo gdebi StarUML-v2.8.0-64-bit.deb
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading state information... Done
此套件無法安裝
Dependency is not satisfiable: libgcrypt11 (>= 1.4.5)



建議您可以再回去看我上面的回覆,還有研讀相關的參考連結

在「16.04」,您的案例,照我提到過的方法,
本來就是安裝不起來阿,我並沒說可以安裝成功

Orz....

這跟套件相依有關

clarkliang 寫到:
此套件無法安裝
Dependency is not satisfiable: libgcrypt11 (>= 1.4.5)



上面的回覆,我紀錄了很多執行結果,只是要引導您了解,發生這個狀況的緣由,
結果我造成您誤解了歹勢

簡單說,您要安裝「StarUML-v2.8.0-64-bit.deb」這個套件,
其中之一需要額外安裝「libgcrypt11」這個套件,
不過在「16.04」的套件庫中,並沒有「libgcrypt11」這個套件,
所以不管您使用

方法一: 「sudo dpkg -i StarUML-v2.8.0-64-bit.deb」+ 「sudo apt-get install -f」

方法二: 「sudo gdebi StarUML-v2.8.0-64-bit.deb」

結果都會是一樣的,「套件管理系統(1)」不允許您「安裝」「StarUML-v2.8.0-64-bit.deb」。

因為無法從遠端的套件庫,下載「libgcrypt11」這個套件來安裝,進而滿足「套件相依」。

然後若是使用

方法三: 「sudo dpkg -x StarUML-v2.8.0-64-bit.deb StarUML」

解開「deb檔」,然後直接執行「staruml」,
會顯示缺少「libgcrypt.so.11」這個提示訊息,這個我在上面的回覆有紀錄,
您可以再回去研讀上面的回覆內容(包含參考連結的內容),來琢磨了解。

然而缺的應該不是只有「libgcrypt.so.11」,一樣有紀錄在上面的回覆。

以上釐清

================================================================================

另外題外話

我個人的經驗是如此,
一些觀念,需要一點一點的累積建立,累積到某個點,就能觸類旁通了,
建議可以先聚焦在某個小範疇,先把那個小範疇的困惑迷惘,一一地去釐清,
有道是,一回生,二回熟,所以這需要時間,需要時間下功夫反覆地去琢磨推敲,進而獲得理解。
一開始我也都是霧裡看花,心生畏懼,不過經過不斷推敲理解後,
一些指令下了之後,知道執行後,要獲得什麼資訊,或是要達到什麼動作目標
一些觀念理解了,一些概念熟悉了,一些模式掌握了,
視野就變得開闊,有些迷惘,就不再是迷惘了,有些困惑,就不再是困惑,
這個就好像玩遊戲,開地圖,經過探索,慢慢的你就能清晰地看到輪廓,進而看到全貌了,
當然我也還沒完整的看到全貌,還在不斷的探索中,持續溫故知新中,就彼此勉勵摟!

================================================================================



2017/2/24 22:59
應用擴展 工具箱
回覆: 如何安裝 StarUML-v2.8.0-64-bit.deb ?
管理員
註冊日期:
2010/5/7 5:46
所屬群組:
已註冊使用者
討論區管理群
等級: 31
HP : 0 / 755
MP : 434 / 17789
EXP: 23
離線
查詢依頼
dpkg -I StarUML-v2.8.0-64-bit.deb | grep libgcrypt11
-I 是大寫的i
Depends: gconf-service, libasound2 (>= 1.0.23), libatk1.0-0 (>= 1.12.4), libc6 (>= 2.11), libcairo2 (>= 1.6.0), libcups2 (>= 1.4.0), libdbus-1-3 (>= 1.2.14), libexpat1 (>= 1.95.8), libfontconfig1 (>= 2.8.0), libfreetype6 (>= 2.3.9), libgcc1 (>= 1:4.1.1), libgconf-2-4 (>= 2.31.1), libgcrypt11 (>= 1.4.5), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.18.0), libgtk2.0-0 (>= 2.24.0), libnspr4 (>= 1.8.0.10), libnss3 (>= 3.12.6), libpango1.0-0 (>= 1.22.0), libstdc++6 (>= 4.6), libudev0 (>= 147) | libudev1 (>= 198), libx11-6 (>= 2:1.4.99.1), libxcomposite1 (>= 1:0.3-1), libxdamage1 (>= 1:1.1), libxext6, libxfixes3, libxrandr2 (>= 2:1.2.0), libxrender1, ca-certificates, libcurl3, lsb-base (>= 3.2), xdg-utils (>= 1.0.2), wget

我們可以看到 libgcrypt11 (>= 1.4.5) ,這在 Ubuntu 16.04 是沒有的。
libgcrypt11 來源
http://packages.ubuntu.com/trusty/amd64/libgcrypt11/download 下載 libgcrypt11 。
http://security.ubuntu.com/ubuntu/pool/main/libg/libgcrypt11/libgcrypt11_1.5.3-2ubuntu4.4_amd64.deb
下載14.04的 libgcrypt11
跟原來的檔案放同一個資料夾,然後下指令。

查詢安裝檔相依資訊
dpkg -I libgcrypt11_1.5.3-2ubuntu4.4_amd64.deb | grep Depends
-I 是大寫的i

Pre-Depends: multiarch-support
Depends: libc6 (>= 2.15), libgpg-error0 (>= 1.10)


查詢系統 libc6 和 libgpg-error0 是否符合安裝條件,大於 libc6 (>= 2.15), libgpg-error0 (>= 1.10) 版本號即可。
dpkg -l | grep -E "libc6|libgpg-error0"
-l 是小寫的L

ii libc6:amd64 2.19-18+deb8u7 amd64 GNU C Library: Shared libraries
ii libc6-dev:amd64 2.19-18+deb8u7 amd64 GNU C Library: Development Libraries and Header Files
ii libgpg-error0:amd64 1.17-3 amd64 library for common error values and messages in GnuPG components


確認之後下達安裝指令。
sudo dpkg -i libgcrypt11_1.5.3-2ubuntu4.4_amd64.deb StarUML-v2.8.0-64-bit.deb
沒意外的話這樣即可。

2017/2/25 12:12
應用擴展 工具箱
回覆: 如何安裝 StarUML-v2.8.0-64-bit.deb ?
會員五級
註冊日期:
2012/4/22 10:50
所屬群組:
已註冊使用者
等級: 33
HP : 163 / 815
MP : 522 / 14524
EXP: 62
離線
nana 寫到:
查詢依頼
dpkg -I StarUML-v2.8.0-64-bit.deb | grep libgcrypt11
-I 是大寫的i
Depends: gconf-service, libasound2 (>= 1.0.23), libatk1.0-0 (>= 1.12.4), libc6 (>= 2.11), libcairo2 (>= 1.6.0), libcups2 (>= 1.4.0), libdbus-1-3 (>= 1.2.14), libexpat1 (>= 1.95.8), libfontconfig1 (>= 2.8.0), libfreetype6 (>= 2.3.9), libgcc1 (>= 1:4.1.1), libgconf-2-4 (>= 2.31.1), libgcrypt11 (>= 1.4.5), libgdk-pixbuf2.0-0 (>= 2.22.0), libglib2.0-0 (>= 2.18.0), libgtk2.0-0 (>= 2.24.0), libnspr4 (>= 1.8.0.10), libnss3 (>= 3.12.6), libpango1.0-0 (>= 1.22.0), libstdc++6 (>= 4.6), libudev0 (>= 147) | libudev1 (>= 198), libx11-6 (>= 2:1.4.99.1), libxcomposite1 (>= 1:0.3-1), libxdamage1 (>= 1:1.1), libxext6, libxfixes3, libxrandr2 (>= 2:1.2.0), libxrender1, ca-certificates, libcurl3, lsb-base (>= 3.2), xdg-utils (>= 1.0.2), wget

我們可以看到 libgcrypt11 (>= 1.4.5) ,這在 Ubuntu 16.04 是沒有的。
libgcrypt11 來源
http://packages.ubuntu.com/trusty/amd64/libgcrypt11/download 下載 libgcrypt11 。
http://security.ubuntu.com/ubuntu/pool/main/libg/libgcrypt11/libgcrypt11_1.5.3-2ubuntu4.4_amd64.deb
下載14.04的 libgcrypt11
跟原來的檔案放同一個資料夾,然後下指令。

查詢安裝檔相依資訊
dpkg -I libgcrypt11_1.5.3-2ubuntu4.4_amd64.deb | grep Depends
-I 是大寫的i

Pre-Depends: multiarch-support
Depends: libc6 (>= 2.15), libgpg-error0 (>= 1.10)


查詢系統 libc6 和 libgpg-error0 是否符合安裝條件,大於 libc6 (>= 2.15), libgpg-error0 (>= 1.10) 版本號即可。
dpkg -l | grep -E "libc6|libgpg-error0"
-l 是小寫的L

ii libc6:amd64 2.19-18+deb8u7 amd64 GNU C Library: Shared libraries
ii libc6-dev:amd64 2.19-18+deb8u7 amd64 GNU C Library: Development Libraries and Header Files
ii libgpg-error0:amd64 1.17-3 amd64 library for common error values and messages in GnuPG components


確認之後下達安裝指令。
sudo dpkg -i libgcrypt11_1.5.3-2ubuntu4.4_amd64.deb StarUML-v2.8.0-64-bit.deb
沒意外的話這樣即可。



哇,厲害,佩服

感恩指點

統整上面的步驟,以下是安裝成功的指令


wget -c http://staruml.io/download/release/v2.8.0/StarUML-v2.8.0-64-bit.deb
wget -c http://security.ubuntu.com/ubuntu/pool/main/libg/libgcrypt11/libgcrypt11_1.5.3-2ubuntu4.4_amd64.deb
sudo dpkg -i libgcrypt11_1.5.3-2ubuntu4.4_amd64.deb StarUML-v2.8.0-64-bit.deb



執行下面指令產生「/lib/x86_64-linux-gnu/libudev.so.0」


cd /lib/x86_64-linux-gnu/
sudo ln -s libudev.so.1 libudev.so.0



上面的動作,只是「Symbolic link」到「/lib/x86_64-linux-gnu/libudev.so.1」


然後執行


staruml



可以啟動「staruml」

================================================================================

註:

* 因為我沒在新的系統測試,
是在我目前的工作的環境測試,以前應該有安裝了很多套件,
所以若是您的系統,執行上面的步驟安裝的時候,還是有缺相依套件的話,
一樣使用「sudo apt-get install -f」來補足缺少的相依套件,
若還是不行的話,就依照nana提到的模式,手動去安裝相依的套件了。

* 一開始執行「staruml」會出現下面的訊息


/usr/bin/staruml: error while loading shared libraries: libudev.so.0: cannot open shared object file: No such file or directory


所以才執行「產生 /lib/x86_64-linux-gnu/libudev.so.0」那個動作。

可以再參考上面的回覆

================================================================================

若是要移除,以下是參考指令



sudo rm /lib/x86_64-linux-gnu/libudev.so.0

sudo apt-get remove libgcrypt11

# sudo apt-get remove libgcrypt11 staruml



================================================================================

報告完畢


2017/2/25 12:44
應用擴展 工具箱

(1) 2 »

 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.