移除核心時發生錯誤 [論壇 - Ubuntu 與 GNOME]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊



移除核心時發生錯誤
會員一級
註冊日期:
2014/1/25 11:45
所屬群組:
已註冊使用者
等級: 4
HP : 0 / 75
MP : 9 / 846
EXP: 3
離線
移除核心時發生錯誤

執行
sudo apt-get remove $(dpkg -l|egrep '^ii linux-(im|he)'|awk '{print $2}'|grep -v `uname -r`)


以下套件為自動安裝,並且已經無用:
thermald
以 sudo apt autoremove 將之移除。
下列套件將會被【移除】:
linux-generic linux-headers-4.10.0-20 linux-headers-4.10.0-20-generic
linux-headers-4.10.0-21 linux-headers-4.10.0-21-generic
linux-headers-4.8.0-46 linux-headers-4.8.0-46-generic linux-headers-generic
linux-image-4.10.0-20-generic linux-image-4.8.0-46-generic
linux-image-extra-4.10.0-20-generic linux-image-extra-4.8.0-46-generic
linux-image-generic
升級 0 個,新安裝 0 個,移除 13 個,有 0 個未被升級。
此操作完成之後,會空出 704 MB 的磁碟空間。
是否繼續進行 [Y/n]? [Y/n] y
dpkg: 錯誤: 讀取套件 info 檔 '/var/lib/dpkg/available': 是個目錄
E: 子程序 dpkg --set-selections 傳回錯誤碼 (2)
E: Couldn't record the approved state changes as dpkg selection states


要如何解決dpkg的錯誤呢?

麻煩各位解惑

感激不盡

5/27 14:24:24
應用擴展 工具箱
回覆: 移除核心時發生錯誤
會員五級
註冊日期:
2012/4/22 10:50
所屬群組:
已註冊使用者
等級: 33
HP : 160 / 804
MP : 505 / 13132
EXP: 18
離線
小火車 寫到:
移除核心時發生錯誤

執行
sudo apt-get remove $(dpkg -l|egrep '^ii  linux-(im|he)'|awk '{print $2}'|grep -v `uname -r`)


以下套件為自動安裝,並且已經無用:
thermald
以 sudo apt autoremove 將之移除。
下列套件將會被【移除】:
linux-generic linux-headers-4.10.0-20 linux-headers-4.10.0-20-generic
linux-headers-4.10.0-21 linux-headers-4.10.0-21-generic
linux-headers-4.8.0-46 linux-headers-4.8.0-46-generic linux-headers-generic
linux-image-4.10.0-20-generic linux-image-4.8.0-46-generic
linux-image-extra-4.10.0-20-generic linux-image-extra-4.8.0-46-generic
linux-image-generic
升級 0 個,新安裝 0 個,移除 13 個,有 0 個未被升級。
此操作完成之後,會空出 704 MB 的磁碟空間。
是否繼續進行 [Y/n]? [Y/n] y
dpkg: 錯誤: 讀取套件 info 檔 '/var/lib/dpkg/available': 是個目錄
E: 子程序 dpkg --set-selections 傳回錯誤碼 (2)
E: Couldn't record the approved state changes as dpkg selection states


要如何解決dpkg的錯誤呢?

麻煩各位解惑

感激不盡



從下面這個提示訊息

小火車 寫到:
dpkg: 錯誤: 讀取套件 info 檔 '/var/lib/dpkg/available': 是個目錄
E: 子程序 dpkg --set-selections 傳回錯誤碼 (2)
E: Couldn't record the approved state changes as dpkg selection states



您可以嘗試確認,在您的系統,「/var/lib/dpkg/available」這個檔案是否是資料夾?

實際上「/var/lib/dpkg/available」應該是檔案,不是資料夾。

另外從之前的討論「更新套件時發生錯誤」,感覺您的系統,怎麼有點錯亂了? Orz...


在我的系統「Xubuntu 16.04 amd64 英文界面」,

執行


$ file /var/lib/dpkg/available



顯示


/var/lib/dpkg/available: UTF-8 Unicode text, with very long lines



執行


$ ls /var/lib/dpkg/available -l



顯示


-rw-r--r-- 1 root root 170080 Apr 21 2016 /var/lib/dpkg/available




===========================================================

另外在一般的狀況下,遇到下面的提示訊息,
只要執行「sudo apt-get autoremove」或「sudo apt autoremove」就行了,

之前的「#2 回覆: 更新套件時發生錯誤」有說明「apt-get autoremove」這一段。

小火車 寫到:
以下套件為自動安裝,並且已經無用:
thermald
以 sudo apt autoremove 將之移除。


5/27 14:53:05
應用擴展 工具箱


 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.