py2048 [論壇 - Ubuntu 影音及遊戲]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊



py2048
會員三級
註冊日期:
2009/3/12 22:37
所屬群組:
已註冊使用者
等級: 13
HP : 0 / 309
MP : 68 / 7643
EXP: 38
離線
安裝後不能玩

安裝command

~$ wget https://raw.githubusercontent.com/ralphembree/py2048/master/install.sh -q -O - | bash



error message如下

~$ py2048
Traceback (most recent call last):
File "/home/ww1/.local/bin/py2048", line 22, in <module>
from gtk import *
ImportError: No module named gtk

7/28 17:27:17
應用擴展 工具箱
回覆: py2048
會員五級
註冊日期:
2012/4/22 10:50
所屬群組:
已註冊使用者
等級: 32
HP : 155 / 776
MP : 464 / 12107
EXP: 7
離線
w1w 寫到:
安裝後不能玩

安裝command

~$ wget https://raw.githubusercontent.com/ralphembree/py2048/master/install.sh -q -O - | bash



error message如下

~$ py2048
Traceback (most recent call last):
File "/home/ww1/.local/bin/py2048", line 22, in <module>
from gtk import *
ImportError: No module named gtk




以下測試,在「Xubuntu 14.04 amd64 中文界面」

參考「https://raw.githubusercontent.com/ralphembree/py2048/master/install.sh」的內容

執行下面指令


$ wget -c https://raw.githubusercontent.com/ralphembree/py2048/master/py2048 -O py2048.py



正常的狀況下,會下載一個檔案,重新命名為「py2048.py」。

然後執行


$ python2 ./py2048.py



在我的環境,是可以正常執行的

就會看到「原始專案」裡面給的「Screenshot」的畫面。

================================================

然後在我的環境執行


$ python2



接下來操作顯示


Python 2.7.6 (default, Oct 26 2016, 20:30:19) 
[GCC 4.8.4] on linux2
Type "help", "copyright", "credits" or "license" for more information.
>>> import gtk 
>>> gtk 
<module 'gtk' from '/usr/lib/python2.7/dist-packages/gtk-2.0/gtk/__init__.pyc'>
>>> 



然後按下「Ctrl+d」離開,

接下來先執行


$ dpkg -S /usr/lib/python2.7/dist-packages/gtk-2.0/gtk/__init__.pyc



顯示


dpkg-query: 找不到符合 /usr/lib/python2.7/dist-packages/gtk-2.0/gtk/__init__.pyc 的路徑




再執行


$ dpkg -S /usr/lib/python2.7/dist-packages/gtk-2.0/gtk



顯示


python-gtk2, python-glade2: /usr/lib/python2.7/dist-packages/gtk-2.0/gtk



再加上您提供的提示訊息


w1w 寫到:
error message如下

~$ py2048
Traceback (most recent call last):
File "/home/ww1/.local/bin/py2048", line 22, in <module>
from gtk import *
ImportError: No module named gtk




所以推測,在您的環境,應該是沒有安裝「python-gtk2」這個套件,


您可以執行下面指令,來安裝「python-gtk2」這個套件


$ sudo apt-get install python-gtk2



您可以再測看看,在您的環境,「py2048」是否能正常執行


================================================

若是已經安裝「python-gtk2」這個套件,

可以執行下面指令,了解「python-gtk2」這個套件,安裝了那些檔案在系統上,


$ dpkg -L python-gtk2



顯示


/.
/usr
/usr/share
/usr/share/doc
/usr/share/doc/python-gtk2
/usr/share/doc/python-gtk2/README
/usr/share/doc/python-gtk2/MAPPING.gz
/usr/share/doc/python-gtk2/TODO
/usr/share/doc/python-gtk2/copyright
/usr/share/doc/python-gtk2/NEWS.gz
/usr/share/doc/python-gtk2/README.Debian
/usr/share/doc/python-gtk2/THREADS.gz
/usr/share/doc/python-gtk2/changelog.Debian.gz
/usr/lib
/usr/lib/python2.7
/usr/lib/python2.7/dist-packages
/usr/lib/python2.7/dist-packages/gtk-2.0
/usr/lib/python2.7/dist-packages/gtk-2.0/pangocairo.so
/usr/lib/python2.7/dist-packages/gtk-2.0/atk.so
/usr/lib/python2.7/dist-packages/gtk-2.0/gtk
/usr/lib/python2.7/dist-packages/gtk-2.0/gtk/deprecation.py
/usr/lib/python2.7/dist-packages/gtk-2.0/gtk/compat.py
/usr/lib/python2.7/dist-packages/gtk-2.0/gtk/__init__.py
/usr/lib/python2.7/dist-packages/gtk-2.0/gtk/keysyms.py
/usr/lib/python2.7/dist-packages/gtk-2.0/gtk/_gtk.so
/usr/lib/python2.7/dist-packages/gtk-2.0/gtk/_lazyutils.py
/usr/lib/python2.7/dist-packages/gtk-2.0/pango.so
/usr/lib/python2.7/dist-packages/gtk-2.0/gtkunixprint.so



其餘的套件操作的討論案例,請參考「[索引] 套件操作實務」。

================================================

以上提供參考

報告完畢


7/29 13:04:38
應用擴展 工具箱


 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.