請問 USB型 RTL8192EU 網卡要怎麼安裝? [論壇 - 新手村]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊

(1) 2 »


請問 USB型 RTL8192EU 網卡要怎麼安裝?
會員三級
註冊日期:
2015/1/29 12:22
所屬群組:
已註冊使用者
等級: 11
HP : 0 / 269
MP : 54 / 3048
EXP: 78
離線
晚安好~
光碟附的LINUX驅動不會安裝...我把驅動上傳免空...
盼熱心人士幫忙.感恩~
https://drive.google.com/open?id=1PZGV9VMyat94qewbsGkEy6baaKDNJ-IB
作業系統是 LMDE 2 Betsy (32-bit) 脫線的部落格的版本.
PS:先前這邊求助的RTL8192CU 的驅動,安裝過 沒有支援這個型號( RTL8192EU )

*以下是自己把先前的操作筆記與RTL8192CU 備份存檔起來 , 非常受益.很感恩,感謝幫助~
https://drive.google.com/drive/folders/1nLUkB8ASgsAhYeKcWwMSs1TI266Ot_pm

7/25 0:27:14
應用擴展 工具箱
回覆: 請問 USB型 RTL8192EU 網卡要怎麼安裝?
會員三級
註冊日期:
2006/1/11 0:33
所屬群組:
已註冊使用者
等級: 12
HP : 0 / 279
MP : 57 / 10544
EXP: 17
離線

7/25 9:40:58
這個站可以廢了, 很愛言論審核, 發廢文亂回答答錯的卻很快就審核通過
應用擴展 工具箱
回覆: 請問 USB型 RTL8192EU 網卡要怎麼安裝?
會員三級
註冊日期:
2015/1/29 12:22
所屬群組:
已註冊使用者
等級: 11
HP : 0 / 269
MP : 54 / 3048
EXP: 78
離線
已廢站 寫到:
試試看github上的

https://github.com/Mange/rtl8192eu-linux-driver


昨晚有試一些 ,用DKMS的安裝方式.但是有出現一排字之後現在系統掛了..沒有想到測試那種東西要使用虛擬系統了。

其實安裝方法我不懂 ..現在仍無法開機進入桌面,
那個網頁英文我稍微估狗翻譯一下,他第一個步驟要先下載連結的檔嗎?
DWA-131 Linux driver v4.3.1.1.zip (5.88 MB)
http://files.dlink.com.au/products/DWA-131/REV_E/Drivers/DWA-131_Linux_driver_v4.3.1.1.zip

然後怎麼安裝呢?謝謝
(作業系統是 LMDE 2 Betsy (32-bit) )

7/25 11:39:54
應用擴展 工具箱
回覆: 請問 USB型 RTL8192EU 網卡要怎麼安裝?
會員二級
註冊日期:
2017/3/23 10:15
所屬群組:
已註冊使用者
等級: 5
HP : 0 / 122
MP : 16 / 616
EXP: 90
離線
KMS原始碼並不是每個 Linux 核心的版本 都能正常編譯
該板不能編譯就是要打補釘

例如我的是 Linux 4.16 github 上的可以編譯,你附的就沒辦法編譯

#############################
不使用dkms編譯安裝的方法
#############################
cd 20140812_rtl8192EU_linux_v4.3.1.1_11320

編譯
IGNORE_CC_MISMATCH=1 make SYSSRC=/lib/modules/$(uname -r)/build MODULE_NAME="8192eu"

安裝
sudo install -D -m644 8192eu.ko /lib/modules/$(uname -r)/kernel/drivers/net/wireless/8192eu.ko

重建 modules.dep
sudo depmod

載入模組
sudo modprobe 8192eu

寫入核心
sudo update-initramfs -u

#############################
使用dkms編譯安裝的方法
#############################
添加 dkms.conf 到 20140812_rtl8192EU_linux_v4.3.1.1_11320 目錄內

內容為:
PACKAGE_NAME="rtl8192eu"
PACKAGE_VERSION="1.0"
BUILT_MODULE_NAME="8192eu"
DEST_MODULE_LOCATION="/kernel/drivers/net/wireless/"
REMAKE_INITRD="yes"
AUTOINSTALL="yes"
MAKE="'make' all KVER=${kernelver}"
CLEAN="make clean"


把 20140812_rtl8192EU_linux_v4.3.1.1_11320 改名為 rtl8192eu-1.0
複製到 /usr/src

使用dkms編譯安裝
sudo dkms install -m rtl8192eu -v 1.0 -k $(uname -r)

7/25 13:49:27
應用擴展 工具箱
回覆: 請問 USB型 RTL8192EU 網卡要怎麼安裝?
會員三級
註冊日期:
2015/1/29 12:22
所屬群組:
已註冊使用者
等級: 11
HP : 0 / 269
MP : 54 / 3048
EXP: 78
離線
對了...這些操作電腦白痴看不懂的...如果能更口語更簡單的方法就更棒了,我想另外問一下,不知道有沒有相關類似的套件整合,包含這個驅動的安裝呢?(像安裝該套件就能完成安裝那樣子,希望有人知道我想表達的意思)感謝妳們不厭其煩的幫助 感恩
謝謝大家

7/25 21:15:42
應用擴展 工具箱
回覆: 請問 USB型 RTL8192EU 網卡要怎麼安裝?
會員二級
註冊日期:
2017/3/23 10:15
所屬群組:
已註冊使用者
等級: 5
HP : 0 / 122
MP : 16 / 616
EXP: 90
離線
電腦白ㄘ看不懂 ?

那好吧用LMDE表演一下,我沒32-bit舊版本,只有64-bit新版本。

linux 4.14 範例


首先取得原始碼,並 cd 到目錄
git clone https://github.com/Mange/rtl8192eu-linux-driver.git



然後編譯


編譯好之後安裝


你會看到安裝好的檔案在這裡


然後重建一下Linux 開機載入模組的清單 modules.dep


這樣重新啟動模組(驅動)就會載入就可以用了

如果不想重新啟動,要馬上用,直接載入模組


重建 initrd 這可能是多餘的,RUN一下也好。


要等人做好套件,DEB 的現在沒看人做,Arch Linux AUR 有套件,那也是用指令編譯安裝。

不然的話等一陣子 看新版的 Linux 會不會加入 這樣連裝都不用裝,但是你堅持用舊版的,如不等人做出來,就是要自己動手

7/26 0:48:53
應用擴展 工具箱
回覆: 請問 USB型 RTL8192EU 網卡要怎麼安裝?
會員三級
註冊日期:
2015/1/29 12:22
所屬群組:
已註冊使用者
等級: 11
HP : 0 / 269
MP : 54 / 3048
EXP: 78
離線
先謝謝百忙之中提供圖片教學,是一劑大補帖,,,,
謝謝建議..都會作筆記與參考的,我抽空會官網下載新版本64bit ,然後找時間...然後再灌入USB...(想搞這些..光想就有些頭疼了)抽空再來搞搞看了摟,,,,如有不懂會再上來提問問題哦 謝謝你們 感恩~~ 晚安各位

7/26 1:32:24
應用擴展 工具箱
回覆: 請問 USB型 RTL8192EU 網卡要怎麼安裝?
會員三級
註冊日期:
2015/1/29 12:22
所屬群組:
已註冊使用者
等級: 11
HP : 0 / 269
MP : 54 / 3048
EXP: 78
離線
剛剛網頁發現出LMDE 3 版本,不知道內建有沒有這些驅動~如果有就可以帶來便利了,如果新版本沒有增加內建驅動,我這邊只有WIFI網路...要安裝相當的麻煩...LMDE 3 64bit慢慢下載中,(迷之音:沒有驅動的話更新這個版本。。基本上也是沒有屁用的吧~~)

8/7 23:24:38
Ubuntu 桌面版 32bit/64 bit
應用擴展 工具箱
回覆: 請問 USB型 RTL8192EU 網卡要怎麼安裝?
會員二級
註冊日期:
2017/3/23 10:15
所屬群組:
已註冊使用者
等級: 5
HP : 0 / 122
MP : 16 / 616
EXP: 90
離線
LMDE3 應該是 Debian stretch 版核心 4.9 版,你的驅動應該也沒加入,因為我用Linux 4.16 都沒有了。


你可以自己按照上面方法編譯看看,應該可以

8/8 9:16:30
應用擴展 工具箱
回覆: 請問 USB型 RTL8192EU 網卡要怎麼安裝?
會員三級
註冊日期:
2015/1/29 12:22
所屬群組:
已註冊使用者
等級: 11
HP : 0 / 269
MP : 54 / 3048
EXP: 78
離線
呆丸廖添丁 寫到:
LMDE3 應該是 Debian stretch 版核心 4.9 版,你的驅動應該也沒加入,因為我用Linux 4.16 都沒有了。


你可以自己按照上面方法編譯看看,應該可以


傍晚好,我對驅動不懂..隔行如隔山...能不能幫我製作或教我怎麼下載驅動USB裡...讓我離線安裝那樣子...我這邊WIFI網路.重灌後沒有驅動.真的是傷腦筋.^^~"感恩妳

8/8 18:54:17
應用擴展 工具箱

(1) 2 »

 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.