如何安裝Intel顯示卡最新驅動? [論壇 - Ubuntu安裝問題]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊

« 1 (2) 3 4 5 6 »


訪客
回覆: 如何安裝Intel顯示卡最新驅動?
Anon:訪客
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o

沒安裝linux-headers 吧

2008/11/25 14:55 | 75878 66430 9b1e1 2165b
應用擴展 工具箱
訪客
回覆: 如何安裝Intel顯示卡最新驅動?
Anon:訪客
編譯準備:
sudo apt-get install build-essential xorg-dev libdrm-dev mesa-common-dev

2008/11/25 17:44 | ee583 373d2 f6ddc 2da4e
應用擴展 工具箱
sss
回覆: 如何安裝Intel顯示卡最新驅動?
Anon:sss
請問這個驅動是不是每次Kernel Update之後都要手動重裝一次?

要怎麼知道我的系統是否正在使用自編譯的驅動呢?

2008/11/28 13:28 | ee583 373d2 f6ddc 2da4e
應用擴展 工具箱
回覆: 如何安裝Intel顯示卡最新驅動?
會員三級
註冊日期:
2008/4/29 0:29
所屬群組:
已註冊使用者
等級: 10
HP : 0 / 241
MP : 45 / 9159
EXP: 66
離線

2008/11/28 15:17
應用擴展 工具箱
回覆: 如何安裝Intel顯示卡最新驅動?
會員五級
註冊日期:
2007/8/9 23:18
所屬群組:
已註冊使用者
等級: 23
HP : 0 / 555
MP : 216 / 22225
EXP: 22
離線
Kernel Update後不需要再手動安裝一次driver吧?...
我記得以前在8.04的時候從來沒有遇到這種問題過...

只有更新時不要讓synaptic去覆蓋掉xserver-xorg-video-intel...
這個可以在synaptic裡用鎖定版本來解決...

2008/11/28 15:28
應用擴展 工具箱
sss
回覆: 如何安裝Intel顯示卡最新驅動?
Anon:sss
我裝完後
查了Synaptic,
xserver-xorg-video-intel的版本仍然是2.2.2-1-1ubnutu3.7
這樣對嗎?

2008/12/1 11:14 | ee583 373d2 f6ddc 2da4e
應用擴展 工具箱
回覆: 如何安裝Intel顯示卡最新驅動?
會員五級
註冊日期:
2007/8/9 23:18
所屬群組:
已註冊使用者
等級: 23
HP : 0 / 555
MP : 216 / 22225
EXP: 22
離線
Synaptic只會顯示deb的版本號...
沒辦法管理自己用make insatll的軟體版本...

所以版號是不會變的...

要用鎖定版本或是ellon兄之前說的移除都是為了以後自動更新不要去蓋過現在自己編的driver...

2008/12/1 14:27
應用擴展 工具箱
回覆: 如何安裝Intel顯示卡最新驅動?
會員一級
註冊日期:
2008/7/22 9:20
所屬群組:
已註冊使用者
等級: 1
HP : 0 / 15
MP : 2 / 561
EXP: 60
離線
請問用什麼指令才能查到目前實際使用的intel driver版本?

2008/12/2 17:54
應用擴展 工具箱
回覆: 如何安裝Intel顯示卡最新驅動?
會員一級
註冊日期:
2009/1/12 11:13
所屬群組:
已註冊使用者
等級: 1
HP : 0 / 0
MP : 0 / 0
EXP: 0
離線
(1)同上,如何知道目前安裝的是否為INTEL 2.5.1 ?
(2)我的3D 特效無法開啟,是否為我的xorg.conf的Device那邊沒有INTEL
DRIVER造成?

2009/1/12 17:14
應用擴展 工具箱
sss
回覆: 如何安裝Intel顯示卡最新驅動?
Anon:sss
ellon 寫到:
Intel的開源驅動不時更新的。最新的為2.5.1。Ubuntu 8.04用的是2.2.1, Ubuntu 8.10用的是2.4.1。

對於編譯Intel顯示卡最新的驅動,好像很多人都不知道如何是好。所以,我在這裡留一個簡單教程: for 8.04

下載最新libdrm 2.4.4
http://dri.freedesktop.org/libdrm/libdrm-2.4.4.tar.bz2

最新Intel Video Driver 2.5.1
http://myubuntu.dreamhosters.com/download/xf86-video-intel-2.5.1.tar.bz2
(打了patch的)


編譯準備:
sudo apt-get install build-essential xorg-dev mesa-common-dev


編譯:
tar xvjf libdrm-2.4.4.tar.bz2
cd libdrm-2.4.4
./configure --prefix=/usr
make
sudo make install

cd ..

tar xvjf xf86-video-intel-2.5.1.tar.bz2
cd xf86-video-intel-2.5.1
./configure --prefix=/usr
make
sudo make install


驅動還原:
sudo apt-get install libdrm2 --reinstall
sudo apt-get install xserver-xorg-video-intel --reinstall

P.S.
xorg.conf的section "Device"裡,最好有一項Driver "intel",但不一定需要的。(如果3d用不了,就把Driver "intel"加到那個section)
還有在xorg.conf的最後,加入:
Section "DRI"
Mode 0666
EndSection

為了防止Ubuntu更新時,更換了驅動。
請在synaptic鎖定xserver-xorg-video-intel和libdrm2的版本!


請問這個最近有新的更新了嗎?

2009/2/6 14:55 | ee583 373d2 f6ddc 2da4e
應用擴展 工具箱

« 1 (2) 3 4 5 6 »

 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.