〔已解決〕有關andLinux [論壇 - Ubuntu 與 KDE]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊



〔已解決〕有關andLinux
會員五級
註冊日期:
2008/10/7 21:19
所屬群組:
已註冊使用者
等級: 36
HP : 0 / 896
MP : 661 / 36659
EXP: 85
離線
前幾天看到了andLinux http://www.andlinux.org/
這是除了虛擬機器外在Win上使用Ubuntu的方法(KDE介面),直接執行Linux的核心,裝完之後速度還不錯
但是前天在裝好了中文化之後重新啟動後就發現無法再執行圖形化介面的程式:
http://xs136.xs.to/xs136/09083/001614.png

我認為可能是因為不小心設定到了系統預設語言(我改成中文)導致的,所以上網查了一些文章後把語系設定成這樣:
http://xs136.xs.to/xs136/09083/002295.png

PS:我的修改是設定/etc/environment檔案為:
http://xs136.xs.to/xs136/09083/003780.png

並且從官網查到如果發生error code 9錯誤的話,就把launcher殺掉並重開 http://www.andlinux.org/forum/viewtopic.php?t=77
但是途中會出現像是語系錯誤的問題:
http://xs136.xs.to/xs136/09083/004286.png

請問有人知道這是出了什麼問題嗎?
以及該如何解決呢?
謝謝

2009/2/19 1:48
I′m UGP
應用擴展 工具箱
回覆: 有關andLinux
會員五級
註冊日期:
2008/6/15 2:56
所屬群組:
已註冊使用者
等級: 38
HP : 0 / 945
MP : 757 / 39528
EXP: 81
離線
你先修改下面三個檔案,最好先備份一下
/var/lib/locales/supported.d/zh
zh_TW.UTF-8  UTF-8

/var/lib/locales/supported.d/local
zh_TW.UTF-8 UTF-8 
en_US.UTF-8 UTF-8

/etc/environment
LANG="zh_TW.UTF-8"
LANGUAGE="zh_TW:zh"
LC_ALL="zh_TW.UTF-8"

改好後生成中文環境
sudo locale-gen

在打locale看看有沒有成功生成zh_TW,有的話重新開機試試
p.s我沒裝過你那個

2009/2/19 2:17
應用擴展 工具箱
回覆: 有關andLinux
會員五級
註冊日期:
2008/10/7 21:19
所屬群組:
已註冊使用者
等級: 36
HP : 0 / 896
MP : 661 / 36659
EXP: 85
離線
嗯嗯,我照著步驟設定了這三個檔案:
http://xs536.xs.to/xs536/09083/001534.png

其中需要注意的是原本沒有/var/lib/locales/supported.d/local這個檔案,所以我就自己建一個

locale-gen時出現了不知名的語系「zh_US.UTF-8」:
http://xs536.xs.to/xs536/09083/002960.png

locale:
http://xs536.xs.to/xs536/09083/003519.png

或許這個「zh_US.UTF-8」是主因吧?不清楚哪裡有這個設定值...

2009/2/19 10:38
I′m UGP
應用擴展 工具箱
回覆: 有關andLinux
會員四級
註冊日期:
2008/5/10 10:23
來自 烏煙"賬"氣的香港
所屬群組:
已註冊使用者
等級: 19
HP : 0 / 460
MP : 146 / 19400
EXP: 43
離線
Windows + Ubuntu那是不是不用wine都可以安裝及執行windows software。

2009/2/19 11:37
膠神萬歲
應用擴展 工具箱
回覆: 有關andLinux
會員五級
註冊日期:
2008/10/7 21:19
所屬群組:
已註冊使用者
等級: 36
HP : 0 / 896
MP : 661 / 36659
EXP: 85
離線
在Ubuntu下我不清楚是不是不需要Wine了,不過andLinux是在Win下執行Ubuntu的,要執行Win程式的話直接在Win下執行就可以了吧
http://xs536.xs.to/xs536/09083/2009-02-19586.png

2009/2/19 11:47
I′m UGP
應用擴展 工具箱
回覆: 有關andLinux
會員五級
註冊日期:
2008/6/15 2:56
所屬群組:
已註冊使用者
等級: 38
HP : 0 / 945
MP : 757 / 39528
EXP: 81
離線
看/var/lib/locales/supported.d/是否有除了zh跟local的檔案,有的話刪掉在sudo locale-gen看看
話說這樣應該可以進x window了吧?不妨試試看囉!

2009/2/19 14:45
應用擴展 工具箱
回覆: 有關andLinux
會員五級
註冊日期:
2008/10/7 21:19
所屬群組:
已註冊使用者
等級: 36
HP : 0 / 896
MP : 661 / 36659
EXP: 85
離線
hepha 寫到:
看/var/lib/locales/supported.d/是否有除了zh跟local的檔案,有的話刪掉在sudo locale-gen看看
話說這樣應該可以進x window了吧?不妨試試看囉!

只有zh、zh的備份檔、自己建的local,其他什麼都沒有
andLinux是KDE的,也是X window嗎(還是圖形化都叫X window)?

2009/2/19 16:51
I′m UGP
應用擴展 工具箱
回覆: 有關andLinux
會員五級
註冊日期:
2008/10/7 21:19
所屬群組:
已註冊使用者
等級: 36
HP : 0 / 896
MP : 661 / 36659
EXP: 85
離線
我去翻了官網的Wiki之後,知道問題點在哪了
Ubuntu的網卡IP設定跳掉了,要改回預設的192.168.11.150
http://www.andlinux.org/wiki/index.php5?title=Howto:_change_andLinux_network_configuration

重新設定/etc/network/interfaces這個檔案,改變eth1網卡的IP
改完之後就可以使用了:
http://xs536.xs.to/xs536/09084/2009-02-19893.png

2009/2/19 18:19
I′m UGP
應用擴展 工具箱


 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.