[分享] 在Ubuntu 9.04啟用Framebuffer [論壇 - Ubuntu基本設定]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊



Max
[分享] 在Ubuntu 9.04啟用Framebuffer
Anon:Max
如果想在Linux的文字介面(Console)看影片等等 需啟用Framebuffer
在Ubuntu 9.04上 可試試下列方法 (註:以下是在nVidia顯卡上測試的)

在終端機中
sudo apt-get install hwinfo
sudo hwinfo --framebuffer

記住適合你的螢幕的Mode的「0x0...」 例如:0x0318

然後備份開機設定檔
sudo cp /boot/grub/menu.lst /boot/grub/menu.lst.bak

編輯開機設定檔
sudo gedit /boot/grub/menu.lst

在開機項目「Ubuntu 9.04, kernel 版號-generic」
及「Ubuntu 9.04, kernel 版號-generic (recovery mode)」
的 kernel 行最後面加上 vga=0x0... 例如:vga=0x0318

儲存檔案 關閉文字編輯器

接著在終端機中將使用者加入video群組
sudo gpasswd -a 使用者 video

大功告成重新開機

最後 測試是否能在Console播放影片
請按 Ctrl+Alt+F1 進入tty1 登入後打
mplayer -vo fbdev -fs 影片

應該成功地播放了 按q關閉影片
打 exit 登出 按 Ctrl+Alt+F7 回到x window

假如沒聲音 那麼請輸入
sudo gpasswd -a 使用者 audio
然後重開機

除了能在Console播放影片 還能
顯示及輸入中文(zhcon) 瀏覽圖片(fbi) 聽音樂(mpg123) 截圖(fbgrab) 等等
有興趣的話 請自行研究 

參考文獻:http://cha.homeip.net/blog/archives/2008/12/_ubuntu_framebu.html

2009/8/12 2:32 | 3ccbb 1f821 c20a5 d4b29
應用擴展 工具箱
Max
回覆: [分享] 在Ubuntu 9.04啟用Framebuffer
Anon:Max
注意

編輯開機設定檔時
不要因為文字過長的折行 而加錯地方了
kernel 行的尾巴分別是

...... locale=zh_TW quiet splash
...... locale=zh_TW single

加在它們後面

2009/8/12 2:49 | 3ccbb 1f821 c20a5 d4b29
應用擴展 工具箱
回覆: [分享] 在Ubuntu 9.04啟用Framebuffer
會員三級
註冊日期:
2009/1/1 10:11
所屬群組:
已註冊使用者
等級: 9
HP : 0 / 205
MP : 34 / 7401
EXP: 20
離線
讚!

2009/8/12 13:28
應用擴展 工具箱
回覆: [分享] 在Ubuntu 9.04啟用Framebuffer
版主
註冊日期:
2006/12/24 16:54
所屬群組:
網站管理員
已註冊使用者
等級: 33
HP : 0 / 816
MP : 524 / 34296
EXP: 67
離線
for grub 1 users:
建議 vga 的選項加在
#defoptions=quiet splash

後面,變成
#defoptions=quiet splash vga=794

注意不要去掉註解
再用 update-grub 就可以更新 kernel option

好處是以後有更新 kernel 的話,不會再被 update-grub 洗掉,導致要重改一次

grub 2 的使用者要去更改 /etc/default/grub 的變數

2009/8/12 20:34
就算你百分之一百認定某人是渣滓中的渣滓,請仍然展示你的冷靜、體諒、尊重。

* My Blog
* My Twitter <- follow me!
* My Plurk
FoolproofProject:
* KomiX latest stable: v0.1.0 (Comics Viewer)
* Khopper latest stable: v0.4.2 (Audio Converter with CUE Sheet Support)
* PicKing latest stable: v0.2.3 (File Picking)
應用擴展 工具箱
回覆: [分享] 在Ubuntu 9.04啟用Framebuffer
版主
註冊日期:
2008/5/13 23:12
來自 Ciudad de Kaohsiung, Taiwán
所屬群組:
網站管理員
已註冊使用者
等級: 15
HP : 0 / 369
MP : 94 / 14004
EXP: 76
離線
這篇文章真不錯,幫你收錄進本論壇的精華區了!^_^

2009/8/12 20:38
The owl of Minerva spreads its wings only with the falling of the dusk.

--- G.W.F. Hegel (1770 - 1831)
應用擴展 工具箱
回覆: [分享] 在Ubuntu 9.04啟用Framebuffer
會員五級
註冊日期:
2008/6/15 2:56
所屬群組:
已註冊使用者
等級: 38
HP : 0 / 945
MP : 757 / 35618
EXP: 81
離線
sudo hwinfo --framebuffer沒反應的話有vga對照表
2Be: 調整 Linux Console 解析度
http://blog.2be.com.tw/2009/07/linux-console.html

2009/8/12 21:26
應用擴展 工具箱
回覆: [分享] 在Ubuntu 9.04啟用Framebuffer
會員五級
註冊日期:
2008/10/7 21:19
所屬群組:
已註冊使用者
等級: 36
HP : 0 / 896
MP : 661 / 32952
EXP: 85
離線
我發現這樣用完之後圖形介面下的工作列會變白,我是使用Ubuntu 8.04
之後依照:
http://cha.homeip.net/blog/archives/2008/12/_ubuntu_framebu.html

這裡的設定修改,目前沒有問題使用中

= = = = =

話說zhcon好像有些問題,中文顯示會怪怪的
有人知道怎麼解決嗎?

使用指令:
$ zhcon --utf8
$ w3m http://www.ubuntu-tw.org/

fbgrab截圖:

2009/8/13 1:36
I′m UGP
應用擴展 工具箱
回覆: [分享] 在Ubuntu 9.04啟用Framebuffer
版主
註冊日期:
2006/12/24 16:54
所屬群組:
網站管理員
已註冊使用者
等級: 33
HP : 0 / 816
MP : 524 / 34296
EXP: 67
離線
我個人是都用 jfbterm 啦...沒發生過什麼問題

2009/8/13 12:24
就算你百分之一百認定某人是渣滓中的渣滓,請仍然展示你的冷靜、體諒、尊重。

* My Blog
* My Twitter <- follow me!
* My Plurk
FoolproofProject:
* KomiX latest stable: v0.1.0 (Comics Viewer)
* Khopper latest stable: v0.4.2 (Audio Converter with CUE Sheet Support)
* PicKing latest stable: v0.2.3 (File Picking)
應用擴展 工具箱


 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.