build-essential 無法安裝 [論壇 - Ubuntu 與工具程式及軟體推薦]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊



build-essential 無法安裝

註冊日期:
2006/9/3 16:56
所屬群組:
已註冊使用者
等級: NAN
HP : NAN / NAN
MP : NAN / NAN
EXP: NAN
離線
小弟想自己Compiler 安裝PostgreSQL
遇到找不到gcc的問題!
爬文發現要安裝
sudo apt-get install build-essential
但是卻出現以下錯訊息不讓我裝
----------------------
build-essential: 依存關係:
libc6-dev 但是它卻不會被安裝。或 libc-dev
依存關係: gcc (>= 4:4.0) 但是它卻不會被安裝。
依存關係: g++ (>= 4:4.0) 但是它卻不會被安裝。
----------------------
怎麼辦?請大大幫忙

2006/10/3 23:21
應用擴展 工具箱
Re: build-essential 無法安裝
管理員
註冊日期:
2005/6/10 6:54
所屬群組:
網站管理員
已註冊使用者
等級: 4
HP : 0 / 92
MP : 11 / 4583
EXP: 68
離線
你的 source.list 內容是??

這種狀況有可能是亂定 source.list 以及亂裝 deb 所造成的狀況.

2006/10/4 9:14
應用擴展 工具箱
Re: build-essential 無法安裝

註冊日期:
2006/9/3 16:56
所屬群組:
已註冊使用者
等級: NAN
HP : NAN / NAN
MP : NAN / NAN
EXP: NAN
離線
小弟忘了是從那兒抓到的,麻煩shunhsiung大大幫忙看一下:
-------------------------------
# Ubuntu@TW DebTeam
deb http://apt.ubuntu.org.tw ubtw/

# Official Ubuntu@TW APT mirror source
deb http://apt.ubuntu.org.tw/ubuntu breezy-updates main restricted universe multiverse
deb-src http://apt.ubuntu.org.tw/ubuntu breezy-updates main restricted universe multiverse
deb http://apt.ubuntu.org.tw/ubuntu breezy main universe multiverse restricted
deb-src http://apt.ubuntu.org.tw/ubuntu breezy main universe multiverse restricted
deb http://apt.ubuntu.org.tw/ubuntu breezy-security main restricted universe multiverse
deb-src http://apt.ubuntu.org.tw/ubuntu breezy-security main restricted universe multiverse
deb http://apt.ubuntu.org.tw/ubuntu breezy-backports main restricted universe multiverse
deb-src http://apt.ubuntu.org.tw/ubuntu breezy-backports main restricted universe multiverse

# security update
deb http://security.ubuntu.com/ubuntu breezy-security main restricted universe multiverse
deb-src http://security.ubuntu.com/ubuntu breezy-security main restricted universe multiverse
------------------------------------

2006/10/4 9:59
應用擴展 工具箱
Re: build-essential 無法安裝
管理員
註冊日期:
2005/6/10 6:54
所屬群組:
網站管理員
已註冊使用者
等級: 4
HP : 0 / 92
MP : 11 / 4583
EXP: 68
離線
你目前的版本是 ? breezy or dapper ?

sudo apt-get update 更新套件清單看看。


2006/10/4 10:56
應用擴展 工具箱
Re: build-essential 無法安裝

註冊日期:
2006/9/3 16:56
所屬群組:
已註冊使用者
等級: NAN
HP : NAN / NAN
MP : NAN / NAN
EXP: NAN
離線
小弟是使用 Ubuntu 6.06 ,應該是dapper沒錯吧!!
update 的動作也作了好幾次了。 >“<

2006/10/4 11:24
應用擴展 工具箱
Re: build-essential 無法安裝
管理員
註冊日期:
2005/6/10 6:54
所屬群組:
網站管理員
已註冊使用者
等級: 4
HP : 0 / 92
MP : 11 / 4583
EXP: 68
離線
cat /etc/issue 或者 lsb_release -a 這兩個指令可以幫助你知道你是哪個 Ubuntu 版本.

若你的 Ubuntu 是 dapper , 而你的 /etc/source.list 確是 breezy , 這樣安裝套件當然會有問題.

mv /etc/apt/source.list /etc/apt/source.list.bkup
wget http://apt.ubuntu.org.tw/sources.list.dapper
mv sources.list.dapper /etc/apt/source.list
sudo apt-get update

2006/10/4 11:50
應用擴展 工具箱
Re: build-essential 無法安裝

註冊日期:
2006/9/3 16:56
所屬群組:
已註冊使用者
等級: NAN
HP : NAN / NAN
MP : NAN / NAN
EXP: NAN
離線
謝謝 shunhsiung 大大指導,小弟是新手,因為大大問起sources.list版
本的問題,小弟才去查資料,了解二個版本的不同!
小弟當初好像是載到breezy版本的,但是要等回家查看才知道了!
先謝謝shunhsiung大大了!!問題如果解決了再來回報!!感恩~

2006/10/4 13:58
應用擴展 工具箱
Re: build-essential 無法安裝

註冊日期:
2006/9/3 16:56
所屬群組:
已註冊使用者
等級: NAN
HP : NAN / NAN
MP : NAN / NAN
EXP: NAN
離線
可以了~感謝大大救命之恩啊!

不過修正一下,
是 sources.list ,不是 source.list 哦!少了一個s

2006/10/4 21:58
應用擴展 工具箱


 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.