請問一下安裝 pcmanx-pure-gtk2 的錯誤 [論壇 - Ubuntu 與工具程式及軟體推薦]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊



請問一下安裝 pcmanx-pure-gtk2 的錯誤
會員一級
註冊日期:
2005/10/13 16:52
所屬群組:
已註冊使用者
等級: 1
HP : 0 / 0
MP : 0 / 0
EXP: 0
離線
之前安裝都會成功
這次卻出現

下列的套件有無法滿足的依存關係:
pcmanx-pure-gtk2: 依存關係: libpcmanx-core0 但是它卻不會被安裝。
依存關係: libstdc++6 (>= 4.0.2) 但是『4.0.1-4ubuntu9』卻將被安裝。
依存關係: libxrender1 (> 1:0.9.0-1) 但是『1:0.9.0-1』卻將被安裝。
E: 損毀的套件

請問一下這個要怎麼解決呢

感謝

P.S
我的source.list除了原本的還有
deb http://www.calno.com unstable main
deb-src http://www.calno.com unstable main
deb http://apt.debian.org.tw unstable main
deb-src http://apt.debian.org.tw unstable main
deb http://ub.tnc.edu.tw/pub1 ubtw/
deb http://apt.ubuntu.org.tw ubtw/


版本
Linux home 2.6.12-8-386 #1 Tue Aug 30 22:41:30 BST 2005 i686 GNU/Linux
Ubuntu 5.10


UBUNTU新人,請多指教

2005/10/13 16:56
應用擴展 工具箱
Re: 請問一下安裝 pcmanx-pure-gtk2 的錯誤
站長
註冊日期:
2005/6/10 9:50
來自 Taichung, Taiwan.
所屬群組:
網站管理員
已註冊使用者
等級: 19
HP : 0 / 452
MP : 140 / 22697
EXP: 9
離線

ajer001 寫到:
我的source.list除了原本的還有
deb http://www.calno.com unstable main
deb-src http://www.calno.com unstable main
deb http://apt.debian.org.tw unstable main
deb-src http://apt.debian.org.tw unstable main
deb http://ub.tnc.edu.tw/pub1 ubtw/
deb http://apt.ubuntu.org.tw ubtw/
UBUNTU新人,請多指教


請將
deb http://apt.debian.org.tw unstable main
deb-src http://apt.debian.org.tw unstable main
中的 unstable 改為 testing 即可

因為 apt.dot unstable 中的 pcmanx 為 for debian unstable 的版本,dependency 跟 ubuntu hoary 的不同,所以請愛用 apt.ubtw 所提供的 pcmanx 套件 :)

另:
deb http://ub.tnc.edu.tw/pub1 ubtw/
deb http://apt.ubuntu.org.tw ubtw/
這兩個是同一個主機,所以僅留
deb http://apt.ubuntu.org.tw ubtw/
即可。

2005/10/15 1:09
應用擴展 工具箱
Re: 請問一下安裝 pcmanx-pure-gtk2 的錯誤
會員一級
註冊日期:
2005/10/13 16:52
所屬群組:
已註冊使用者
等級: 1
HP : 0 / 0
MP : 0 / 0
EXP: 0
離線
太感謝了,我在試試看。

另外,我想請問,台灣有那些不錯的deb站台呢

2005/10/19 1:23
應用擴展 工具箱
訪客
Re: 請問一下安裝 pcmanx-pure-gtk2 的錯誤
Anon:訪客
>> deb http://apt.ubuntu.org.tw ubtw/

收到,謝謝!
又請問:這是額外的, 還是全包括了(不需要其它 source)

2005/10/19 1:47 | a165f bd61c 27774 5f187
應用擴展 工具箱
Re: 請問一下安裝 pcmanx-pure-gtk2 的錯誤
會員一級
註冊日期:
2005/7/31 14:13
所屬群組:
已註冊使用者
等級: 4
HP : 0 / 75
MP : 9 / 3770
EXP: 3
離線
收到,謝謝!
又請問:這是額外的, 還是全包括了(不需要其它 source)


這裡面是包括gcin和pcmanx等軟體,
所以應該算是額外的套件庫,
您本來的那些套件庫還是要保留下來。

2005/10/19 8:08
應用擴展 工具箱
Re: 請問一下安裝 pcmanx-pure-gtk2 的錯誤
站長
註冊日期:
2005/6/10 9:50
來自 Taichung, Taiwan.
所屬群組:
網站管理員
已註冊使用者
等級: 19
HP : 0 / 452
MP : 140 / 22697
EXP: 9
離線
deb http://apt.ubuntu.org.tw ubtw/
這是額外的
deb http://apt.ubuntu.org.tw ubuntu/
這是原本的

所以都設就是全包了 XD

2005/10/19 10:17
應用擴展 工具箱
訪客
Re: 請問一下安裝 pcmanx-pure-gtk2 的錯誤
Anon:訪客
sudo apt-get update:
deb http://apt.ubuntu.org.tw ubuntu/ 無法讀取

2005/10/19 12:55 | a165f bd61c 27774 5f187
應用擴展 工具箱
訪客
Re: 請問一下安裝 pcmanx-pure-gtk2 的錯誤
Anon:訪客
deb http://apt.ubuntu.org.tw ubtw/ 的 pcmanx-pure-gtk2-0.3.2
請更新到 pcmanx-pure-gtk2-0.3.3

wiki 內的 sudo make install
應修改成:
sudo checkinstall
sudo dpkg -i pcmanx-pure-gtk2-0.3.3-1_i386.deb
(先 sudo apt-get install checkinstall 裝 checkinstall)

2005/10/20 13:09 | a165f bd61c 27774 5f187
應用擴展 工具箱


 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.