"四步驟" 在 Ubuntu 64 位元底下看 PPStream [論壇 - Ubuntu 影音及遊戲]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊

« 1 2 (3)


回覆: "四步驟" 在 Ubuntu 64 位元底下看 PPStream
會員一級
註冊日期:
2011/8/6 18:07
等級: 1
HP : 0 / 0
MP : 0 / 15
EXP: 2
離線
安装出现問题 以下:
-------------------
spymantw@ubuntu:/media/DATA$ sudo apt-get install libqt4-core libqt4-dbus libqt4-gui libqt4-network libqt4-webkit libqt4-xml libfuse2 mplayer
正在讀取套件清單... 完成
正在重建相依關係
正在讀取狀態資料... 完成
libfuse2 已經是最新版本了。
mplayer 已經是最新版本了。
libqt4-dbus 已經是最新版本了。
libqt4-gui 已經是最新版本了。
libqt4-network 已經是最新版本了。
libqt4-xml 已經是最新版本了。
libqt4-core 已經是最新版本了。
libqt4-webkit 已經是最新版本了。
升級 0 個,新安裝 0 個,移除 0 個,有 0 個未被升級。
spymantw@ubuntu:/media/DATA$ ls -al lib32qtwebkit4_2.0.0~0ubuntu1-2_amd64.deb
-rw------- 1 spymantw spymantw 7156870 2011-08-06 02:04 lib32qtwebkit4_2.0.0~0ubuntu1-2_amd64.deb
spymantw@ubuntu:/media/DATA$
spymantw@ubuntu:/media/DATA$
spymantw@ubuntu:/media/DATA$
spymantw@ubuntu:/media/DATA$ chmode 755 lib32qtwebkit4_2.0.0~0ubuntu1-2_amd64.deb
找不到 'chmode' 這個命令, 您是指這命令嗎:
命令 'chmod' 來自於套件 'coreutils' (main)
chmode: command not found
spymantw@ubuntu:/media/DATA$ chmod 755 lib32qtwebkit4_2.0.0~0ubuntu1-2_amd64.deb
spymantw@ubuntu:/media/DATA$
spymantw@ubuntu:/media/DATA$
spymantw@ubuntu:/media/DATA$ sudo dpkg -i lib32qtwebkit4_2.0.0~0ubuntu1-2_amd64.deb
選取了原先未被選取的套件 lib32qtwebkit4。
(正在讀取資料庫 ... 163513 files and directories currently installed.)
正在解開 lib32qtwebkit4 (從 lib32qtwebkit4_2.0.0~0ubuntu1-2_amd64.deb)...
dpkg:因相依問題,不能設定 lib32qtwebkit4:
lib32qtwebkit4 相依於 ia32-libs (>= 20080808)﹔然而:
未曾安裝套件 `ia32-libs'。
dpkg:在處理 lib32qtwebkit4 (--install) 時發生錯誤:
相依問題 - 保留為未設定
在處理時有錯誤發生:
lib32qtwebkit4
spymantw@ubuntu:/media/DATA$ sudo dpkg -i lib32qtwebkit4_2.0.0~0ubuntu1-2_amd64.deb
(正在讀取資料庫 ... 163522 files and directories currently installed.)
正準備替換 lib32qtwebkit4 2.0.0~0ubuntu1-2(使用 lib32qtwebkit4_2.0.0~0ubuntu1-2_amd64.deb)...
正在解開替換的套件檔 lib32qtwebkit4 ...
dpkg:因相依問題,不能設定 lib32qtwebkit4:
lib32qtwebkit4 相依於 ia32-libs (>= 20080808)﹔然而:
未曾安裝套件 `ia32-libs'。
dpkg:在處理 lib32qtwebkit4 (--install) 時發生錯誤:
相依問題 - 保留為未設定
在處理時有錯誤發生:
lib32qtwebkit4
spymantw@ubuntu:/media/DATA$ sudo apt-get install ia32-libs
正在讀取套件清單... 完成
正在重建相依關係
正在讀取狀態資料... 完成
下列【新】套件將會被安裝:
ia32-libs
升級 0 個,新安裝 1 個,移除 0 個,有 0 個未被升級。
1 個沒有完整得安裝或移除。
需要下載 0 B/60.3 MB 的套件檔。
此操作完成之後,會多佔用 199 MB 的磁碟空間。
選取了原先未被選取的套件 ia32-libs。
(正在讀取資料庫 ... 163522 files and directories currently installed.)
正在解開 ia32-libs (從 .../ia32-libs_20090808ubuntu13_amd64.deb)...
dpkg:在處理 /var/cache/apt/archives/ia32-libs_20090808ubuntu13_amd64.deb (--unpack) 時發生錯誤:
trying to overwrite '/usr/lib32/libQtWebKit.so.4.7', which is also in package lib32qtwebkit4 2.0.0~0ubuntu1-2
正在進行 libglib2.0-0 的觸發程式 ...
在處理時有錯誤發生:
/var/cache/apt/archives/ia32-libs_20090808ubuntu13_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
spymantw@ubuntu:/media/DATA$ sudo dpkg -i --force-overwrite /usr/lib32/libQtWebKit.so* lib32qtwebkit4_2.0.0~0ubuntu1-2_amd64.deb
dpkg-deb: error: `/usr/lib32/libQtWebKit.so.4' 並非 debian 格式的套件檔
dpkg:在處理 /usr/lib32/libQtWebKit.so.4 (--install) 時發生錯誤:
子程序 dpkg-deb --control 傳回了錯誤退出狀態 2
dpkg-deb: error: `/usr/lib32/libQtWebKit.so.4.7' 並非 debian 格式的套件檔
dpkg:在處理 /usr/lib32/libQtWebKit.so.4.7 (--install) 時發生錯誤:
子程序 dpkg-deb --control 傳回了錯誤退出狀態 2
dpkg-deb: error: `/usr/lib32/libQtWebKit.so.4.7.0' 並非 debian 格式的套件檔
dpkg:在處理 /usr/lib32/libQtWebKit.so.4.7.0 (--install) 時發生錯誤:
子程序 dpkg-deb --control 傳回了錯誤退出狀態 2
(正在讀取資料庫 ... 163522 files and directories currently installed.)
正準備替換 lib32qtwebkit4 2.0.0~0ubuntu1-2(使用 lib32qtwebkit4_2.0.0~0ubuntu1-2_amd64.deb)...
正在解開替換的套件檔 lib32qtwebkit4 ...
dpkg:因相依問題,不能設定 lib32qtwebkit4:
lib32qtwebkit4 相依於 ia32-libs (>= 20080808)﹔然而:
未曾安裝套件 `ia32-libs'。
dpkg:在處理 lib32qtwebkit4 (--install) 時發生錯誤:
相依問題 - 保留為未設定
在處理時有錯誤發生:
/usr/lib32/libQtWebKit.so.4
/usr/lib32/libQtWebKit.so.4.7
/usr/lib32/libQtWebKit.so.4.7.0
lib32qtwebkit4
spymantw@ubuntu:/media/DATA$ sudo apt-add-repository ppa:cnav/ppa
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /etc/apt/secring.gpg --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver hkp://keyserver.ubuntu.com:80/ --recv EF79402F73A1B0968E5EF58A9601B5C6B3EFAC28
gpg: 正在請求金鑰 B3EFAC28 自 hkp 伺服器 keyserver.ubuntu.com
gpg: 金鑰 B3EFAC28: "Launchpad PPA for some restrict audio and video programs in China" 未改變
gpg: 處理總量: 1
gpg: 未改變的: 1
spymantw@ubuntu:/media/DATA$ sudo apt-get install ppstream
正在讀取套件清單... 完成
正在重建相依關係
正在讀取狀態資料... 完成
您也許得執行 'apt-get -f install' 以修正這些問題:
下列的套件有未滿足的相依關係:
lib32qtwebkit4 : 相依關係: ia32-libs (>= 20080808) 但它卻將不會被安裝
ppstream : 相依關係: ia32-libs (>= 20080808) 但它卻將不會被安裝
E: 未能滿足相依關係。請試著不指定套件來執行 'apt-get -f install'(或採取其它的解決方案)。
spymantw@ubuntu:/media/DATA$ sudo apt-get install -f
正在讀取套件清單... 完成
正在重建相依關係
正在讀取狀態資料... 完成
正在修正相依關係... 完成
下列的額外套件將被安裝:
ia32-libs
下列【新】套件將會被安裝:
ia32-libs
升級 0 個,新安裝 1 個,移除 0 個,有 0 個未被升級。
1 個沒有完整得安裝或移除。
需要下載 0 B/60.3 MB 的套件檔。
此操作完成之後,會多佔用 199 MB 的磁碟空間。
是否繼續進行 [Y/n]?y
(正在讀取資料庫 ... 163522 files and directories currently installed.)
正在解開 ia32-libs (從 .../ia32-libs_20090808ubuntu13_amd64.deb)...
dpkg:在處理 /var/cache/apt/archives/ia32-libs_20090808ubuntu13_amd64.deb (--unpack) 時發生錯誤:
trying to overwrite '/usr/lib32/libQtWebKit.so.4.7', which is also in package lib32qtwebkit4 2.0.0~0ubuntu1-2
正在進行 libglib2.0-0 的觸發程式 ...
在處理時有錯誤發生:
/var/cache/apt/archives/ia32-libs_20090808ubuntu13_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
spymantw@ubuntu:/media/DATA$ ls -al /var/cache/apt/archives/ia32-libs_20090808ubuntu13_amd64.deb
-rw-r--r-- 1 root root 60343440 2011-04-21 23:06 /var/cache/apt/archives/ia32-libs_20090808ubuntu13_amd64.deb

2011/8/9 11:07
應用擴展 工具箱
回覆: "四步驟" 在 Ubuntu 64 位元底下看 PPStream
會員三級
註冊日期:
2011/8/16 11:15
等級: 11
HP : 0 / 274
MP : 55 / 6037
EXP: 96
離線
弟試的結果﹝都在VirtualBox上玩的﹞,

10.4(Lucid Lynx)的64-bit,需先安裝ia32-libs_20090808ubuntu9_amd64.deb,
與lib32qtwebkit4_2.0.0~0ubuntu1-2_amd64.deb等兩樣後,
然後在終端機輸入樓主在#12樓提供的指令就可以;

11.4(Natty Narwhal)的64-bit,則是在軟體中心中輸入ia32,應該就搜尋得到“ia32
shared libraries for use on amd64 and ia64 system (ia32-libs)”
的軟體,安裝完後在終端機輸入#12樓的指令即可。

如果是32-bit版的,只要在終端機輸入#12樓的指令即可。

(然後個人在Windows下養成的習慣,安裝完先重新開機...)

要是安裝完可啟動PPS並播放卻沒聲音,請到PPS面板的“工具”→“選項”
→“選擇音頻設備”,選擇系統目前使用的輸出(常見是oss或alsa)。

感謝樓主與前面各位囉,提供頭緒去嘗試,多了一個可推Ubuntu的理由,
覺得對很多媽媽阿姨姊妹們,甚至是叔叔伯伯類,PPS是電腦很重要的功能~

2011/8/16 14:03
應用擴展 工具箱
回覆: "四步驟" 在 Ubuntu 64 位元底下看 PPStream
會員三級
註冊日期:
2011/8/16 11:15
等級: 11
HP : 0 / 274
MP : 55 / 6037
EXP: 96
離線
10.10(Maverick Meerkat)的64位元版,一樣先在軟體中心尋找ia32
shared libraries for use on amd64 and ia64 system (ia32-libs),
確定有安裝後,跑一下軟體更新,應該會從20090808ubuntu9版,
更新到20090808ubuntu9.1版。

然後安裝lib32qtwebkit4_2.0.0~0ubuntu1-2_amd64.deb
https://launchpad.net/~cnav/+archive/ppa/+build/2040892

然後輸入本串#12樓的指令1~3;當輸入第4個指令時,
應該會被提示找不到套件。

然後下載安裝ppstream_1.0.0-3lucid2_amd64.deb
https://launchpad.net/~cnav/+archive/ppa/+sourcepub/1361478/+listing-archive-extra

之後...應該就可以了。

2011/8/19 18:16
應用擴展 工具箱
回覆: "四步驟" 在 Ubuntu 64 位元底下看 PPStream
會員三級
註冊日期:
2011/8/16 11:15
等級: 11
HP : 0 / 274
MP : 55 / 6037
EXP: 96
離線
Ubuntu 11.10(Oneiric Ocelot) 64位元的PPA版PPStream似乎還沒做好,
其實Oneiric Ocelot可以使用11.04(Natty Narwhal) 64位元的PPStream版本,

先在終端機執行:
sudo apt-get install libqt4-core libqt4-dbus libqt4-gui libqt4-network libqt4-webkit libqt4-xml libfuse2 mplayer

然後下載安裝Natty Narwhal 64位元的PPStream:
https://launchpad.net/~cnav/+archive/ppa/+build/2397739

記得初次啟動PPStream時,先到PPStream面板>>工具>>選項>>選擇音頻設備,
將預設的oss改成alsa,播放時才會有聲音。

2011/10/22 23:58
應用擴展 工具箱
回覆: "四步驟" 在 Ubuntu 64 位元底下看 PPStream
會員一級
註冊日期:
2011/12/5 15:13
等級: 1
HP : 0 / 2
MP : 1 / 57
EXP: 10
離線
太好了,终于安装上了PPS来看,试了太多的办法都没装上,搞了24小时.
现在能看了,按八楼的方法来做PPS就能看到了.感谢.

2011/12/5 16:06
應用擴展 工具箱
回覆: "四步驟" 在 Ubuntu 64 位元底下看 PPStream
會員一級
註冊日期:
2012/7/18 23:38
等級: 1
HP : 0 / 15
MP : 2 / 291
EXP: 60
離線
下列【新】套件將會被安裝:
ppstream
升級 0 個,新安裝 1 個,移除 0 個,有 0 個未被升級。
需要下載 0 B/1,672 kB 的套件檔。
此操作完成之後,會多佔用 4,108 kB 的磁碟空間。
(正在讀取資料庫 ... 190748 files and directories currently installed.)
正在解開 ppstream (從 .../ppstream_1.0.0+1-1_amd64.deb)...
dpkg:在處理 /var/cache/apt/archives/ppstream_1.0.0+1-1_amd64.deb (--unpack) 時發生錯誤:
trying to overwrite '/usr/lib32/libphonon.so.4.4.0', which is also in package lib32qtwebkit4 2.0.0~0ubuntu1-2
dpkg-deb: error: subprocess paste was killed by signal (中斷的 pipe)
在處理時有錯誤發生:
/var/cache/apt/archives/ppstream_1.0.0+1-1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


請問這個的錯誤問題 要怎麼解決???

2012/7/18 23:40
應用擴展 工具箱
回覆: "四步驟" 在 Ubuntu 64 位元底下看 PPStream
管理員
註冊日期:
2011/3/11 6:32
等級: 44
HP : 216 / 1084
MP : 1088 / 25225
EXP: 38
離線
檔案名稱衝突
看看有沒有您的Linux發行版版本適用的軟體包裹吧

2012/7/19 1:22
應用擴展 工具箱
回覆: "四步驟" 在 Ubuntu 64 位元底下看 PPStream

註冊日期:
2009/12/6 10:32
等級: 71
HP : 1404 / 1756
MP : 4456 / 47304
EXP: 24
離線
試試 # 直接 copy 貼上你的終端機 以免打錯字
1. sudo dpkg -i --force-overwrite /var/cache/apt/archives/ppstream_1.0.0+1-1_amd64.deb
如果 還不成功
再試試
sudo dpkg -i --force-all /var/cache/apt/archives/ppstream_1.0.0+1-1_amd64.deb
然後
2. sudo apt-get install -f # 把所有因爲 相依問題而 沒安裝的 全部安裝
3. sudo dpkg --configure -a # 設定剛才的安裝
4. sudo apt-get -y autoremove # 把 爲了滿足相依條件而自動安裝的套件 但是用不到的套件 移除
5. sudo apt-get -y clean # 移除自動抽離的套件
6. sudo apt-get -y check # 檢查是否都安裝妥當

參考來源
A. Fix DPKG Error "Trying to Overwrite X Which Is Also In Package Y" In Ubuntu [Quick Tip]
B. apt-get - APT package handling utility -- command-line interface

2012/7/19 5:41
應用擴展 工具箱
回覆: "四步驟" 在 Ubuntu 64 位元底下看 PPStream
會員二級
註冊日期:
2005/12/8 15:36
等級: 8
HP : 0 / 196
MP : 32 / 7569
EXP: 84
離線
pps 現在 好看得節目 愈來愈少
請問 誰有把快播 也弄到linux嗎?

2012/7/19 12:23
應用擴展 工具箱
回覆: "四步驟" 在 Ubuntu 64 位元底下看 PPStream
會員五級
註冊日期:
2010/2/9 18:20
等級: 31
HP : 0 / 758
MP : 438 / 20036
EXP: 33
離線
最近對岸視頻網站似乎都循著賺錢→被警告→支持版權→消砍影片
的方式在運作

土豆、搜狐好像開始會砍版權物了,甚至還公開聲明支持影片著作權

2012/7/19 16:01
在下有時候會回答的很簡略
請善用google搜尋回答中的關鍵字

應用擴展 工具箱

« 1 2 (3)

 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.