使用 apt-get build 編譯你的 firefox [論壇 - Ubuntu 套件打包]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊

« 1 2 3 4 (5) 6 7 8 ... 10 »


回覆: 使用 apt-get build 編譯你的 firefox
會員五級
註冊日期:
2008/4/9 14:04
所屬群組:
已註冊使用者
等級: 31
HP : 0 / 765
MP : 447 / 26390
EXP: 60
離線
to Overing
壞人(指指指)
其實是因為前陣子要幫我老婆去背,結果沒有cmyk的支援,變成去好的path存成RGB的EPS之後,到windows底下用PH把path copy出來貼到原始檔案上面來解決。
另外,我那陣子用了gimp之後,就覺得gimp的穩定性,還是沒有PH的好,不能存檔是個問題,偶爾也會整個突然結束程式,沒有任何訊息。當去背去了一個多小時之後,突然結束程式,那種幹在心理的感覺,真的會想把gimp丟掉。
很可惜的就是沒有辦法丟掉,哈....(苦笑)

to hepha
感覺還是您比較衝啊~~~~
我還在猶豫要用3.0去跑PGO還是3.1跑PGO.....
哈...

to 路人x
可以參考摩托學園與Mozilla Taiwan吧我想.....
不過這個議題應該也不用多說了,免得被誤會。

to all
這篇討論串是這陣子在這邊發言以來,感覺最棒的。因為那種把冷飯炒熱的感覺,加上有很多朋友的互動。讓失業在家的我感覺到有那麼一些存在感。(笑)
祝福大家能夠順心如意。

2009/3/12 18:04
應用擴展 工具箱
回覆: 使用 apt-get build 編譯你的 firefox
版主
註冊日期:
2006/12/24 16:54
所屬群組:
網站管理員
已註冊使用者
等級: 33
HP : 0 / 816
MP : 524 / 31257
EXP: 67
離線
Overing 寫到:
rossiliu 寫到:
另外想請教,您的khopper是否可以直接將cue轉成ogg呢?
因為mp3既然老是有授權的麻煩,又有ID3 tag中文編碼轉換等等問題,轉成ogg後不管什麼播放器都變得比較簡單播放,並且音質方面也不會差。是否有那種可能可以直接轉呢?
不好意思,離題了。

khopper是"ダメ人間大"大的作品
相關訊息可以到他blog上面看看
至於轉ogg...
記得之前他是說不知多久的未來(?)
會以多格式輸出為目標xp
現在還是只能2mp3

不過轉ogg記得有別的軟體能作到了
像是cue2tracks之類的...


抱歉亂入一下,因為這篇回覆完全和主題無關:P

當初其實有考慮做ogg
不過ogg本身只是container
裡面常用的編碼是flac(lossless)和virbos(lossy,vbr)
要考慮怎麼交代使用者介面
後來由於時程的關係就先放著了

我自己也正在考試中,沒辦法像寒假那樣整天唸文件爬mailing list
有熱心人士想幫忙的話我會很感激 ... 只要會一點C++和C就好了

如果需要的話也可以提前在0.x新增這種功能(如果我有空又有力氣的話)
目前trunk裡的程式架構己經和0.1相差甚遠

2009/3/13 11:22
就算你百分之一百認定某人是渣滓中的渣滓,請仍然展示你的冷靜、體諒、尊重。

* My Blog
* My Twitter <- follow me!
* My Plurk
FoolproofProject:
* KomiX latest stable: v0.1.0 (Comics Viewer)
* Khopper latest stable: v0.4.2 (Audio Converter with CUE Sheet Support)
* PicKing latest stable: v0.2.3 (File Picking)
應用擴展 工具箱
回覆: 使用 apt-get build 編譯你的 firefox
會員五級
註冊日期:
2007/8/9 23:18
所屬群組:
已註冊使用者
等級: 23
HP : 0 / 555
MP : 216 / 20247
EXP: 22
離線
路人X 寫到:
rossiliu 寫到:
to 路人x
用mediawarp這個plug-in會不會改善媒體播放的問題?

謝謝提醒
剛剛去測試播WMV 顯示需要安裝套件無法播放,使用mediawarp 1.7.3版

http://it.oc.com.tw/ocitview.asp?gitid=723922
超頻者天堂 IT 的影片WMV3格式

我是可以播放的...
所以可能是套件衝到...

新開個profile試試看吧...

對CPU最佳化有興趣的可以看這兩個...
http://gcc.gnu.org/onlinedocs/gcc-4.3.3/gcc/Optimize-Options.html#Optimize-Options

http://gcc.gnu.org/onlinedocs/gcc-4.3.3/gcc/i386-and-x86_002d64-Options.html#i386-and-x86_002d64-Options

或是直接拿知名社群版...在網址列打about :buildconfig來參考...
orangefox也是我的參考對象之一...XD
---
要編就拿3.1來編吧...
除了新增的影音支援比較不穩以外...其他的穩定度都不錯...

3.0.x要用gcc 4.3編的話要打patch...
(8.10目前預設就是4.3...)
http://forums.mozillazine.org/viewtopic.php?f=42&t=877255&start=0&st=0&sk=t&sd=a
不然編不出來...

2009/3/13 19:23
應用擴展 工具箱
回覆: 使用 apt-get build 編譯你的 firefox
會員三級
註冊日期:
2006/12/14 1:06
所屬群組:
已註冊使用者
等級: 12
HP : 0 / 283
MP : 59 / 10891
EXP: 35
離線
請問一下,有人遇到這個問題過嗎?
make package的時候,出現這樣的錯誤
Linking .xpt files...
[browser]
FAILED: fopen: No such file or directory
' /home/plany/mozilla-1.9.1/obj-i686-pc-linux-gnu/dist/bin/xpt_link ../../dist/firefox/components/browser.xpt ../../dist/xpt/browser/components/intl.xpt ../../dist/xpt/browser/components/locale.xpt ../../dist/xpt/browser/components/lwbrk.xpt ../../dist/xpt/browser/components/necko.xpt ../../dist/xpt/browser/components/pref.xpt ../../dist/xpt/browser/components/proxyObjInst.xpt ../../dist/xpt/browser/components/storage.xpt ../../dist/xpt/browser/components/uconv.xpt ../../dist/xpt/browser/components/unicharutil.xpt ../../dist/xpt/browser/components/xpcom_base.xpt ../../dist/xpt/browser/components/xpcom_components.xpt ../../dist/xpt/browser/components/xpcom_ds.xpt ../../dist/xpt/browser/components/xpcom_io.xpt ../../dist/xpt/browser/components/xpcom_system.xpt ../../dist/xpt/browser/components/xpcom_threads.xpt ../../dist/xpt/browser/components/xpcom_xpti.xpt' failed at /home/plany/mozilla-1.9.1/xpinstall/packager/xptlink.pl line 161.
make[2]: *** [stage-package] Error 2
make[2]: Leaving directory `/home/plany/mozilla-1.9.1/obj-i686-pc-linux-gnu/browser/installer'
make[1]: *** [default] Error 2
make[1]: Leaving directory `/home/plany/mozilla-1.9.1/obj-i686-pc-linux-gnu/browser/installer'
make: *** [package] Error 2

2009/3/14 2:03
應用擴展 工具箱
回覆: 使用 apt-get build 編譯你的 firefox
會員五級
註冊日期:
2008/6/15 2:56
所屬群組:
已註冊使用者
等級: 38
HP : 189 / 945
MP : 757 / 32101
EXP: 81
離線
沒遇過你要不要清掉在重新來過Q_Q
make distclean

2009/3/14 18:45
應用擴展 工具箱
回覆: 使用 apt-get build 編譯你的 firefox
會員三級
註冊日期:
2008/4/29 0:29
所屬群組:
已註冊使用者
等級: 10
HP : 0 / 241
MP : 45 / 8299
EXP: 66
離線
我成功編譯了,但是firefox慢了很多。
還是原生的好。

2009/3/17 14:50
應用擴展 工具箱
回覆: 使用 apt-get build 編譯你的 firefox
會員五級
註冊日期:
2008/4/9 14:04
所屬群組:
已註冊使用者
等級: 31
HP : 0 / 765
MP : 447 / 26390
EXP: 60
離線
????
why???
怎麼可能?

2009/3/17 14:53
應用擴展 工具箱
回覆: 使用 apt-get build 編譯你的 firefox
會員五級
註冊日期:
2008/4/9 14:04
所屬群組:
已註冊使用者
等級: 31
HP : 0 / 765
MP : 447 / 26390
EXP: 60
離線
wine又更新了,用apt-build更新編譯。
但是在下閒著看一下編譯訊息,突然看到,其gcc的編譯參數,都是採用-O2的層級進行編譯,即使在apt-build.conf裏面設定了-O3仍然是一樣跑-O2,不知道其他的朋友是不是也是如此?

2009/3/17 17:20
應用擴展 工具箱
回覆: 使用 apt-get build 編譯你的 firefox
版主
註冊日期:
2006/12/24 16:54
所屬群組:
網站管理員
已註冊使用者
等級: 33
HP : 0 / 816
MP : 524 / 31257
EXP: 67
離線
參數沒變+1

之前玩apt-build時就是因為參數都沒
(iceweasel的about :buildconfig都沒差)
才沒繼續玩下去

正在好奇為什麼大家都可以動XD

2009/3/17 17:29
就算你百分之一百認定某人是渣滓中的渣滓,請仍然展示你的冷靜、體諒、尊重。

* My Blog
* My Twitter <- follow me!
* My Plurk
FoolproofProject:
* KomiX latest stable: v0.1.0 (Comics Viewer)
* Khopper latest stable: v0.4.2 (Audio Converter with CUE Sheet Support)
* PicKing latest stable: v0.2.3 (File Picking)
應用擴展 工具箱
回覆: 使用 apt-get build 編譯你的 firefox
會員五級
註冊日期:
2008/4/9 14:04
所屬群組:
已註冊使用者
等級: 31
HP : 0 / 765
MP : 447 / 26390
EXP: 60
離線
恩.....
很奇怪,在我這邊除了-O2這個參數之外,其他的參數會使用耶,但是卻並不是「每一個」gcc編譯都會用。
恩....這麼說好了,今天編譯ffmpeg (今天更新了),在編譯的過程當中,會呼叫n次的gcc,不是每一次呼叫的時候都會用設定的參數。
在編譯的過程當中,也有看到-O3出現,但是大多數都是跑-O2。
難到說,在編譯的過程當中,會自動調變????

2009/3/17 18:11
應用擴展 工具箱

« 1 2 3 4 (5) 6 7 8 ... 10 »

 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.