您好,關於更新管理員要升級成10.10之問題 [論壇 - Ubuntu 養蟲箱 - bug share]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊



您好,關於更新管理員要升級成10.10之問題
會員三級
註冊日期:
2011/1/9 20:30
所屬群組:
已註冊使用者
等級: 9
HP : 0 / 201
MP : 33 / 5014
EXP: 5
離線
今日想要把一台電腦從10.04.2升級成10.10,我是從系統-管理-更新管理員這邊升級
但出現以下之錯誤畫面,當時網路都正常連線,不清楚是我操作有誤還是哪邊有問題呢?




我也提供關於此錯誤畫面之/var/log/dist-upgrade目錄壓縮後之tarball檔案
http://rapidshare.com/files/447866559/20110214.tar.gz

謝謝大家

2011/2/14 19:35
應用擴展 工具箱
回覆: 您好,關於更新管理員要升級成10.10之問題
會員五級
註冊日期:
2009/10/29 4:50
所屬群組:
已註冊使用者
等級: 41
HP : 201 / 1005
MP : 889 / 28571
EXP: 21
離線
先更換套件來源
http://www.ubuntu-tw.org/modules/newbb/viewtopic.php?post_id=164314#forumpost164314
並移除xserver-xorg-video-geode這個套件

2011/2/14 20:40
應用擴展 工具箱
回覆: 您好,關於更新管理員要升級成10.10之問題

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1404 / 1756
MP : 4456 / 49355
EXP: 24
離線
把一台電腦從10.04.2升級成10.10

1. 先幫你找一個連線狀況最好的更新伺服器
#2 xenomorph0525 已貼文文章連結
2. 先把 10.04 更新到目前 的套件庫
依順序執行
重新載入
標記所有升級
套用
更新 10.04 完畢
3. 最好先把你的10.04備存起來 以備升級有問題時有機會重來一次
4. 把 與 ubuntu 無關的套件庫 取消打勾
系統 / 管理 / synaptic 套件管理程式 / 設定 / 套件庫 / ubuntu 軟體來源
四個都打勾 main, universe, restricted, universe, multiverse
如果你有需用到 原始嗎 也可以打勾, 一般使用者 原始嗎 可以取消打勾
系統 / 管理 / synaptic 套件管理程式 / 設定 / 套件庫 / 其它軟體
canonical 夥伴 可以打勾
canonical 夥伴 原始嗎 也可以打勾, 一般使用者 原始嗎 可以取消打勾
除了以上 其它軟體 的套件庫 全部取消打勾
(這些 其它軟體 的套件庫 因爲更新 不與 ubuntu 同步 常常是更新錯誤訊息的來源)
系統 / 管理 / synaptic 套件管理程式 / 設定 / 套件庫 / ubuntu 更新
security, updates, proposed, backports 四個可以都打勾
升級發佈版本 / 顯示新的發行版本發佈 :一般發行 (只有升級到 LTS 版本才要選 只有長期支援版)
關閉
5. 升級 最好從 終端機 資訊比較透明
sudo apt-get update # 更新套件庫索引
sudo apt-get install update-manager-core # 安裝更新所需套件
sudo gedit /etc/update-manager/release-upgrades
Prompt=normal # 只有升級到 LTS 版本才要選 只有長期支援版 才設定 lts
sudo do-release-upgrade # 依照 螢幕指示更新
6. 更新完後 最好 立刻 備存
7. 補 安裝 其它軟體來源 的 套件
萬一 安裝 其它軟體來源 的 套件 不成功
可以把 6. 的備存檔 存回 有機會重來一次
8. 祝你 更新順利

資料來源
Get Ubuntu Desktop Edition Upgrade

有一些是自己的經驗, 看過的文章, 與這一篇的內容 綜合而成
歡迎幫忙訂正

2011/2/14 21:24
應用擴展 工具箱


 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.