HDMI沒聲音 [論壇 - Ubuntu硬體支援]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊



訪客
HDMI沒聲音
Anon:訪客
MB:Gigabyte GA-MA69GM-S2H
Mon:Benq SQ4242

最近將這塊主機板拿到客廳組裝成HTPC,安裝的作業系統是Ubuntu 10.04版,無奈聲音一直無法從HDMI傳出來,也試著放棄從HDMI傳聲音,改為一般的音源出來,但卻依然聽不到聲音。

也到Realtek抓了驅動程式來安裝,依然無解,懇請各位給予指點。

2011/5/11 9:42 | b25a9 83bc0 e1ea1 54e14
應用擴展 工具箱
回覆: HDMI沒聲音

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1404 / 1756
MP : 4456 / 45857
EXP: 24
離線
1. 系統 / 偏好設定 / 多媒體系統選擇器 /
預設輸出 外掛程式 選 ALSA 裝置 ALC883 Analog
預設輸入 外掛程式 選 ALSA 裝置 ALC883 Analog

2. 系統 / 偏好設定 / 聲音
2-1. 硬體
Analog Stereo Duplex

HDMI output
2-2. 聲音輸入裝置
Analog Stereo
2-3. 聲音輸出裝置
Analog Stereo

HDMI output

3. 右上角 音量控制器
靜音 不要 打勾
調整音量 控制條

有問題 歡迎再貼文

2011/5/11 12:59
應用擴展 工具箱
回覆: HDMI沒聲音
會員五級
註冊日期:
2008/6/15 2:56
所屬群組:
已註冊使用者
等級: 38
HP : 189 / 945
MP : 757 / 28759
EXP: 81
離線
sudo alsaconf
選擇你的音效卡,如果沒有顯示你的設備,有可能硬體有問題或需要另外裝驅動程式,我的音效是在主機板上,但因為過於老舊時常找不到音效卡,有時重開機好了,有時會破音…
alsamixer
F6 選擇音效卡調整音效

2011/5/11 14:08
應用擴展 工具箱
回覆: HDMI沒聲音
會員四級
註冊日期:
2008/9/17 14:25
所屬群組:
已註冊使用者
等級: 19
HP : 0 / 467
MP : 150 / 13885
EXP: 71
離線
你這個版子裡 有hdmi的音效輸出跟realtek的音效輸出這兩種
前面那種顧名思義是hdmi輸出聲音用的(690G的附加功能)
後面的是從主機板背後audio output 輸出聲音的(不是從hdmi) <-主機板廠商另外附加realtek的音效晶片提供的功能

以690G + realtek 這兩者 老舊及普及的程度 ubuntu 不至於沒有驅動
建議檢查一下基本設定,或者硬體問題

2011/5/11 14:57
應用擴展 工具箱
訪客
回覆: HDMI沒聲音
Anon:訪客
我試過用原本內建的驅動程式無聲音,也去抓過Realtek的最新版驅動程式,並用alsamixer確認過,有抓到兩個音效卡,一個是SBX00,一個是HDMI的,但就是沒聲音出來。

2011/5/11 22:52 | a8dfe 573d5 7bd73 57325
應用擴展 工具箱
回覆: HDMI沒聲音

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1404 / 1756
MP : 4456 / 45857
EXP: 24
離線
這個 bug report 可能跟你的問題 有關 追蹤看看
Bug #414000
Possible missing/contradicting PCI aliasing information in sound driver

這個 bug report 不知道跟你的問題是否有關 追蹤看看
Card1.Amixer.info:
Card hw:1 'HDMI'/'HDA ATI HDMI at 0xfdffc000 irq 19'
Mixer name : 'ATI RS690/780 HDMI'
Components : 'HDA:1002791a,00791a00,00100000'
Controls : 4
Simple ctrls : 1
Bug #476755
[Gigabyte Technology Co., Ltd. GA-MA69GM-S2H] hibernate/resume failure

這裏有兩個網頁 專門指導 如何解決 聲音問題 看對你有沒有幫助
SoundTroubleshooting
Debugging Sound Problems

2011/5/12 7:27
應用擴展 工具箱
訪客
回覆: HDMI沒聲音
Anon:訪客
感謝,我研究看看。

2011/5/12 10:21 | 941c8 cf88f b2f9f c6490
應用擴展 工具箱
回覆: HDMI沒聲音
會員三級
註冊日期:
2008/9/27 12:17
所屬群組:
已註冊使用者
等級: 12
HP : 0 / 298
MP : 64 / 8832
EXP: 93
離線
我也遇到HDMI沒辦法輸出聲音的問題

照這篇做就ok了~給遇到一樣問題的人參考參考
http://bruce30262.pixnet.net/blog/post/95157302-%5B%E7%9F%A5%E8%AD%98+%E7%8B%82%E8%B3%80%5D%E7%B5%82%E6%96%BC%E8%A7%A3%E6%B1%BAhdmi%E8%9E%A2%E5%B9%95%E5%9C%A8linux%E5%BA%95%E4%B8%8B%E7%84%A1%E6%B3%95%E7%99%BC

擷取網站的內容
==
首先開啟終端機,輸入指令: sudo vim /etc/default/grub

接著找到這一行: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

把它改成: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash radeon.audio=1"

儲存並離開後,在終端機再輸入一行: sudo update-grub



重新啟動電腦之後

Bingo!!

Finally, it works!!! Q口Q

可喜可賀可歌可泣!!!!
==

2013/12/5 0:51
應用擴展 工具箱


 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.