LoNote更新到1.0了 [論壇 - Ubuntu 與工具程式及軟體推薦]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊

(1) 2 3 4 ... 6 »


LoNote更新到1.0了
會員三級
註冊日期:
2008/12/10 7:19
所屬群組:
已註冊使用者
等級: 15
HP : 0 / 369
MP : 94 / 15076
EXP: 76
離線
大概半年前,我在這裡發了一篇文,向大家推薦我寫的筆記軟體LoNote。

舊文在此:
http://www.ubuntu-tw.org/modules/newbb/viewtopic.php?topic_id=39942

時間慢慢過去,LoNote的版本號也逐漸往上翻。最近又重寫了底層,內部資料結構大更新,版本一口氣翻上1.0。

截圖一張:

↑==單看外觀,看起來沒什麼不一樣……

目前LoNote已經在Google Code安家,所有更新、訊息、檔案都集中在這裡:
http://code.google.com/p/lonote/

與發佈最初的0.4版相比,新版本的更新大致上包括:

 0. 無數的bug修復。
 1. 完成國際化框架,透過po檔支援多國語言。現在支援:
  * 繁體中文(由我維護)
  * 簡體中文
  * 原生英語
 2. 對新手友善的筆記範本
  * 現有架構下,筆記範本不用怕被使用者玩壞,會在下一次載入時恢復,使用者可以任意試驗操作。
 3. 終於完整地支援了windows
 4. 全筆記本搜尋功能,搜尋不再僅限於單一頁面。
 5. 真正好用的歷史記錄功能。不像以前那樣雖然有記錄,但很難恢復取出,根本只是記心酸的……
  * 不再依賴Mercurial做版本記錄
 6. 比以前好用十倍的附件功能。
 7. 提供了圖形設定介面
 8. 自動記憶窗格開合與視窗大小。
 9. 阻止使用者同時打開兩個LoNote
 10. 大量便於瀏覽的快速鍵
 11. 諸如此類很多很多……

詳細更新情報請參看:
http://code.google.com/p/lonote/wiki/Changelog

另外,也嚐試包了lonote的非正式deb檔。
ubuntu使用者可以下載deb檔案,然後用以下指令安裝:

dpkg -i deb檔名


注意,系統必須要裝有python3.2以上版本,否則安裝不能。請自行用apt-get來安裝它。另外程式要跑還需要python3-pyqt4這個包,不過遺憾的是ubuntu直到目前(11.10)為止都沒有提供這個包,要等到12.04後才會開始提供(感謝Chen, Chien-ting提供情報)

在ubuntu提供python3-pyqt4包之前,要讓LoNote跑起來(不管要不要透過deb安裝),必須先自行編譯python3-pyqt4:
這邊有超簡單教學:
http://code.google.com/p/lonote/wiki/RuntimeEnv


請求支援:
  我是很想把example用英文重寫一次啦,不過以我的英文實力好像有點勉強。哪位願意支援的話請聯絡我,我會告訴你怎麼做。


最後,感謝以下協力者:
  網友Robin Lee:
    目前的deb打包框架是基於他的前期工作,真是多虧了他的支援。不只如此,他還包了Fedora的rpm檔與替LoNote進行簡體中文化。
  Chen, Chien-ting:
    幾次嘗試替windows版與deb版本進行打包工作。話說回來,我好像老是在他剛同步完版本庫時推送更新,恐怕造成人家不少困擾,真是不好意思嘿嘿……

2012/1/17 12:43
應用擴展 工具箱
回覆: LoNote更新到1.0了
會員四級
註冊日期:
2010/12/22 12:40
所屬群組:
已註冊使用者
等級: 19
HP : 0 / 466
MP : 149 / 16276
EXP: 65
離線
英文我可以幫忙

2012/1/17 16:07
應用擴展 工具箱
回覆: LoNote更新到1.0了
會員三級
註冊日期:
2008/12/10 7:19
所屬群組:
已註冊使用者
等級: 15
HP : 0 / 369
MP : 94 / 15076
EXP: 76
離線
謝謝支援英文!

總之先下載原始碼檔案,解壓縮然後執行它。

執行之後會自動跳出example筆記本(也就是期待翻譯的範本),不過注意這個example筆記本其實是存在tmp下的副本,會在關閉程式後自動刪除,所以直接翻譯您眼前看到的東西是無效的,關掉程式之後辛苦做出的成果就人間蒸發了。

如果希望工作成果能保存下來,必須直接用「打開筆記」功能,打開原始碼目錄下的example資料夾。以這種方式對開啟的example筆記本做翻譯,更動就會被確實保存下來。

翻譯方面,只需要意譯就可以了,我的用詞本來也不精確。總之,目的就是讓使用者能夠在範本中隨手測試一些功能,同時也稍微導覽一下。

如果由我來寫的話,八成會冒出很多時態錯誤與文法不正確,因此沒啥自信,就一直拖著……

總之多謝幫忙了,大感恩!

2012/1/17 16:20
應用擴展 工具箱
回覆: LoNote更新到1.0了
會員三級
註冊日期:
2008/12/10 7:19
所屬群組:
已註冊使用者
等級: 15
HP : 0 / 369
MP : 94 / 15076
EXP: 76
離線
喂喂,願意幫我翻譯的人還在嗎?

我這裡另外發現有個人有意願替我翻譯example,如果您已經開始工作了的話,那我就回絕對方了。

如果沒有下文的話,那傢伙的翻譯工作應該會在明早開始。

請儘量在那之前聯絡我,不管是誰,我不想讓協力者做白工啊……

總之,無論結果為何,我都非常感謝你們。

2012/1/18 19:37
應用擴展 工具箱
回覆: LoNote更新到1.0了
會員四級
註冊日期:
2010/12/22 12:40
所屬群組:
已註冊使用者
等級: 19
HP : 0 / 466
MP : 149 / 16276
EXP: 65
離線
他開公時間較早的話讓他做好了
我要週六才有時間翻
總之我也會再翻譯一份

2012/1/19 13:53
應用擴展 工具箱
回覆: LoNote更新到1.0了
會員三級
註冊日期:
2008/12/10 7:19
所屬群組:
已註冊使用者
等級: 15
HP : 0 / 369
MP : 94 / 15076
EXP: 76
離線
嗯,謝謝你viphone,那邊已經搞到一半了,雖然看似還要點時間,不過應該翻得完沒問題。

不用再翻譯一次啦,沒有國際化的好軟體多的是,重複消耗大家的時間總覺得會遭雷劈……此外就算有兩份翻譯,我也只能在軟體中附上一份而已。

不過即使如此,翻譯完成後多半還是會有些不盡理想的地方,那時也歡迎多鞭兩下XD

感謝大家的大力支持啊 m(_ _)m

2012/1/19 15:31
應用擴展 工具箱
回覆: LoNote更新到1.0了
版主
註冊日期:
2008/7/14 0:03
來自 螢幕的另一端
所屬群組:
網站管理員
已註冊使用者
討論區管理群
等級: 33
HP : 0 / 806
MP : 508 / 33904
EXP: 26
離線
ubuntu 10.04 版本的要安裝 LoNote1.0 的難度有點高哦~

因為套件源裡的 python3 是 3.1 版,不能直接從源裡安裝,得下載source code 來安裝 PyQt4 也是.....

哎呀~~正在研究安裝方法當中

2012/1/19 18:13
應用擴展 工具箱
回覆: LoNote更新到1.0了
會員三級
註冊日期:
2008/12/10 7:19
所屬群組:
已註冊使用者
等級: 15
HP : 0 / 369
MP : 94 / 15076
EXP: 76
離線
python3.2的部份,重新翻找了一下程式,大致上把所有用到3.2功能的部份都找出來了。多半都是些非常特定狀態才會用到,而且即使是那種狀態下也並非必要的功能,所以我讓程式內部偵測一下,如果環境是3.1,就把那部份的碼pass過去了。

至少在裝python3.1的windows虛擬機上測試是可以跑了啦……算是降轉成功吧。

pyqt4那個實在是沒辦法,我自己的機器上也得編譯……編譯經驗上面有連結,這邊隨手再貼一次:
http://code.google.com/p/lonote/wiki/RuntimeEnv

大概也只能支援到這種程度了。看看行不行吧……

2012/1/19 23:11
應用擴展 工具箱
回覆: LoNote更新到1.0了
版主
註冊日期:
2008/7/14 0:03
來自 螢幕的另一端
所屬群組:
網站管理員
已註冊使用者
討論區管理群
等級: 33
HP : 0 / 806
MP : 508 / 33904
EXP: 26
離線
裝起來了....我的 ubuntu10.04 要裝 LoNote 還真是多災多難呀~

在這裡記錄一下我的安裝過程

lonote 安裝
sudo aptitude install python3 python3-dev libqt4-dev libxext-dev g++
wget http://www.riverbankcomputing.co.uk/static/Downloads/sip4/sip-4.13.1.tar.gz
tar zxvf sip-4.13.1.tar.gz
cd sip-4.13.1
python3 configure.py
make
sudo make install
cd /tmp
wget http://www.riverbankcomputing.co.uk/static/Downloads/PyQt4/PyQt-x11-gpl-4.9.tar.gz
tar zxvf PyQt-x11-gpl-4.9.tar.gz
cd PyQt-x11-gpl-4.9/
python3 configure.py
這裡問你是否同意授權,需輸入 yes 才能繼續


編譯過程中出現此錯誤訊息
sip: QDBusPendingCall has not been defined
Error: Unable to create the C++ code.

在網路上查了下資料,
http://stackoverflow.com/questions/8664863/installing-pyqt-4-9-on-centos-6-0-fails
發現它要求 qt 的版本必須是 4.7 以上的,可用此指令檢查你的 qt 版本
aptitude show qt4-qmake

升級方法: http://ubuntuforums.org/showthread.php?t=1552263
加入此來源
## kubuntu-ppa backports
deb http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu lucid main

sudo apt-key adv --recv-keys --keyserver keyserver.ubuntu.com 2836CB0A8AC93F7A
aptitude update

先移除舊版的 qt
aptitude remove qt4-qmake
再裝新版的 qt
aptitude install qt4-qmake

裝好新版的qt4後繼續編譯
python3 configure.py

結果又報錯
Determining the layout of your Qt installation...
Error: Failed to determine the layout of your Qt installation. Try again using
the --verbose flag to see more detail about the problem.

在網路上查了資料 http://ubuntuforums.org/showthread.php?t=1427918
才發現原來我在移除舊版的 qt 時,這個 libqt4-dev 也被移掉了

重新裝上之後,就可以正常編譯了
sudo aptitude install libqt4-dev

之後再
make
sudo make install
就正常了

折騰了這麼久,總算可以開始試用了 O_Q

之後我會再整理一份比較正式的安裝筆記。

2012/1/20 16:26
應用擴展 工具箱
回覆: LoNote更新到1.0了
版主
註冊日期:
2008/7/14 0:03
來自 螢幕的另一端
所屬群組:
網站管理員
已註冊使用者
討論區管理群
等級: 33
HP : 0 / 806
MP : 508 / 33904
EXP: 26
離線
初步的試用了一下....

有點要感動到要落淚 O_Q

這就是我一直要尋找的筆記程式呀!

真的是不枉費我花了那麼久的時間去折騰它的安裝方法呀!

真是太感動了!

對於一個經常在用電腦記筆記的人來說,很多小細節都考慮到了,這真的是很用心的一個程式!

真的是要給你一個 "超級無敵我讚你" 呀! ^^b

2012/1/20 17:00
應用擴展 工具箱

(1) 2 3 4 ... 6 »

 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.