LoNote更新到1.0了 [論壇 - Ubuntu 與工具程式及軟體推薦]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊

« 1 2 3 (4) 5 6 »


回覆: LoNote更新到1.0了
版主
註冊日期:
2008/7/14 0:03
來自 螢幕的另一端
所屬群組:
網站管理員
已註冊使用者
討論區管理群
等級: 33
HP : 0 / 807
MP : 509 / 34316
EXP: 28
離線
1.2.1 版,沒有了

打開筆記
新筆記簿

這兩個功能了.....所以,我找不到方法可以去叫回我之前打的舊筆記了...


書籤功能

也無法去叫我放在某個資料夾裡的筆記,它的那個"加入"功能好像只能針對已打開的筆記去加入...問題是我找不到方法來開舊筆記呀。


sorry....剛剛找到了,原來"打開筆記"是第一個小圖示呀,所有的圖案都點過了,竟會忘了去點第一個小圖示...|||||


感謝! 改版這麼快! 真是熱血呀!

2012/1/22 19:37
應用擴展 工具箱
回覆: LoNote更新到1.0了
會員三級
註冊日期:
2008/2/2 17:35
所屬群組:
已註冊使用者
等級: 16
HP : 0 / 375
MP : 98 / 16473
EXP: 3
離線
我是用10.10,「準備啟動」出現後就沒下文
終端機啟動則是冒出這個
能不能幫我翻譯一下,這是在講什麼?

Traceback (most recent call last):
File "/usr/local/bin/lonote", line 10, in <module>
import lonote.path as path
ImportError: No module named lonote.path

2012/1/22 21:12
 Ubuntu 優蹦兔| Kubuntu 酷蹦兔 | Xubuntu 小蹦兔
應用擴展 工具箱
回覆: LoNote更新到1.0了

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1053 / 1756
MP : 4456 / 67493
EXP: 24
離線
Traceback (most recent call last):
File "/usr/local/bin/lonote", line 10, in <module>
import lonote.path as path
ImportError: No module named lonote.path

往回追蹤(最近的呼叫)
檔案 “"/usr/local/bin/lonote" 在 <module> 第十行
匯入 lonote.path 當 路徑
匯入錯誤:沒有名稱爲 lonote.path的模組

2012/1/22 21:35
應用擴展 工具箱
回覆: LoNote更新到1.0了
會員三級
註冊日期:
2008/12/10 7:19
所屬群組:
已註冊使用者
等級: 15
HP : 0 / 369
MP : 94 / 15253
EXP: 76
離線
看起來像是系統沒有找到lonote的模組。

請問您的系統是用python3.1嗎?這可能是一個打包錯誤……

2012/1/23 0:39
應用擴展 工具箱
回覆: LoNote更新到1.0了
會員三級
註冊日期:
2008/12/10 7:19
所屬群組:
已註冊使用者
等級: 15
HP : 0 / 369
MP : 94 / 15253
EXP: 76
離線
這看起來確實是一個打包錯誤。這個錯誤導致lonote模組被安裝入python3.2的專屬的搜索路徑--緊急修復後,應該算是把它給解決了。

請您下載1.2.1-1重新安裝一次,問題應該就會消失。

http://code.google.com/p/lonote/downloads/detail?name=lonote_1.2.1-1_all.deb

謝謝您回報錯誤囉~感恩。

2012/1/23 1:22
應用擴展 工具箱
回覆: LoNote更新到1.0了
會員三級
註冊日期:
2008/2/2 17:35
所屬群組:
已註冊使用者
等級: 16
HP : 0 / 375
MP : 98 / 16473
EXP: 3
離線
感謝,我安裝好了
不過下載1.2.3,但裝好後,關於與說明出現卻是1.2.2?

2012/1/25 1:20
 Ubuntu 優蹦兔| Kubuntu 酷蹦兔 | Xubuntu 小蹦兔
應用擴展 工具箱
回覆: LoNote更新到1.0了

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1053 / 1756
MP : 4456 / 67493
EXP: 24
離線
安裝 lonote 在 ubuntu 11.10 筆記

1. 確定 ubuntu 11.10 已預裝 python3.2
sudo dpkg -l | grep python3.2
python3.2 3.2.2-0ubuntu1

2. 安裝 相依套件 python3-sip (版本必須 >= 4.13.1~)
2-1. 檢查 ubuntu 11.10 現裝版本
sudo dpkg -l | grep python3-sip
python3-sip: 4.12.4-1 (ubuntu 11.10)
2-2. 升級爲 4.13.1-3
sudo add-apt-repository ppa:n-muench/calibre
sudo aptitude update
sudo aptitude install python3-sip
sudo dpkg -l | grep python3-sip
python3-sip 4.13.1-3~ppa1

3. 下載並安裝 相依套件 python3-pyqt4 # 這個就是目前 ubuntu 12.04 所用的 套件包
3-1. python3-pyqt4 4.9-2ubuntu1 in i386 # 按一下 就下載
3-2. sudo dpkg -i python3-pyqt4_4.9-2ubuntu1_i386.deb

4. 下載並安裝 lonote_1.2.3_all.deb
4-1. lonote_1.2.3_all.deb # 按一下 就下載
4-2. sudo dpkg -i lonote_1.2.3_all.deb
4-2. lonote

5. 如果 你打開 lonote 時出現一個人形 出來喊疼...










先別手忙腳亂
sudo rm ~/.config/lonote/FILELOCK.lock
下次就不會再出現了

6. 歡迎 網友 在 11.04 10.10 10.04 試試看 能否順利依樣安裝 再來分享

2012/1/25 8:23
應用擴展 工具箱
回覆: LoNote更新到1.0了
會員三級
註冊日期:
2008/12/10 7:19
所屬群組:
已註冊使用者
等級: 15
HP : 0 / 369
MP : 94 / 15253
EXP: 76
離線
chillyswallow 寫到:
感謝,我安裝好了
不過下載1.2.3,但裝好後,關於與說明出現卻是1.2.2?


奇怪,如果您說的是1.2.3的deb檔案的話,檔案本身並沒有問題的呀。我實際測試而且還解開deb的內部檔案觀察,所有和版本號有關的位置都寫著1.2.3。

也許您下錯版本了?我一時之間也只能這樣猜了。

To poloshiao:

辛苦您的文章了,真是好用心啊!

順便一提,在那個警告畫面中,只要點擊 "Yes" 之後,檔案鎖就會被LoNote自動刪除,並繼續啟動LoNote主程式。應該是不需要手動刪除的啦。

2012/1/25 11:41
應用擴展 工具箱
回覆: LoNote更新到1.0了

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1053 / 1756
MP : 4456 / 67493
EXP: 24
離線
只要點擊 "Yes" 之後

因爲信任你的文章
所以你要增加說明

2012/1/25 12:42
應用擴展 工具箱
回覆: LoNote更新到1.0了
會員三級
註冊日期:
2008/12/10 7:19
所屬群組:
已註冊使用者
等級: 15
HP : 0 / 369
MP : 94 / 15253
EXP: 76
離線
會這樣寫的原因是因為在windowsXP下,自動刪除功能會因為一個很奇怪的編碼問題而無法運作。因為這個錯誤我實在無法理解原因,怕Linux下在某些特殊情況下也會發生,所以才加以保留,作為自動刪除功能無法運作導致程式無法開啟時的備援方案。

當初貼出的bug訊息在此:
https://groups.google.com/forum/#!topic/lonote/pPz-yvpWekU

造成您的困擾不好意思……

2012/1/25 13:30
應用擴展 工具箱

« 1 2 3 (4) 5 6 »

 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.