[已解決] dia無法輸入中文 [論壇 - Ubuntu 與中文]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊

(1) 2 »


[已解決] dia無法輸入中文
會員五級
註冊日期:
2010/9/26 16:05
所屬群組:
已註冊使用者
等級: 27
HP : 0 / 660
MP : 317 / 17190
EXP: 43
離線
不知道為什麼,最近一次重裝以後,就無法輸入中文了
我的dia版本0.97.2.5
我google過,所有的解法都說是輸入法選擇簡單就可以了
不過我怎麼試就是不行
也懷疑過是我的輸入法不相容,
所以gcin ,hime, scim都試了,也都不行
有沒有解丫,幫個忙吧



PS:解法如下

修改 /usr/bin/dia 如下就可以用 gcin 了

#dia-gnome --integrated "$@"
dia-gnome "$@"


不夠這會造成 toolbar 獨立出來

2012/3/30 0:33
應用擴展 工具箱
回覆: 〔求救〕dia無法輸入中文
會員五級
註冊日期:
2010/9/26 16:05
所屬群組:
已註冊使用者
等級: 27
HP : 0 / 660
MP : 317 / 17190
EXP: 43
離線
自行找到正解了
apt-get install scim-bridge-client-gtk

然後,在dia中,選擇scim bridge input method
不過好像只能使用scim,gcin好像不行

2012/3/30 0:55
應用擴展 工具箱
回覆: 〔求救〕dia無法輸入中文
會員三級
註冊日期:
2006/12/24 18:19
所屬群組:
已註冊使用者
等級: 13
HP : 0 / 309
MP : 68 / 11454
EXP: 38
離線
gcin 在 dia 中可以使用。

不過 dia 不會移動 gcin 輸入 window.

gcin 在 firefox/chrome 等 gtk2 的程式可以用嗎?dia 也是 gtk2 的程式。

2012/3/30 8:23
應用擴展 工具箱
回覆: 〔求救〕dia無法輸入中文
會員五級
註冊日期:
2010/9/26 16:05
所屬群組:
已註冊使用者
等級: 27
HP : 0 / 660
MP : 317 / 17190
EXP: 43
離線
eliu 寫到:
gcin 在 dia 中可以使用。

不過 dia 不會移動 gcin 輸入 window.

gcin 在 firefox/chrome 等 gtk2 的程式可以用嗎?dia 也是 gtk2 的程式。

其他程式都正常,就單只dia無法使用中文輸入
試了半天,就只有在scim加裝scim-bridge-client-gtk套件的時候,可以正常輸入
但使用上也有問題,在dia呼叫中文以後,好像scim就被dia給lock住了,變成其他程式無法輸入中文,dia切回英文模式以後,其他程式才又能正常輸入中文
有人跟我有同樣問題嗎?

原來是gcin作者上來回答,感謝
那可以請教一下,dia要使用gcin輸入中文,是否應該是安裝gcin-gtk3-immodule套件?
我昨天是有安裝但仍然無法使用,我有漏掉那個套件嗎?
我使用版本是gcin 2.7.5+dfsg-1

2012/3/30 8:48
應用擴展 工具箱
回覆: 〔求救〕dia無法輸入中文

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1404 / 1756
MP : 4456 / 49805
EXP: 24
離線
1. Dia 0.97輸入中文
2. Ubuntu 的 Dia 0.97 與中文輸入

以上兩篇文章的作者 與本站網友前輩
camabula
同名
不知是否同一人
如果是
你可以向他請益

2012/3/30 8:54
應用擴展 工具箱
回覆: 〔求救〕dia無法輸入中文
會員三級
註冊日期:
2006/12/24 18:19
所屬群組:
已註冊使用者
等級: 13
HP : 0 / 309
MP : 68 / 11454
EXP: 38
離線
dia 目前 0.97.1-9 還是用 gtk2,所以與 gtk3 的 im-gcin.so 無關。

2012/3/30 9:09
應用擴展 工具箱
回覆: 〔求救〕dia無法輸入中文
會員五級
註冊日期:
2010/9/26 16:05
所屬群組:
已註冊使用者
等級: 27
HP : 0 / 660
MP : 317 / 17190
EXP: 43
離線
eliu 寫到:
dia 目前 0.97.1-9 還是用 gtk2,所以與 gtk3 的 im-gcin.so 無關。

查了一下,我裝的是dia 0.97.2
會是因為版本關係導致嗎?

2012/3/30 9:17
應用擴展 工具箱
回覆: 〔求救〕dia無法輸入中文
會員五級
註冊日期:
2010/9/26 16:05
所屬群組:
已註冊使用者
等級: 27
HP : 0 / 660
MP : 317 / 17190
EXP: 43
離線
poloshiao 寫到:
1. Dia 0.97輸入中文
2. Ubuntu 的 Dia 0.97 與中文輸入

以上兩篇文章的作者 與本站網友前輩
camabula
同名
不知是否同一人
如果是
你可以向他請益

二篇昨天都有google到,但都無助我的狀況,不過還是感謝
其實現在改scim是可以使用了,只是想了解原因
還有就是比較習慣gcin, 希望可以調整回來

2012/3/30 9:20
應用擴展 工具箱
回覆: 〔求救〕dia無法輸入中文
版主
註冊日期:
2008/7/14 0:03
來自 螢幕的另一端
所屬群組:
網站管理員
已註冊使用者
討論區管理群
等級: 32
HP : 0 / 798
MP : 496 / 25905
EXP: 94
離線
我的 dia 是 0.97.1 版,可以正常的使用 gcin(1.6.9.pre7) 輸入中文。
給你參考一下

2012/3/30 10:41
應用擴展 工具箱
回覆: 〔求救〕dia無法輸入中文
會員五級
註冊日期:
2010/9/26 16:05
所屬群組:
已註冊使用者
等級: 27
HP : 0 / 660
MP : 317 / 17190
EXP: 43
離線
安裝12.04後,使用gcin
在dia上仍然無法輸入中文
這是系統的bug嗎?

2012/5/12 18:21
應用擴展 工具箱

(1) 2 »

 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.