[BUG] 開機掛載分割區出錯時的訊息為亂碼(Ubuntu 12.04起) [論壇 - Ubuntu 養蟲箱 - bug share]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊



[BUG] 開機掛載分割區出錯時的訊息為亂碼(Ubuntu 12.04起)
會員五級
註冊日期:
2009/10/29 4:50
所屬群組:
已註冊使用者
等級: 41
HP : 201 / 1005
MP : 889 / 28555
EXP: 21
離線
 
Ubuntu 12.04起在漢語台灣環境下 開機掛載分割區出錯時的訊息裡 中文為缺字模樣 變成內有數字的方框
該訊息的中文來自/usr/share/locale-langpack/zh_TW/LC_MESSAGES/mountall.mo


『重現Bug的方法』(生手勿試)

1.先備份/etc/fstab
sudo cp /etc/fstab /etc/fstab.bak

2.修改其中任意UUID數值
sudo vi /etc/fstab

例如:
# /home was on /dev/sda2 during installation
UUID=d82aa9c9-7408-43b1-af9a-a40192a0726e /home ext4 defaults 0 2

改為
# /home was on /dev/sda2 during installation
UUID=x82aa9c9-7408-43b1-af9a-a40192a0726e /home ext4 defaults 0 2

3.重新開機 等待有亂碼的訊息出現

4.看過之後按s略過掛載 按Ctrl+Alt+F1進入tty1
自行將/etc/fstab復原

2012/7/18 1:46
應用擴展 工具箱
回覆: [BUG] 開機掛載分割區出錯時的訊息為亂碼(Ubuntu 12.04)
管理員
註冊日期:
2011/3/11 6:32
所屬群組:
討論區管理群
等級: 44
HP : 216 / 1084
MP : 1088 / 26483
EXP: 38
離線
我記得之前有看過顯示正常的情形過...

2012/7/18 5:42
應用擴展 工具箱
回覆: [BUG] 開機掛載分割區出錯時的訊息為亂碼(Ubuntu 12.04)
會員五級
註冊日期:
2009/10/29 4:50
所屬群組:
已註冊使用者
等級: 41
HP : 201 / 1005
MP : 889 / 28555
EXP: 21
離線
Vdragon 寫到:
我記得之前有看過顯示正常的情形過...


嗯 在10.04是正常的
10.04沒有這段翻譯

2012/7/18 9:40
應用擴展 工具箱
回覆: [BUG] 開機掛載分割區出錯時的訊息為亂碼(Ubuntu 12.04)
管理員
註冊日期:
2011/3/11 6:32
所屬群組:
討論區管理群
等級: 44
HP : 216 / 1084
MP : 1088 / 26483
EXP: 38
離線
xenomorph0525 寫到:
Vdragon 寫到:
我記得之前有看過顯示正常的情形過...


嗯 在10.04是正常的
10.04沒有這段翻譯

呃我的意思是看到「正常的中文」
不過應該不是12.04...

2012/7/18 9:47
應用擴展 工具箱
回覆: [BUG] 開機掛載分割區出錯時的訊息為亂碼(Ubuntu 12.04)
會員五級
註冊日期:
2009/10/29 4:50
所屬群組:
已註冊使用者
等級: 41
HP : 201 / 1005
MP : 889 / 28555
EXP: 21
離線
Vdragon 寫到:
xenomorph0525 寫到:
Vdragon 寫到:
我記得之前有看過顯示正常的情形過...


嗯 在10.04是正常的
10.04沒有這段翻譯

呃我的意思是看到「正常的中文」
不過應該不是12.04...


經您的提醒 我想起12.04的不是亂碼而是缺字 呈現方框內有數字的模樣
或許更改相關的字型設定就可以正常顯示?

2012/7/18 9:53
應用擴展 工具箱
回覆: [BUG] 開機掛載分割區出錯時的訊息為亂碼(Ubuntu 12.04)
管理員
註冊日期:
2011/3/11 6:32
所屬群組:
討論區管理群
等級: 44
HP : 216 / 1084
MP : 1088 / 26483
EXP: 38
離線
xenomorph0525 寫到:
Vdragon 寫到:
xenomorph0525 寫到:
Vdragon 寫到:
我記得之前有看過顯示正常的情形過...


嗯 在10.04是正常的
10.04沒有這段翻譯

呃我的意思是看到「正常的中文」
不過應該不是12.04...


經您的提醒 我想起12.04的不是亂碼而是缺字 呈現方框內有數字的模樣
或許更改相關的字型設定就可以正常顯示?

有可能,雖然我不認為錯誤訊息會用到啥字型不存在的字...
想辦法抓個圖送bug吧?

2012/7/18 10:06
應用擴展 工具箱
回覆: [BUG] 開機掛載分割區出錯時的訊息為缺字模樣(Ubuntu 12.04)

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1404 / 1756
MP : 4456 / 49341
EXP: 24
離線
我想起12.04的不是亂碼而是缺字 呈現方框內有數字的模樣 或許更改相關的字型設定就可以正常顯示?

記得 當初 反應
/etc/fonts/conf.avail/69-language-selector-zh-tw.conf 中文為方框
後來 解決方案 是將 /etc/fonts/conf.avail/69-language-selector-zh-tw.conf 修正及連結
其後 在本論壇有提到該解決方案的檔案連結好像有問題 # 我暫時 還沒找到這一段在哪裏
也許 你現在發現的問題 跟這個連結有關
再找找看 是否有關

2012/7/18 10:30
應用擴展 工具箱


 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.