請各位朋友推薦linux c++入門書籍 [論壇 - Ubuntu 程式設計]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊

« 1 (2)


回覆: 請各位朋友推薦linux c++入門書籍
版主
註冊日期:
2006/12/24 16:54
所屬群組:
網站管理員
已註冊使用者
等級: 33
HP : 0 / 816
MP : 524 / 34296
EXP: 67
離線
b1265 寫到:
PTT Soft_Job上那篇 不是我發的感謝您
為什麼版上的朋友都好像不是很喜歡C++??有很大的缺點嗎


因為 C++ 難學難精

如果魔鬼都藏在細節裡, 那 C++ 大概就是十八層煉獄

2013/1/18 17:03
就算你百分之一百認定某人是渣滓中的渣滓,請仍然展示你的冷靜、體諒、尊重。

* My Blog
* My Twitter <- follow me!
* My Plurk
FoolproofProject:
* KomiX latest stable: v0.1.0 (Comics Viewer)
* Khopper latest stable: v0.4.2 (Audio Converter with CUE Sheet Support)
* PicKing latest stable: v0.2.3 (File Picking)
應用擴展 工具箱
回覆: 請各位朋友推薦linux c++入門書籍
會員一級
註冊日期:
2011/7/15 18:15
所屬群組:
已註冊使用者
等級: 1
HP : 0 / 18
MP : 2 / 527
EXP: 73
離線
不好意思新手又來發外了,祝大家新春愉快
Ubuntu和下手動架設c/c++環境與gtk

ubuntu12.10下
1.如何建置環境 c/c++ (有個源碼gcc是用舊版的不知道直接安裝新版會不會有問題)
看自動安裝的開發套件有一長串,不知道各別間的差異需要裝哪個...

2.IDE
2.1 codeblocks 想從官方下載不想用自動下載的,但是到官網選項很多
不知道如何安裝
有需要安裝GDB嗎?(這個是否跟Debug有關?)
2.2還有哪些配套需要安裝?
http://www.codeblocks.org/


3.GTK 與MYSQL
如何從官網下載離線安裝包 看到有很多的選項
主要是codeblocks 好像沒有內建需要下載...但是不知道該如何做
http://www.gtk.org/


4.codeblocks 安裝gtk後是否能直接拉出圖形介面?
如果不行那麼有輔助工具嗎?

5.gtk 與 codeblocks教學網站

備註:
我是想手動到官網下載安裝,了解每個套件大概的功用。
用自動安裝哪天出了問題,我想大概也一知半解不知道問題在何處。
再來就是怕自動安裝新版,編譯得時候他要舊版的,我想會出問題。

2013/2/12 19:45
應用擴展 工具箱
回覆: 請各位朋友推薦linux c++入門書籍
管理員
註冊日期:
2011/3/11 6:32
所屬群組:
討論區管理群
等級: 44
HP : 216 / 1084
MP : 1088 / 32202
EXP: 38
離線
b1265 寫到:
我是想手動到官網下載安裝,了解每個套件大概的功用。
用自動安裝哪天出了問題,我想大概也一知半解不知道問題在何處。
再來就是怕自動安裝新版,編譯得時候他要舊版的,我想會出問題。

基本上透過軟體包管理系統安裝才是最正統的 ubuntu way
如果人家都已經處理好了何必自己安裝呢 :P
您的「自動安裝」是不會安裝到新版的,因為 ubuntu 的釋出版本都會功能凍結(feature freeze)不會安裝更新的版本

...至於哪一天真的遇到版本相容問題再來想如何自行安裝

2013/2/12 23:07
本篇發表文章以「創用CC BY 3.0 或更新之台灣地區版本」授權條款釋出,如何使用敬請參考
 Creative Commons — 姓名標示 3.0 台灣 — CC BY 3.0 TW
 http://creativecommons.org/licenses/by/3.0/tw/

「你不懂的東西就不要亂講,被懂得人看破手腳就算了,騙不懂的人誤導別人,還要別人把你當成大師,這就真的是說不過去了。」
 by Allen Own
 出處 http://www.plurk.com/p/i4uogm

自由知識創作平台介紹
 https://docs.google.com/document/d/1MGG6lW_0qCgH4U785R-IwSc_INdoBGej1l-JxiA4gPE
如何建立新的自由知識創作平台文件
 https://docs.google.com/document/d/11NdzOW2lGYksfyQIcPMPye5tlmj1J0QTkgPTmQvIvKA
應用擴展 工具箱
回覆: 請各位朋友推薦linux c++入門書籍
會員一級
註冊日期:
2011/7/15 18:15
所屬群組:
已註冊使用者
等級: 1
HP : 0 / 18
MP : 2 / 527
EXP: 73
離線
謝謝版本問題解了一半了
新系統想安裝舊的mysql該怎麼辦?
聽朋友說那個範例需要mysql4.0的版本....

2013/2/13 0:48
應用擴展 工具箱
回覆: 請各位朋友推薦linux c++入門書籍
管理員
註冊日期:
2011/3/11 6:32
所屬群組:
討論區管理群
等級: 44
HP : 216 / 1084
MP : 1088 / 32202
EXP: 38
離線
b1265 寫到:
聽朋友說那個範例需要mysql4.0的版本....

需要有很多種
有的是「至少要」
有的是「一定要」
建議您先判斷是哪一種再說,除非舊的用法被廢棄否則通常新的版本還是可以用的

如果真的要手動安裝的話...軟體包管理系統不要安裝 MySQL 然後再看看手動要怎麼安裝

至少目前我用到的 MySQL 都沒有一定要在舊版本上才能用的功能

可以查詢 MySQL 官方的說明文件

2013/2/13 0:56
本篇發表文章以「創用CC BY 3.0 或更新之台灣地區版本」授權條款釋出,如何使用敬請參考
 Creative Commons — 姓名標示 3.0 台灣 — CC BY 3.0 TW
 http://creativecommons.org/licenses/by/3.0/tw/

「你不懂的東西就不要亂講,被懂得人看破手腳就算了,騙不懂的人誤導別人,還要別人把你當成大師,這就真的是說不過去了。」
 by Allen Own
 出處 http://www.plurk.com/p/i4uogm

自由知識創作平台介紹
 https://docs.google.com/document/d/1MGG6lW_0qCgH4U785R-IwSc_INdoBGej1l-JxiA4gPE
如何建立新的自由知識創作平台文件
 https://docs.google.com/document/d/11NdzOW2lGYksfyQIcPMPye5tlmj1J0QTkgPTmQvIvKA
應用擴展 工具箱
回覆: 請各位朋友推薦linux c++入門書籍
會員一級
註冊日期:
2011/7/15 18:15
所屬群組:
已註冊使用者
等級: 1
HP : 0 / 18
MP : 2 / 527
EXP: 73
離線
只知道他那個老舊源碼需要 mysql4.0以下 5.0以上的會錯誤...
所以我也不知道是否為一定要

2013/2/13 7:52
應用擴展 工具箱
回覆: 請各位朋友推薦linux c++入門書籍
管理員
註冊日期:
2011/3/11 6:32
所屬群組:
討論區管理群
等級: 44
HP : 216 / 1084
MP : 1088 / 32202
EXP: 38
離線
b1265 寫到:
只知道他那個老舊源碼需要 mysql4.0以下 5.0以上的會錯誤...
所以我也不知道是否為一定要

那就表示要手動想辦法安裝舊版本了
不過安裝未受支援的舊版本 MySQL 可能會有安全上的疑慮
最好的方式是把程式碼移植到新版本 MySQL(當然,不一定實際)

2013/2/13 11:20
本篇發表文章以「創用CC BY 3.0 或更新之台灣地區版本」授權條款釋出,如何使用敬請參考
 Creative Commons — 姓名標示 3.0 台灣 — CC BY 3.0 TW
 http://creativecommons.org/licenses/by/3.0/tw/

「你不懂的東西就不要亂講,被懂得人看破手腳就算了,騙不懂的人誤導別人,還要別人把你當成大師,這就真的是說不過去了。」
 by Allen Own
 出處 http://www.plurk.com/p/i4uogm

自由知識創作平台介紹
 https://docs.google.com/document/d/1MGG6lW_0qCgH4U785R-IwSc_INdoBGej1l-JxiA4gPE
如何建立新的自由知識創作平台文件
 https://docs.google.com/document/d/11NdzOW2lGYksfyQIcPMPye5tlmj1J0QTkgPTmQvIvKA
應用擴展 工具箱

« 1 (2)

 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.