KDE+compiz fusion沒有邊框... [論壇 - Ubuntu 與 KDE]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊



KDE+compiz fusion沒有邊框...
會員三級
註冊日期:
2006/2/26 21:00
所屬群組:
已註冊使用者
等級: 13
HP : 0 / 312
MP : 69 / 15024
EXP: 48
離線
我安裝kubuntu後又安裝了compiz fusion, emerald, 和主題
然後下載安裝了nvidia官方最新的驅動程式
執行compiz後卻沒有邊框.......在終端機執行有出現以下錯誤:

X Error: BadDevice, invalid or uninitialized input device 169
Major opcode: 147
Minor opcode: 3
Resource id: 0x0
Failed to open device
X Error: BadDevice, invalid or uninitialized input device 169
Major opcode: 147
Minor opcode: 3
Resource id: 0x0
Failed to open device
compiz.real (core) - Warn: No GLXFBConfig for depth 32
compiz.real (core) - Warn: No GLXFBConfig for depth 32
compiz.real (core) - Warn: No GLXFBConfig for depth 32

然後我上網找了一些文章,也修改了xorg.conf
在screen加入了:
Option "AddARGBGLXVisuals" "True"
Option "DisableGLXRootClipping" "True"
還有
Section "Extensions"
Option "Composite" "Enable"
EndSection

可是狀況還是一樣......幫幫我解決吧!

2007/8/14 11:44
應用擴展 工具箱
回復: KDE+compiz fusion沒有邊框...
會員五級
註冊日期:
2007/1/15 14:06
所屬群組:
已註冊使用者
等級: 29
HP : 0 / 705
MP : 369 / 32119
EXP: 20
離線
sudo nvidia-xconfig --add-argb-glx-visuals
重啟

2007/8/14 12:19
新手安裝完第一件事:灌Ubuntu懶人包就對啦!
新手安裝完第二件事:,欲觀看請指向這裡。
應用擴展 工具箱
回復: KDE+compiz fusion沒有邊框...
會員三級
註冊日期:
2006/2/26 21:00
所屬群組:
已註冊使用者
等級: 13
HP : 0 / 312
MP : 69 / 15024
EXP: 48
離線
還是沒有辦法...結果一樣

2007/8/14 13:18
應用擴展 工具箱
回復: KDE+compiz fusion沒有邊框...
會員五級
註冊日期:
2007/1/15 14:06
所屬群組:
已註冊使用者
等級: 29
HP : 0 / 705
MP : 369 / 32119
EXP: 20
離線
你有沒有開indirect rendering?
開看看....

裝了Fusion Icon之後就可以調了 (你有裝嗎 ?)

然後你啟動compiz fusion 的指令是什麼?

(加上 compiz --replace --indirect-rendering?)

2007/8/14 21:34
新手安裝完第一件事:灌Ubuntu懶人包就對啦!
新手安裝完第二件事:,欲觀看請指向這裡。
應用擴展 工具箱
回復: KDE+compiz fusion沒有邊框...
會員三級
註冊日期:
2006/2/26 21:00
所屬群組:
已註冊使用者
等級: 13
HP : 0 / 312
MP : 69 / 15024
EXP: 48
離線
我試過了後情形也是一樣...想跟我安裝的最新官方驅動程式有關系,
不過之前如果我先安裝了源裡面的驅動程式,然後完整刪除,再安裝官方最新驅動程式卻是可以的.....真是奇怪...我也有把桌面預設顏色深度改成16萬色,但他一直說不支援32色的...

2007/8/15 12:23
應用擴展 工具箱
回復: KDE+compiz fusion沒有邊框...
會員三級
註冊日期:
2006/2/26 21:00
所屬群組:
已註冊使用者
等級: 13
HP : 0 / 312
MP : 69 / 15024
EXP: 48
離線
終於發現問題所在
把xorg.conf的screen選項的預設顏色深度改成24就可以了....
真是簡單啊

2007/9/7 23:47
應用擴展 工具箱


 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.