Mint安裝農曆失敗 [論壇 - LinuxMint]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊



Mint安裝農曆失敗
會員一級
註冊日期:
2012/11/27 23:53
所屬群組:
已註冊使用者
等級: 4
HP : 0 / 80
MP : 10 / 1622
EXP: 22
離線
Linux Mint(Xfce Desktop),使用[sudo apt-get install lunar-applet]指令安裝農曆日曆,系統提示「找不到套件lunar-applet」,該怎麼辦呢?通常情況GNOME的東西Xfce也可以用啊。

謝謝。

2012/12/18 17:28
應用擴展 工具箱
回覆: Mint安裝農曆失敗

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1404 / 1756
MP : 4456 / 50648
EXP: 24
離線
試試

1. 打開 Ubuntu 軟體中心 / 編輯 / 軟體來源 / ubuntu 軟體 / universe 打勾
2. sudo apt-get update
3. sudo apt-get install lunar

2012/12/18 17:51
應用擴展 工具箱
回覆: Mint安裝農曆失敗
會員一級
註冊日期:
2012/11/27 23:53
所屬群組:
已註冊使用者
等級: 4
HP : 0 / 80
MP : 10 / 1622
EXP: 22
離線
sudo apt-get update
sudo apt-get install lunar
仍然無效

2012/12/18 23:47
應用擴展 工具箱
回覆: Mint安裝農曆失敗
管理員
註冊日期:
2011/3/11 6:32
所屬群組:
討論區管理群
等級: 44
HP : 216 / 1084
MP : 1088 / 27290
EXP: 38
離線
Ubuntu 10.04 以後官方軟體來源就沒有 lunar-applet 軟體包了
大概是被廢棄了吧

2012/12/19 0:24
應用擴展 工具箱
回覆: Mint安裝農曆失敗

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1404 / 1756
MP : 4456 / 50648
EXP: 24
離線
sudo apt-get install lunar
仍然無效


1. sudo gedit /etc/apt/sources.list
找到 "precise" 這一行 把 "main restricted universe multiverse" 四個套件庫 補齊
deb http://archive.ubuntu.com/ubuntu/ precise main restricted universe multiverse
儲存

2. sudo apt-get update
3. sudo apt-get upgrade

4. sudo apt-get install lunar
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following NEW packages will be installed:
lunar
0 upgraded, 1 newly installed, 0 to remove and 485 not upgraded.
Need to get 15.5 kB of archives.
After this operation, 81.9 kB of additional disk space will be used.
Get:1 http://archive.ubuntu.com/ubuntu/ precise/universe lunar amd64 2.2-3.1 [15.5 kB]
Fetched 15.5 kB in 0s (16.3 kB/s)
Selecting previously unselected package lunar.
(Reading database ... 133089 files and directories currently installed.)
Unpacking lunar (from .../lunar_2.2-3.1_amd64.deb) ...
Processing triggers for man-db ...
Setting up lunar (2.2-3.1) ...


5. 安裝成功 在 Linux Mint 13 Xfce AMD 64
從終端機
lunar
Lunar Version 2.2 (October 28, 2001)
Usage:
Solar->Lunar: lunar [-h] [-b] year month day [hour]
(in Solar Calendar, 24 hour clock)
Lunar->Solar: lunar [-h] [-b] -i [-l] year month day [hour]
(in Lunar Calendar, 24 hour clock)
-l means the month is a leap month ("run4 yue4")
-h means output in hanzi (GB)
-b means output in "bitmap"
--utf8 means output in hanzi (UTF-8)
--gb means output in hanzi (GB)
--big5 means output in hanzi (Big5)
Date range: about 150 years from the Solar Date 1900.1.31

2012/12/19 7:15
應用擴展 工具箱
回覆: Mint安裝農曆失敗
會員三級
註冊日期:
2012/4/26 9:45
所屬群組:
已註冊使用者
等級: 10
HP : 0 / 231
MP : 42 / 5064
EXP: 26
離線
另一個方法是使用ics匯入evolution的行事曆:
ics的來源網站
http://www.wretch.cc/blog/evanade/13210161

如果你沒有個人的行事曆事件的話,可以直接匯入evolution裡的行事曆中的個人裡面,這樣子你再用indicator去顯示evolution就可以顯示每天的農曆了。
如果你有個人的行事曆事件的話,可以先在evolution的行事曆裡新增一個行事曆,並且把它取名為農曆,然後匯入時點選叫做農曆的行事曆,這樣就跟你原有的私人行事曆分開了。

這個方法是附著於郵件軟體的行事曆上,只有該軟體有ics功能才可以用。

不過,這個方法可能無法被其它程式語言的程式呼叫利用。

2012/12/19 16:33
應用擴展 工具箱
回覆: Mint安裝農曆失敗
會員一級
註冊日期:
2012/11/27 23:53
所屬群組:
已註冊使用者
等級: 4
HP : 0 / 80
MP : 10 / 1622
EXP: 22
離線
poloshiao老兄,我依照您的建議,使用sudo apt-get upgrade時,終端提示大意如下:「需要下載的東西大概要花一整天時間才能下完」!不知為何,使用apt-get upgrade時網速就超級慢。

2012/12/20 1:43
應用擴展 工具箱
回覆: Mint安裝農曆失敗
管理員
註冊日期:
2011/3/11 6:32
所屬群組:
討論區管理群
等級: 44
HP : 216 / 1084
MP : 1088 / 27290
EXP: 38
離線
lovefreeware 寫到:
poloshiao老兄,我依照您的建議,使用sudo apt-get upgrade時,終端提示大意如下:「需要下載的東西大概要花一整天時間才能下完」!不知為何,使用apt-get upgrade時網速就超級慢。

請改用頻寬較高的軟體來源(在台灣目前是 free.nchc.org.tw)
或是請升級您的網路方案


另外 lunar-applet 跟 lunar 軟體包是不同的東西。

2012/12/20 2:00
應用擴展 工具箱
回覆: Mint安裝農曆失敗

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1404 / 1756
MP : 4456 / 50648
EXP: 24
離線
请造訪
lunar-applet
注:本 lunar-applet 项目已停止

后续开发及维护
请造訪
http://liblunar.googlecode.com

2012/12/20 15:56
應用擴展 工具箱
回覆: Mint安裝農曆失敗

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1404 / 1756
MP : 4456 / 50648
EXP: 24
離線
使用sudo apt-get upgrade時,終端提示大意如下:「需要下載的東西大概要花一整天時間才能下完」!不

可能原因
1. 你很久沒有 更新 已安裝 套件 # 經常更新
2. 你與下載伺服器的連線 連線速度 太慢
可能原因
你的上網方案 速度太慢
下載伺服器很忙 所以分配給你的頻寬太小 # 換個下載伺服器 看看
3. 備註
你沒更新就先安裝 lunar 也沒關係
但是有時會碰到 相依套件版本不符的錯誤 導致 安裝 失敗
所以養成平時電腦閒置時間就更新的好習慣

2012/12/20 16:11
應用擴展 工具箱


 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.