Lazybuntu - Ubuntu 懶人包,測試版釋出 [論壇 - Ubuntu 與工具程式及軟體推薦]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊

« 1 2 (3) 4 5 6 ... 10 »


回復: Lazybuntu - Ubuntu 懶人包,測試版釋出
會員三級
註冊日期:
2005/6/23 11:51
所屬群組:
網站管理員
已註冊使用者
等級: 14
HP : 0 / 343
MP : 82 / 17492
EXP: 72
離線
0.1 beta 2 釋出
http://rt.openfoundry.org/Foundry/Project/Download/Attachment/93778/64319/Lazybuntu-0.1b2.tar.gz
新增 Hinedo 網路廣播,用來掛載 iso 檔的 GMountIso,
Deluge BT 軟體,Filezilla 3,以及一些小修正。

2007/10/6 21:17
應用擴展 工具箱
回復: Lazybuntu - Ubuntu 懶人包,測試版釋出
會員二級
註冊日期:
2007/6/13 0:38
所屬群組:
已註冊使用者
等級: 6
HP : 0 / 126
MP : 17 / 5710
EXP: 5
離線
或許可以順便也把GPicView一起包進去
這樣也可以讓更多的人體驗一下^^

2007/10/6 22:25
應用擴展 工具箱
回復: Lazybuntu - Ubuntu 懶人包,測試版釋出
會員一級
註冊日期:
2005/6/27 22:22
所屬群組:
已註冊使用者
等級: 1
HP : 0 / 18
MP : 2 / 937
EXP: 73
離線
喔,對不起,我可能沒說清楚
lock是用來確保一次只有一個apt-get執行
如果只有Lazybuntu在執行就沒有問題

問題是說
1.我在另一個視窗執行apt-get upgrade
2.同時執行Lazybuntu
則Lazybuntu會順著script一直跑下去
但所有的deb都不能成功安裝(因為lock打不開)
script會跑到完並顯示出安裝成功
使用者會以為安裝成功

只要在script的最前面加上一行檢查lock
如果lock在,中止script
這樣而已

2007/10/7 8:20
應用擴展 工具箱
回復: Lazybuntu - Ubuntu 懶人包,測試版釋出
會員三級
註冊日期:
2005/6/23 11:51
所屬群組:
網站管理員
已註冊使用者
等級: 14
HP : 0 / 343
MP : 82 / 17492
EXP: 72
離線
accord 寫到:
喔,對不起,我可能沒說清楚
lock是用來確保一次只有一個apt-get執行
如果只有Lazybuntu在執行就沒有問題

問題是說
1.我在另一個視窗執行apt-get upgrade
2.同時執行Lazybuntu
則Lazybuntu會順著script一直跑下去
但所有的deb都不能成功安裝(因為lock打不開)
script會跑到完並顯示出安裝成功
使用者會以為安裝成功

只要在script的最前面加上一行檢查lock
如果lock在,中止script
這樣而已

這個我知道,問題是要怎麼檢查.... 我在 python 裡面試了沒效
不只是檢查到就停止 script,根本應該一開始執行的時候
我們就要去 lock 那個檔案,使得其他套件管理工具不能執行
這樣才是保險的作法。
Synaptic 不知道是透過什麼機制來 lock 確保只有一個 synaptic
我檢查過,並不是靠 /var/lib/dpkg/lock。
如果你知道正確的作法,請送 patch,感謝。

2007/10/7 9:25
應用擴展 工具箱
回復: Lazybuntu - Ubuntu 懶人包,測試版釋出
會員一級
註冊日期:
2005/6/27 22:22
所屬群組:
已註冊使用者
等級: 1
HP : 0 / 18
MP : 2 / 937
EXP: 73
離線
啊...原來是這樣
抱歉了,我不知道正確的作法
還是謝謝您為大家寫的程式!

2007/10/7 14:01
應用擴展 工具箱
回復: Lazybuntu - Ubuntu 懶人包,測試版釋出
會員三級
註冊日期:
2005/6/23 11:51
所屬群組:
網站管理員
已註冊使用者
等級: 14
HP : 0 / 343
MP : 82 / 17492
EXP: 72
離線
0.1 Beta 3 測試 3 版釋出,包含多項修正,敬請大家用力測試
經過許多測試和修正,現在已經很適合在剛安裝好的 gutsy 上執行。
http://rt.openfoundry.org/Foundry/Project/Download/Attachment/93828/64338/Lazybuntu-0.1b3.tar.gz

願意幫忙測試的朋友,可以用 virtualbox 裝個乾淨的 gutsy
然後跑一次看看,我想目前應該動起來都 ok 了。

我今天才這樣測試過一次...
之前的版本,執行結果出了不少小瑕疵,只能用慘不忍睹來形容
不過經過反覆測試和修正, 現在應該是很 ok 了。
希望 gutsy 釋出的時候,可以把這個工具推薦給所有想接觸的新手。

2007/10/7 17:11
應用擴展 工具箱
回復: Lazybuntu - Ubuntu 懶人包,測試版釋出
管理員
註冊日期:
2006/6/9 20:09
來自 草木叢生之所
所屬群組:
網站管理員
已註冊使用者
等級: 23
HP : 0 / 568
MP : 227 / 27393
EXP: 75
離線
有點小想法,預設安裝的項目可不可以少一點...尤其是遊戲~@_@

已經裝過的套件能夠在列表上提示

另外可以在進行動作前顯示清單這樣好像也不錯

先寫在 OpenFoundary 吧~@_@

2007/10/7 17:16
~^_^~...快樂用 GNU/Linux 中...
應用擴展 工具箱
回復: Lazybuntu - Ubuntu 懶人包,測試版釋出
會員二級
註冊日期:
2007/6/13 0:38
所屬群組:
已註冊使用者
等級: 6
HP : 0 / 126
MP : 17 / 5710
EXP: 5
離線
剛剛下載Lazybuntu-0.1b3.tar.gz
安裝網路防火牆
出現"有一些索引檔案不能下載"......
的字樣

2007/10/7 20:15
應用擴展 工具箱
回復: Lazybuntu - Ubuntu 懶人包,測試版釋出
會員四級
註冊日期:
2005/6/13 11:56
所屬群組:
已註冊使用者
等級: 17
HP : 0 / 419
MP : 121 / 21408
EXP: 77
離線
使用0.1b3
安裝smplayer時找不到套件(所以沒安裝)
並且用tw.archive的source更新時到一半會卡住不動
可安裝Arcobat 8.1
但是沒有中文化(是本來就沒有嗎??)
啟動arcobat時會出現需要libgtkembedmoz
不知可否預設安裝...因為不知要去哪找source??
謝謝

2007/10/8 14:26
應用擴展 工具箱
回復: Lazybuntu - Ubuntu 懶人包,測試版釋出
版主
註冊日期:
2006/12/24 16:54
所屬群組:
網站管理員
已註冊使用者
等級: 33
HP : 0 / 816
MP : 524 / 38041
EXP: 67
離線
你好
我想要把它轉成KDE也能使用
因此正在著手pyqt4的ui重寫(雖然我很確定進度會很緩慢,除非找到人一起研究)
請問會在project的銜接上發生問題嗎?
謝謝

2007/10/8 22:25
就算你百分之一百認定某人是渣滓中的渣滓,請仍然展示你的冷靜、體諒、尊重。

* My Blog
* My Twitter <- follow me!
* My Plurk
FoolproofProject:
* KomiX latest stable: v0.1.0 (Comics Viewer)
* Khopper latest stable: v0.4.2 (Audio Converter with CUE Sheet Support)
* PicKing latest stable: v0.2.3 (File Picking)
應用擴展 工具箱

« 1 2 (3) 4 5 6 ... 10 »

 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.