沒有聲音了? [論壇 - Ubuntu硬體支援---音效卡專區]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊



沒有聲音了?
會員四級
註冊日期:
2011/7/29 14:20
所屬群組:
已註冊使用者
等級: 18
HP : 0 / 446
MP : 137 / 10211
EXP: 85
離線
今天我的計算機突然沒有聲音了,以前有聲音。
輸入命令:alsamixer
可以看見我的聲卡,附件是我的選項,爲何還是沒有聲音呢?

附件:



jpg  sound.jpg (190.15 KB)
26348_510eed0e71fd4.jpg 1280X800 px

2013/2/4 7:04
應用擴展 工具箱
回覆: 沒有聲音了?

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1404 / 1756
MP : 4456 / 48597
EXP: 24
離線
預設是由 pulseaudio : PulseAudio sound server
管理 音效 除非你有改變

安裝 pavucontrol : PulseAudio Volume Control 套件

PulseAudio, previously known as Polypaudio, is a sound server for POSIX and
WIN32 systems. It is a drop in replacement for the ESD sound server with
much better latency, mixing/re-sampling quality and overall architecture.

PulseAudio Volume Control (pavucontrol) is a simple GTK+ based volume
control tool (mixer) for the PulseAudio sound server. In contrast to
classic mixer tools this one allows you to control both the volume of
hardware devices and of each playback stream separately. It also allows
you to redirect a playback stream to another output device without
interrupting playback.


它是 PulseAudio 的音量控制 程式 可以控制 軟體 硬體 音量 還可以把 音流 導向
sudo apt-get install pavucontrol # 在 Ubuntu 的 universe 套件庫
不知道 debian 在哪個套件庫 你找一找

安裝好以後 從終端機 下指令
pavucontrol
如果有權限問題 再加

輸入命令:alsamixer


除非 你有 額外安裝的 聲卡 或 特別的 音效設備
如果是 主機板 內建的 音效卡
目前 預設 PulseAudio 應該足夠

alsamixer 等你 成爲 進階高端 使用者時 再來研究

有空 讀讀 這一篇 你就相信了

In a typical installation scenario under Linux, the user configures ALSA to use a virtual device provided by PulseAudio. Thus, applications using ALSA will output sound to PulseAudio, which then uses ALSA itself to access the real sound card.
使用 ALSA 的程式 把聲音 送到 PulseAudio 提供的 虛擬裝置 ...

PulseAudio also provides its own native interface to applications that want to support PulseAudio directly, as well as a legacy interface for ESD applications, making it suitable as a drop-in replacement for ESD.
PulseAudio 也提供 原生的界面 給 直接支援 PulseAudio 的程式

2013/2/4 7:50
應用擴展 工具箱
回覆: 沒有聲音了?
會員四級
註冊日期:
2011/7/29 14:20
所屬群組:
已註冊使用者
等級: 18
HP : 0 / 446
MP : 137 / 10211
EXP: 85
離線
這個問題是這樣產生的。
新買了個usb音箱,插上usb口後,無法使用,於是上網google,在gnome classic界面,system-preferences-sound setting ,選中usb audio,可以用了。
現在我把usb音箱拔下來,再進入lxde界面,筆記本的內置音箱不能使用了。
問題歸結爲一個,lxde界面下,如何選定網卡?
lxde終端可以識別聲卡。
root@debian:/home/debian# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC660-VD Analog [ALC660-VD Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 6: Si3054 Modem [Si3054 Modem]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: sc [madsn sc], device 0: USB Audio [USB Audio]
Subdevices: 1/1
Subdevice #0: subdevice #0
root@debian:/home/debian#
pavucontrol設定了,不起反應。


如何設定呢?

目前,我是這樣將就着用,在gnome classic界面,進入system-preferences-system setting--sound,設定好,退出gnome classi,再進入lxde界面。
我想知道如何在lxde進行設置。(電腦配置低,使用lxde比gnome classic更穩定更快,兩種界面我都安裝了)

附件:



jpg  sound2.jpg (70.29 KB)
26348_510eff7acbd3a.jpg 1280X800 px

2013/2/4 8:21
應用擴展 工具箱
回覆: 沒有聲音了?

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1404 / 1756
MP : 4456 / 48597
EXP: 24
離線
pavucontrol設定了,不起反應。


參閱
pavucontrol lxde

configure
input
output
這三個先設定好
每個按鈕都玩一玩
最後再設定
playback
record

有疑難 參考

pavucontrol
pavucontrol help ubuntu

在gnome classic界面,進入system-preferences-system setting--sound,設定好,退出gnome classi,再進入lxde界面。
我想知道如何在lxde進行設置。


這個設定的所有選項
system-preferences-system setting--sound
好像 pavucontrol
都已經包含在內了
你檢查一下

如果是
你就直接使用 pavucontrol
不就好了

lxde界面下,如何選定網卡?

試試
Output 標籤 選擇設備
選擇 類比 立體音效

2013/2/4 8:33
應用擴展 工具箱
回覆: 沒有聲音了?
管理員
註冊日期:
2010/5/7 5:46
所屬群組:
已註冊使用者
討論區管理群
等級: 31
HP : 0 / 755
MP : 434 / 19996
EXP: 23
離線
不用的關閉,要用的打開
或是在Output Devices設定預設裝置(要預設的打勾按下去)

2013/2/4 16:21
應用擴展 工具箱
回覆: 沒有聲音了?
會員四級
註冊日期:
2011/7/29 14:20
所屬群組:
已註冊使用者
等級: 18
HP : 0 / 446
MP : 137 / 10211
EXP: 85
離線
終於搞定了。圖標測試了幾遍。

2013/2/4 18:09
應用擴展 工具箱


 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.