有關「裝置」 [論壇 - Ubuntu硬體支援]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊

(1) 2 »


有關「裝置」
會員二級
註冊日期:
2012/8/18 9:23
所屬群組:
已註冊使用者
等級: 5
HP : 0 / 104
MP : 13 / 1764
EXP: 19
離線
我的Ubuntu 12.04開機後,
打開家目錄,左上角的「電腦」上面應該會有個「裝置」,
顯示我其它的磁區或其它硬碟的磁區,
但今早發現,我開機後,裝置沒了,重開機試過好幾次,
有時候正常顯示四個磁區,有時候卻只顯示兩個或三個,或一個都沒有。

但我可透過終端機正常掛載各個磁區,
請問我的「裝置」為什麼會顯示不正常?
有人說是我的power供電不穩導致,
如果真的是power供電不穩,可能容易使硬碟壞軌。
可是我又可手動

(sudo mount /dev/sdb1 /home/john/桌面/disks/B)

掛載所有磁區,有可能是其它原因嗎?

2013/4/19 21:42
應用擴展 工具箱
回覆: 有關「裝置」

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1404 / 1756
MP : 4456 / 43398
EXP: 24
離線
請提供 Ubuntu 版本
# 不同版本 也許 引起問題的原因 稍有差異 解決方法 可能也不同

2013/4/20 7:46
應用擴展 工具箱
回覆: 有關「裝置」
會員二級
註冊日期:
2012/8/18 9:23
所屬群組:
已註冊使用者
等級: 5
HP : 0 / 104
MP : 13 / 1764
EXP: 19
離線
我的是Ubuntu12.04

2013/4/20 9:42
應用擴展 工具箱
回覆: 有關「裝置」
管理員
註冊日期:
2011/3/11 6:32
所屬群組:
討論區管理群
等級: 44
HP : 216 / 1084
MP : 1088 / 22813
EXP: 38
離線
基本上比較像是軟體上的問題

2013/4/20 10:41
本篇發表文章以「創用CC BY 3.0 或更新之台灣地區版本」授權條款釋出,如何使用敬請參考
 Creative Commons — 姓名標示 3.0 台灣 — CC BY 3.0 TW
 http://creativecommons.org/licenses/by/3.0/tw/

「你不懂的東西就不要亂講,被懂得人看破手腳就算了,騙不懂的人誤導別人,還要別人把你當成大師,這就真的是說不過去了。」
 by Allen Own
 出處 http://www.plurk.com/p/i4uogm

自由知識創作平台介紹
 https://docs.google.com/document/d/1MGG6lW_0qCgH4U785R-IwSc_INdoBGej1l-JxiA4gPE
如何建立新的自由知識創作平台文件
 https://docs.google.com/document/d/11NdzOW2lGYksfyQIcPMPye5tlmj1J0QTkgPTmQvIvKA
應用擴展 工具箱
回覆: 有關「裝置」

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1404 / 1756
MP : 4456 / 43398
EXP: 24
離線
請問我的「裝置」為什麼會顯示不正常?

沒有看到 「裝置」時
拿個 USB 碟 插進去 USB 插槽
靜觀 幾秒
看看 會不會 出現 「裝置」

如果出現 「裝置」
把 USB 碟 卸載 或 安全移除
看看 「裝置」 會不會 消失

或者 你的 「裝置」 還有別的掛載
統統使用右鍵 卸載
看看 「裝置」 會不會 消失

如果 「裝置」 會 再度消失
你的結論 是 ?
有時候正常顯示四個磁區,有時候卻只顯示兩個或三個,或一個都沒有。

從終端機
sudo cat /etc/fstab
sudo ls -al /dev/disk/by-uuid/*
把上述兩個指令結果 直接 copy 貼上來
幫你研讀看看

2013/4/20 10:52
應用擴展 工具箱
回覆: 有關「裝置」
會員二級
註冊日期:
2012/8/18 9:23
所屬群組:
已註冊使用者
等級: 5
HP : 0 / 104
MP : 13 / 1764
EXP: 19
離線
我剛用USB試過,正常。

sudo cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc nodev,noexec,nosuid 0 0
# / was on /dev/sda6 during installation
UUID=63325969-c993-4ae3-9300-80c32983e6c3 / ext4 errors=remount-ro 0 1
# swap was on /dev/sda5 during installation
UUID=b3a64e24-dbfb-48ba-9a4c-693d68e62438 none swap sw 0 0


sudo ls -al /dev/disk/by-uuid/*
lrwxrwxrwx 1 root root 10 4月 20 23:02 /dev/disk/by-uuid/1038A13D38A122A8 -> ../../sdd1
lrwxrwxrwx 1 root root 10 4月 20 23:03 /dev/disk/by-uuid/10F862910E0044A1 -> ../../sdd4
lrwxrwxrwx 1 root root 10 4月 20 23:02 /dev/disk/by-uuid/63325969-c993-4ae3-9300-80c32983e6c3 -> ../../sdd5
lrwxrwxrwx 1 root root 10 4月 20 23:02 /dev/disk/by-uuid/b3a64e24-dbfb-48ba-9a4c-693d68e62438 -> ../../sdd3

2013/4/20 23:12
應用擴展 工具箱
回覆: 有關「裝置」

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1404 / 1756
MP : 4456 / 43398
EXP: 24
離線
你的
sudo cat /etc/fstab
沒有
/dev/sdd1, /dev/sdd2, /dev/sdd3, /dev/sdd4
所以開機 不會 自動掛載

開完機
會不會在你的 家目錄 / 電腦 下面 出現一個
/dev/sdd1
/dev/sdd2
/dev/sdd3
/dev/sdd4
的 UUID (或 標籤) 的 書籤
需看你的設定
設定方法
安裝桌面環境設定工具「unsettings」

如果你設定會顯示
可能在桌面也會顯示 硬碟分割區 的圖示

從終端機
sudo ls -l /media
看看 有沒有這些 UUID (或 標籤) 的 書籤

建議
如果
/dev/sdd1, /dev/sdd2, /dev/sdd3, /dev/sdd4
是 固定硬碟 或 外加硬碟
全部都掛載在 /etc/fstab
這樣 一開機就掛載
就沒有這些問題

讓 裝置
只是 顯示 USB 碟 或 CD/DVD
有人說是我的power供電不穩導致,

這個可能性不大
1. 如果 power 供電不穩
會使得 /dev/sdd1, /dev/sdd2, /dev/sdd3, /dev/sdd4 全部不見了
sudo ls -al /dev/disk/by-uuid/*
會全部不見了
2. 如果你從 終端機 下指令
sudo fdisk -l
會找不到 /dev/sdd 及 /dev/sdd1, /dev/sdd2, /dev/sdd3, /dev/sdd4
3. 有時 會導致 當機 或 滑鼠 不動
4. 所以 依你的描述 不可能是 電源問題 (因爲你還能使用指令掛載)

建議 你把 /dev/sdd1, /dev/sdd2, /dev/sdd3, /dev/sdd4
全部掛載在 /etc/fstab
開機就自動掛載
測試一段時間 看看是否穩定

2013/4/20 23:39
應用擴展 工具箱
回覆: 有關「裝置」
會員二級
註冊日期:
2012/8/18 9:23
所屬群組:
已註冊使用者
等級: 5
HP : 0 / 104
MP : 13 / 1764
EXP: 19
離線
我不想開機自動掛載

剛發現,我用USB,有時候家目錄那也不會出現我的USB,

但是

sudo fdisk -l

看的到。

2013/4/21 1:00
應用擴展 工具箱
回覆: 有關「裝置」

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1404 / 1756
MP : 4456 / 43398
EXP: 24
離線
我不想開機自動掛載

不是 長期 開機自動掛載
目的 是 診斷 問題 跟 nautilus 裏的 自動掛載程式 有沒有關聯
隨時 可以取消的
我用USB,有時候家目錄那也不會出現我的USB,
但是
sudo fdisk -l
看的到。

猜測 有 nautilus 裏的 程式 安裝不完整或有瑕疵

1. 先備存 Ubuntu 系統
2. 按 alt + ctrl + F1 # 進 tty1 登入 帳號/密碼
3. sudo stop lightdm # 把 tty7 圖形界面 關閉
4. sudo apt-get update
5. sudo apt-get upgrade
6. sudo apt-get install --reinstall ubuntu-desktop
時間需要一下子 泡杯咖啡
7. sudo reboot
看看 情況有沒有改善

如果問題還沒改善
要考慮檢查你的
電腦硬體 - 與 USB 有關的實體線路
電腦韌體 - 與 USB 有關的 BIOS
作業系統 - 與 USB 有關的 界面的 驅動程式
特別是 如果 /dev/sdd 是 USB 外接硬碟的話

2013/4/21 6:34
應用擴展 工具箱
回覆: 有關「裝置」
會員二級
註冊日期:
2012/8/18 9:23
所屬群組:
已註冊使用者
等級: 5
HP : 0 / 104
MP : 13 / 1764
EXP: 19
離線
我剛才將我主機裡所有的磁區,都開機自動掛載,
(加在/etc/fstab最後):

/dev/sda1 /mnt/40 NTFS defaults 0 2
/dev/sda4 /mnt/78 NTFS defaults 0 2
/dev/sdb1 /mnt/200 NTFS defaults 0 2

重開機後發生錯誤,


另外,

我發現我每次重開機看
sudo fdisk -l
我的「裝置代號」都不一樣,
例如同一個硬碟:
有時是
/dev/sda1
/dev/sda2
/dev/sda3
/dev/sda4
/dev/sda5

下次重開時變成
/dev/sdb1
/dev/sdb2
/dev/sdb3
/dev/sdb4
/dev/sdb5

難道是因為我有兩個硬碟,雖然一個是SATA,一個是IDE,
但我還是要把IDE設成slave,才會運作正常?!

其實我最近有主機硬碟有換,
以前是一顆SATA,兩個IDE,
其中兩個IDE的,一個設Master,一個設Slave

最近換成一個SATA,一個IDE,IDE設Master

(以前三個硬碟時運作正常一段時間,後來「裝置」有問題後才換硬碟試試)

2013/4/22 11:24
應用擴展 工具箱

(1) 2 »

 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.