安裝-Steam-遊戲軟體-及-Steam-遊戲入門網頁-(Beta-版) [論壇 - 自由軟體中文翻譯討論]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊



安裝-Steam-遊戲軟體-及-Steam-遊戲入門網頁-(Beta-版)

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1756 / 1756
MP : 4456 / 38790
EXP: 24
離線
以下以 Ubuntu 12.04 及 nVidia 顯卡 爲例
如果你是使用 不同版本 或者 使用別品牌的顯卡 碰到問題 歡迎貼文討論

1. 安裝 Steam

1-1. 先安裝合適的 nVidia 顯卡驅動版本
1-1-1. 開機選單 選 第二項 recovery mode / resume 進 桌面
1-1-1-1. 終端機 sudo add-apt-repository ppa:xorg-edgers/ppa
1-1-1-2. 軟體中心 / 編輯 / 軟體來源 / 更新 / 把 proposed / updates 套件庫 打勾
1-1-2. sudo apt-get update
1-1-3. sudo apt-get upgrade
1-1-4. sudo jockey-text -l # 看目前 (專有, 已啟用, 使用中) 的 顯卡驅動 (例如 xorg:nvidia_experimental_310)
1-1-5. sudo jockey-text -d xorg:nvidia_experimental_310 (停用 xorg:nvidia_experimental_310)
1-1-6. sudo jockey-text -l # 確認 已 停用 xorg:nvidia_experimental_310
1-1-7. sudo apt-get install nvidia_319
1-1-8. sudo jockey-text -l # 看新安裝的 kmod:nvidia_319 是否已進入可選名單內
1-1-9. sudo jockey-text -e kmod:nvidia_319 (啓用 kmod:nvidia_319)
1-1-10. sudo jockey-text -l # 確認 kmod:nvidia_319 (專有, 已啟用, 未使用)

1-2. 重開機
1-2-1. 開機選單 選 第二項 recovery mode / resume 進 桌面
1-2-2. sudo apt-get install gksu # 如果你已安裝 可以跳過
1-2-3. 按 alt + F2 輸入 gksudo nvidia-settings
1-2-4. 設定正確後 最下面選項 儲存 /home/username/.nvidia-settings-rc # username 用你登入的帳號名稱取代
1-2-5. udo jockey-text -l # 確認 kmod:nvidia_319 (專有, 已啟用, 使用中)

1-3. 重開機
1-3-1. 開機選單 選 第一項 normal 進 桌面
1-3-2. 安裝需要的 套件 curl libgl1-mesa-dri:i386, libgl1-mesa-glx:i386
1-3-2-1. sudo apt-get install ia32-libs
1-3-2-2. sudo apt-get install curl
1-3-2-3. sudo apt-get install libgl1-mesa-dri:i386
1-3-2-4. sudo apt-get install libgl1-mesa-glx:i386

1-4. 安裝 steam 套件
1-4-1. 下載 steam_latest.deb 到 家目錄
wget http://repo.steampowered.com/steam/archive/precise/steam_latest.deb
1-4-2. 安裝 steam
sudo dpkg -i steam_latest.deb
sudo apt-get install -fy # 如果安裝程序 因有錯誤訊息 才需執行此程序

1-5. 重開機
1-5-1. 從桌面 按下 Steam 圖示
或 從終端機 steam
或 應用程式 / 遊戲 / Steam
註冊帳號/密碼
登入



2. 安裝 Steam Portal Beta

2-1. 先啓動你的 steam 並且 登入你的帳號

2-2. 按下 下面的 網頁連結

Portal Beta via Steam Client

2-3. 如果無效 或 沒反應
請 按下 此鏈結 的 藍色按鈕
Download Portal Beta Via Steam Client











3. 如果 有誤 歡迎指正

4. 進一步參閱
4-1. Valve Release Portal Beta For Linux
4-2. Portal Released For Steam On Linux

2013/5/4 21:33
應用擴展 工具箱
回覆: 安裝-Steam-遊戲軟體-及-Steam-遊戲入門網頁-(Beta-版)
管理員
註冊日期:
2011/3/11 6:32
所屬群組:
討論區管理群
等級: 44
HP : 216 / 1084
MP : 1088 / 19964
EXP: 38
離線
poloshiao 寫到:
1-1-1-1. 終端機 sudo add-apt-repository ppa:xorg-edgers/ppa

Xorg edgers PPA 為 bleeding edge 的軟體
應改用 Xorg updates

poloshiao 寫到:
1-1-1-2. 軟體中心 / 編輯 / 軟體來源 / 更新 / 把 proposed / updates 套件庫 打勾

proposed 軟體倉庫為尚未經過完整測試的軟體更新
完全沒有為了要玩遊戲就啟用它的理由

poloshiao 寫到:
1-1-4. sudo jockey-text -l # 看目前 (專有, 已啟用, 使用中) 的 顯卡驅動 (例如 xorg:nvidia_experimental_310)
1-1-5. sudo jockey-text -d xorg:nvidia_experimental_310 (停用 xorg:nvidia_experimental_310)
1-1-6. sudo jockey-text -l # 確認 已 停用 xorg:nvidia_experimental_310
1-1-7. sudo apt-get install nvidia_319
1-1-8. sudo jockey-text -l # 看新安裝的 kmod:nvidia_319 是否已進入可選名單內
1-1-9. sudo jockey-text -e kmod:nvidia_319 (啓用 kmod:nvidia_319)
1-1-10. sudo jockey-text -l # 確認 kmod:nvidia_319 (專有, 已啟用, 未使用)

全部在「額外驅動程式」中做不就好了?

poloshiao 寫到:
1-2. 重開機
1-2-1. 開機選單 選 第二項 recovery mode / resume 進 桌面
1-2-2. sudo apt-get install gksu # 如果你已安裝 可以跳過
1-2-3. 按 alt + F2 輸入 gksudo nvidia-settings
1-2-4. 設定正確後 最下面選項 儲存 /home/username/.nvidia-settings-rc # username 用你登入的帳號名稱取代
1-2-5. udo jockey-text -l # 確認 kmod:nvidia_319 (專有, 已啟用, 使用中)

直接啟動 NVIDIA X Server Settings 不就好了?
為何要進 recovery mode?

poloshiao 寫到:
1-3. 重開機
1-3-1. 開機選單 選 第一項 normal 進 桌面
1-3-2. 安裝需要的 套件 curl libgl1-mesa-dri:i386, libgl1-mesa-glx:i386
1-3-2-1. sudo apt-get install curl
1-3-2-2. sudo apt-get install libgl1-mesa-dri:i386
1-3-2-3. sudo apt-get install libgl1-mesa-glx:i386

Ubuntu 預設安裝基於 Mesa 的 OpenGL 函式庫
多此一舉
更何況 NVIDIA 官方驅動程式根本就用自己的 OpenGL 實作

2013/5/4 21:57
本篇發表文章以「創用CC BY 3.0 或更新之台灣地區版本」授權條款釋出,如何使用敬請參考
 Creative Commons — 姓名標示 3.0 台灣 — CC BY 3.0 TW
 http://creativecommons.org/licenses/by/3.0/tw/

「你不懂的東西就不要亂講,被懂得人看破手腳就算了,騙不懂的人誤導別人,還要別人把你當成大師,這就真的是說不過去了。」
 by Allen Own
 出處 http://www.plurk.com/p/i4uogm

自由知識創作平台介紹
 https://docs.google.com/document/d/1MGG6lW_0qCgH4U785R-IwSc_INdoBGej1l-JxiA4gPE
如何建立新的自由知識創作平台文件
 https://docs.google.com/document/d/11NdzOW2lGYksfyQIcPMPye5tlmj1J0QTkgPTmQvIvKA
應用擴展 工具箱
回覆: 安裝-Steam-遊戲軟體-及-Steam-遊戲入門網頁-(Beta-版)
會員五級
註冊日期:
2010/2/9 18:20
所屬群組:
已註冊使用者
等級: 31
HP : 0 / 758
MP : 438 / 16353
EXP: 33
離線
V字龍 寫到:
proposed 軟體倉庫為尚未經過完整測試的軟體更新
完全沒有為了要玩遊戲就啟用它的理由



說實話,其實有XD

2013/5/4 22:44
應用擴展 工具箱
回覆: 安裝-Steam-遊戲軟體-及-Steam-遊戲入門網頁-(Beta-版)
管理員
註冊日期:
2011/3/11 6:32
所屬群組:
討論區管理群
等級: 44
HP : 216 / 1084
MP : 1088 / 19964
EXP: 38
離線
BrLi 寫到:
V字龍 寫到:
proposed 軟體倉庫為尚未經過完整測試的軟體更新
完全沒有為了要玩遊戲就啟用它的理由



說實話,其實有XD

遇到 bug 除外w

2013/5/4 22:54
本篇發表文章以「創用CC BY 3.0 或更新之台灣地區版本」授權條款釋出,如何使用敬請參考
 Creative Commons — 姓名標示 3.0 台灣 — CC BY 3.0 TW
 http://creativecommons.org/licenses/by/3.0/tw/

「你不懂的東西就不要亂講,被懂得人看破手腳就算了,騙不懂的人誤導別人,還要別人把你當成大師,這就真的是說不過去了。」
 by Allen Own
 出處 http://www.plurk.com/p/i4uogm

自由知識創作平台介紹
 https://docs.google.com/document/d/1MGG6lW_0qCgH4U785R-IwSc_INdoBGej1l-JxiA4gPE
如何建立新的自由知識創作平台文件
 https://docs.google.com/document/d/11NdzOW2lGYksfyQIcPMPye5tlmj1J0QTkgPTmQvIvKA
應用擴展 工具箱
回覆: 安裝-Steam-遊戲軟體-及-Steam-遊戲入門網頁-(Beta-版)
管理員
註冊日期:
2005/6/11 0:21
來自 Chia-yi City
所屬群組:
已註冊使用者
討論區管理群
等級: 20
HP : 0 / 480
MP : 159 / 16928
EXP: 23
離線
嗯,因為為了修臭蟲而放的包會先放在 proposed 中測試。

還滿實用的,搶先試用修正版不賴的,但仍遇到問題就只好節哀了。XD

2013/5/4 23:15
應用擴展 工具箱
回覆: 安裝-Steam-遊戲軟體-及-Steam-遊戲入門網頁-(Beta-版)
會員三級
註冊日期:
2009/2/1 11:47
所屬群組:
已註冊使用者
等級: 11
HP : 0 / 265
MP : 52 / 6521
EXP: 62
離線
Portal玩了半小時快吐了

2013/5/5 15:37
應用擴展 工具箱
回覆: 安裝-Steam-遊戲軟體-及-Steam-遊戲入門網頁-(Beta-版)
會員四級
註冊日期:
2010/12/22 12:40
所屬群組:
已註冊使用者
等級: 19
HP : 0 / 466
MP : 149 / 8876
EXP: 65
離線
13.04安裝Steam倒市很順利
下載DEB 安裝 正常更新
12.10的時候可沒這麼順利
不過手賤又去安裝Nvidia官方驅動
桌面又只剩桌布了 Unity很愛動不動搞失蹤

2013/5/6 9:19
應用擴展 工具箱
回覆: 安裝-Steam-遊戲軟體-及-Steam-遊戲入門網頁-(Beta-版)
會員一級
註冊日期:
2007/12/30 14:01
所屬群組:
已註冊使用者
等級: 3
HP : 0 / 68
MP : 8 / 1894
EXP: 73
離線
我在安裝libgl1-mesa-dri 時, 發生以下狀況, 導致沒辦法安裝stream

# sudo apt-get install libgl1-mesa-dri:i386
正在讀取套件清單... 完成
正在重建相依關係
正在讀取狀態資料... 完成
有些套件無法安裝。這可能意謂著您的要求難以解決,或是若您使用的是
unstable 發行版,可能有些必要的套件尚未建立,或是被移出 Incoming 了。
以下的資訊或許有助於解決當前的情況:

下列的套件有未滿足的相依關係:
libegl1-mesa : 相依關係: libgl1-mesa-dri (= 11.2.0-1ubuntu2.2) 但它卻將不會被安裝
libgl1-mesa-dri:i386 : 相依關係: libdrm-amdgpu1:i386 (>= 2.4.63) 但它卻將不會被安裝
相依關係: libdrm-intel1:i386 (>= 2.4.48) 但它卻將不會被安裝
相依關係: libdrm-nouveau2:i386 (>= 2.4.66) 但它卻將不會被安裝
相依關係: libdrm-radeon1:i386 (>= 2.4.31) 但它卻將不會被安裝
相依關係: libdrm2:i386 (>= 2.4.38) 但它卻將不會被安裝
相依關係: libllvm3.8:i386 但它卻將不會被安裝
libubuntuoneauth-2.0-0 : 相依關係: account-plugin-tools 但它卻將不會被安裝
E: 錯誤,pkgProblemResolver::Resolve 的建立中斷了,這可能肇因於保留 (hold) 套件。

我是
Distributor ID: Ubuntu
Description: Ubuntu 16.04.1 LTS
Release: 16.04
Codename: xenial

1/21 11:49:29
應用擴展 工具箱


 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.