13.10 的 ibus [論壇 - Ubuntu 與中文]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊

(1) 2 »


13.10 的 ibus
會員一級
註冊日期:
2013/10/31 21:52
所屬群組:
已註冊使用者
等級: 1
HP : 0 / 11
MP : 2 / 196
EXP: 47
離線
Hi.
之前用 13.04 很開心的,升上 13.10 之後,發現 ibus 輸入法消失了。
Google 一下後,發現其實還在,只是需要改成 Ctrl-space
(在 Terminal 打 ibus-setup 修改)

問題來了:ibus 的「在系統匣顯示圖示」沒顯示 (看到的還是大大的 Zh),之前習慣的下方組字、設定面板也不見了,所以無蝦米裡面打()就變全型的,而且不知道在哪裡改。

請問大家該怎麼辦呢?感謝!

2013/10/31 21:58
應用擴展 工具箱
回覆: 13.10 的 ibus
會員二級
註冊日期:
2009/4/23 12:32
所屬群組:
已註冊使用者
等級: 4
HP : 0 / 98
MP : 12 / 2951
EXP: 94
離線
我在這邊也碰到類似的問題。我使用的是新酷音,同樣地,沒有出現新酷音的符號,所以也是一堆東西無法修改。

2013/10/31 22:34
應用擴展 工具箱
回覆: 13.10 的 ibus

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1404 / 1756
MP : 4456 / 49397
EXP: 24
離線

2013/11/1 0:02
應用擴展 工具箱
回覆: 13.10 的 ibus
會員一級
註冊日期:
2013/10/31 21:52
所屬群組:
已註冊使用者
等級: 1
HP : 0 / 11
MP : 2 / 196
EXP: 47
離線
試著切到 gnome-shell ,比較不習慣,而且 iBus 的 panel 還是沒跑出來。

有趣的是 ps ax 的時候看到這個:

$ ps ax|grep ibus
3120 ? Sl 0:02 /usr/bin/ibus-daemon --replace --xim --panel disable
3124 ? Sl 0:00 /usr/lib/ibus/ibus-dconf
3126 ? Sl 0:00 /usr/lib/ibus/ibus-x11 --kill-daemon
3142 ? Sl 0:00 /usr/lib/ibus/ibus-engine-simple

為什麼會有個 --panel disable 呢? 要去哪裡把它改回來?

2013/11/3 20:03
應用擴展 工具箱
回覆: 13.10 的 ibus
會員一級
註冊日期:
2013/10/31 21:52
所屬群組:
已註冊使用者
等級: 1
HP : 0 / 11
MP : 2 / 196
EXP: 47
離線
還有一個可能的解法是:

sudo apt-get install xfce-desktop

切進 XFCE 幾乎一切都正常了,連 wicd (不是 Network-Manager) 都可以正確顯示。

2013/11/3 20:24
應用擴展 工具箱
回覆: 13.10 的 ibus

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1404 / 1756
MP : 4456 / 49397
EXP: 24
離線
3120 ? Sl 0:02 /usr/bin/ibus-daemon --replace --xim --panel disable

ibus-daemon --replace --xim
參考
cat /usr/share/im-config/data/20_ibus.rc | grep ibus-daemon
/usr/bin/ibus-daemon --daemonize --xim
為什麼會有個 --panel disable 呢? 要去哪裡把它改回來?

sudo apt-get install dconf-editor
dconf-editor
desktop/ibus/panel/show-icon-on-systray
打勾或不打勾

備註
是否有效 你試試
我的體驗是
某些項目有效
某些項目無效 好像另有設定機制會覆蓋它
我已寫好 Ubuntu 13.10 ibus-chewing 的 說明文件
但是這一點 還在摸索 所以還沒貼出來

2013/11/3 21:24
應用擴展 工具箱
回覆: 13.10 的 ibus
會員一級
註冊日期:
2013/10/31 21:52
所屬群組:
已註冊使用者
等級: 1
HP : 0 / 11
MP : 2 / 196
EXP: 47
離線
Hmm 謝謝回覆。

dconf 試改了幾個值,都沒作用。
更糟的是,前幾天 ubuntu update, 現在用 Ctrl-Space 切換後會有一個小小的 delay, 不能一按 Ctrl-Space 就馬上打字,不然它就不會切到另一個輸入法。

這對打字很快的人是個致命傷 -- 完全沒辦法照原來的節奏打字。

上面提到的使用 XFCE 引起別的問題:「暫停」會不斷地暫停、喚醒、暫停、喚醒,直到我 shutdown -r now 為止。所以又切回 Unity 了。

2013/11/12 21:30
應用擴展 工具箱
回覆: 13.10 的 ibus
會員一級
註冊日期:
2012/11/8 23:52
所屬群組:
已註冊使用者
等級: 3
HP : 0 / 65
MP : 8 / 1286
EXP: 62
離線
嘸蝦米/倉頡

雖然右下角面板不見了,但用快捷鍵設定還是有效:

shift (切換中打或英打)
shift + space (切換"英數"的全形或半形)
ctrl + . (切換"符號"的全形或半形)

2013/11/13 1:10
應用擴展 工具箱
回覆: 13.10 的 ibus
會員一級
註冊日期:
2013/10/31 21:52
所屬群組:
已註冊使用者
等級: 1
HP : 0 / 11
MP : 2 / 196
EXP: 47
離線
不過因為我常常用 ctrl-space 切換中、英文,最近這個 update 讓我沒辦法維持打字的節奏。

昨天換成了 fcitx ,照版上的說明設定了一堆東西之後,果然現在順手多了,選字視窗也出來了。不知道他們有沒有機會把這些設定變預設的...

2013/11/14 0:09
應用擴展 工具箱
回覆: 13.10 的 ibus
會員一級
註冊日期:
2013/11/19 17:19
所屬群組:
已註冊使用者
等級: 1
HP : 0 / 0
MP : 0 / 0
EXP: 0
離線
樓上說得算含蓄了
更新後的輸入法系統切換慢到有點離譜
有時甚至是按幾次才有反應
問題是又沒辦法切回gcin

2013/11/19 17:28
應用擴展 工具箱

(1) 2 »

 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.