Canon 印表機 ip90 驅動? [論壇 - Ubuntu硬體支援---印表機專區]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊



Canon 印表機 ip90 驅動?
會員一級
註冊日期:
2009/7/24 0:06
所屬群組:
已註冊使用者
等級: 2
HP : 0 / 31
MP : 4 / 1015
EXP: 25
離線
大家好, 最近我的老闆丟了一台 ip90 給我用, 但卻印不出來。
canon 官方似乎沒有給 linux 的程式
上網google了之後, 發現有一位日本人有寫了,
於是我就去套件庫新增了
deb http://mambo.kuhp.kyoto-u.ac.jp/~takushi/ubuntu ./
但在安裝
libcnbj-2.2 bjfilter-2.2 pstocanonbj
時出了一點問題,我有點看不懂:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
pstocanonbj:i386 : Depends: libcupsys2:i386 (>= 1.2.3)
Depends: cupsys:i386 but it is not installable
W: Duplicate sources.list entry http://packages.medibuntu.org/ precise/free amd64 Packages (/var/lib/apt/lists/packages.medibuntu.org_dists_precise_free_binary-amd64_Packages)
W: Duplicate sources.list entry http://packages.medibuntu.org/ precise/non-free amd64 Packages (/var/lib/apt/lists/packages.medibuntu.org_dists_precise_non-free_binary-amd64_Packages)
W: Duplicate sources.list entry http://packages.medibuntu.org/ precise/free i386 Packages (/var/lib/apt/lists/packages.medibuntu.org_dists_precise_free_binary-i386_Packages)
W: Duplicate sources.list entry http://packages.medibuntu.org/ precise/non-free i386 Packages (/var/lib/apt/lists/packages.medibuntu.org_dists_precise_non-free_binary-i386_Packages)
W: You may want to run apt-get update to correct these problems
E: Unable to correct problems, you have held broken packages.

請問有人可以幫忙看看嗎?
我在猜是不是套件損毀, 或是它不能給64位元用。
加了套件庫之後也有記得 apt-get update。
我的系統是 Linux Mint 13 - 也就是 ubuntu 12.04 precice pangolin 的改版。

或是有其他的解法, 都十分感謝。

2013/12/2 19:32
應用擴展 工具箱
回覆: Canon 印表機 ip90 驅動?
會員四級
註冊日期:
2010/12/22 12:40
所屬群組:
已註冊使用者
等級: 19
HP : 0 / 466
MP : 149 / 13141
EXP: 65
離線
Antares 寫到:
The following packages have unmet dependencies:
pstocanonbj:i386 : Depends: libcupsys2:i386 (>= 1.2.3)
Depends: cupsys:i386 but it is not installable


這段是說明相依性問題
pstocanonbj:i386相依於後面兩個套件
一個要求版本,一個跟你說不穩定
若要強行安裝
sudo apt-get install -f

Antares 寫到:
W: Duplicate sources.list entry http://packages.medibuntu.org/ precise/free amd64 Packages (/var/lib/apt/lists/packages.medibuntu.org_dists_precise_free_binary-amd64_Packages)
W: Duplicate sources.list entry http://packages.medibuntu.org/ precise/non-free amd64 Packages (/var/lib/apt/lists/packages.medibuntu.org_dists_precise_non-free_binary-amd64_Packages)
W: Duplicate sources.list entry http://packages.medibuntu.org/ precise/free i386 Packages (/var/lib/apt/lists/packages.medibuntu.org_dists_precise_free_binary-i386_Packages)
W: Duplicate sources.list entry http://packages.medibuntu.org/ precise/non-free i386 Packages (/var/lib/apt/lists/packages.medibuntu.org_dists_precise_non-free_binary-i386_Packages)
W: You may want to run apt-get update to correct these problems
E: Unable to correct problems, you have held broken packages.

這是說你的sources.list裡的repo有重複的來源
參考這篇的solution http://askubuntu.com/questions/120621/how-to-fix-duplicate-sources-list-entry
基本上是把你的sources.list備份(改成另一個檔名)
然後重建一個新的sources.list

2013/12/3 13:30
應用擴展 工具箱
回覆: Canon 印表機 ip90 驅動?
會員一級
註冊日期:
2009/7/24 0:06
所屬群組:
已註冊使用者
等級: 2
HP : 0 / 31
MP : 4 / 1015
EXP: 25
離線
感謝回答。
我把 source.list 的重複來源去掉了, 但還是沒辦法安裝。
用強制安裝也一樣:

Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
pstocanonbj:i386 : Depends: libcupsys2:i386 (>= 1.2.3)
Depends: cupsys:i386 but it is not installable
E: Unable to correct problems, you have held broken packages.

問題好像出在 clibcupsys2 沒辦法安裝。

我 google 了一下, 似乎是個 bug:
https://bugs.launchpad.net/ubuntu/+source/cups/+bug/1192210

也有人說 libcupsys2 是舊名, 後來改成 libcups2
libcups2http://web.archiveorange.com/archive/v/jgLs0FWaZn3aB94ma6m7

我曾考慮把 libcups2 解除安裝, 重裝舊版的 libcupsys2, 但libcups2 牽連到蠻多東西的, 我不敢試。
看來沒法輕易解決了... 現在只好開 windows 印了...

2013/12/3 15:45
應用擴展 工具箱


 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.