ubuntu無法update [論壇 - 伺服器架設]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊



ubuntu無法update
會員三級
註冊日期:
2010/12/13 6:50
所屬群組:
已註冊使用者
等級: 9
HP : 0 / 206
MP : 35 / 5421
EXP: 25
離線
它就顯示以下資訊

==============================
root@cloud:/var/log/apache2# apt-get install fail2ban
正在讀取套件清單... 完成
正在重建相依關係
正在讀取狀態資料... 完成
有些套件無法安裝。這可能意謂著您的要求難以解決,或是若您使用的是
unstable 發行版,可能有些必要的套件尚未建立,或是被移出 Incoming 了。
以下的資訊或許有助於解決當前的情況:

下列的套件有未滿足的相依關係:
fail2ban : 相依關係: python-central (>= 0.6.11) 但它卻無法安裝
推薦: whois 但它卻無法安裝
推薦: python-gamin 但它卻無法安裝
E: 無法修正問題,您保留 (hold) 了損毀的套件。
================================
root@cloud:/var/log/apache2# apt-get update
錯誤 http://ubuntu.stu.edu.tw precise Release.gpg
暫時無法解析 'ubuntu.stu.edu.tw'
錯誤 http://ubuntu.stu.edu.tw precise-updates Release.gpg
暫時無法解析 'ubuntu.stu.edu.tw'
錯誤 http://ubuntu.stu.edu.tw precise-backports Release.gpg
暫時無法解析 'ubuntu.stu.edu.tw'
錯誤 http://security.ubuntu.com precise-security Release.gpg
暫時無法解析 'security.ubuntu.com'
錯誤 http://extras.ubuntu.com precise Release.gpg
暫時無法解析 'extras.ubuntu.com'
錯誤 http://download.opensuse.org Release.gpg
暫時無法解析 'download.opensuse.org'
正在讀取套件清單... 完成
W: 無法取得 http://ubuntu.stu.edu.tw/ubuntu/dists/precise/Release.gpg,暫時無法解析 'ubuntu.stu.edu.tw'

W: 無法取得 http://ubuntu.stu.edu.tw/ubuntu/dists/precise-updates/Release.gpg,暫時無法解析 'ubuntu.stu.edu.tw'

W: 無法取得 http://ubuntu.stu.edu.tw/ubuntu/dists/precise-backports/Release.gpg,暫時無法解析 'ubuntu.stu.edu.tw'

W: 無法取得 http://security.ubuntu.com/ubuntu/dists/precise-security/Release.gpg,暫時無法解析 'security.ubuntu.com'

W: 無法取得 http://extras.ubuntu.com/ubuntu/dists/precise/Release.gpg,暫時無法解析 'extras.ubuntu.com'

W: 無法取得 http://download.opensuse.org/repositories/isv:ownCloud:community/xUbuntu_12.04/Release.gpg,暫時無法解析 'download.opensuse.org'

W: 某些索引檔未能下載。其已遭略過,或改為使用舊的。
===================================
不知道有沒有大大知道遇到這種情形該怎麼處理?

2014/3/17 12:26
應用擴展 工具箱
回覆: ubuntu無法update
會員五級
註冊日期:
2010/1/25 17:27
所屬群組:
已註冊使用者
等級: 26
HP : 0 / 637
MP : 292 / 18382
EXP: 50
離線
apt-get update的問題參考這篇的方法看看,應該是DNS出狀況
http://www.ubuntu-tw.org/modules/newbb/viewtopic.php?post_id=212970#forumpost212970

2014/3/17 12:40
應用擴展 工具箱
回覆: ubuntu無法update
會員四級
註冊日期:
2010/12/22 12:40
所屬群組:
已註冊使用者
等級: 19
HP : 0 / 466
MP : 149 / 12212
EXP: 65
離線
更新管理員的設定裡
把伺服器換一個

先試管理員幫你測出最佳的伺服器
如果不行 再換成美國的伺服器

2014/3/17 13:39
應用擴展 工具箱


 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.