USB3.0無法正確連接外接硬碟裝置 [論壇 - Ubuntu硬體支援]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊



USB3.0無法正確連接外接硬碟裝置
會員二級
註冊日期:
2006/12/2 19:03
所屬群組:
已註冊使用者
等級: 8
HP : 0 / 186
MP : 30 / 6514
EXP: 46
離線
USB3.0介面卡是Uptech UTB246

連接3.0讀卡機運作正常

kernel: [ 109.165192] usb 10-4: new SuperSpeed USB device number 2 using xhci_hcd May 6 07:31:12 tenki-freeland kernel: [ 109.182287] usb 10-4: Parent hub missing LPM exit latency info. Power management will be impacted.
kernel: [ 109.185415] usb 10-4: New USB device found, idVendor=8564, idProduct=4000
kernel: [ 109.185419] usb 10-4: New USB device strings: Mfr=3, Product=4, SerialNumber=5
kernel: [ 109.185422] usb 10-4: Product: Transcend kernel: [ 109.185425] usb 10-4: Manufacturer: TS-RDF8 kernel: [ 109.185427] usb 10-4: SerialNumber: 000000002 kernel: [ 109.187402] usb-storage 10-4:1.0: USB Mass Storage device detected
kernel: [ 109.187478] scsi11 : usb-storage 10-4:1.0 mtp-probe: checking bus 10, device 2: "/sys/devices/pci0000:00/0000:00:1c.0/0000:02:00.0/usb10/10-4" mtp-probe: bus: 10, device: 2 was not an MTP device
kernel: [ 110.184817] scsi 11:0:0:0: Direct-Access Generic STORAGE DEVICE TS21 PQ: 0 ANSI: 6
kernel: [ 110.185195] scsi 11:0:0:1: Direct-Access Generic STORAGE DEVICE TS21 PQ: 0 ANSI: 6
kernel: [ 110.185577] scsi 11:0:0:2: Direct-Access Generic STORAGE DEVICE TS21 PQ: 0 ANSI: 6
kernel: [ 110.185844] sd 11:0:0:0: Attached scsi generic sg9 type 0
kernel: [ 110.186041] sd 11:0:0:1: Attached scsi generic sg10 type 0
kernel: [ 110.186222] sd 11:0:0:2: Attached scsi generic sg11 type 0
kernel: [ 110.905285] sd 11:0:0:1: [sdj] 15523840 512-byte logical blocks: (7.94 GB/7.40 GiB)
kernel: [ 110.906830] sd 11:0:0:2: [sdk] Attached SCSI removable disk
kernel: [ 110.910288] sd 11:0:0:1: [sdj] Write Protect is on
kernel: [ 110.910291] sd 11:0:0:1: [sdj] Mode Sense: 21 00 80 00
kernel: [ 110.915623] sd 11:0:0:1: [sdj] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA kernel: [ 110.917629] sd 11:0:0:0: [sdi] Attached SCSI removable disk
kernel: [ 110.946942] sdj: sdj1
kernel: [ 110.967965] sd 11:0:0:1: [sdj] Attached SCSI removable disk udisksd[2384]: Mounted /dev/sdj1 at /media/tenki/9D0C-D7BC on behalf of uid 1000


連接SATA-USB轉接卡(Mukii TiP-Q120U3Si)時不但無法運作, 介面卡也無法再重新連接任何裝置

kernel: [ 74.892096] usb 9-4: new high-speed USB device number 2 using xhci_hcd
kernel: [ 79.892072] xhci_hcd 0000:02:00.0: Timeout while waiting for address device command
kernel: [ 79.896064] xhci_hcd 0000:02:00.0: Stopped the command ring failed, maybe the host is dead
kernel: [ 79.896064] xhci_hcd 0000:02:00.0: Host not halted after 16000 microseconds.
kernel: [ 79.896064] xhci_hcd 0000:02:00.0: Abort command ring failed
kernel: [ 92.584623] xhci_hcd 0000:02:00.0: HC died; cleaning up
kernel: [ 92.585570] [sched_delayed] sched: RT throttling activated
kernel: [ 97.788075] xhci_hcd 0000:02:00.0: Timeout while waiting for address device command
kernel: [ 97.788080] xhci_hcd 0000:02:00.0: Abort the command ring, but the xHCI is dead.
kernel: [ 97.992069] usb 9-4: device not accepting address 2, error -108
kernel: [ 102.992032] xhci_hcd 0000:02:00.0: Timeout while waiting for a slot
kernel: [ 102.992038] xhci_hcd 0000:02:00.0: Abort the command ring, but the xHCI is dead.
kernel: [ 107.992045] xhci_hcd 0000:02:00.0: Timeout while waiting for a slot
kernel: [ 107.992051] xhci_hcd 0000:02:00.0: Abort the command ring, but the xHCI is dead.
kernel: [ 112.992077] xhci_hcd 0000:02:00.0: Timeout while waiting for a slot
kernel: [ 112.992082] xhci_hcd 0000:02:00.0: Abort the command ring, but the xHCI is dead.


這張轉接卡在Windows上是運作正常的
請問各位這是否是相容性的問題?

我的os是14.04

update
剛剛google了一下
這問題是不是一個還沒解的bug?
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/994248

2014/5/6 7:56
應用擴展 工具箱
回覆: USB3.0無法正確連接外接硬碟裝置
會員二級
註冊日期:
2006/12/2 19:03
所屬群組:
已註冊使用者
等級: 8
HP : 0 / 186
MP : 30 / 6514
EXP: 46
離線


今天再去試試這顆轉接器...發現如果是開機前先連接好那這顆硬碟就可以使用...
可是也不能熱插拔了, 我還刻意的只換硬碟不拔轉接器
系統也只能辨識換上去的硬碟, 接著還是 timing out command, waited 30s
除非我重開機了...

而且去做一下速度測試, 不管新舊硬碟速度居然都一樣不到40M, usb3.0下不該這麼差

請問有人知道原因是什麼, 有辦法自行解決嗎? 謝謝 Q_Q

2014/5/10 11:55
應用擴展 工具箱
我也受此問題困擾
會員一級
註冊日期:
2015/2/10 13:26
所屬群組:
已註冊使用者
等級: 1
HP : 0 / 21
MP : 3 / 238
EXP: 86
離線
我很久以前就有發現這個問題了,我這幾個月以來Google只能確認Linux是最早支援USB 3.0這樣的相關描述,但我實際上遇到的是Linux對USB 3.0支援相當的有問題,其實不管用什麼裝置都會有問題,光碟機、鍵盤都一樣,只是你連接的裝置傳輸量越少問題越不明顯,我用的是Debian,如果Ubuntu最新的發行版還有這個問題,看來也許跟Debian系列略有關聯,但這個問題在Scientific Linux也同樣遇到,神奇的是CentOS就沒有問題,可見這兩者核心並沒有完全相同,我目前唯一的解法是改用CentOS,我認為這是核心技術問題,我在想可能跟USB 3.0的專利技術授權有關,但我不知道如何修好它,與你一起期待正解。

2015/2/10 16:37
應用擴展 工具箱


 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.