apt-get upgrade 遇到問題 [論壇 - 站務公告]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊



apt-get upgrade 遇到問題
會員一級
註冊日期:
2012/10/10 11:05
所屬群組:
已註冊使用者
等級: 1
HP : 0 / 21
MP : 3 / 483
EXP: 86
離線
各位先進大家好


1)在upgrade的時候遇到下列問題
*****************************************

正在讀取套件清單... 完成
正在重建相依關係
正在讀取狀態資料... 完成
您也許得執行 'apt-get -f install' 以修正這些問題。
下列的套件有未滿足的相依關係:
libgnuradio-osmosdr0.0.0 : 相依關係: librtlsdr0 但它卻尚未安裝
E: 未能滿足相依關係。試試 -f 選項。


2)根據系統建議使用-f 選項也無法解決
*****************************************

正在讀取套件清單... 完成
正在重建相依關係
正在讀取狀態資料... 完成
正在修正相依關係... 完成
以下套件為自動安裝,並且已經無用:
libgnuradio-audio3.7.2.1 librtlsdr-bin libgnuradio-atsc3.7.2.1 libgnuradio-trellis3.7.2.1 libgnuradio-channels3.7.2.1 libgnuradio-osmosdr-apps python-reportlab libdbus-1-3:i386
language-pack-kde-zh-hans-base libgnuradio-runtime3.7.2.1 libgnuradio-uhd3.7.2.1 libgnuradio-pmt3.7.2.1 libgnuradio-pager3.7.2.1 firefox-locale-zh-hans python-renderpm libboost-test1.48.0
libgnuradio-fec3.7.2.1 nvidia-settings-304 nvidia-settings-319 libgnuradio-fft3.7.2.1 libgnuradio-osmosdr librtlsdr libgnuradio-fcdproplus libgnuradio-analog3.7.2.1 libgnuradio-vocoder3.7.2.1
language-pack-kde-en kde-l10n-engb libgnuradio-filter3.7.2.1 libgnuradio-video-sdl3.7.2.1 libgnuradio-wxgui3.7.2.1 language-pack-kde-zh-hant-base libgnuradio-wavelet3.7.2.1 language-pack-zh-hans-base
libgnuradio-comedi3.7.2.1 libart-2.0-2 kde-l10n-zhcn language-pack-zh-hans language-pack-kde-zh-hans language-pack-kde-zh-hant libgnuradio-qtgui3.7.2.1 libgnuradio-blocks3.7.2.1 kde-l10n-zhtw
language-pack-kde-en-base libgnuradio-digital3.7.2.1 libgnuradio-fcd3.7.2.1 libboost-regex1.48.0 libssl1.0.0:i386 python-reportlab-accel libgnuradio-noaa3.7.2.1
使用 'apt-get autoremove' 來將其移除。
下列的額外套件將被安裝:
librtlsdr0
下列【新】套件將會被安裝:
librtlsdr0
升級 0 個,新安裝 1 個,移除 0 個,有 286 個未被升級。
2 個沒有完整得安裝或移除。
需要下載 0 B/35.5 kB 的套件檔。
此操作完成之後,會多佔用 140 kB 的磁碟空間。
是否繼續進行 [Y/n]?y
(正在讀取資料庫 ... 目前共安裝了 831481 個檔案和目錄。)
正在解開 librtlsdr0 (從 .../librtlsdr0_0.5.3-gqrx~precise1_amd64.deb)...
dpkg:在處理 /var/cache/apt/archives/librtlsdr0_0.5.3-gqrx~precise1_amd64.deb (--unpack) 時發生錯誤:
正要取代 '/usr/lib/x86_64-linux-gnu/librtlsdr.so.0',它也是套件 librtlsdr 0.5.1+1git20131118-aced2dbd-gqrx~precise1 的檔案
在處理時有錯誤發生:
/var/cache/apt/archives/librtlsdr0_0.5.3-gqrx~precise1_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)


3)嘗試移除問題的軟體,卻仍然失敗
*****************************************

sudo apt-get remove libgnuradio-osmosdr0.0.0
正在讀取套件清單... 完成
正在重建相依關係
正在讀取狀態資料... 完成
您也許得執行 'apt-get -f install' 以修正這些問題:
下列的套件有未滿足的相依關係:
gqrx : 相依關係: libgnuradio-osmosdr0.0.0 但它卻將不會被安裝
E: 未能滿足相依關係。請試著不指定套件來執行 'apt-get -f install'(或採取其它的解決方案)。


4)請問上述問題是否有解決的方法
*****************************************

謝謝

謝謝指導

2014/8/9 10:33
應用擴展 工具箱


 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.