更新出問題 [論壇 - Ubuntu 與 LXDE]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊



更新出問題
會員四級
註冊日期:
2010/10/28 17:23
來自 台灣-台南市
所屬群組:
已註冊使用者
等級: 19
HP : 0 / 459
MP : 145 / 8930
EXP: 36
離線
這幾天在進行系統更新時,出現問題:
$ sudo apt-get upgrade 正在讀取套件清單... 完成 正在重建相依關係 正在讀取狀態資料... 完成 籌備升級中... 完成 下列套件將會被升級: lxsession-default-apps 升級 1 個,新安裝 0 個,移除 0 個,有 0 個未被升級。 需要下載 46.3 kB 的套件檔。 此操作完成之後,會多佔用 9,216 B 的磁碟空間。 Do you want to continue? [Y/n] y 下載:1 http://ppa.launchpad.net/lubuntu-dev/lubuntu-daily/ubuntu/ trusty/main lxsession-default-apps amd64 0.5.0+bzr773+201410160048~ubuntu14.04.1 [46.3 kB] 取得 46.3 kB 用了 1秒 (32.5 kB/s) (讀取資料庫 ... 目前共安裝了 218743 個檔案和目錄。) 準備解開 .../lxsession-default-apps_0.5.0+bzr773+201410160048~ubuntu14.04.1_amd64.deb ... Unpacking lxsession-default-apps (0.5.0+bzr773+201410160048~ubuntu14.04.1) over (0.5.0+bzr765+201410142000~ubuntu14.04.1) ... dpkg: error processing archive /var/cache/apt/archives/lxsession-default-apps_0.5.0+bzr773+201410160048~ubuntu14.04.1_amd64.deb (--unpack): 正要取代 '/usr/share/man/man1/lxsession-default-app.1.gz',它也是套件 lxsession 0.5.0+bzr773+201410160048~ubuntu14.04.1 的檔案 Processing triggers for man-db (2.6.7.1-1ubuntu1) ... 處理時發生錯誤: /var/cache/apt/archives/lxsession-default-apps_0.5.0+bzr773+201410160048~ubuntu14.04.1_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1)

其它的更新都順利安裝完畢,就只有它沒辦法。請問各位高手這是什麼問題? 該如何解決? 謝謝!

2014/10/18 3:45
lubuntu 15.10 (AMD64)
ASUS K53BR筆電
RAM: 1.5GB
應用擴展 工具箱
回覆: 更新出問題
會員五級
註冊日期:
2012/4/22 10:50
所屬群組:
已註冊使用者
等級: 31
HP : 152 / 762
MP : 443 / 11516
EXP: 48
離線
reppk 寫到:
這幾天在進行系統更新時,出現問題:
$ sudo apt-get upgrade 正在讀取套件清單... 完成 正在重建相依關係 正在讀取狀態資料... 完成 籌備升級中... 完成 下列套件將會被升級: lxsession-default-apps 升級 1 個,新安裝 0 個,移除 0 個,有 0 個未被升級。 需要下載 46.3 kB 的套件檔。 此操作完成之後,會多佔用 9,216 B 的磁碟空間。 Do you want to continue? [Y/n] y 下載:1 http://ppa.launchpad.net/lubuntu-dev/lubuntu-daily/ubuntu/ trusty/main lxsession-default-apps amd64 0.5.0+bzr773+201410160048~ubuntu14.04.1 [46.3 kB] 取得 46.3 kB 用了 1秒 (32.5 kB/s) (讀取資料庫 ... 目前共安裝了 218743 個檔案和目錄。) 準備解開 .../lxsession-default-apps_0.5.0+bzr773+201410160048~ubuntu14.04.1_amd64.deb ... Unpacking lxsession-default-apps (0.5.0+bzr773+201410160048~ubuntu14.04.1) over (0.5.0+bzr765+201410142000~ubuntu14.04.1) ... dpkg: error processing archive /var/cache/apt/archives/lxsession-default-apps_0.5.0+bzr773+201410160048~ubuntu14.04.1_amd64.deb (--unpack): 正要取代 '/usr/share/man/man1/lxsession-default-app.1.gz',它也是套件 lxsession 0.5.0+bzr773+201410160048~ubuntu14.04.1 的檔案 Processing triggers for man-db (2.6.7.1-1ubuntu1) ... 處理時發生錯誤: /var/cache/apt/archives/lxsession-default-apps_0.5.0+bzr773+201410160048~ubuntu14.04.1_amd64.deb E: Sub-process /usr/bin/dpkg returned an error code (1)

其它的更新都順利安裝完畢,就只有它沒辦法。請問各位高手這是什麼問題? 該如何解決? 謝謝!



把「/var/cache/apt/archives/lxsession-default-apps_0.5.0+bzr773+201410160048~ubuntu14.04.1_amd64.deb」這個檔刪除。

然後在執行下面的指令

$ sudo apt-get update

$ sudo apt-get upgrade

或是一行

$ sudo apt-get update && sudo apt-get upgrade -y # -y 表示不會出現確認訊息,會替你回答「YES」

以上是提供你解決的方案。

以下只是討論為什麼請你這麼做。
我剛剛去「這一頁」下載「lxsession-default-apps_0.5.0+bzr773+201410160048~ubuntu14.04.1_amd64.deb」,然後解開,可以解開。

從你貼出來的訊息中猜測,你下載「lxsession-default-apps_0.5.0+bzr773+201410160048~ubuntu14.04.1_amd64.deb」這個檔不完全或是有未知的問題,導致無法解開,所以才請你用上面的方法,重新下載試試看。

$ wget -c http://ppa.launchpad.net/lubuntu-dev/lubuntu-daily/ubuntu/pool/main/l/lxsession/lxsession-default-apps_0.5.0+bzr773+201410160048~ubuntu14.04.1_amd64.deb

$ dpkg -x lxsession-default-apps_0.5.0+bzr773+201410160048~ubuntu14.04.1_amd64.deb lxsession-default-apps

另外你也可以執行

$ sudo apt-get clean

把「/var/cache/apt/archives」把這個資料夾裡的deb檔完全清掉。


另外有個疑問,是「Lubuntu」預設會加這個「https://launchpad.net/~lubuntu-dev」「PPA」套件庫嗎?
因為看那個網址「http://ppa.launchpad.net/lubuntu-dev/lubuntu-daily/ubuntu/pool/main/l/lxsession/lxsession-default-apps_0.5.0+bzr773+201410160048~ubuntu14.04.1_amd64.deb」在「lubuntu-dev/lubuntu-daily」有「dev」和「daily」就會讓我
聯想到「unstable」的字樣,不過我不確定,只是有這樣的聯想 :p

2014/10/18 7:38
應用擴展 工具箱
回覆: 更新出問題
會員四級
註冊日期:
2010/10/28 17:23
來自 台灣-台南市
所屬群組:
已註冊使用者
等級: 19
HP : 0 / 459
MP : 145 / 8930
EXP: 36
離線
samwhelp 寫到:
以下只是討論為什麼請你這麼做。
我剛剛去「這一頁」下載「lxsession-default-apps_0.5.0+bzr773+201410160048~ubuntu14.04.1_amd64.deb」,然後解開,可以解開。

從你貼出來的訊息中猜測,你下載「lxsession-default-apps_0.5.0+bzr773+201410160048~ubuntu14.04.1_amd64.deb」這個檔不完全或是有未知的問題,導致無法解開,所以才請你用上面的方法,重新下載試試看。

$ wget -c http://ppa.launchpad.net/lubuntu-dev/lubuntu-daily/ubuntu/pool/main/l/lxsession/lxsession-default-apps_0.5.0+bzr773+201410160048~ubuntu14.04.1_amd64.deb
$ dpkg -x lxsession-default-apps_0.5.0+bzr773+201410160048~ubuntu14.04.1_amd64.deb lxsession-default-apps

另外你也可以執行
$ sudo apt-get clean
把「/var/cache/apt/archives」把這個資料夾裡的deb檔完全清掉。

有趣的事情發生了!

該套件已經更新至0.5.0+bzr776,但我依然無法安裝。一氣之下,我手動下載了0.5.0+bzr773與0.5.0+bzr776兩個套件,776手動一樣裝不上去,但是昨天不行的773卻可以了。問題發生原因依舊成謎……


另外有個疑問,是「Lubuntu」預設會加這個「https://launchpad.net/~lubuntu-dev」「PPA」套件庫嗎?
因為看那個網址「http://ppa.launchpad.net/lubuntu-dev/lubuntu-daily/ubuntu/pool/main/l/lxsession/lxsession-default-apps_0.5.0+bzr773+201410160048~ubuntu14.04.1_amd64.deb」在「lubuntu-dev/lubuntu-daily」有「dev」和「daily」就會讓我
聯想到「unstable」的字樣,不過我不確定,只是有這樣的聯想 :p

您想的沒錯,這是自己加的PPA。應該是之前想試LxQt時裝的,不過還沒時間搞。XDDD

2014/10/19 1:56
lubuntu 15.10 (AMD64)
ASUS K53BR筆電
RAM: 1.5GB
應用擴展 工具箱
回覆: 更新出問題
會員五級
註冊日期:
2012/4/22 10:50
所屬群組:
已註冊使用者
等級: 31
HP : 152 / 762
MP : 443 / 11516
EXP: 48
離線
reppk 寫到:

有趣的事情發生了!

該套件已經更新至0.5.0+bzr776,但我依然無法安裝。一氣之下,我手動下載了0.5.0+bzr773與0.5.0+bzr776兩個套件,776手動一樣裝不上去,但是昨天不行的773卻可以了。問題發生原因依舊成謎……


猜測有可能開發團隊,在測試他們包好的deb。



reppk 寫到:
samwhelp 寫到:
另外有個疑問,是「Lubuntu」預設會加這個「https://launchpad.net/~lubuntu-dev」「PPA」套件庫嗎?
因為看那個網址「http://ppa.launchpad.net/lubuntu-dev/lubuntu-daily/ubuntu/pool/main/l/lxsession/lxsession-default-apps_0.5.0+bzr773+201410160048~ubuntu14.04.1_amd64.deb」在「lubuntu-dev/lubuntu-daily」有「dev」和「daily」就會讓我
聯想到「unstable」的字樣,不過我不確定,只是有這樣的聯想 :p

您想的沒錯,這是自己加的PPA。應該是之前想試LxQt時裝的,不過還沒時間搞。XDDD



若你只是要測試「LXQt」,安裝完「LXQt」。
你可以編輯「/etc/apt/sources.list.d/lubuntu-dev-lubuntu-daily-trusty.list」

把下面兩行註解,如下所示
# deb http://ppa.launchpad.net/lubuntu-dev/lubuntu-daily/ubuntu trusty main
# deb-src http://ppa.launchpad.net/lubuntu-dev/lubuntu-daily/ubuntu trusty main

這樣你執行下面的指令,就不會到更新哪個ppa提供的相關資訊了
$ sudo apt-get update

2014/10/19 10:31
應用擴展 工具箱
回覆: 更新出問題
會員一級
註冊日期:
2016/6/28 23:47
所屬群組:
已註冊使用者
等級: 2
HP : 0 / 40
MP : 5 / 117
EXP: 62
離線
升級的項目可能有衝突!所以這種更新風險很高!

2016/11/22 13:29
應用擴展 工具箱


 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.