「已解決」vim 提示信息亂碼 [論壇 - Ubuntu 與中文]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊



「已解決」vim 提示信息亂碼
會員一級
註冊日期:
2014/12/25 0:49
所屬群組:
已註冊使用者
等級: 1
HP : 0 / 2
MP : 1 / 37
EXP: 10
離線
我使用的VIM在左下角的提示信息亂碼.
請問有人知道怎樣可以解決這問題嗎?

我曾上網爬了很多文都是說在/ETC/VIM/VIMRC 中加入
source $VIMRUNTIME/delmenu.vim
language messages zh_TW.utf-8

但都沒有反應的...請問有其他人試過嗎?

附件:



jpg  problem.jpg (66.65 KB)
41474_549af59daabe5.jpg 1920X1080 px

2014/12/25 1:12
應用擴展 工具箱
回覆: vim 提示信息亂碼
會員五級
註冊日期:
2008/10/7 21:19
所屬群組:
已註冊使用者
等級: 36
HP : 0 / 896
MP : 661 / 28649
EXP: 85
離線
不只是左下角,畫面中央的文字有些也是消失的
你用的Linux和終端機版本是?

2014/12/25 1:39
I′m UGP
應用擴展 工具箱
回覆: vim 提示信息亂碼
會員一級
註冊日期:
2014/12/25 0:49
所屬群組:
已註冊使用者
等級: 1
HP : 0 / 2
MP : 1 / 37
EXP: 10
離線
我用的是Ubuntu 14.04.1 LTS再加上xfce 4.1,用的是X終端機輸入顯示做XTerm(297)

2014/12/25 22:27
應用擴展 工具箱
回覆: vim 提示信息亂碼
會員五級
註冊日期:
2008/10/7 21:19
所屬群組:
已註冊使用者
等級: 36
HP : 0 / 896
MP : 661 / 28649
EXP: 85
離線
個人的Ubuntu 12.04上開xterm + vim也是看到一樣的畫面,應該是終端機的問題
搜尋到xterm上正確顯示中文字教學,沒有試過能不能正常
http://linwenjang.blogspot.tw/2010/03/xterm.html

如果沒有一定要用xterm的話,可以用xfce帶的xfce4-terminal終端機

2014/12/26 18:34
I′m UGP
應用擴展 工具箱
回覆: vim 提示信息亂碼
會員五級
註冊日期:
2009/10/16 8:57
所屬群組:
已註冊使用者
等級: 22
HP : 0 / 541
MP : 204 / 15701
EXP: 67
離線
我也認為這是終端機的問題。目前我未使用 xterm,以前有用過,也是要經過中文設定的。

其實判別的方式很簡單,打開你的終端機,輸入些中文,或是貼上一些中文,看看呈現的效果如何,就了解中文設定上有無問題。

在以下有篇參考文章,供樓主參考一下:
http://tuhaihe.com/2013/10/16/xterm-discover.html

另外想請教一下,為何要用 xterm 呢?

2014/12/26 18:46
同源一体、感同身受、樂於分享、教學相長!
寬廣的心, 世界不會小 ^_^
CreMaker 的生活網誌
應用擴展 工具箱
回覆: vim 提示信息亂碼
會員一級
註冊日期:
2014/12/25 0:49
所屬群組:
已註冊使用者
等級: 1
HP : 0 / 2
MP : 1 / 37
EXP: 10
離線
謝謝~果然換了終端機就可以....

2014/12/30 0:35
應用擴展 工具箱
回覆: vim 提示信息亂碼
會員五級
註冊日期:
2012/4/22 10:50
所屬群組:
已註冊使用者
等級: 34
HP : 169 / 845
MP : 571 / 18289
EXP: 83
離線
beginner1234 寫到:
謝謝~果然換了終端機就可以....


除了上面提的「xfce4-terminal」,

沒有什麼特別考量的話,「gnome-terminal」和「konsole」這兩個也可以參考使用。


2014/12/30 0:44
應用擴展 工具箱


 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.