關於steam遊戲--Portal 2 無法顯示中文字型 [論壇 - Ubuntu 影音及遊戲]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊



關於steam遊戲--Portal 2 無法顯示中文字型
會員一級
註冊日期:
2016/10/27 21:24
所屬群組:
已註冊使用者
等級: 2
HP : 0 / 28
MP : 3 / 19
EXP: 12
離線
如題 看圖

我是用ubuntu 16.04 LTS

有沒有 哪一位有玩steam的大大可以指點迷津的

英文可以顯示 但中文就不行了

附件:



jpg  2016-11-29 23-45-52 的螢幕擷圖.jpg (892.22 KB)
47682_583dab9fd7483.jpg 1920X1080 px

2016/11/30 0:24
應用擴展 工具箱
回覆: 關於steam遊戲--Portal 2 無法顯示中文字型
管理員
註冊日期:
2011/3/11 6:32
所屬群組:
討論區管理群
等級: 44
HP : 433 / 1083
MP : 1086 / 18600
EXP: 35
離線
剛好我也有在玩 Portal 2

家目錄中新增一個叫作 .fonts.conf 的純文字文件家目錄底下的 .config/fontconfig 資料夾(如果沒有請自行建立)中新增一個叫作 fonts.conf 的純文字文件檔案,內容加入:

<?xml version='1.0'?>
<!DOCTYPE fontconfig SYSTEM 'fonts.dtd'>
<fontconfig>
 <match target="pattern">
  <test name="family" qual="any">
   <string>Nimbus Sans L</string>
  </test>
  <edit name="family" mode="assign" binding="same">
<!-- 暫時迴避目前預設使用的 Noto Sans CJK TC 中文字型顯示異常的已知問題,如要使用系統預設字型請改註解第二個 string 元素
    <string>sans-serif</string> -->
    <string>文泉驛微米黑</string>
  </edit>
 </match>
</fontconfig>


然後安裝文泉驛微米黑字型(軟體包名稱:fonts-wqy-microhei)即可

感謝 Jiazheng 幫我找到解法!

附件:



jpg  20161201015651_1.jpg (193.07 KB)
24266_583f1310356da.jpg 1920X1080 px

2016/12/1 1:57
本篇發表文章以「創用CC BY 3.0 或更新之台灣地區版本」授權條款釋出,如何使用敬請參考
 Creative Commons — 姓名標示 3.0 台灣 — CC BY 3.0 TW
 http://creativecommons.org/licenses/by/3.0/tw/

「你不懂的東西就不要亂講,被懂得人看破手腳就算了,騙不懂的人誤導別人,還要別人把你當成大師,這就真的是說不過去了。」
 by Allen Own
 出處 http://www.plurk.com/p/i4uogm

自由知識創作平台介紹
 https://docs.google.com/document/d/1MGG6lW_0qCgH4U785R-IwSc_INdoBGej1l-JxiA4gPE
如何建立新的自由知識創作平台文件
 https://docs.google.com/document/d/11NdzOW2lGYksfyQIcPMPye5tlmj1J0QTkgPTmQvIvKA
應用擴展 工具箱
回覆: 關於steam遊戲--Portal 2 無法顯示中文字型
會員五級
註冊日期:
2012/4/22 10:50
所屬群組:
已註冊使用者
等級: 30
HP : 146 / 732
MP : 403 / 10181
EXP: 30
離線
V字龍 寫到:
...略...

家目錄中新增一個叫作 .fonts.conf 的純文字文件,內容加入:

...略...




## 題外話

### 前提

* 以下測試環境基於「Xubuntu 16.04 (64位元) 英文界面」。
* 以下非關討論樓主原本要問的,只是討論設定檔路徑。

### 說明

關於「~/.fonts.conf」雖然目前還是可以使用,
但是建議將這個路徑改到「~/.config/fontconfig/fonts.conf」。


可以參考我最近紀錄在「這頁」的幾篇分析。

或是執行下面指令,直接觀看「/etc/fonts/conf.d/50-user.conf」內容,就可以看到一些端倪了。



$ cat /etc/fonts/conf.d/50-user.conf



顯示


<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<fontconfig>
	<!--
	    Load per-user customization files where stored on XDG Base Directory
	    specification compliant places. it should be usually:
	      $HOME/.config/fontconfig/conf.d
	      $HOME/.config/fontconfig/fonts.conf
	-->
	<include ignore_missing="yes" prefix="xdg">fontconfig/conf.d</include>
	<include ignore_missing="yes" prefix="xdg">fontconfig/fonts.conf</include>
	<!-- the following elements will be removed in the future -->
	<include ignore_missing="yes" deprecated="yes">~/.fonts.conf.d</include>
	<include ignore_missing="yes" deprecated="yes">~/.fonts.conf</include>
</fontconfig>




最下面有一行,其中一個屬性「deprecated="yes"」


	<include ignore_missing="yes" deprecated="yes">~/.fonts.conf</include>




或是執行「$ man fonts-conf」閱讀「Manpage」,
可以輸入「/deprecated」,按下「Enter」找尋「deprecated」,
「持續按n」可以持續找下一個「deprecated」所在,
可以找到一段說明如下



FILES

...略...

$XDG_CONFIG_HOME/fontconfig/fonts.conf and ~/.fonts.conf is the
conventional location for per-user font configuration, although the
actual location is specified in the global fonts.conf file. please note
that ~/.fonts.conf is deprecated now. it will not be read by default in
the future version.



以上提供參考


2016/12/1 12:55
應用擴展 工具箱
回覆: 關於steam遊戲--Portal 2 無法顯示中文字型
管理員
註冊日期:
2011/3/11 6:32
所屬群組:
討論區管理群
等級: 44
HP : 433 / 1083
MP : 1086 / 18600
EXP: 35
離線
samwhelp 寫到:
關於「~/.fonts.conf」雖然目前還是可以使用,
但是建議將這個路徑改到「~/.config/fontconfig/fonts.conf」。

正確,感謝指正!

2016/12/2 4:21
本篇發表文章以「創用CC BY 3.0 或更新之台灣地區版本」授權條款釋出,如何使用敬請參考
 Creative Commons — 姓名標示 3.0 台灣 — CC BY 3.0 TW
 http://creativecommons.org/licenses/by/3.0/tw/

「你不懂的東西就不要亂講,被懂得人看破手腳就算了,騙不懂的人誤導別人,還要別人把你當成大師,這就真的是說不過去了。」
 by Allen Own
 出處 http://www.plurk.com/p/i4uogm

自由知識創作平台介紹
 https://docs.google.com/document/d/1MGG6lW_0qCgH4U785R-IwSc_INdoBGej1l-JxiA4gPE
如何建立新的自由知識創作平台文件
 https://docs.google.com/document/d/11NdzOW2lGYksfyQIcPMPye5tlmj1J0QTkgPTmQvIvKA
應用擴展 工具箱
回覆: 關於steam遊戲--Portal 2 無法顯示中文字型
會員一級
註冊日期:
2016/10/27 21:24
所屬群組:
已註冊使用者
等級: 2
HP : 0 / 28
MP : 3 / 19
EXP: 12
離線
感謝 已解決!!

2016/12/10 12:20
應用擴展 工具箱
回覆: 關於steam遊戲--Portal 2 無法顯示中文字型
會員二級
註冊日期:
2011/10/7 0:22
所屬群組:
已註冊使用者
等級: 5
HP : 0 / 118
MP : 16 / 1839
EXP: 75
離線
趁著冬季特賣,也購入了傳送門2;依照這個討論串設定,發現如果在Ubuntu 14.04的環境下,設定檔的位置擺在家目錄下如:
~/.fonts.conf
才會起作用。

題外話:

Steam Controller無法隨插即用讓人小失望,不想探究太多懶人般跟著這個連結:
How do I get a Steam Controller working?做以下設定才正常運作:

創建設定檔
/lib/udev/rules.d/99-steam-controller-perms.rules
內容如下:

# This rule is needed for basic functionality of the controller in Steam and keyboard/mouse emulation
SUBSYSTEM=="usb", ATTRS{idVendor}=="28de", MODE="0666"

# This rule is necessary for gamepad emulation; make sure you replace 'pgriffais' with a group
# that the user that runs Steam belongs to
KERNEL=="uinput", MODE="0660", GROUP="pgriffais", OPTIONS+="static_node=uinput"

# Valve HID devices over USB hidraw
KERNEL=="hidraw*", ATTRS{idVendor}=="28de", MODE="0666"

# Valve HID devices over bluetooth hidraw
KERNEL=="hidraw*", KERNELS=="*28DE:*", MODE="0666"

# DualShock 4 over USB hidraw
KERNEL=="hidraw*", ATTRS{idVendor}=="054c", ATTRS{idProduct}=="05c4", MODE="0666"

# DualShock 4 wireless adapter over USB hidraw
KERNEL=="hidraw*", ATTRS{idVendor}=="054c", ATTRS{idProduct}=="0ba0", MODE="0666"

# DualShock 4 Slim over USB hidraw
KERNEL=="hidraw*", ATTRS{idVendor}=="054c", ATTRS{idProduct}=="09cc", MODE="0666"

# DualShock 4 over bluetooth hidraw
KERNEL=="hidraw*", KERNELS=="*054C:05C4*", MODE="0666"

# DualShock 4 Slim over bluetooth hidraw
KERNEL=="hidraw*", KERNELS=="*054C:09CC*", MODE="0666"



然後安裝:
sudo apt-get install python3-autopilot


裝完之後,Steam就自動偵測到手把的存在了。

2016/12/28 20:55
應用擴展 工具箱


 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.