如何設定基於 Ghostscript 的印表機,例如 Epson EPL 6200L [論壇 - 新手村]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊



如何設定基於 Ghostscript 的印表機,例如 Epson EPL 6200L
會員三級
註冊日期:
2007/7/3 16:11
所屬群組:
已註冊使用者
等級: 12
HP : 0 / 297
MP : 64 / 13246
EXP: 90
離線
辦公室有一台老舊的 Epson EPL 6200L 雷射印表機,搭配著老舊的32位元電腦(使用 Ubuntu 14.04 32bit) 用到現在,要換新的64位元電腦,想用 Ubuntu 20.04或 22.04 64,但印表機因當初買了太多碳粉匣還不能換。
這台 Epson EPL 6200L 根據這個網站所述
https://openprinting.org/driver/epsonepl
它是屬於 IJS-based, Ghostscript 而非標準的 Post script 印表機,而官網上也沒有專屬 Linux 驅動程式,這個網站有一篇問答號稱可以解決 Ubuntu 16.04~18.04的問題:
https://askubuntu.com/questions/943360/epson-epl-6200l-doesnt-print-the-test-page-on-ubuntu-16-04
可是我要用的是 Ubuntu 20.04 ,若要編譯不知是否行得通,會不會和其他套件相衝,如今看到 https://snapcraft.io/ghostscript-printer-app有一個APP 叫 ghostscript-printer-app 官宣上說:
"It supports ~5000 different printer models, mainly with drivers from the well-known Ghostscrip..."
不曉得它是不是就是許多 Ghostscript 的通用程式,請各位高手指點一下要如何設定才能列印 Epson EPL 6200L 等基於 IJS & Ghostscript 的印表機

8/7 12:02:21
應用擴展 工具箱
回覆: 如何設定基於 Ghostscript 的印表機,例如 Epson EPL 6200L
會員五級
註冊日期:
2012/4/22 10:50
所屬群組:
已註冊使用者
等級: 36
HP : 177 / 885
MP : 641 / 26985
EXP: 42
在線
我沒有印表機,對於「如何在Ubuntu設定列印」,也沒有概念,

只是剛剛稍微測試編譯您提到的參考連結當中的「epsoneplijs-0.4.1.tgz」。

以下簡易紀錄編譯步驟,提供您參考。

我測試的環境是「Ubuntu 22.04 Desktop」。

================================================================================

## 安裝 build-essential

執行下面指令,安裝「build-essential


sudo apt-get install build-essential



================================================================================

根據您提供的參考連結

* https://askubuntu.com/questions/943360/epson-epl-6200l-doesnt-print-the-test-page-on-ubuntu-16-04
* https://sourceforge.net/projects/epsonepl/files/epsonepl/0.4.1/epsoneplijs-0.4.1.tgz/download
* https://sourceforge.net/projects/epsonepl/files/epsonepl/0.4.1/

================================================================================

## 下載 epsoneplijs-0.4.1.tgz

執行下面指令,下載「epsoneplijs-0.4.1.tgz


wget -c 'https://sourceforge.net/projects/epsonepl/files/epsonepl/0.4.1/epsoneplijs-0.4.1.tgz/download' -O 'epsoneplijs-0.4.1.tgz'



會下載一個檔案「epsoneplijs-0.4.1.tgz」

================================================================================

## 解開 epsoneplijs-0.4.1.tgz

執行下面指令,解開「epsoneplijs-0.4.1.tgz」


tar xf epsoneplijs-0.4.1.tgz



就會解開到「epsoneplijs-0.4.1」這個資料夾

================================================================================

## 切換到「epsoneplijs-0.4.1」這個資料夾

執行下面指令,切換到「epsoneplijs-0.4.1」這個資料夾


cd epsoneplijs-0.4.1



================================================================================

## configure

執行


./configure



若要知道「configure」有那些參數可以下,可以執行「./configure -h」觀看。

================================================================================

## 編譯

執行下面指令,進行編譯


make



================================================================================

## 安裝

執行下面指令,進行安裝


sudo make install



顯示


/usr/bin/install -c ijs_server_epsonepl -c /usr/local/bin/ijs_server_epsonepl



基本上只有安裝一個檔案。

也就是安裝「ijs_server_epsonepl」這個檔案,到「/usr/local/bin/ijs_server_epsonepl」這個路徑。

================================================================================

## 移除

執行下面指令,進行移除


sudo make uninstall



顯示


rm -f /usr/local/bin/ijs_server_epsonepl



================================================================================

若要探索「make install」或「make uninstall」做了那些動作

可以執行下面指令


grep '^install' Makefile -A 5



顯示


install: all
	$(INSTALL) ijs_server_epsonepl$(EXE) -c $(bindir)/ijs_server_epsonepl$(EXE)

uninstall:
	$(RM) $(bindir)/ijs_server_epsonepl$(EXE)




================================================================================

另外「epsoneplijs-0.4.1.tgz」有提供四個「README」


ls -1 ./README*



顯示


./README
./README.FlowControl
./README.foomatic
./README.ijs



================================================================================

另外我在還沒有編譯前,執行下面指令,觀看「epsoneplijs-0.4.1」有那些檔案


tree epsoneplijs-0.4.1



顯示


epsoneplijs-0.4.1
├── apsfilter
│   └── epsonepl.apsfilter
├── ChangeLog
├── common.mak
├── configure
├── configure.in
├── cups
│   ├── 00_README
│   ├── contrib-Debian-3.0-1.eml
│   ├── contrib-Makdrake-9.0-5700L-1.eml
│   ├── contrib-Makdrake-9.0-5700L-2.eml
│   ├── contrib-SuSE-8.0-5700L-1.eml
│   ├── contrib-SuSE-8.0-5700L-2.eml
│   ├── Epson-EPL-5700L-epl5700l-cups.ppd.gz
│   ├── Epson-EPL-5700L-epl5700l.ppd.gz
│   ├── Epson-EPL-5700L-epl5700lusb-cups.ppd.gz
│   ├── Epson-EPL-5700L-epl5700lusb.ppd.gz
│   ├── Epson-EPL-5800L-epl5800l-cups.ppd.gz
│   ├── Epson-EPL-5800L-epl5800l.ppd.gz
│   ├── Epson-EPL-5900L-epl5900l-cups.ppd.gz
│   └── Epson-EPL-5900L-epl5900l.ppd.gz
├── epl_57interpret.c
├── epl_59interpret.c
├── epl_62interpret.c
├── epl_bid.h
├── epl_bid_replies.c
├── epl_bid_utils.c
├── epl_compress.c
├── epl_compress.h
├── epl_config.h
├── epl_docs
│   ├── epl-5700.c
│   ├── epl-5800.c
│   ├── epl5x00l.c
│   ├── epl-protocol.pdf
│   ├── message.eml
│   └── README.1st
├── epl_job_footer.c
├── epl_job.h
├── epl_job_header.c
├── epl_lowmem-gen.c
├── epl_lowmem_msg.h
├── epl_page_footer.c
├── epl_page_header.c
├── epl_poll.c
├── epl_print_stripe.c
├── epl_status.c
├── epl_test.ps
├── epl_test.sh
├── epl_time.c
├── epl_time.h
├── epl_utils_kusb.c
├── epl_utils_libieee1284.c
├── epl_utils_libusb.c
├── epl_utils_null.c
├── epl_write.c
├── epsoneplijs.spec
├── FAQ
├── foomatic
│   ├── driver
│   │   ├── epl5700l.xml
│   │   ├── epl5800l.xml
│   │   ├── epl5900l.xml
│   │   ├── epl6100l.xml
│   │   └── epl6200l.xml
│   ├── opt
│   │   ├── epsonepl-Density.xml
│   │   ├── epsonepl-Dpi.xml
│   │   ├── epsonepl-FlowControl.xml
│   │   ├── epsonepl-PageSize.xml
│   │   ├── epsonepl-Ritech.xml
│   │   └── epsonepl-TonerSave.xml
│   └── printer
│       ├── 312297.xml
│       ├── Epson-EPL-5800L.xml
│       ├── Epson-EPL-5900L.xml
│       ├── Epson-EPL-6100L.xml
│       └── Epson-EPL-6200L.xml
├── foomatic_PPDs
│   ├── Epson-EPL-5700L-epl5700l-cups.ppd.gz
│   ├── Epson-EPL-5800L-epl5800l-cups.ppd.gz
│   ├── Epson-EPL-5900L-epl5900l-cups.ppd.gz
│   ├── Epson-EPL-6100L-epl6100l-cups.ppd.gz
│   └── Epson-EPL-6200L-epl6200l-cups.ppd.gz
├── foomatic_scripts
│   ├── install_customfoomatic
│   ├── install_debian
│   ├── install_mandrake
│   ├── install_redhat8
│   └── install_redhat9
├── gs-wts.ps
├── ijs.c
├── ijs_client.c
├── ijs_client_example.c
├── ijs_client.h
├── ijs-config.in
├── ijs_exec_unix.c
├── ijs_exec_win.c
├── ijs.h
├── ijs_server.c
├── ijs_server_epsonepl.c
├── ijs_server_example.c
├── ijs_server.h
├── ijs_spec.pdf
├── ijs_spec.sgml
├── install-sh
├── libieee1284-0.2.11.tar.bz2
├── libusb-0.1.12.tar.gz
├── LIMITATIONS
├── low_mem_msg.xbm
├── Makefile
├── Makefile.in
├── ps2epl
├── ps2epl.pl
├── README
├── README.FlowControl
├── README.foomatic
├── README.ijs
├── state.eps
├── state.fig
├── test5700lusb.c
├── unistd_.h
├── unix.mak
└── windows.mak

9 directories, 115 files




================================================================================

若要研究打包成「Debian Package」。

可以參考另一個討論串回覆「#16 - 回覆: Ubuntu 22.04 LTS (Jammy Jellyfish) Released」。

================================================================================

以上簡易探索

提供參考


8/7 16:09:59
應用擴展 工具箱
回覆: 如何設定基於 Ghostscript 的印表機,例如 Epson EPL 6200L
會員五級
註冊日期:
2012/4/22 10:50
所屬群組:
已註冊使用者
等級: 36
HP : 177 / 885
MP : 641 / 26985
EXP: 42
在線
另外我從您提供的「參考連結」,看到一個關鍵字「cups

剛執行下面指令,簡易探索在我的系統安裝了那些相關的「Package」


dpkg -l '*cups*'



顯示



Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                      Version             Architecture Description
+++-=========================-===================-============-===================================================================
ii  bluez-cups                5.64-0ubuntu1       amd64        Bluetooth printer driver for CUPS
ii  cups                      2.4.1op1-1ubuntu4.1 amd64        Common UNIX Printing System(tm) - PPD/driver support, web interface
ii  cups-browsed              1.28.15-0ubuntu1    amd64        OpenPrinting CUPS Filters - cups-browsed
ii  cups-bsd                  2.4.1op1-1ubuntu4.1 amd64        Common UNIX Printing System(tm) - BSD commands
ii  cups-client               2.4.1op1-1ubuntu4.1 amd64        Common UNIX Printing System(tm) - client programs (SysV)
ii  cups-common               2.4.1op1-1ubuntu4.1 all          Common UNIX Printing System(tm) - common files
ii  cups-core-drivers         2.4.1op1-1ubuntu4.1 amd64        Common UNIX Printing System(tm) - driverless printing
ii  cups-daemon               2.4.1op1-1ubuntu4.1 amd64        Common UNIX Printing System(tm) - daemon
ii  cups-filters              1.28.15-0ubuntu1    amd64        OpenPrinting CUPS Filters - Main Package
ii  cups-filters-core-drivers 1.28.15-0ubuntu1    amd64        OpenPrinting CUPS Filters - Driverless printing
ii  cups-ipp-utils            2.4.1op1-1ubuntu4.1 amd64        Common UNIX Printing System(tm) - IPP developer/admin utilities
un  cups-pdf                  <none>              <none>       (no description available)
ii  cups-pk-helper            0.2.6-1ubuntu5      amd64        PolicyKit helper to configure cups with fine-grained privileges
ii  cups-ppdc                 2.4.1op1-1ubuntu4.1 amd64        Common UNIX Printing System(tm) - PPD manipulation utilities
ii  cups-server-common        2.4.1op1-1ubuntu4.1 all          Common UNIX Printing System(tm) - server common files
un  ghostscript-cups          <none>              <none>       (no description available)
un  hplip-cups                <none>              <none>       (no description available)
ii  libcups2:amd64            2.4.1op1-1ubuntu4.1 amd64        Common UNIX Printing System(tm) - Core library
ii  libcupsfilters1:amd64     1.28.15-0ubuntu1    amd64        OpenPrinting CUPS Filters - Shared library
ii  libcupsimage2:amd64       2.4.1op1-1ubuntu4.1 amd64        Common UNIX Printing System(tm) - Raster image library
ii  printer-driver-hpcups     3.21.12+dfsg0-1     amd64        HP Linux Printing and Imaging - CUPS Raster driver (hpcups)
un  python-cupshelpers        <none>              <none>       (no description available)
ii  python3-cups:amd64        2.0.1-5build1       amd64        Python3 bindings for CUPS
ii  python3-cupshelpers       1.5.16-0ubuntu3     all          Python utility modules around the CUPS printing system
un  python3.10-cups           <none>              <none>       (no description available)




* Package: cups / filelist
* $ man cups


## 關鍵字查尋

* Google Search: 「cups linux
* Google Search: 「cups ubuntu

其中可找到一篇還蠻多相關資訊的「參考文件」,也許可從這篇找到一些關鍵字,當作探索的起點。

8/7 16:47:54
應用擴展 工具箱


 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.