wine玩魔獸出現的問題 [論壇 - Ubuntu 與工具程式及軟體推薦]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊



wine玩魔獸出現的問題
會員一級
註冊日期:
2009/3/23 15:28
所屬群組:
已註冊使用者
等級: 1
HP : 0 / 5
MP : 1 / 197
EXP: 21
離線
請問各位大大,我現在用wine跑魔獸一進去畫面就變成全黑,只有下面有一小片銀色的霧狀顯示,但是可以聽到暴雪的音樂,不過我之前用7.10時用wine0.9.X可以正常執行,現在用8.10就不能安裝那個版本了,用較新的1.1X版卻出現這樣的問題,是wine版本的問題嗎?我應該如何解決,謝謝

2009/3/23 15:33
應用擴展 工具箱
sss
回覆: wine玩魔獸出現的問題
Anon:sss
或許可以試試看最新版的wine-doors輔助安裝

也可以不同版本wine並存啊,只要用先前那個可正常工作的wine去啟動遊戲應該就可以了。


1. 下載舊版wine.deb
2. 按右鍵解壓縮到任意處, 例如 ~/wines/wine-0.9.51


用這個方式可以依自己需要,用各種適合的版本 都不會衝到喔

例如用wine 0.9.51啟動ie4linux:

WINEPREFIX=~/.ies4linux /home/xxx/wines/wine-0.9.51/usr/bin/wine /xxx/xxx/xxx/iexplore.exe

Or

/home/xxx/wine-0.9.x/usr/bin/wine /xxx/xxx/xxx/wow.exe

2009/3/23 15:46 | ee583 373d2 f6ddc 2da4e
應用擴展 工具箱
回覆: wine玩魔獸出現的問題
會員三級
註冊日期:
2009/2/8 0:40
所屬群組:
已註冊使用者
等級: 12
HP : 0 / 283
MP : 59 / 10355
EXP: 35
離線
改用較舊版本看看,
有時新版有問題,舊版反而沒問題哦,
再者就是顯示卡的問題,N廠的問題較少,
A廠的我怎麼試都有問題=.=
到最後直接放棄......

2009/3/23 15:48
應用擴展 工具箱
回覆: wine玩魔獸出現的問題
會員一級
註冊日期:
2009/3/23 15:28
所屬群組:
已註冊使用者
等級: 1
HP : 0 / 5
MP : 1 / 197
EXP: 21
離線
之前可以正常模擬的那個版本是0.9.45,但是是for 7.04的,
8.10下他不讓我安裝,
顯示Error:Dependency is not satisfiable:libldap2
請問還有別的方法嗎?謝謝

2009/3/23 22:56
應用擴展 工具箱
回覆: wine玩魔獸出現的問題
會員三級
註冊日期:
2009/2/8 0:40
所屬群組:
已註冊使用者
等級: 12
HP : 0 / 283
MP : 59 / 10355
EXP: 35
離線
看樣子好像是少了libdap2的樣子,
不知道裝了會不會改善,
我在8.04有裝過1.0.8的,
你可以試試看
如果有耐心的話一個一個版本試....

2009/3/24 8:00
應用擴展 工具箱
barun@ms76.url.com.tw
回覆: wine玩魔獸出現的問題
Anon:barun@ms76.url.com.tw
之前碰到同樣的問題,後來發現是解析度和更新率的問題.....(在wow中會自行切換不同的解析度和更新率)....
解決的方式是copy wow程式到別台可跑wow的電腦,進入遊戲後重設解析度和更新率到Ubuntu的安全值後再copy回這台電腦上用....(沒試過直接copy個人登入資料檔方式)....或者改用視窗模式有時也可以(75%左右成功率....個人感覺值,不是統計值),希望對你有幫助.

2009/3/24 9:14 | 75878 66430 9b1e1 2165b
應用擴展 工具箱


 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.