PUD下的Error [論壇 - Ubuntu 與 LXDE]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊



PUD下的Error
會員五級
註冊日期:
1970/1/1 8:00
來自 台北
所屬群組:
已註冊使用者
等級: 23
HP : 0 / 573
MP : 231 / 88141
EXP: 93
離線
我在PUD 0.4.8.6的終端機下了sudo apt-get upgrade 跑了一堆之後出現錯誤,我再下sudo apt-get instll -f 想去修復,仍然無效.他跑出如下:


更新 0 個套件,新安裝 0 個套件,刪除 0 個套件,另不更新 236 個套件。
1 個套件沒有完全安裝或刪除完畢。
After this operation, 0B of additional disk space will be used.
正在設定 util-linux (2.13.1-5ubuntu3) ...
update-rc.d: /etc/init.d/hwclock.sh: file does not exist
dpkg:處理 util-linux (--configure)時出錯:
子程序·post-installation script·返回了錯誤號·1
在處理時有錯誤發生:
util-linux
E: Sub-process /usr/bin/dpkg returned an error code (1)

補上我的sources.list
deb http://tw.archive.ubuntu.com/ubuntu/ hardy main restricted
deb-src http://tw.archive.ubuntu.com/ubuntu/ hardy main restricted

deb http://tw.archive.ubuntu.com/ubuntu/ hardy-updates main restricted
deb-src http://tw.archive.ubuntu.com/ubuntu/ hardy-updates main restricted

deb http://tw.archive.ubuntu.com/ubuntu/ hardy universe
deb-src http://tw.archive.ubuntu.com/ubuntu/ hardy universe
deb http://tw.archive.ubuntu.com/ubuntu/ hardy-updates universe
deb-src http://tw.archive.ubuntu.com/ubuntu/ hardy-updates universe

deb http://tw.archive.ubuntu.com/ubuntu/ hardy multiverse
deb-src http://tw.archive.ubuntu.com/ubuntu/ hardy multiverse
deb http://tw.archive.ubuntu.com/ubuntu/ hardy-updates multiverse
deb-src http://tw.archive.ubuntu.com/ubuntu/ hardy-updates multiverse

deb http://security.ubuntu.com/ubuntu hardy-security main restricted
deb-src http://security.ubuntu.com/ubuntu hardy-security main restricted
deb http://security.ubuntu.com/ubuntu hardy-security universe
deb-src http://security.ubuntu.com/ubuntu hardy-security universe
deb http://security.ubuntu.com/ubuntu hardy-security multiverse
deb-src http://security.ubuntu.com/ubuntu hardy-security multiverse

請幫忙,我要如何修護?感謝

2009/5/16 19:32
egret
Lubuntu 14.04
每月第一個週六免費導覽田寮洋
https://www.facebook.com/groups/187049057048/
應用擴展 工具箱
回覆: PUD下的Error
會員五級
註冊日期:
2008/6/15 2:56
所屬群組:
已註冊使用者
等級: 38
HP : 0 / 945
MP : 757 / 39074
EXP: 81
離線

2009/5/17 0:33
應用擴展 工具箱
回覆: PUD下的Error
會員五級
註冊日期:
1970/1/1 8:00
來自 台北
所屬群組:
已註冊使用者
等級: 23
HP : 0 / 573
MP : 231 / 88141
EXP: 93
離線
Dear hepha:

謝謝您的幫忙,問題仍沒解決,我需要一點時間
消化這資料.
成功時,會再來回報,感謝.

2009/5/17 22:59
egret
Lubuntu 14.04
每月第一個週六免費導覽田寮洋
https://www.facebook.com/groups/187049057048/
應用擴展 工具箱
回覆: PUD下的Error
會員五級
註冊日期:
1970/1/1 8:00
來自 台北
所屬群組:
已註冊使用者
等級: 23
HP : 0 / 573
MP : 231 / 88141
EXP: 93
離線
謝謝您,解決了

但用sudo apt-get upgrade 時仍有另一個錯誤,如下:

正在替換安裝的套件中的檔案 initscripts ...
dpkg:處理 /var/cache/apt/archives/libc6_2.7-10ubuntu4_i386.deb (--unpack)時出錯:
無法建立“./usr/share/man/man1/getent.1.gz”: No such file or directory
dpkg-deb: 子程序 paste 被信號(Broken pipe)終止了
在處理時有錯誤發生:
/var/cache/apt/archives/libc6_2.7-10ubuntu4_i386.deb

以上,再請幫忙,感謝

2009/5/18 13:15
egret
Lubuntu 14.04
每月第一個週六免費導覽田寮洋
https://www.facebook.com/groups/187049057048/
應用擴展 工具箱
回覆: PUD下的Error
會員五級
註冊日期:
2008/6/15 2:56
所屬群組:
已註冊使用者
等級: 38
HP : 0 / 945
MP : 757 / 39074
EXP: 81
離線

2009/5/18 16:25
應用擴展 工具箱
回覆: PUD下的Error
會員五級
註冊日期:
1970/1/1 8:00
來自 台北
所屬群組:
已註冊使用者
等級: 23
HP : 0 / 573
MP : 231 / 88141
EXP: 93
離線
hepha兄:

這些英文分開來看的懂,合在一起,就有些難了.
我目前全面改用PUD.還有一堆不懂的,
感謝大家支持

2009/5/18 21:41
egret
Lubuntu 14.04
每月第一個週六免費導覽田寮洋
https://www.facebook.com/groups/187049057048/
應用擴展 工具箱


 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.