硬新套件後dpkg說有問題... [論壇 - Ubuntu安裝問題]


正在瀏覽:   1 名遊客


 到底部   前一個主題   下一個主題  [無發表權] 請登錄或者註冊



硬新套件後dpkg說有問題...
會員二級
註冊日期:
2009/11/13 19:17
所屬群組:
已註冊使用者
等級: 5
HP : 0 / 118
MP : 16 / 4531
EXP: 75
離線
硬新套件後dpkg說有問題...
系統叫我打 dpkg --configure -a
打入指令後得如下結果

user@ubuntu-desktop:~$ sudo dpkg --configure -a
dpkg:因相依問題,不能設定 kdelibs5:
kdelibs5 相依於 kdelibs5-data (>= 4:4.4.5-0ubuntu1)﹔然而:
kdelibs5-data 在系統上的版本為 4:4.4.2-0ubuntu4。
dpkg:在處理 kdelibs5 (--configure) 時發生錯誤:
相依問題 - 保留為未設定
dpkg:因相依問題,不能設定 kdelibs-bin:
kdelibs-bin 相依於 kdelibs5 (= 4:4.4.5-0ubuntu1)﹔然而:
kdelibs5 套件尚未設定。
dpkg:在處理 kdelibs-bin (--configure) 時發生錯誤:
相依問題 - 保留為未設定
dpkg:因相依問題,不能設定 libplasma3:
libplasma3 相依於 kdelibs5 (>= 4:4.4.5)﹔然而:
kdelibs5 套件尚未設定。
libplasma3 相依於 kdelibs5-data (= 4:4.4.5-0ubuntu1)﹔然而:
kdelibs5-data 在系統上的版本為 4:4.4.2-0ubuntu4。
dpkg:在處理 libplasma3 (--configure) 時發生錯誤:
相依問題 - 保留為未設定
dpkg:因相依問題,不能設定 kdepimlibs5:
kdepimlibs5 相依於 kdelibs5 (>= 4:4.4.5)﹔然而:
kdelibs5 套件尚未設定。
dpkg:在處理 kdepimlibs5 (--configure) 時發生錯誤:
相依問題 - 保留為未設定
dpkg:因相依問題,不能設定 plasma-scriptengine-javascript:
plasma-scriptengine-javascript 相依於 kdelibs5 (>= 4:4.4.5)﹔然而:
kdelibs5 套件尚未設定。
plasma-scriptengine-javascript 相依於 libplasma3﹔然而:
libplasma3 套件尚未設定。
dpkg:在處理 plasma-scriptengine-javascript (--configure) 時發生錯誤:
相依問題 - 保留為未設定
dpkg:因相依問題,不能設定 kimagemapeditor:
kimagemapeditor 相依於 kdelibs5 (>= 4:4.4.5)﹔然而:
kdelibs5 套件尚未設定。
dpkg:在處理 kimagemapeditor (--configure) 時發生錯誤:
相依問題 - 保留為未設定
dpkg:因相依問題,不能設定 libkdcraw8:
libkdcraw8 相依於 kdelibs5 (>= 4:4.4.5)﹔然而:
kdelibs5 套件尚未設定。
dpkg:在處理 libkdcraw8 (--configure) 時發生錯誤:
相依問題 - 保留為未設定
dpkg:因相依問題,不能設定 python-kde4:
python-kde4 相依於 kdelibs5 (>= 4:4.4.5)﹔然而:
kdelibs5 套件尚未設定。
python-kde4 相依於 kdepimlibs5 (>= 4:4.4.5)﹔然而:
kdepimlibs5 套件尚未設定。
python-kde4 相依於 libplasma3﹔然而:
libplasma3 套件尚未設定。
dpkg:在處理 python-kde4 (--configure) 時發生錯誤:
相依問題 - 保留為未設定
dpkg:因相依問題,不能設定 kdebase-runtime:
kdebase-runtime 相依於 kdelibs5 (>= 4:4.4.5)﹔然而:
kdelibs5 套件尚未設定。
kdebase-runtime 相依於 libplasma3﹔然而:
libplasma3 套件尚未設定。
kdebase-runtime 相依於 plasma-scriptengine-javascript﹔然而:
plasma-scriptengine-javascript 套件尚未設定。
dpkg:在處理 kdebase-runtime (--configure) 時發生錯誤:
相依問題 - 保留為未設定
在處理時有錯誤發生:
kdelibs5
kdelibs-bin
libplasma3
kdepimlibs5
plasma-scriptengine-javascript
kimagemapeditor
libkdcraw8
python-kde4
kdebase-runtime



進入更新管理員畫面,見到有兩個套件沒法安裝,
kdelibs5-data
linux-firmware


請問要如何解救? 謝謝

2011/2/11 10:12
應用擴展 工具箱
回覆: 硬新套件後dpkg說有問題...

註冊日期:
2009/12/6 10:32
所屬群組:
已註冊使用者
等級: 71
HP : 1053 / 1756
MP : 4456 / 66678
EXP: 24
離線
硬新套件後dpkg說有問題... 系統叫我打 dpkg --configure -a 打入指令後得如下結果


試試看 依序下指令
sudo apt-get install aptitude
sudo aptitude purge kdelibs5

sudo aptitude clean

sudo aptitude autoclean

sudo apt-get autoremove

sudo aptitude update

sudo aptitude install -f

sudo dpkg --configure -a

sudo aptitude full-upgrade

sudo apt-get check

sudo aptitude install kdelibs5 kdelibs-bin libplasma3 kdepimlibs5 plasma-scriptengine-javascript kimagemapeditor libkdcraw8 python-kde4 kdebase-runtime
(這個指令全部同一行)

有錯誤再把錯誤訊息貼上來

2011/2/11 10:22
應用擴展 工具箱
回覆: 硬新套件後dpkg說有問題...
會員五級
註冊日期:
2008/6/15 2:56
所屬群組:
已註冊使用者
等級: 38
HP : 0 / 945
MP : 757 / 39966
EXP: 81
離線
apt-cache policy kdelibs5-data
結果貼上來

2011/2/13 4:11
應用擴展 工具箱
回覆: 硬新套件後dpkg說有問題...
會員二級
註冊日期:
2009/11/13 19:17
所屬群組:
已註冊使用者
等級: 5
HP : 0 / 118
MP : 16 / 4531
EXP: 75
離線
按#2的方法安裝了很多東西
之後
按#3的指示打入
apt-cache policy kdelibs5-data
得如下結果:
kdelibs5-data:
已安裝:4:4.4.5-0ubuntu1
候選:4:4.4.5-0ubuntu1
版本列表:
*** 4:4.4.5-0ubuntu1 0
500 http://hk.archive.ubuntu.com/ubuntu/ lucid-updates/main Packages
100 /var/lib/dpkg/status
4:4.4.2-0ubuntu4 0
500 http://hk.archive.ubuntu.com/ubuntu/ lucid/main Packages

--------

2011/2/17 10:07
應用擴展 工具箱


 [無發表權] 請登錄或者註冊


可以查看帖子.
不可發帖.
不可回覆.
不可編輯自己的帖子.
不可刪除自己的帖子.
不可發起投票調查.
不可在投票調查中投票.
不可上傳附件.
不可不經審核直接發帖.